Ubuntu

Wrong tint in flash when it uses video acceleration

Reported by Aloysius on 2012-03-28
This bug affects 518 people
Affects Status Importance Assigned to Milestone
Adobe Flash Plugin Tools
Undecided
Unassigned
libvdpau
Fix Released
Undecided
Unassigned
adobe-flashplugin (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
apparmor (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Micah Gersten
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
flashplugin-nonfree (Debian)
New
Undecided
Unassigned
libvdpau (Ubuntu)
Undecided
Unassigned
Precise
High
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

Using Ubuntu 11.10 64 bit, nvidia binary driver, youtube videos show blue faces after the upgrade to flashplugin 11.2.
Didn't occur with 11.1.

See example at: http://i.imgur.com/S58GP.jpg

SRU description

[IMPACT]

 * Flash videos have the wrong tint ("blue faces") on Precise when
   using nvidia-current or nvidia-current-updates.

 * This effectively renders Flash videos unwatchable for all LTS users
   with an NVidia video card.

[TESTCASE]

 * Install nvidia-current, view any Flash video on YouTube,
   eg. https://www.youtube.com/watch?v=dkVBXW4JeUI.

 * Reproducable with various Nvidia video cards from at least the
   GeForce 8 series up to the GeForce 600 series.

 * Screenshot included in Aloysius' original bug description.

[Regression Potential]

 * While Stephen Warren's patch is not exactly a one-liner, it is
   rather straightforward and only changes libvdpau's behaviour for
   Flash.

 * On the off-chance that this change causes instability, it can be
   easily disabled via vdpau_wrapper.cfg.

 * The patch is widely tested, is included in upstream since 0.5 and
   has been backported for 0.4.1 by the Debian team. The fix is
   included in Quantal (0.4.1-6ubuntu1).

Marc Deslauriers (mdeslaur) wrote :

I can't reproduce this. Latest flash works fine here with amd64 11.10 and the 280.13-0ubuntu6 driver.

Changed in adobe-flashplugin (Ubuntu):
status: New → Incomplete
Aloysius (aloysius-w) wrote :

Using nvidia 9800GT, setting EnableLinuxHWVideoDecode = 1 in /etc/adobe/mms.cfg solved the problem.
Using driver 295.33-0ubuntu1~oneiric~xup1 haven't tested back with 280.13-0ubuntu6.

Joshua R. Poulson (jrp) wrote :

This also happens on precise with 11.2.202.228-0precise1 on my nvidia-based system

Appears to be related to https://bugbase.adobe.com/index.cfm?event=bug&id=3109467

Changed in adobe-flashplugin (Ubuntu):
status: Incomplete → Confirmed
Adrian (anoland) wrote :

Happened to me after the recent updates.

Ubuntu 10.10
Nvidia binary: 285.05.09
video card: GeForce 240M
linux 2.6.35-32-generic

Marc Deslauriers (mdeslaur) wrote :

It would be great if someone tried different combinations of OverrideGPUValidation and EnableLinuxHWVideoDecode in the /etc/adobe/mms.cfg file to see if there's a workaround.

See:
https://bugbase.adobe.com/index.cfm?event=bug&id=3109467
http://blogs.adobe.com/penguinswf/2008/08/secrets_of_the_mmscfg_file_1.html

Aloysius (aloysius-w) wrote :

It's bizarre. I removed /etc/adobe/mms.cfg and now everything works.

For some reason youtube clips show "software video rendering" and "software video decoding"
now, although they were both set as hardware just yesterday, or hardware and software respectively when the problem was occurring.

(Also I'm back on the stock nvidia 280.13-0ubuntu6 driver)

Marc Deslauriers (mdeslaur) wrote :

The flash package never shipped /etc/adobe/mms.cfg, so that's probably a file you created yourself.

Is anyone else having issues after removing /etc/adobe/mms.cfg?

Marc Deslauriers (mdeslaur) wrote :

OK, so with my test laptop.

No mms.cfg, no libvdpau1 = flash works fine

after installing libvdpau1 = wrong tint (LP: #967091)

after adding "EnableLinuxHWVideoDecode=1" to mms.cfg = black flash video (LP: #967182)
after adding "EnableLinuxHWVideoDecode=1" and "OverrideGPUValidation=true" to mms.cfg = flash works fine

YMMV.

summary: - Wrong tint after upgrading to 11.2
+ Wrong tint with Nvidia after upgrading to 11.2

I created /etc/adobe/mms.cfg when trying to address the problem.

Anyway, I've noticed that blue faces appear only when the "accelerated video rendering " "software video decoding" combination.
If the latter is accelerated as well (via EnableLinuxHWVideoDecode=1) colours are fine but the plugin is very unstable.

On the other hand, with "software video rendering" and "software video decoding" things are perfect (lower speed notwisthanding), but as you pointed out the only way to disable the acceleration in the former is by removing libvdpau1, since the "Enable Hardware Acceleration" option in the settings is uncheckable.

Now, it would be nice to know if there is a way to keep libvdpau1 for other uses...

Joshua R. Poulson (jrp) wrote :

On precise: No mms.cfg for me, but I did have libvdpau. I created a mms.cfg and was able to fix the tiny, but it made Flash highly unstable.

Joshua R. Poulson (jrp) wrote :

Looks like there's a fix for vdpau described here: http://www.nvnews.net/vbulletin/showpost.php?p=2518770&postcount=104

Aloysius (aloysius-w) wrote :

Disabling hardware acceleration at all while keeping libvdpau1 would be the best short-term solution, IMHO.
Unfortunately it's impossible to do so via the settings menu, since it's not possible to uncheck "Enable Hardware Acceleration".

I've found the relevant setting to be into ~/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/settings.sol and I have a working copy of it from another installation that somehow works, but even with a 1-1 comparison with the default file I couldn't identify the correct variable to set.

Rodney Dawes (dobey) wrote :

Unchecking "Enable Hardware Acceleration" in Flash works for me, but you have to reload the page, after doing so. It doesn't take effect with the currently running instance of the plug-in.

However, it also more than doubles CPU usage for me. And for some reason, I have so far only encountered this problem on YouTube, or sites embedding YouTube videos. Watching a video on Vimeo seems to work fine for me, as does videos on South Park Studios.

Aloysius (aloysius-w) wrote :

@dobey: I tried like you said, but the settings window gets stuck and no button is responsive.
Clicking anyway and reloading doesn't do anything on my system.

ambossarm (ambossarm) wrote :

vimeo videos with flash are playing fine. youtube HTML5 videos also play fine. I tried a webM video with HTML and with flash, the blue faces where only there with flash.

A blue shirt was displayed as yellow (so it is a total mix, not only a blue filter)

After mkdir /etc/adobe and adding the next to lines to /etc/adobe/mms.cfg:
EnableLinuxHWVideoDecode=1
OverrideGPUValidation=true

the colors are fine. (Problem solved)

Another (perhaps related) problem is that I have a transparent overlay of the flashplayer in KVIrc. It is over the background but under the font, it looks like a nice feature (video as background in chat). It will not be on a screenshot, but the gnome screenshot tool does also have that video as background effect.

Adam Porter (alphapapa) wrote :

Adobe is refusing to fix the bug--or perhaps I should say, they're sticking their heads in the sand, claiming they can't reproduce it, in spite of numerous reports on their own bug tracker and across the Internet:

https://bbs.archlinux.org/viewtopic.php?pid=1079711#p1079711
https://bugbase.adobe.com/index.cfm?event=bug&id=3136745

A few days ago it was fine--now, after Flash was upgraded, everything's blue.

Disabling hardware acceleration is not a solution--it's simply a workaround for a major regression. And it seems that the "trace patch" is an "ugly hack", so it's probably not eligible for distributing in Ubuntu.

Something's got to be done, though. We all know that Adobe is abandoning Flash on Linux, but are they really going to leave us with this broken mess? Is this going to be their "farewell"? Can Ubuntu and other distros exert some pressure to get them to fix it? If all it really is is that the color planes are reversed, it would probably take all of 5 minutes for one guy to fix it--probably a one-line patch.

axel (axel334) wrote :

I support this Adam's idea. Canonical should ask Adobe to repair flash or make previous version available in repositories. I read that it was the last flash plugin for Firefox, so it should just work for people who still want to use it. Make sure that solution will be available for Natty as well.

Adam Porter (alphapapa) wrote :

So far Adobe's response is:

https://bugbase.adobe.com/index.cfm?event=bug&id=3109467

"thanks for your support Adobe Flash and report this issue. But we do not support Linux anymore post 11.2"

Is this a parting shot at Linux users? A few days ago it worked fine--today it's broken. And they refuse to fix it? So our choice is between using a version with known security holes or having people turn into smurfs in YouTube videos?

FYI: Archived (previous) Flash Player versions are located at http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

axel (axel334) wrote :

@ Vladimir Skvortsov (vskvortsoff)
Thank you.
I downloaded fp_11.1.102.63_archive.zip unpacked, removed all flash with synaptic and copied to locations as is described here:
http://scottlinux.com/2011/07/14/install-flash-player-11-in-linux-mint-debian-edition-64bit/
It worked for Opera and Chromium. I also created
/home/user/.mozilla/plugins
and copied libflashplayer.so there, which worked for Firefox.
Now about:plugins in firefox shows Shockwave Flash 11.1 r102
You can also block flash in Synaptic, so that you don't update again to the broken version accidentally.

I had the same problem on Ubuntu 11.10 (adobe-flashplugin 11.2.202.228-0oneiric1) and nVidia GeForce 9600 GT.

sudo mkdir /etc/adobe
echo -e "EnableLinuxHWVideoDecode=1\nOverrideGPUValidation=true" | sudo tee /etc/adobe/mms.cfg > /dev/null

Those commands resolved it no more problems with colors.

Jan Vlnas (jnv) wrote :

For some people, EnableLinuxHWVideoDecode makes Flash Player unstable – if that's your case, consider another options which I've summed up here: https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/968647/comments/16
So far all the solutions we have are hacks and workarounds for Flash Player's faulty behaviour.

Again, only the players using Stage Video are affected – namely YouTube, Brightcove, and Viddler. See http://www.adobe.com/devnet/flashplayer/stagevideo.html – especially the demo with The Big Buck Bunny is useful to experience the bug and compare the CPU usage.

Aloysius (aloysius-w) wrote :

Does it mean that if using the libvdpau patch the colours would appear swapped on players other than Stage Video?

Jan Vlnas (jnv) wrote :

Aloysius: No, Stage Video is a feature of Flash Player which allows Flash applications to use hardware acceleration – most Flash video players (including Vimeo) rely on software rendering which doesn't use VDPAU at all.
Other desktop video players (like VLC or Totem) also aren't affected. libvdpau fix is "opt-in" – it swaps colours only for applications with VDPAU_TRACE environment variable enabled. It could, however, affect the native "HTML5" video in web browsers.

The current libvdpau patch is hack because it uses vdpau_trace library for unrelated purpose and removes the original functionality.
On the other hand it's a proof of concept how the proper and out-of-the-box workaround could work – swap the colours for some applications. Unfortunately it's a very crude method; AFAIK there's no way to detect which application sends data to VDPAU so we have to rely on environment variables. And that would mean to patch all the browsers (not to mention applications which can embed Flash through some web view widgets like GtkHtml) – unless there's some way to wrap the Flash Plugin's library invocation.

I'm having the same problem:

flashplugin-installer: 11.2.202.228ubuntu1
nvidia-current: 295.33-0ubuntu1
Kubuntu 12.04 64 bits.

To fix it, just go to www.youtube.com/html5 and ENABLE html5 instead flash.

Aloysius (aloysius-w) wrote :

Enabling html5 wouldn't exactly be a "fix". Also it would require keeping tracking cookies.

Adam Porter (alphapapa) wrote :

The workaround in comment #22 doesn't fix it for me. The colors are still off when watching the Stage Video videos. And on top of that, now Flash crashes regularly.

Adam Porter (alphapapa) wrote :

To clarify, after doing:

$ echo -e "EnableLinuxHWVideoDecode=1\nOverrideGPUValidation=true" | sudo tee /etc/adobe/mms.cfg

Then on YouTube, 360p and 480p videos had proper tint. But 720p videos still were blue. And Flash crashed regularly. After removing that file, all YouTube videos are tinted blue, and Flash doesn't crash.

Sven Romeike (lun4tic) wrote :

This affects me too since yesterdays updates as far as I can tell. before that all youtube videos in 12.04 showed up normal. HTML5 Videos as well as local videos in VLC and so on are definately not affected. Also it only seems to affect videos as flashplayer animations in flash show red color as intended.

#26 only fixes the problem for HTML5 Videos not for Youtube H264 videos.

Aloysius (aloysius-w) wrote :

I'm trying the vdpau_trace patch and it seems to be working well so far.
I wonder if it would really be unthinkable to include it in the next releases.

axel (axel334) wrote :

I was wrong in saying in comment #21 that you can block it in Synaptic. After uninstall I don't see anything to bock. Just to correct my mistake. But going back to previous version worked for me. Opera, Firefox and Chromium work fine.
For Opera it might be necessary to do:
sudo cp libflashplayer.so /usr/lib/opera/plugins
I have natty 32-bit. The same should work for 64-bit.

Sven Romeike (lun4tic) wrote :

I only experienced the problem on youtube so far. vimeo and others don't seem to be affected.

Ole Jon Bjørkum (oj88) wrote :

Same problem here (NVIDIA). Enbling HW-acceleration in mms.cfg solves it, but makes it way to unstable on my 64-bit laptop (though HW-acceleration works great on my 32-bit HTPC).

Removing VDPAU is not a solution at all. It will disable HW-acceleration on all video, and I have a lot of packages that depend on it.

Ole Jon Bjørkum (oj88) wrote :

Downloaded 11.1 and put it libflashplayer.so in /usr/lib/mozilla/plugins (works in Chrome as well).

http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.1.102.63_archive.zip

Not a very good idea to use an old version of Flash, though (security...)

Jan Vlnas (jnv) wrote :

To my knowledge (and from my tests) Flash Player 11.1 doesn't support Stage Video HW acceleration on Linux, 11.2 is the first version which supports hardware decoding through VDPAU (and therefore causes this bug).
By downgrading to Flash Player 11.1 you probably won't get HW accelerated video, but you will definitely get known security vulnerability, see http://www.adobe.com/support/security/bulletins/apsb12-07.html – while the first one seems to be WIndows only, the second one (CVE-2012-0773) allows an arbitrary code execution on all platforms. But hey, it's your call.

If you still want to downgrade, Flash Player 10.3 is maintained, see http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html#main_Archived_versions – it is possible this version also supports EnableLinuxHWVideoDecode without crashing so often (I've not tested it).

Again, currently the easiest/most stable/safest way to fix colours is to disable hardware acceleration in Flash Player Display settings: http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html
If the Settings window doesn't respond to clicks, switch to Unity 2D, uncheck the box and switch back to standard Unity.

swiftgeek (swiftgeek) wrote :

(64-bit, hwaccel enabled in /etc , opera-next and chromium)
HWAccel works with YouTube site, but embedded yt player crashes all instances of flashplugin (eg. http://www.joemonster.org/filmy/43422/Skyrim_w_wykonaniu_Lindsey_Stirling ). But embedded player alone, eg. " http://www.youtube.com/v/BSLPH9d-jsI " works fine.

Detailed info about crash with export "VDPAU_TRACE=1" http://pastebin.com/tJrXXqFk

swiftgeek (swiftgeek) wrote :

Also i have noticed that with changes in "/etc/adobe" and "VDPAU_TRACE=1" flashplugin is "reserving" pure white instead of usual black

summary: - Wrong tint with Nvidia after upgrading to 11.2
+ Wrong tint in flash when it uses libvdpau acceleration
summary: - Wrong tint in flash when it uses libvdpau acceleration
+ Wrong tint in flash when it uses video acceleration
Changed in libvdpau:
status: New → Invalid
137 comments hidden view all 217 comments

This is fixed in 0.4.1-6ubuntu1 (released in quantal). Stephen Warren's patch was backported to libvdpau-0.4.1-6 by the Debian team.

Changed in libvdpau:
status: Invalid → Fix Released

I'd like to get the existing bugfix accepted as an SRU. Hope I get the SRU process more or less right.

While simply using the Quantal revision's changes in Precise would work perfectly well, I also created an update for the Precise version that includes only patches relevant for this bug. See the linked bzr branch and debdiff.

description: updated

Here's the debdiff that includes only the changes relevant for this bug.

Aaron Plattner (aplattner) wrote :

Hi Sebastian,

It probably doesn't matter for the Debian build system, but Stephen's version of the change breaks distcheck. I'd suggest using the upstream version: git format-patch -1 ca9e637c61e80145f0625a590c91429db67d0a40

Hi Aaron,

Sorry, the SRU process is fairly new to me, but could you explain how to reproduce your problems with distcheck?

The debdiff that I uploaded just applies the patches that are already in use in Quantal to Precise. Basically this amounts to Stephen's upstream patch that you just referenced plus some minor packaging modifications:

 - debian/libvdpau1.symbol
 - debian/changelog
 - debian/rules

Again, I'm rather new to the whole process, so if you have any suggestions, please let me know.

Aaron,

I just checked both the bzr branch linked above and the debdiff and can't reproduce any problems with either the Debian build system or a manual "./configure && make distcheck".

apt-get source libvdpau && patch -p0 < libvdpau_0.4.1-3ubuntu2.debdiff
and
bzr branch lp:~sometimesfood/ubuntu/precise/libvdpau/libvdpau.fix-967091

both work fine for me on a pristine Precise machine.

Aaron Plattner (aplattner) wrote :

Strange. The line in question is the one I mentioned in my reply to Stephen's original mail: http://lists.freedesktop.org/archives/vdpau/2012-September/000023.html

>> +
>> +libvdpausysconfdir=$(sysconfdir)
>> +libvdpausysconf_DATA = vdpau_wrapper.cfg
>
> This breaks distcheck:
>
> make[3]: *** No rule to make target `vdpau_wrapper.cfg', needed by `all-am'. Stop.
>
> I think this needs to be dist_libvdpausysconf_DATA.

I'm not sure why you wouldn't be seeing that in the Debian package since your debdiff adds the incorrect line rather than the fixed version in the upstream repository:

+@@ -27,3 +28,6 @@ libvdpauincludedir = $(includedir)/vdpau
+ libvdpauinclude_HEADERS = \
+ $(top_srcdir)/include/vdpau/vdpau.h \
+ $(top_srcdir)/include/vdpau/vdpau_x11.h
++
++libvdpausysconfdir=$(sysconfdir)
++libvdpausysconf_DATA = vdpau_wrapper.cfg

In any case, if it works for you and no one is actually expecting to use dist / distcheck from the Ubuntu package, then the difference is moot.

You were right, of course. I should have run "quilt push -a" before checking the distcheck results.

> In any case, if it works for you and no one is actually expecting to use dist / distcheck from the Ubuntu package, then the difference is moot.

Still I'd prefer to have a proper patch for this, I'll change my branch and the debdiff according to your suggestions tomorrow.

Ok, just updated my bzr branch and the debdiff.

Aaron, could you have a look at it? I tried to keep changes to the bare minimum.

Linards Ticmanis (ticmanis) wrote :

Just found what is probably an (admittedly rather unimportant) typo in your debdiff: "a has table of VdpDevice". I assume that it's supposed to be "a hash table", no?

EVERYTHING that plays video with hardware acceleration has the colors messed up (even playing video files from disk on any player), not just flash. Been so since Ubuntu 11.04 or 11.10.

Isn't this the same bug as #862831 ?
What does "fix released" mean? I still see the bug. (not in flash, 'cause I've disabled hw acceleration ages ago)

Matteo,

No, LP: #862831 is definitely a different problem. Video playback using VDPAU works well in general for me and others on a lot of different machines, the tint bug only affects Flash videos and is fixed in Ubuntu 12.10 (Quantal).

"Fix released" just means that a fix for this bug has been released in a newer version of the software.

See https://help.launchpad.net/Bugs/Statuses for reference.

On 10/23/2012 02:11 PM, Sebastian Boehm wrote:
> Ok, just updated my bzr branch and the debdiff.
>
> Aaron, could you have a look at it? I tried to keep changes to the bare
> minimum.

Looks okay to me.

-----------------------------------------------------------------------------------
This email message is for the sole use of the intended recipient(s) and may contain
confidential information. Any unauthorized review, use, disclosure or distribution
is prohibited. If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
-----------------------------------------------------------------------------------

Hans Deragon (deragon) wrote :

Any chances to see the fix backported to 12.04 LTS? Many users that suffer from this bug do not want to have to upgrade to a non LTS. And I would hate the idea to have to wait until 14.04 to get this bug fixed.

Hans,

the fix posted above is intended as a backport for 12.04, but the update process for stable releases is somewhat more involved than for development releases. See https://wiki.ubuntu.com/StableReleaseUpdates for reference.

Changed in adobe-flashplugin (Ubuntu Raring):
status: Confirmed → Won't Fix
Changed in libvdpau (Ubuntu Precise):
status: New → Confirmed
Changed in libvdpau (Ubuntu Quantal):
status: New → Fix Released
Changed in libvdpau (Ubuntu Raring):
status: New → Fix Released
Changed in adobe-flashplugin (Ubuntu Precise):
status: New → Won't Fix
Changed in adobe-flashplugin (Ubuntu Quantal):
status: New → Won't Fix
Changed in adobe-flashplugin (Ubuntu):
status: Confirmed → Won't Fix
Marc Deslauriers (mdeslaur) wrote :

ACK on the merge request. I've uploaded a slightly modified version of it to precise-proposed for processing by the SRU team.

@Marc Deslauriers the precise version hasn't been approved from SRU team [1]

do you know the reason?

[1] https://launchpad.net/ubuntu/precise/+queue?queue_state=1&queue_text=libvdpau
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Tobin Davis (gruemaster) wrote :

I just heard about this bug, thought it was an old monitor I had, but wasn't.

Now here's the rub. I have an x86 system that started showing this issue when I upgraded to Precise from Lucid (32bit only for old reasons - will reimage when I get a chance to backup 500G worth of development stuff). My system is a Core2Quad with nVidia 9600GT, and I have dual monitors setup using nVidia's Separate X Screens configuration. On my main monitor, I get this issue. On the other monitor, I don't. Video accelleration is active on both.

I tried installing libvdpau1_0.4.1-6ubuntu1_i386.deb, but it doesn't appear to have changed anything for me. Will reboot tomorrow and see if that helps.

Tobin Davis (gruemaster) wrote :

Nevermind. Restarted firefox and it works now. Still, quite odd that it worked on display=:0.1 but not display=:0.0.

Changed in libvdpau (Ubuntu Precise):
importance: Undecided → High
milestone: none → ubuntu-12.04.2

Hello Aloysius, or anyone else affected,

Accepted libvdpau into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libvdpau/0.4.1-3ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libvdpau (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Micah Gersten (micahg) wrote :

There's an apparmor multimedia abstraction change needed if /etc/vdpau_wrapper.cfg is installed as Firefox tries to read it. This is already present in quantal and raring.

Changed in apparmor (Ubuntu Raring):
status: New → Invalid
Changed in apparmor (Ubuntu Quantal):
status: New → Invalid
Micah Gersten (micahg) on 2012-11-30
Changed in apparmor (Ubuntu Precise):
assignee: nobody → Micah Gersten (micahg)
status: New → In Progress
Adam Conrad (adconrad) wrote :

Hello Aloysius, or anyone else affected,

Accepted apparmor into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/apparmor/2.7.102-0ubuntu3.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apparmor (Ubuntu Precise):
status: In Progress → Fix Committed
Micah Gersten (micahg) wrote :

Verified that the new apparmor package doesn't warn on /etc/vdpau_wrapper.cfg when accessing flash in Firefox.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.7.102-0ubuntu3.5

---------------
apparmor (2.7.102-0ubuntu3.5) precise-proposed; urgency=low

  * Allow reading of /etc/vdpau_wrapper.cfg in multimedia abstraction
    (LP: #967091)
    - add debian/patches/0020-vdpau_wrapper.patch
    - update debian/patches/series
 -- Micah Gersten <email address hidden> Thu, 29 Nov 2012 19:50:01 -0600

Changed in apparmor (Ubuntu Precise):
status: Fix Committed → Fix Released

libvdpau-0.4.1-3ubuntu1.1 works great for me on all tested machines.

However, since I am the one who submitted the original merge request it would probably be better if somenone else could confirm this independently and change the tag to verification-done.

tags: added: verification-done
removed: verification-needed
MC Reezy (deezy4reezy) wrote :

12.4 can not install an up date.

John Schroeder (jschroed) wrote :

MC Reezy, did you apply one of the workarounds? You may need to remove libvdpau1 and reinstall the Ubuntu version. I followed what pst007x (turone) wrote on 2012-04-02. He provided the link to: http://askubuntu.com/questions/117127/flash-video-appears-blue. The fix at the top involves adding a repository "ppa:tikhonov/misc" to use a special patched version of libvdpau1. To revert back to the Ubuntu libvdpau1, I disabled the repository and then followed the steps to enable proposed updates. Here's what I did:

Open Update Manager. Click on "Settings", then click on the "Other Software" tab.
Uncheck (or remove) the tikhonov repository.
Remove libvdpau1 at the command line with "sudo apt-get remove libvdpau1".
Check that flash videos (e.g. YouTube) are "blue" again.
Open Update Manager. Click on "Settings", then click on the "Updates" tab.
Check the checkbox next to "Pre-released updates (precise-proposed)". Close Software Sources.
At Update Manager, click on "Check".
There should be about 59 or so updates that come up. If you just want libvdpau1, unselect all the updates by clicking the box next to proposed, then look for libvdpau1 in the list and check it.
Click install updates. Once the update(s) is installed, you can go back to software sources and deselect proposed updates.
Check that flash videos (e.g. YouTube) are fixed.

Of course, if you applied a different fix, you will have to follow different steps to undo what you did.

chocolateboy (chocolateboy) wrote :

@jschroed: thanks for the instructions.

I can confirm that libvdpau-0.4.1-3ubuntu1.1 fixes the problem for me on Ubuntu 12.04 with Flash 11.2 r202.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libvdpau - 0.4.1-3ubuntu1.1

---------------
libvdpau (0.4.1-3ubuntu1.1) precise-proposed; urgency=low

  [ Sebastian Boehm ]
  * Apply Stephen Warren's patch for blue tint in Adobe Flash videos
    (LP: #967091). (Applied to Debian version libvdpau-0.4.1-5.1 by
    Maurizio Avogadro.)

  [ Marc Deslauriers ]
  * debian/libvdpau1.install: also ship /etc/vdpau_wrapper.cfg
 -- Marc Deslauriers <email address hidden> Wed, 07 Nov 2012 13:10:33 -0500

Changed in libvdpau (Ubuntu Precise):
status: Fix Committed → Fix Released
Matthias Niess (mniess) wrote :

I've just installed libvdpau 0.4.1-6ubuntu1 in Ubuntu 12.10 and have the blue tinted video.

Marc Deslauriers (mdeslaur) wrote :

@Mathhias: please file a new bug, you most certainly have a different issue.

Tommy_CZ (t-kijas) wrote :

I am experiencing this too.... I use latest Ubuntu 12.04.1 64bit and NVIDIA 310.14 drivers, all youtube videos have wrong colors (blue tinted).

Tommy_CZ: Which version of libvdpau1 are you using?

Michał Zając (quintasan) wrote :

Running Kubuntu 12.10 and same things happens here, looks like the bug somehow got reintroduced

Linux demonbane 3.5.0-19-generic #30-Ubuntu SMP Tue Nov 13 17:48:01 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
01:00.0 VGA compatible controller: NVIDIA Corporation GF114 [GeForce GTX 560] (rev a1)
libvdpau1 version is 0.4.1-6ubuntu1
nvidia-experimental-310 version is 310.14-0ubuntu1 (running experimental since stable have worse performance on my card)

The fix mentioned in comment #9 works and I can't say I had any problems with flash after creating /etc/adobe/mms.cfg and adding "EnableLinuxHWVideoDecode=1" and "OverrideGPUValidation=true" there

Michał,

libvdpau1 has not been updated on Quantal and I can't say I have noticed a regression. All my NVidia machines were affected with 12.04 and don't have any problems with either the recently updated libvdpau1 or the one in 12.10.

sebastian@foucault ~ % uname -a
Linux foucault 3.5.0-19-generic #30-Ubuntu SMP Tue Nov 13 17:48:01 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
sebastian@foucault ~ % lspci | grep NVIDIA
01:00.0 VGA compatible controller: NVIDIA Corporation GF114 [GeForce GTX 560 Ti] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF114 HDMI Audio Controller (rev a1)
sebastian@foucault ~ % aptitude show libvdpau1 | grep Version
Version: 0.4.1-6ubuntu1
sebastian@foucault ~ % aptitude show nvidia-current-updates | grep Version
Version: 304.51-0ubuntu1
sebastian@foucault ~ % aptitude show flashplugin-installer | grep Version
Version: 11.2.202.258ubuntu0.12.10.1

evuraan (evuraan) wrote :

Glad that a fix has been provided for 12.04.

Will this fix be extended to 10.04 (lucid) as well? I've a bunch of machines running 10.04, and has this problem.

As for specifics,

root@lmo:/usr/lib/vdpau# aptitude show libvdpau1 | grep Version
 Version: 0.3-2build1

root@lmo:/usr/lib/vdpau# ls -ltr *vdpau*
-rwxr-xr-x 1 root root 65640 2012-11-06 18:06 libvdpau_trace.so.304.64
-rwxr-xr-x 1 root root 1867256 2012-11-06 18:06 libvdpau_nvidia.so.304.64
lrwxrwxrwx 1 root root 24 2012-11-06 18:06 libvdpau_trace.so.1 -> libvdpau_trace.so.304.64
lrwxrwxrwx 1 root root 25 2012-11-06 18:06 libvdpau_nvidia.so.1 -> libvdpau_nvidia.so.304.64

thanks!

CHADWICK OWINO (owinoc) on 2013-01-17
Changed in adobe-flash-plugin-tools:
assignee: nobody → CHADWICK OWINO (owinoc)
Changed in adobe-flash-plugin-tools:
assignee: CHADWICK OWINO (owinoc) → nobody
eros2 (eros2) wrote :

I installed nvidia-experimental-310 package and got a blue tint. Then I reinstalled libvdpau package and blue ting is gone.

Looks like nvidia driver package includes it's own unfixed libvdpau.

Yaroslav (yarosla) wrote :

This blue tint / blue overlay was driving me crazy. Tried all offered solutions - none helped. Finally I found out that it is my new Dell U3014 monitor that is causing this trouble. It has very nice feature called "Smart Video Enhance". Turned it off.

Alexis Wilke (alexis-m2osw) wrote :

I had that problem on one of my computers where I installed the CUDA development system. The CUDA installs its own libraries and the libvdpau_nvidia.so library was not getting used!

I used the following command to remove the "offensive" vdpau library:

   sudo rm /usr/lib/libvdpau.so /usr/lib/libvdpau.so.1 /usr/lib/libvdpau.so.304.54 /usr/lib/libvdpau_trace.so

Then I restarted my browser and it worked like a charm.

You should have another library named:

   /usr/lib/libvdpau_nvidia.so

If not, then you probably will have problems...

FYI, I had CUDA installed with:

cuda_5.0.35_linux_64_ubuntu11.10-1.run

When running 12.04 and it worked fine. When I upgraded to 13.04 I decided to remove CUDA for the time being and still had that color problem.

I found the solution (a mention of that library) from this Adobe bug report:

https://bugbase.adobe.com/index.cfm?event=bug&id=3109467

Displaying first 40 and last 40 comments. View all 217 comments or add a comment.