Flash not working: Intrepid, 2.6.27, FF3

Bug #262693 reported by Dylan Hunter on 2008-08-29
128
This bug affects 13 people
Affects Status Importance Assigned to Milestone
PulseAudio
New
Undecided
Unassigned
adobe-flashplugin (Ubuntu)
High
Unassigned
firefox-3.0 (Ubuntu)
Undecided
Unassigned
nspluginwrapper (Ubuntu)
Undecided
Unassigned

Bug Description

Since about 2 days ago, Flash stopped working in FF3 on Intrepid. Yesterday, just got a white box, (i.e. entirely not working) today get a grey box, (still entirely not working - often with a blank external window popping up) and often crashes Firefox.

Dell M1530
Kernel: 2.6.27
Video Driver: nvidia-glx-177, (flaky)
Video Card: Nvidia GeForce 8400
Resolution: 1280x800

Tobias Pflug (tobias-pflug) wrote :

Same behavior here. Flash was working fine via flashplugin-nonfree
but now ceased working.

Alexander Jones (alex-weej) wrote :

Also in Epiphany.

Dustin Kirkland  (kirkland) wrote :

Same behavior here, marking confirmed.

:-Dustin

Changed in flashplugin-nonfree:
status: New → Confirmed
Nick Colgan (nick-colgan) wrote :

Same issue here.

Mahdi (mahdi-hates-spam) wrote :

+1

Amit Kucheria (amitk) wrote :

I am seeing this too. I am on a 64-bit machine.

Amit Kucheria (amitk) wrote :

Downgrading to nspluginwrapper_0.9.91.5-2ubuntu2_amd64.deb makes the problem go away.

You can download it from http://nl.archive.ubuntu.com/ubuntu/pool/multiverse/n/nspluginwrapper/

Dustin Kirkland  (kirkland) wrote :

Confirming Amit's workaround, and marking as "Triaged" in nspluginwrapper, as it seems that's where the regression has occurred.

:-Dustin

Changed in nspluginwrapper:
status: New → Confirmed
Changed in firefox:
status: New → Confirmed
Changed in nspluginwrapper:
status: Confirmed → Triaged
Niels Egberts (nielsegberts) wrote :

I'm confirming this bug on 64bit.

nullack (nullack) wrote :

When trying to browse flash sites such as tv.com FF will vanish for me everytime and leave npviewer.bin hanging around as a process. I'm on nsplugin 1.1.0-0ubuntu2 and flash plugin 10.0.1.218+10.0.0525ubuntu1. Cleaning out my cache/profile does not appear to resolve the issue nor does a reboot. I do not consistently get this error message in the logs, but it seems sometimes I get this:

Sep 4 07:18:43 PPP kernel: [ 140.970717] npviewer.bin[6153]: segfault at 0 ip 00000000f6cf6f98 sp 00000000ffb8d900 error 4 in libflashplayer.so[f6974000+93b000]

Im on the AMD64 build and am using Nvidia 177.70

Brian Murray (brian-murray) wrote :

I've been unable to recreate this (Firefox crashing) when browsing http://www.tv.com or http://www.anandtech.com or http://youtube.com (Dustin indicated this was problematic) with the following package versions.

16:01:41 - flash:[~] apt-cache policy firefox-3.0
firefox-3.0:
  Installed: 3.0.1+build1+nobinonly-0ubuntu2
  Candidate: 3.0.1+build1+nobinonly-0ubuntu2

16:01:50 - flash:[~] apt-cache policy nspluginwrapper
nspluginwrapper:
  Installed: 1.1.0-0ubuntu2
  Candidate: 1.1.0-0ubuntu2

For what it is worth I'm using the open source ati driver.

nullack (nullack) wrote :

Confirming that also using the NV open source driver the problem still occurs for my configuration when testing at tv.com.

nullack@PPP:~$ apt-cache policy firefox-3.0
firefox-3.0:
  Installed: 3.0.1+build1+nobinonly-0ubuntu2
  Candidate: 3.0.1+build1+nobinonly-0ubuntu2

nullack@PPP:~$ apt-cache policy nspluginwrapper
nspluginwrapper:
  Installed: 1.1.0-0ubuntu2
  Candidate: 1.1.0-0ubuntu2

nullack@PPP:~$ apt-cache policy flashplugin-nonfree
flashplugin-nonfree:
  Installed: 10.0.1.218+10.0.0.525ubuntu1
  Candidate: 10.0.1.218+10.0.0.525ubuntu1

nullack (nullack) wrote :

Thanks to Alexander S on IRC there is a fix for flash always crashing. In a terminal run:

sudo apt-get install --reinstall flashplugin-nonfree

The root cause that some have it and others do not relates to the way that individuals have upgraded their Intrepid build configuration overtime. Alexander said he will trigger the --reinstall, but we can do this now for our own builds.

Brian Murray (brian-murray) wrote :

Based off the last comment from nullack it sounds like this isn't a Firefox 3.0 bug then so I am closing that task as invalid.

Changed in firefox-3.0:
status: Confirmed → Invalid
Alexander Sack (asac) wrote :

nspluginwrapper was fixed in ubuntu2 upload.

Changed in nspluginwrapper:
status: Triaged → Fix Released
Alexander Sack (asac) wrote :

What is needed is a reinstall upload of flashplugin-nonfree. I am just waiting for someone to give me feedback on the i386 performance when used with nspluginwrapper 1.1.0

Changed in flashplugin-nonfree:
status: Confirmed → Triaged
Alexander Sack (asac) wrote :

beta milestoning this.

Changed in flashplugin-nonfree:
importance: Undecided → High
milestone: none → ubuntu-8.10-beta

Working for me now, in amd64.

Thanks,
:-Dustin

abatcher (geens-toon) wrote :

Same problem, ubuntu 8.04 64bit on intel dual core
It's been 20 days and no real solutions ?

abatcher (geens-toon) wrote :

Sorry, this thread is for ubuntu 8.10

ktp420 (ktp420) wrote :

I had everything working, sound and video, in Intredpid, but recent updates broke it. Now if I have other apps playing sound, then flash will start but no sound and hangs after 1 second. I am using the ALSA pulse plugin to redirect sound using the /etc/asound.conf.

ktp420 (ktp420) wrote :

I think it is the pulseaudio packages itself that cause this regression. I downgraded them to 0.9.10-2ubuntu2 and things work again.

https://launchpad.net/ubuntu/+source/pulseaudio

Kyle M Weller (kylew) wrote :

wow this really sucks, how do I get this fixed?

ktp420 (ktp420) wrote :

Things should be better with todays updates...and latest flash plugin is coming down...so things should be working good.

Kyle M Weller (kylew) wrote :

for some reason reinstalling ubuntu fixed this issue for me, I tried everything, upgrading pulseaudio, downgrading firefox, using opera, and every other browser, couldnt fix it. But a complete reinstall fixed it heh

Christoph Langner (chrissss) wrote :

I had this issue too. I had those grey boxes instead e.g. the youtube video. I tried to install flash rc 10 from the adobe labs site, but this didn't help. Reinstalling flash

$ sudo apt-get install --reinstall flashplugin-nonfree

worked... Strange!

Patrick Waters (pwaterz) wrote :

same problem here, tried installing from adobe website, package manager, terminal, and also tried reinstalling and nothing. Any one figure this out yet??

Changed in flashplugin-nonfree:
milestone: ubuntu-8.10-beta → ubuntu-8.10
GarthPS (garthps) wrote :

17 0CT still does not working for me
Intrepid 32bit up to date flashplugin nonfree installer (so flash version 10)
It is nbot a version probleme? flash10 is not completely retrocompatible with 9 no?
anyway for me the preoblem is that video are played but without sound and musique players like in myspace don't even start

i had repaired my flash plugin, it was the libnss3-1d package (require since flash 10rc), il was a svn version and it didn't upgrade to the stable version...

quigibo (compfreakkev) wrote :

I have the same problem except I don't even see the grey box.
On YouTube for instance, it says "you either have JavaScript turned off or an old version of Adobe's Flash Player."
Javascript is turned on and I just upgraded to the latest version of Flash.
Hopefully this will be fixed soon.

Daniel T Chen (crimsun) wrote :

For everyone still experiencing this symptom in current intrepid, please first ensure that you are not using any manually installed (i.e., in ~/.mozilla/firefox/...) Flash plugins, and second try:

sudo aptitude reinstall flashplugin-nonfree

Also, please report whether the steps resolve the symptom for you.

Note: Again, the above procedure is relevant /only/ for current intrepid (on either i386 or amd64 arch) using Ubuntu's flashplugin-nonfree package of Flash 10 final!

GarthPS (garthps) wrote :

I did not solve the probleme for me.

Dani (danielfrechoso) wrote :

Re-installing fixed the problem for me (intrepid beta amd64).

But I did try to reinstall from synaptic before reading this posts and that did not work, then I turned off "visual effects" off and in the meantime I found this bug-report. From there I reinstalled from terminal with the code provided and worked fine.

Now It is working with "visual effects" on (I do not know if the "visual effects is relevant at all).

Thanks!

GarthPS (garthps) wrote :

retested...still does not work
Intrepid kubuntu i686 up to date

GarthPS (garthps) wrote :

I have perhaps some news about this!
I reported this fews seconds ago:
https://bugs.launchpad.net/ubuntu/+source/kubuntu-meta/+bug/287545

Alexander Sack (asac) wrote :

maybe cased by nvidial-glx-177?

GarthPS (garthps) wrote :

nope was not that!
I have just tested the new Kubuntu intrepid ibex i386 RC
on a new account this time(not an hold home) and all work well now!
flash is ok with flashplugin-nonfree

E Liberman (register-fl) wrote :

Reinstall flashplugin-nonfree using Synaptic did the trick for me (using 8.10 RC).

I just upgraded from 8.04 to 8.10 this morning. Flash doesn't work. I tried reinstalling as suggested above, but no luck. This is frustrating -- flashplugin-nonfree is installed, firefox sees it, but any page that requires flash thinks I don't have it.

hang on, flash *is* working. It's just that the one site I use regularly with flash doesn't:

http://news.bbc.co.uk/1/shared/bsp/hi/live_stats/html/map.stm

It's the BBC's "Most Popular Stories" page.

Alexander Sack (asac) wrote :

On Mon, Oct 27, 2008 at 09:38:40AM -0000, Eamonn Sullivan wrote:
> hang on, flash *is* working. It's just that the one site I use regularly
> with flash doesn't:
>
> http://news.bbc.co.uk/1/shared/bsp/hi/live_stats/html/map.stm
>
> It's the BBC's "Most Popular Stories" page.
>

Thats a website bug then. report to BBC. they shouldnt try to do magic
and detect plugins. most likely they have a check that fails when
using flash 10

 - Alexander

Giorgio Catanzaro (catanzag) wrote :

Yesterday I upgraded to Intrepid and it doesn't work for me, too, and reinstalling doesn't fix it. I have Ubuntu Intrepid i386 fully updated, kernel 2.6.27-7-generic, driver nv.

Giorgio

sudo aptitude reinstall flashplugin-nonfree

Worked for me. This is on Intrepid through a software upgrade, i386 / NVidia.

One thing I noticed in my Firefox plugins:

It lists both Shockwave Flash 10.0 r12 and 9.0 r124.

There were no plugins in my ~/.mozilla/firefox folder, so I did not have to remove anything before trying this command.

But it worked! Thanks!

Michał Rudnicki (stronger) wrote :

I tried reinstalling flashplugin-nonfree several times, even installing it manually using provided Adobe installer. No success. If I run firefox from terminal I get

LoadPlugin: failed to initialize shared library /usr/lib/flashplugin-nonfree/libflashplayer.so [libnss3.so: cannot open shared object file: No such file or directory]
LoadPlugin: failed to initialize shared library /usr/lib/flashplugin-nonfree/libflashplayer.so [libnss3.so: cannot open shared object file: No such file or directory]
LoadPlugin: failed to initialize shared library /usr/lib/flashplugin-nonfree/libflashplayer.so [libnss3.so: cannot open shared object file: No such file or directory]

everyting I try to open a web page with flash on it. The about:plugins do not show Flash plugin on the list. Removing ~/.mozilla didn't make any difference.

And didn't have much success with Gnash and swfdec either, as they are not production ready.

Michał Rudnicki (stronger) wrote :

I just peeked at dmesg output and found a single line:

[ 1132.514942] libflashplayer.[9116]: segfault at 9517a4 ip b772b136 sp bfe4c6c4 error 4 in libflashplayer.so[b76fc000+951000]

There is only one line like that, despite I was running flash over and over again.

Alexander Sack (asac) wrote :

is that on amd64?

Michał Rudnicki (stronger) wrote :

Sorry, forgot to add my box spec. It's IA32. Video driver is fglrx

$ apt-cache show firefox | grep Version
Version: 3.0.3+nobinonly-0ubuntu2

$ apt-cache show flashplugin-nonfree | grep Version
Version: 10.0.12.36ubuntu1

$ uname -a
Linux uglybox 2.6.27-7-generic #1 SMP Thu Oct 30 04:18:38 UTC 2008 i686 GNU/Linux

$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]

mbana (m.bana) wrote :

Same problem here. I get an empty grey box.

$ uname -a
Linux mbana-desktop 2.6.27-7-generic #1 SMP Fri Oct 24 06:40:41 UTC 2008 x86_64 GNU/Linux

~$ apt-cache show firefox | grep Version
Version: 3.0.3+nobinonly-0ubuntu2

$ apt-cache show flashplugin-nonfree | grep Version
Version: 10.0.12.36ubuntu1

$ lspci | grep -i NVidia
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GTS 512 (rev a2)

mmorrisson (mmorrisson) wrote :

I was also getting this error when starting firefox:
LoadPlugin: failed to initialize shared library /usr/lib/flashplugin-nonfree/libflashplayer.so [libnss3.so: cannot open shared object file: No such file or directory]

I was able to get both flash and sound to work by resolving that link:
$ sudo ln -s /usr/lib/libnss3.so.1d /usr/lib/libnss3.so

Then there were two more I had to resolve:
$ sudo ln -s /usr/lib/libsmime3.so.1d /usr/lib/libsmime3.so
$ sudo ln -s /usr/lib/libssl3.so.1d /usr/lib/libssl3.so

Michał Rudnicki (stronger) wrote :

That solved the problem. Thanks mmorrisson!

One of Many (xlanton) wrote :

That worked for me to! Thanks!

Giorgio Catanzaro (catanzag) wrote :

Adding links as suggested by mmorison solved the problem for me too (thank you!!!), having the same symptoms. (i386 2.6.27-7 fully updated Intrepid)

Maybe this bug can be closed adding those links either in flashplugin-nonfree package (where problem is shown) or in libnss3-1d package (which provides the three *-ld libraries)

rumburak (s3506963) wrote :

Was fixed for me for a bit, but over the last week to 2 wks, for some reason, flash will work for a bit, (no more than a day or two) after a sudo apt-get install --reinstall flashplugin-nonfree, then it stops working again until I do another sudo apt-get install --reinstall. Is anyone else having this almost daily regression, or is it just me, (-9 kernel, FF 3.0.4)?

Alexander Sack (asac) wrote :

On Fri, Dec 05, 2008 at 08:53:47PM -0000, Dylan Hunter wrote:
> Was fixed for me for a bit, but over the last week to 2 wks, for some
> reason, flash will work for a bit, (no more than a day or two) after a
> sudo apt-get install --reinstall flashplugin-nonfree, then it stops
> working again until I do another sudo apt-get install --reinstall. Is
> anyone else having this almost daily regression, or is it just me, (-9
> kernel, FF 3.0.4)?
>

You sure that a reinstall fixes it? What about a reboot? Does it work
for you at least a few times after a fresh reboot without
reinstalling?

 - Alexander

Reinstall definitely fixes, (and is much quicker than a reboot) but
next time it happens, I'll try a reboot to see if that works and let
you know.

Quoting Alexander Sack <email address hidden>:

> On Fri, Dec 05, 2008 at 08:53:47PM -0000, Dylan Hunter wrote:
>> Was fixed for me for a bit, but over the last week to 2 wks, for some
>> reason, flash will work for a bit, (no more than a day or two) after a
>> sudo apt-get install --reinstall flashplugin-nonfree, then it stops
>> working again until I do another sudo apt-get install --reinstall. Is
>> anyone else having this almost daily regression, or is it just me, (-9
>> kernel, FF 3.0.4)?
>>
>
> You sure that a reinstall fixes it? What about a reboot? Does it work
> for you at least a few times after a fresh reboot without
> reinstalling?
>
>
> - Alexander
>
> --
> Flash not working: Intrepid, 2.6.27, FF3
> https://bugs.launchpad.net/bugs/262693
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Dylan Hunter
Interactive Entrepreneur Making a Difference
http://dylanhunter.com

Just happened again. Reboot also fixes. Will let you know if / when
it fails again.

Don't know if it's related or not, but when I tried to reboot when
flash failed, got the double Ubuntu progress bar, (upper one updating,
lower one doing nothing) that I believe I've only gotten when I
clean-install Ubuntu, (i.e. haven't seen the double bar since I
flattened my laptop after the RC's to install a final, clean 8.10).

Quoting Alexander Sack <email address hidden>:

> On Fri, Dec 05, 2008 at 08:53:47PM -0000, Dylan Hunter wrote:
>> Was fixed for me for a bit, but over the last week to 2 wks, for some
>> reason, flash will work for a bit, (no more than a day or two) after a
>> sudo apt-get install --reinstall flashplugin-nonfree, then it stops
>> working again until I do another sudo apt-get install --reinstall. Is
>> anyone else having this almost daily regression, or is it just me, (-9
>> kernel, FF 3.0.4)?
>>
>
> You sure that a reinstall fixes it? What about a reboot? Does it work
> for you at least a few times after a fresh reboot without
> reinstalling?
>
>
> - Alexander
>
> --
> Flash not working: Intrepid, 2.6.27, FF3
> https://bugs.launchpad.net/bugs/262693
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Dylan Hunter
Interactive Entrepreneur Making a Difference
http://dylanhunter.com

Larry Abee (larryabee) wrote :

simple solution

do: 'sudo apt-get install --reinstall flashplugin-nonfree'

flash /should/ work fine after that in /most/ cases

Chris Mc (cmcneilly) wrote :

I'm experiencing the same issue as Dylan. I can fix it through rebooting my machine OR by reinstalling, but it breaks within a day.

Gustavo Carneiro (gjc) wrote :

No need to reboot the machine, just firefox. Make sure to close all FF windows, then open FF again, flash should be back to normal.

Chris Mc (cmcneilly) wrote :

As of this morning, videos stop working about 15-30 seconds in. I can restart firefox or even browse to a new video, and it will start playing and then stop. Other flash programs, most notably charts on Google Analytics, which used to stop working, appear to continue to show (at least for the last 24 hours). So, maybe this IS a sound issue?

Alexander Sack (asac) wrote :

On Fri, Mar 06, 2009 at 02:21:28PM -0000, Chris Mc wrote:
> As of this morning, videos stop working about 15-30 seconds in. I can
> restart firefox or even browse to a new video, and it will start playing
> and then stop. Other flash programs, most notably charts on Google
> Analytics, which used to stop working, appear to continue to show (at
> least for the last 24 hours). So, maybe this IS a sound issue?
>

Your symptoms sound like a sound buffering issues. yes.

 - Alexander

Chris Mc (cmcneilly) wrote :

Alexander,

Ok, so what can be done about it? Is there a fix for this?

Thanks,

Chris

Alexander Sack wrote:
> On Fri, Mar 06, 2009 at 02:21:28PM -0000, Chris Mc wrote:
>
>> As of this morning, videos stop working about 15-30 seconds in. I can
>> restart firefox or even browse to a new video, and it will start playing
>> and then stop. Other flash programs, most notably charts on Google
>> Analytics, which used to stop working, appear to continue to show (at
>> least for the last 24 hours). So, maybe this IS a sound issue?
>>
>>
>
> Your symptoms sound like a sound buffering issues. yes.
>
> - Alexander
>
>

--
E-mail marketing got smarter, just in the nick of time.
SmartBrief ensures that you reach your target audience and
proves it with measurable results. Optimize your online advertising
spending for a down economy. Contact a SmartBrief expert today.

http://www.smartbrief.com/advertise/contact_us.jsp

--
Chris McNeilly
Vice President, Technology
SmartBrief, Inc.
(202) 737-5500 x225
Fax (202) 737-9601

Chris Mc (cmcneilly) wrote :

As I watch a flash video, it starts off fine, then the firs thing to go is the video, which turns grey, then after about 2-3 seconds, the sound stops. I've followed various instructions on re-installing pulse audio and the like, but nothing is helping.

Alexander Sack (asac) wrote :

seems to be still active ... reassigning to flashplugin package

Changed in flashplugin-nonfree (Ubuntu):
milestone: ubuntu-8.10 → none
Sybrand (sybrand-strauss) wrote :

I'm getting this since installing the Jaunty beta (it affects Firefox and Opera on my machine)

Winston JC Weinert (wjcw) wrote :

I'm getting this on Jaunty. Flash just stops working for new tabs and displays a white box. It happens at least once a week, and is fixed by restarting firefox.

I can't remember, but I think it has the same effect in firefox 3; I am using 3.5 as of late.

Make sure you do NOT have multiple plugins installed.

dpkg -l | grep flash; dpkg -l | grep gnash; dpkg -l | grep swf

should NOT output other than:

flashplgin-nonfree

if it does, remove the other packages in some way (apt-get, aptitude, synaptic etc) and leave the 1 package in tact

You can also use:

http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.32.18.linux-x86_64.so.tar.gz

if you fancy using the 64bit flash (its alpha) just dro pthe file into your plugins folder and you are set, unfortunately this will not autoupdate with system updates.

gcincilla (gcincilla) wrote :

actionparsnip, thank you so much!!! You definitively solved my problem! I was having more than a plug in installed.
Thank you again.

It appears your problem has been solved. If this is not the case, feel free to reopen the bug.

Thanks!

Changed in adobe-flashplugin (Ubuntu):
status: Triaged → Invalid
Changed in nspluginwrapper (Ubuntu):
status: Fix Released → Fix Committed
Changed in nspluginwrapper (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions