Ubuntu

drop synaptics from racy /etc/acpi/asus-touchpad.sh

Reported by Łukasz Wieczorek on 2011-06-30
332
This bug affects 152 people
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Medium
Timo Aaltonen
Precise
Undecided
Unassigned

Bug Description

On my Thinkpad T410 I have a touchapd and a trackpad. When I log in only trackpad responds. I tried to manualny enable touchpad, but it didnt work (xinput). I also tried alternative software like gpointing-device-settings with no effect. The bug is present in Unity and Gnome 3 desktop. I also tried xfce4 which works fine. In Ubuntu 11.04 in classic gnome i had no problems switching between those devices using fn+f8. I'm using Ubuntu 11.10.
---
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007.1)
NonfreeKernelModules: nvidia
Package: unity 4.0.1-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=pl_PL:en
 PATH=(custom, no user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Tags: oneiric unity-2d
Uname: Linux 3.0-2-generic x86_64
UpgradeStatus: Upgraded to oneiric on 2011-06-26 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
---
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110702)
NonfreeKernelModules: nvidia
Package: unity 4.0.1-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 PATH=(custom, no user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Tags: oneiric running-unity unity-2d
Uname: Linux 3.0-2-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Given the evidence in your comment it seems this problem is somehow related to Unity. Please run apport-collect for provide Unity specific version information and logs.

affects: ubuntu → unity (Ubuntu)
Changed in unity (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected oneiric unity-2d
description: updated

apport information

I installed a clean Oneiric daily build and I see no signs of the problem.

I was wrong. It was enough to press fn+f8 for the touchpad to go down again. Trackpad works all the time. Touchpad doesn't want to go up.

tags: added: running-unity
description: updated

apport information

apport information

Lucasz, Did you try to reproduce the bug under Unity in Ubuntu 11.04? as I dont see any indication of that.

I just installed 11.04 and there's no such bug in Unity.

affects: unity (Ubuntu) → ubuntu
summary: - trackpad detected as touchpad
+ can't enable touchpad in Ubuntu 11.10
affects: ubuntu → unity (Ubuntu)

I have same problem, I tested it under unity 2d and 3d and in both, there it occurrs
I have thinkpad T500

Omer Akram (om26er) wrote :

Its not a bug in Unity, the reporter mentioned it explicitly the problem also happens in Gnome3 as well. My best gues would be gnome-settings-daemon(or gnome-control-center or related packages. The issue does not happen because xfce I believe uses something different

affects: unity → null
affects: unity (Ubuntu) → ubuntu
Dave Russell (drussell) wrote :

Just to confirm I'm also seeing this in a fully updated 11.10 as of now on an X201 laptop also.

Fred (fredrooks) wrote :

I'm suffering from this bug, too. My laptop is an R400.

renato one (r-pasq) wrote :

i have the same problem on my thinkpad sl510

first it works but after disabling once the touchpad, its not working in any way

Dave Russell (drussell) on 2011-09-07
Changed in ubuntu:
status: Incomplete → Confirmed
Alberto Milone (albertomilone) wrote :

@Chase: any ideas about this?

Joshua R. Poulson (jrp) wrote :

My W510 touchpad is working, but I cannot get my external Apple trackpad to work, although the bug for that is marked fixed: https://bugs.launchpad.net/ubuntu/oneiric/+source/linux/+bug/814250

Chase Douglas (chasedouglas) wrote :

I'm not sure exactly which devices we're talking about. For me, trackpad and touchpad are synonymous. My working assumption is that the built-in trackpads are working for people, but the Apple Magic Trackpad is not.

The bug referenced by Joshua in comment #16 is a previous bug that was fixed in Natty. There is a new bug that cropped up in Oneiric. That is being tracked in bug #842612. The fix has been committed to the Oneiric kernel repo, but it has not been released yet. The next kernel upload, which I think will happen this week, will include the fix.

If that is the issue people are having, please mark this bug as a duplicate of 842612. Otherwise, please provide information on what devices are working and not working, and attach copies of /var/log/Xorg.0.log and dmesg.

Thanks!

Fred (fredrooks) wrote :

I think this is a bug in gnome-settings-daemon. Here's why:

The touchpad on Thinkpads (see /etc/acpi/events/lenovo-touchpad) is toggled by /etc/acpi/asus-touchpad.sh. On my R400, pressing Fn+F8 successfully changes the value of the Synaptics Off (269) xinput property. The Device Enabled (132) property, however, is set to 0, so the touchpad is disabled for some reason, but enabling it by xinput set-int-prop 11 "Device Enabled" 8 1 doesn't work when the gnome-settings-daemon is running. If I kill it, I can enable the device through xinput set-int-prop, and then the Fn+F8 shortcut works as expected.
See http://irclogs.ubuntu.com/2011/07/04/%23ubuntu-x.txt

Dave Russell (drussell) wrote :

@Chase: No, the built in touchpads on my Lenovo T500 and Lenovo X201 laptops are not working with 11.10.

Therefore this is not a dupe of bug #842612.

dmesg and Xorg.0.log output to follow.

I should add that the "touchpoint" (red nipple shaped mouse in the centre of the keyboard) works fine, its just the touchpad that doesn't work. This is the same on both laptops.

Dave Russell (drussell) wrote :
Marek Kalnik (wdev) wrote :

This bug affects me aswell. The touchpad works in lightgdm then it stops working when Unity loads. Worked well with 11.04. Touchpad is well recognized by kernel (ETPS/2 Elantech Touchpad appears in xinput --list), but is desactivated.

This is what happens when I try to use xinput set-int-prop 13 "Device Enabled" 8 1 (output of watch-props):

 Device Enabled (144) (558): 1
Property 'Device Enabled' changed.
 Device Enabled (144): 1
Property 'Device Enabled' changed.
 Device Enabled (144): 1
Property 'Synaptics Tap Action' changed.
 Synaptics Tap Action (304): 0, 0, 0, 0, 0, 0, 0
Property 'Synaptics Edge Scrolling' changed.
 Synaptics Edge Scrolling (295): 0, 0, 0
Property 'Synaptics Two-Finger Scrolling' changed.
 Synaptics Two-Finger Scrolling (296): 1, 0
Property 'Synaptics Edge Scrolling' changed.
 Synaptics Edge Scrolling (295): 0, 0, 0
Property 'Synaptics Two-Finger Scrolling' changed.
 Synaptics Two-Finger Scrolling (296): 1, 0
Property 'Device Enabled' changed.
 Device Enabled (144): 0
Property 'Device Enabled' changed.
 Device Enabled (144): 0

Marek Kalnik (wdev) wrote :

Just one more thing. After I launch the command:
xinput set-int-prop 13 "Device Enabled" 8 1

A new line appears in Xorg.0.log : [ 1824.302] (--) ETPS/2 Elantech Touchpad: touchpad found

Fred (fredrooks) wrote :

After recent updates, this bug no longer affects me.

martincasc (martincasco) wrote :

I have the same Issue. I've installed Oneiric from a clean instalation. I'm using a MSI CR620 laptop and touchpad doesn't work. Even Fn+F3 work.

Emily Strickland (hypodermia) wrote :

After upgrading to Oneiric from Natty, this bug affects me. After I kill gnome-settings-daemon, I am able to enable the touchpad using xinput. Re-enabling gnome-settings-daemon disables the touchpad again.

martincasc (martincasco) wrote :

Well, a quick solution could be this (From ArchLinux wiki page).

* Install "dconf-tools";
* Launch it
* Search for: /org/gnome/settings-daemon/plugins/touchpad/
* Check "tochpad-enable"

This solution "fixed" the problem, in my case at least.

Regards.

Emily Strickland (hypodermia) wrote :

I would amend comment #26 to say that I had to open the dconf-editor, browse to '/org/gnome/settings-daemon/peripherals/touchpad/', find the key called 'touchpad-enabled', and set it to true by checking it.

RobinJ (robinj) wrote :

Why hasn't this been fixed in the final release?! Come one, someone gave a fix, and in the "final release" I just stumbled upon this problem as well!

Ryan Whalen (qf-ryan-nr) wrote :

I just upgraded. Experiencing this problem as well on a W510. Touchpoint works, trackpad does not.

Patrick Wandro (pwandro) wrote :

I just upgraded and also experienced this problem. I was able to fix it by installing synaptiks, which I found through the software center. After installing I simply started the program and the touchpad worked.

Mervin Mondal (timon-mondal) wrote :

I just did a clean install of 11.10 and experiencing the same problem. The touchpad was working fine during installation but after everything was done and it ran for the first time it wasn't working. The trackpad works. My machine is a Thinkpad T410

Hi All, the bug is due to a change in the name of the touch pad. (possibly due to driver changes.)

Edit the file /etc/acpi/asus-touchpad.sh

change this line:
XINPUTNUM=`xinput list | grep 'SynPS/2 Synaptics TouchPad' | sed -n -e's/.*id=\([0-9]\+\).*/\1/p'`

to this:
XINPUTNUM=`xinput list | grep 'ETPS/2 Elantech Touchpad' | sed -n -e's/.*id=\([0-9]\+\).*/\1/p'`

I did a clean install and under my machine everything seems ok. I can disable/enable touchpad without problems with fn+f8. Although theres no indication that I disable/enable touchpad as there was in 11.04.

zemadz (zemadz) wrote :

I was having this problem too in Ubuntu 3D mode, but when I lost the top and side Unity panels, then I had to resort to Ubuntu 2D mode and it works with the fallback Unity interface.

I can confirm that the fix in comment #32 works with Asus X73E. I'd imagine it works with most Elantech touchpads.

Paul Weiss (interweiss) wrote :

I also have an Asus. My touchpad was working and then for some reason it stopped working today. I tried the solution in post #32 and so far everything is working.

Vince Indriolo (y-vince) wrote :

I have a thinkpad T520, and my touchpad stopped working after upgrade.
I tracked /etc/acpi/events/lenovo-touchpad to a problem with the getXuser function in /usr/share/acpi-support/power-funcs.

I changed this line:
        user=$(who | awk "/:$displaynum)/ { print \$1; exit }")
to this (escaping the parenthesis):
        user=$(who | awk "/:$displaynum\)/ { print \$1; exit }")

and I was able to enable my touchpad.

Graham Hawkins (grahamhawkins) wrote :

My Acer Aspire One afflicted with this. Post #26 solution works for me.

Grady Fields (ramjacvp) wrote :

I also have this problem with a Thinkpad T61 upgraded from natty to oneiric. Post 37 did not fix the issue for me

René Moser (resmo) wrote :

Thinkpad T410, same problem after upgraded from natty to oneiric. Post 37 did not fix it. Touchpad works _before_ login, but after login only trackpoint works.

gabore (gabriel-balazs) wrote :

Gateway p-7811fx, installing synaptiks and launching it solved the issue.

René Moser (resmo) wrote :

Clean install fixed the problem for 10 minutes. Enabled 2 finger scrolling, worked fine. Another 5 minutes, touchpad is gone...

gabore (gabriel-balazs) wrote :

@resmo: It was like that for me - after each login, the touchpad seemed working, but in a few minutes it was off again. Tried installing synaptiks yet?

René Moser (resmo) wrote :

Found a workaround to reenable touchpad:

* sudo aptitude install dconf-tools
* dconf-editor
* Search for: /org/gnome/settings-daemon/peripherals/touchpad/
* Check "touchpad-enabled"

Hope this helps

I got it to work on thinkpad T420 by using
sudo xinput set-int-prop 11 "Synaptics Off" 8 0
the bug happens because there are two properties governing the touchpad "on" status "device Enabled" and "Synaptics Off" and they must be set to 1 and 0 respectively if the touchpad is to work the problem arised because they switched asynchronously when you enable or disable the device. I couldn't change the device enabled property so i changed the "Synaptics Off" to 0 to get them back into sync. you can now disable and enable the device however i didnt yet restart to see what happens next time i boot up

JT Bates (jtbates) wrote :

#46 worked for me on a Thinkpad T400
Thanks Mohamed!

Fabien_Tivolle (tivolle) wrote :

Working on a Thinkpad T61:
I did:
sudo xinput set-int-prop 11 "Synaptics Off" 8 0

Followed with
Fn + F8

Touchpad is working now.

Thanks.

uwer@netic.de (uwer) wrote :

#46 wasn't working on my Thinkpad SL510:

I had to replace the "0" with a "1"

sudo xinput set-int-prop 11 "Synaptics Off" 8 1

and then
Fn + F8

Thank you.

uwer@netic.de (uwer) wrote :

One reboot later the above #49 doesn't work any more and I can't seem to reenable the touchpad. Sorry if I lead anyone astray.

Workaround #45 worked for me.

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
Erica Peterson (probabilistic) wrote :

Workaround #45 worked for me as well; thanks! Thinkpad X201, running 11.10.

Marco Ciampa (ciampix) wrote :

With last update my synaptic touchpad does not work anymore. Now I'm forced to use an external mouse. Noone of the here described remedies worked for me. I have a Ubuntu 11.10 amd64 with a Acer Extensa 5220.

Marco Ciampa (ciampix) wrote :

Something strange going on.

modprobe -r psmouse
modprobe psmouse

reenable it. ???

dansheen (dansheen) wrote :

Workaround #45 worked for me, too: Lenovo T420

This problem is affecting me too.. I usually use an external mouse so I didn't notice before. I'm on a T520 with 11.10. The red nub is good, but the trackpad is disabled. Workaround #45 didn't do it for me. Neither did #46.

Lars Volker (lv) wrote :

I'm affected on an t400 as well. The dconf-editor settings change the same entry in the database as does pushing Fn+F8, hence #45 didn't improve on the situation. #46 didn't fix it and generally showed no noticable changes at all.

eldad (eldad-a) wrote :

Killing gnome-settings-daemon resolves the issue for me (pressing fn-f8 turns the touchpad on/off & shows on screen notice of it).
Killing it a second time turns of some features (including the discussed behaviour) and appearance settings (such as the Unity top bar).
After killing it twice and running it once the desired behaviour is retrieved.

I did not test the functionality further but it seems that gnome-settings-daemon is run more than once when I log-on.

Running ubuntu 11.10 which has been upgraded from previous versions (not a fresh install).

amir (vijayamirtharajit) wrote :

Hi,

I am also facing same problem,I upgraded Ubuntu 11.10 from Ubuntu 11.04.
My laptop model is Sony Vaio VPCZ136GG/B.

Regards,
Vijayamirtharaj

Adis (adis-osmonov) wrote :

#27 works for me greatly. Thx all.

Tessa Lau (tlau) wrote :

#46 worked for me, Lenovo T410 / Oneiric / Gnome 3D desktop. Thanks!

Zentai Andras (andras-zentai) wrote :

I have T500.

Touchpad is gone unresponsible after a few minutes of usage.
I was also unable to switch it on and off with Fn+F8
(The small red trackpoint is still usable.)

#46 worked for me. (#26-#27 not, #32 not, #45 not)

bitinerant (bitinerant) wrote :

This bug effects me with 12.04 fresh install on a ThinkPad T420s. Comment #46 works around the issue nicely (Fn-F8 toggles touchpad on and off properly) until the next reboot:

    sudo xinput set-int-prop 11 "Synaptics Off" 8 0

pierre (pierre-nespo) wrote :

Hello,

I just bought a Thinkpad t420s and i am experiencing this bug.
It happens when the latop is on battery, everything's good when on charge, #46 did it for me until next reboot.

Shimi Chen (shimi-chen) on 2012-05-26
affects: ubuntu → gnome-settings-daemon (Ubuntu)
Sebastien Bacher (seb128) wrote :

is that still an issue in precise? does it happen out of GNOME sessions (i.e under KDE or XFCE)? is that specific to thinkpads?

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
summary: - can't enable touchpad in Ubuntu 11.10
+ can't enable touchpad in Ubuntu 11.10 (thinkpads)

Tested today--yes, it is still a problem on Precise (Unity session, ThinkPad T420s). Fix in comment #46 works until reboot.

summary: - can't enable touchpad in Ubuntu 11.10 (thinkpads)
+ can't enable touchpad in Ubuntu (thinkpads)

Ok, that bug is confusing and mixing several bugs and issues:

- the acpi-support escaping issue described in comment #37 seems to have been addressed since
- the "touchpad stop working after some time" from comment #62 should be fixed in precise
- the other comments seem an issue when the touchpad doesn't work by default

The bug description mentions "trackpad" and "touchpad", what's the difference for those. Do the people having the issue have a rectangle zone bellow their keyboard and a small round device in the middle of the keyboard? Is the issue specific to the flat rectangle area there?

If you still get the issue in precise could you:
- describe your available devices
- describe exactly what issue you get
- run "xinput", note the

Sebastien Bacher (seb128) wrote :

(ups, validated the comment by error)

- run "xinput", note the id=ID
- run "xinput list-props ID" and "xinput list ID" and copy the logs here?

Nick Barcet (nijaba) wrote :

Still having the issue of my touchpad (SynPS/2 Synaptics TouchPad) only working for a few minutes after each reboot with precise.

Attaching the requested logs.

Nick Barcet (nijaba) wrote :
Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Confirmed
Timo Aaltonen (tjaalton) wrote :

Nick, what if you run 'gconftool --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true', does it work then?

If yes, the issue is that your g-s-d settings have it disabled, and then when you log in and g-s-d starts, it sets "Device Enabled" to "0", but doesn't touch "Synaptics Off". The bug is in g-s-d and it's peculiar way to touch both settings, where 'xinput disable' only touches the other one.

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Confirmed → Incomplete
Timo Aaltonen (tjaalton) wrote :

Correction, g-s-d seems to do the right thing, it's /etc/acpi/asus-touchpad.sh that's messing with the "Synaptics Off" property (as pointed out by others).

affects: gnome-settings-daemon (Ubuntu) → acpi-support (Ubuntu)
Changed in acpi-support (Ubuntu):
importance: Low → Medium
status: Incomplete → Triaged
Timo Aaltonen (tjaalton) on 2012-09-12
summary: - can't enable touchpad in Ubuntu (thinkpads)
+ remove racy /etc/acpi/asus-touchpad.sh
Timo Aaltonen (tjaalton) on 2012-09-12
summary: - remove racy /etc/acpi/asus-touchpad.sh
+ remove/edit racy /etc/acpi/asus-touchpad.sh

The only sane way to fix this would be to drop handling synaptics touchpads from asus-touchpad.sh. Don't know if Elantech uses synaptics these days (meaning that g-s-d would handle disabling it), so that could be left in for now.

Timo Aaltonen (tjaalton) on 2012-09-13
summary: - remove/edit racy /etc/acpi/asus-touchpad.sh
+ drop synaptics from racy /etc/acpi/asus-touchpad.sh
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in acpi-support (Ubuntu Precise):
status: New → Confirmed
downward (invisioslice) wrote :

This bug affects me too. Netbook ACER ONE UBUNTU 12.04

This is a partial solution: https://answers.launchpad.net/touchpad-indicator/+question/195181 but the touchpad scroll is dead.

Timo Aaltonen (tjaalton) wrote :

uploaded to both quantal and precise-proposed, waiting in the queue.

Changed in acpi-support (Ubuntu):
status: Triaged → Fix Committed
Changed in acpi-support (Ubuntu Precise):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acpi-support - 0.141

---------------
acpi-support (0.141) quantal; urgency=low

  [ Steve Langasek ]
  * drop asus-brightness-{up,down} handlers and asus-brn-{down,up} scripts.
    LP: #955176.

  [ Timo Aaltonen ]
  * asus-touchpad.sh: Don't handle Synaptics devices. (LP: #804109)
 -- Timo Aaltonen <email address hidden> Tue, 09 Oct 2012 13:32:35 +0300

Changed in acpi-support (Ubuntu):
status: Fix Committed → Fix Released

Hello Łukasz, or anyone else affected,

Accepted acpi-support into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/acpi-support/0.140.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in acpi-support (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

The fix for this bug has been awaiting testing feedback in the -proposed repository for precise for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Timo Aaltonen (tjaalton) wrote :

sorry for the delay, verified it myself

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acpi-support - 0.140.1

---------------
acpi-support (0.140.1) precise-proposed; urgency=low

  * asus-touchpad.sh: Don't handle Synaptics devices. (LP: #804109)
 -- Timo Aaltonen <email address hidden> Tue, 09 Oct 2012 13:35:58 +0300

Changed in acpi-support (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers