X crashes on second resume from suspend-to-ram on Thinkpad X41

Bug #56365 reported by Dagfinn Ilmari Mannsåker on 2006-08-14
50
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: xserver-xorg

Suspend and resume works fine the first time after a reboot, but the second time X crashes and is unable to restart. I'll attach full dmesg and X server logs.

I'm running up-to-date Edgy on a Thinkpad X41, with the following versions of the kernel and X.org:

linux-image-2.6.17-6-686 2.6.17-6.18
xserver-xorg 7.0.22ubuntu7
xserver-xorg-video-i810 1.6.5-0ubuntu2

I can no longer reproduce this with xserver-xorg-video-i810 1.6.5-0ubuntu3, feel free to close.

This seems to have been fixed by xserver-xorg-video-i810 1.6.5-0ubuntu3, closing.

Changed in xorg:
status: Unconfirmed → Fix Released

I seem to have spoken too soon, I can still see the problem with the followng versions of the (I believe) relevant packages:

linux-image-2.6.17-10-generic 2.6.17-10.26
xserver-xorg 7.0.22ubuntu10
xserver-xorg-core 1.1.1-0ubuntu11
xserver-xorg-video-i810 1.6.5-0ubuntu3
vbetool 0.6-1.1

The X.org log is attached.

I don't know why it worked that one time, but it's back again now.

Changed in xorg:
status: Fix Released → Unconfirmed
Gregory Oschwald (osch0001) wrote :

I am seeing this same problem on my X60s. See #63068. The crash report may or may not be relevant there though but the log should be.

Gregory Oschwald (osch0001) wrote :

After setting SAVE_VBE_STATE to false in /etc/default/acpi-support, X appears to resume fine.

Matthew Garrett (mjg59) on 2006-10-10
Changed in xorg:
importance: Undecided → Critical
status: Unconfirmed → Confirmed

SAVE_VBE_STATE=false causes the screen not to come back at all after resume on my X41 (but X doesn't crash, AFAICS from the logs).

Daniel T Chen (crimsun) wrote :

For the X41 users, please ensure that you're using the latest bios, 2.07.

Gregory Oschwald (osch0001) wrote :

Now my screen doesn't turn on after resume from suspend to RAM on my X60s either, although I don't know if it is related to the problems of the X41 users or not. The green moon suspend light continues to blink, but I can reboot it from the command line by logging in blind. This may be related to the recent kernel update, as it was working fine before I rebooted for that.

Rob Latham (rob-terizla) wrote :

I'm seeing a similar inability to come back from sleep on a thinkpad x40. Green moon flashes, but I cannot interact with the computer in any meaningful way except to power it off.

sog (sogrady) wrote :

similar behavior observed on my x60s, see 65806. it's not just X, however; second resume triggers a kernel panic that appears to be SMP related.

sog (sogrady) wrote :

one additional note: updating the x60s to the latest (2.08) BIOS does not affect the inability to suspend. behavior is as before.

Wenzhuo Zhang (wenzhuo) wrote :

I installed edgy on my ThinkPad X32 since 6.10 beta. Both suspending to RAM and to disk have been problematic since then. For details, please check my comments on bug #50031 <https://launchpad.net/bugs/50031>.

After updating the linux-image-2.6.17-10-generic package to 2.6.17-10.33 this morning, the situation is getting better: among about a dozen of suspend-to-ram and suspend-to-disk tests, I was only able to reproduce restoring failures after suspending to RAM twice. The symptoms are blinking "blue moon" LED and black screen.

It might be different bug than this one. I am wondering if I should open a new bug.

The patch at http://www.codon.org.uk/~mjg59/tmp/acpi-support.debdiff seems to fix the problem for me (I've suspended and resumed about half a dozen times without problems now). Thanks a million, Matthew!

Tollef Fog Heen (tfheen) wrote :

acpi-support (0.90) edgy; urgency=low

  * Explicitly switch the screen back to text mode if it was that way
    before resume

 -- Matthew Garrett <email address hidden> Sun, 15 Oct 2006 18:09:03 +0100

Changed in xserver-xorg-video-i810:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers