Ubuntu

[gutsy] resuming from suspend/hibernate broken

Reported by slazZ on 2007-08-31
56
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: acpi-support

After upgrading acpi-support from 0.96ubuntu1 to 0.98, resuming from hibernation and suspension fails.
For me, i got a fresh gdm login screen.
Seems like the xerver state cannot be reverted to its state and gets restartet, but i can't find anything in the logs acpid/dmesg/messages/syslog/Xorg.0.log

Other people get only a black screen during resuming: http://ubuntuforums.org/showthread.php?t=539540
But i think its the same bug, because it appears after the acpi-support upgrade.

Running gutsy on a Thinkpad R60

Related branches

Tom Vetterlein (smbm) wrote :

I'm also suffering from this.

I originally thought it was related to this:

https://bugs.launchpad.net/ubuntu/+source/powermanagement-interface/+bug/136433

but it turns out it's another bug which I am also suffering from.

Russ-ST24 (russ-ryan) wrote :

Same here. T61 with NVidia NVS140. Was working fine until the acpi-support update I picked up today. Now get black screen and flashing sleep light when resuming.
Russ

TJ (tj) wrote :

Checking the differences there are lots of changes, but in particular this relating to Thinkpads:

diff -ru acpi-support-0.96ubuntu1/lib/IBM.config acpi-support-0.98/lib/IBM.config
--- acpi-support-0.96ubuntu1/lib/IBM.config 2007-03-22 03:00:56.000000000 +0000
+++ acpi-support-0.98/lib/IBM.config 2007-08-31 04:17:49.000000000 +0100
@@ -16,6 +16,7 @@
   ACPI_SLEEP=true;
   SAVE_VIDEO_PCI_STATE=true;
   SAVE_VBE_STATE=false;
+ POST_VIDEO=false;
  ;;
  # R52
  1846*|1847*|1848*|1849*|1850*|1858*|1870*)

So, try editing /usr/share/acpi-support/IBM.config and commenting out "POST_VIDEO=false" so that section looks like:

 # R50e
 1834*|1842*|2670*)
  ACPI_SLEEP=true;
  SAVE_VIDEO_PCI_STATE=true;
  SAVE_VBE_STATE=false;
# POST_VIDEO=false;
 ;;
 # R52

That will take the file back to the 0.96 state.

Changed in acpi-support:
assignee: nobody → intuitive-nipple
Joe Smith (yasumoto7) wrote :

I get a black screen when resuming on my Dell E1505 with Gutsy Tribe 5.

khul (klas-hultqvist) wrote :

I seem to be having the same/a similar problem on an hp tc4400. After suspend the X-session is lost and I have to log into a new one. In /var/log/syslog I see

 gdm[5304]: WARNING: gdm_slave_xioerror_handler: Fatal X error - Restarting :0

Was working OK before this morning's upgrade, including

acpi-support (0.96ubuntu1) to 0.98
xserver-xorg-video-vesa (1:1.3.0-1ubuntu4) to 1:1.3.0-1ubuntu5

Nemanja Stefanovic (nemik) wrote :

TJ,

There was no difference for me after applying your change. It does make sense but it seems the issues is not with that line, commenting it out did not allow suspend to return normally.

Taking the acpi_sleep parameter out of the kernel line on boot also did not help.

This is on a Thinkpad T61 with Intel video card.

TJ (tj) wrote :

Nemanja, thank-you for testing that. At least in your case we seem to have ruled that Thinkpad-specific change out.

Up to now the descriptions of the problem had focused on the acpi-support update but I see khul has just reported that xserver-xorg-video-vesa was also updated - and that may have more impact on the errors you're seeing.

Could each of you having this problem please check which updates were applied just prior to you first noticing the problem?

You can do this from Synaptic Package Manager through its File > History dialog and stepping through the dates. Please report all updated packages, not just the two being talked about here, just-in-case others have a bearing on the issue.

Tom Vetterlein (smbm) wrote :

I only noticed that there was a problem with suspend after reading this bug report. At the moment I'm working from home and I only usually suspend if I'm commuting and working on the train etc.

I just checked it to confirm the bug.

I can give you a list of packages I've upgraded over about 2 days during which time I noticed the problem if that's any use.

Tom Vetterlein (smbm) wrote :

Commit Log for Fri Aug 31 09:21:25 2007

Upgraded the following packages:
acpi-support (0.96ubuntu1) to 0.98
hotkey-setup (0.1-17ubuntu11) to 0.1-17ubuntu13
evolution-webcal (2.11.90-0ubuntu1) to 2.11.91-0ubuntu1
file-roller (2.19.90-0ubuntu1) to 2.19.91-0ubuntu1
gnome-applets (2.19.1-0ubuntu3) to 2.19.1-0ubuntu4
gnome-applets-data (2.19.1-0ubuntu3) to 2.19.1-0ubuntu4
gnome-icon-theme (2.19.90-0ubuntu1) to 2.19.91-0ubuntu1
gnome-mag (1:0.14.6-1ubuntu1) to 1:0.14.8-0ubuntu1
gnome-system-monitor (2.19.91-0ubuntu1) to 2.19.91.1-0ubuntu1
gtk2-engines (1:2.11.6-0ubuntu1) to 1:2.11.7-0ubuntu1
libgnome-mag2 (1:0.14.6-1ubuntu1) to 1:0.14.8-0ubuntu1
python-notify (0.1.1-1ubuntu1) to 0.1.1-1ubuntu2
ubuntu-desktop (1.68) to 1.69
ubuntu-minimal (1.68) to 1.69
ubuntu-standard (1.68) to 1.69
xserver-xorg-video-vesa (1:1.3.0-1ubuntu4) to 1:1.3.0-1ubuntu5

Sitsofe Wheeler (sitsofe) wrote :

I think I ran into this yesterday but having done a fix I can no longer reproduce the original problem. Can someone still seeing the issue attach their
/etc/acpi/prepare.sh
file to this bug?

TJ (tj) wrote :

The diff I did yesterday shows:

diff -ru acpi-support-0.96ubuntu1/prepare.sh acpi-support-0.98/prepare.sh
--- acpi-support-0.96ubuntu1/prepare.sh 2006-04-21 16:06:06.000000000 +0100
+++ acpi-support-0.98/prepare.sh 2007-08-31 03:13:20.000000000 +0100
@@ -1,5 +1,7 @@
 #!/bin/bash

 for SCRIPT in /etc/acpi/suspend.d/*.sh; do
- . $SCRIPT
+ if [ -x $SCRIPT]; then
+ . $SCRIPT
+ fi
 done
\ No newline at end of file

So the change there is to ensure $SCRIPT is executable.

Sitsofe Wheeler (sitsofe) wrote :

The change is almost fine it's but the line should be:
if [ -x $SCRIPT ]; then
(note the space between the T and the ])

TJ (tj) wrote :

Well spotted Sitsofe! I'd done a cursory check of that and never noticed it, grrr!

I've attached a patch to fix the issue.

TJ (tj) wrote :

Patch available

Changed in acpi-support:
assignee: intuitive-nipple → ubuntu-kernel-acpi
importance: Undecided → Medium
status: New → In Progress
Sitsofe Wheeler (sitsofe) wrote :

I had a long explanation queued up but basically the problem (at least as an intel X user) was that a VT switch wasn't happening because various suspend scripts weren't running. According to KeithP on http://lists.freedesktop.org/archives/xorg/2007-August/027115.html the intel X driver doesn't like being suspended while active (probably a graphics card state restoration thing).

slazZ (slazz) wrote :

yep, that works!
well done Sitsofe

Tom Vetterlein (smbm) wrote :

Can someone give me a quick run down on how to apply the patch?

Does it need to be applied to the .deb?

Can I apply it to the scripts in situ?

Tom Vetterlein (smbm) wrote :

Not to worry, sorted it.

TJ (tj) wrote :

For clarity, the fix is to open /etc/acpi/prepare.sh and add a single space between the "T" and the "]" in the line:

if [ -x $SCRIPT]; then

so it reads:

if [ -x $SCRIPT ]; then

TJ (tj) on 2007-09-01
Changed in acpi-support:
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

acpi-support (0.99) gutsy; urgency=low

  * prepare.sh: Fix missing space in executability test (thanks, Sitsofe
    Wheeler and TJ; LP: #136453).

 -- Colin Watson <email address hidden> Sat, 01 Sep 2007 17:32:01 +0100

Changed in acpi-support:
status: Fix Committed → Fix Released
TDB (michael-baranov) wrote :

The fix works nice! Thank you.

Russ-ST24 (russ-ryan) wrote :

Thanks, fixed for me too. Nice work.

Jim Pharis (binbrain) wrote :

Am I alone here on my Dell Inspiron 700m? I'm having this problem after a clean install and update today. Recreation steps.

1) suspend 2) resume 3) log in 4) blank screen

I checked the acpi prepare.sh and the 1 line correction is there. Adding the sleep kernel arg to menu.1st makes the problem worse (everything is blank, forced to reboot). Disabling compiz makes no difference. I tried switching from the intel driver to the i810 driver and suspend works now.

ii acpi 0.09-3ubuntu1
ii acpi-support 0.103
ii acpid 1.0.4-5ubuntu8
xserver-xorg-video-intel 2:2.1.1-0ubuntu7

Jim Pharis (binbrain) wrote :

The description in bug https://bugs.launchpad.net/ubuntu/+bug/127101 closely resembles my problem and it seems to be on going at this point. I'll assume that this defect isn't my problem since the things mentioned seem to have been fixed and I still have the issue.

Chris Jones (cmsj) wrote :

My laptop (Thinkpad X40) has started crashing X on resume with the error khul reported, but the resume prepare script has the fix mentioned above (running gutsy final).

xRaich[o]²x (raichoo) wrote :

Same problem here on Hardy. Resuming after supend to RAM leaves the screen corrupted (black with some colored vertical stripes here and there). I'm using KDE 4.0.3 with enabled desktopeffects.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

A can work around the problem by switching to a console and issue "echo mem > /sys/power/state" there. System restarts without any problems.

xRaich[o]²x (raichoo) wrote :

Problem occurs on Hardy

Changed in acpi-support:
status: Fix Released → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

xRaich[o]²x:
(Please subscribe yourself to bugs when you change their status so you see followups)

I can almost guarantee that although the symptoms may sound similar this issue is not yours...

xRaich[o]²x (raichoo) wrote :

I did subscibe. Hm strange i thought i wrote more information about that bug. should i open a new one?

Daniel Hahler (blueyed) wrote :

Yes, please file a new bug report.
This particular report is about the typo, which caused a regression for a lot of people - and got fixed.
Marking fix released again.
Please note: you likely want to file the bug report against pm-utils, which does suspend/hibernate in Hardy - or "linux", the kernel package. Please provide as much information as possible, e.g. /var/log/pm-suspend.log.

Changed in acpi-support:
status: Confirmed → Fix Released
Curtis Hovey (sinzui) on 2012-04-09
Changed in acpi-support (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers