Ubuntu

Xubuntu 12.04 extremely slow login

Reported by Orbital_sFear on 2012-05-08
350
This bug affects 70 people
Affects Status Importance Assigned to Milestone
accountsservice (Ubuntu)
Medium
Unassigned

Bug Description

The core issue is that /usr/lib/accountsservice/accounts-daemon doesn't accept dbus messages on boot.

The symptom to this problem is that, after successfulling entering your login information, the system takes about 85 seconds to boot. The real issue occuring is that /usr/lib/accountsservice/accounts-daemon isn't being started correctly by ligthdm. The accounts-daemon wont accept dbus requests, and so the dbus timeout is hit during boot.

Before I start, here is a run down on my machine/setup:
Intel I7.
Xubuntu 12.04.
Encrypted home drive.
Running compiz.

Enabling the log files on lightdm, the follow warnings are displayed (Notice the times):
[+11.58s] DEBUG: Greeter quit
[+36.60s] WARNING: Could not call SetXSession: Timeout was reached
[+61.63s] WARNING: Could not call FindUserByName: Timeout was reached
[+61.63s] DEBUG: Dropping privileges to uid 1000
[+61.63s] DEBUG: Restoring privileges
[+86.65s] WARNING: Could not call FindUserByName: Timeout was reached

If the /usr/lib/accountsservices/accounts-daemon is restarted, after the lightdm login screen is displayed, but before a login, then xfce will start immediately. Otherwise boot times take about 87 seconds.

Also, it was found that the program d-feet, is unable to retrive valid methods from /usr/lib/accountsservices/accounts-daemon before it is restarted. After the deamon is restarted, all dbus methods are visuable and communicate correctly.

For descussion on the problem, and a temporary fix, see the following thread:
http://ubuntuforums.org/showthread.php?t=1970326

summary: - Xubuntu 12.04 /usr/lib/accountsservice/accounts-daemon doesn't accept
- dbug messages
+ Xubuntu 12.04 extremely slow login
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
description: updated
Thomas82 (tommo1982) wrote :

I'm one of the affected. It should be noted that it doesn't happen every time. Last 2 or 3 boot's were successful, where the last one was not.

ds9 (stephane-lentz) wrote :

As mentioned by Thomas, on my side it happens most of the time but sometimes the issue is not around.

Carsten Meyer (carstenmeyer) wrote :

On XUbuntu 12.04:

mm@X121e:~$ /usr/lib/accountsservice/accounts-daemon --version
accounts-daemon 0.6.15

In "NEWS" from latest http://www.freedesktop.org/software/accountsservice/accountsservice-0.6.21.tar.xz:
[...]
Changes in 0.6.18
=================
* Fix systemd configure check
* Add a few more common system accounts to the blacklist
* Fix some issues in systemd session handling
[...]

Another user reports that version 0.6.20 does not have the issue with the erroneous start (see http://ubuntuforums.org/showpost.php?p=11941318&postcount=28).

Martin Pitt (pitti) on 2012-05-23
affects: xubuntu-meta (Ubuntu) → accountsservice (Ubuntu)
tlennon (tlennon) wrote :

I've had the same issue since installing 12.04. I've noticed however that if networking is completely disabled, the problem does not appear.

0xerror (0x32202) wrote :

I hope this will help.

I have installed xubuntu X times and was tracking from what package the issue might comes from. I have noticed after full update (date 09 Jun 12) the "slow" login issue started.

after selecting only the Important security updates -- no login issue (date 09 Jun 12)
after selecting Recommended updates one by one i found the packages that cause the "slow" login issue:

glib-networking (Size: 52kB) version 2.32.1-ubuntu1
glib-networking-common (Size: 6kB) version 2.32.1-ubuntu1
glib-networking-services (Size: 13kB) version 2.32.1-ubuntu1

I have tested it on a 32bit and 64bit machine. It looks like only the 64bit is afected of this issue.

temp. solution install the old version (2.32.1-1) of the listed packeges.

Calcipher (calcipher) wrote :

The solution suggested by 0xerror did not work for me. I think there may be different issues afoot.

devstefano (devstefano) wrote :

From a terminal, with startx, xfce starts immedialty

ferro (jschwender) wrote :

I have here two machines that are hardware identical, same xubuntu precise 64 bit on it, but one shows the bug and the other not. The only differences are some user applications, and what is more fundamental is that the one that does not have the bug effect is a pure 64 bit environment, while the buggy one has 32 bit compatibility libs (ia32-libs) and 32 bit applications installed. Please can everyone verify or falsify that suspicion?

v66r (pyro-tagtraummusik) wrote :

@ferro, thanks alot for pointing this out, I can confirm this here. Removing i386 libraries solved the problem for me.
Did not have the metapackage "ia32-libs" installed, but alot of :i386 libs. after
apt-get remove libc6:i386
which removed nearly all the other :i386 packets, the error was gone. But this removed also some software I use (wine, rhythmbox).
I reinstalled both. rhythmbox did not seem to have any i386 deps, but wine installed alot of i386 libs again. The problem is STILL gone...

Here is a list of i386 libs now tagged as "rc" in dpkg -l (which were installed but are removed). Maybe one of these is causing the problem:

gstreamer0.10-plugins-good:i386
libaa1:i386
libacl1:i386
libaio1:i386
libao4:i386
libasyncns0:i386
libatk1.0-0:i386
libattr1:i386
libaudiofile1:i386
libavc1394-0:i386
libbz2-1.0:i386
libcaca0:i386
libcairo-gobject2:i386
libcairo2:i386
libcanberra-gtk0:i386
libcanberra0:i386
libcap2:i386
libcdparanoia0:i386
libcroco3:i386
libcupsimage2:i386
libcurl3:i386
libdatrie1:i386
libdbus-glib-1-2:i386
libdv4:i386
libelf1:i386
libesd0:i386
libflac8:i386
libgail18:i386
libgdbm3:i386
libgdk-pixbuf2.0-0:i386
libgdu0:i386
libgnome-keyring0:i386
libgomp1:i386
libgtk-3-0:i386
libgtk2.0-0:i386
libgudev-1.0-0:i386
libibus-1.0-0:i386
libidn11:i386
libiec61883-0:i386
libjack-jackd2-0:i386
libjasper1:i386
libjson0:i386
libllvm2.9:i386
libmad0:i386
libmikmod2:i386
libmng1:i386
libncursesw5:i386
libnspr4:i386
libnss3:i386
libodbc1:i386
libogg0:i386
liboil0.3:i386
libpango1.0-0:i386
libpixman-1-0:i386
libpolkit-agent-1-0:i386
libpolkit-gobject-1-0:i386
libproxy1:i386
libpulse-mainloop-glib0:i386
libpulse0:i386
libqt4-dbus:i386
libqt4-declarative:i386
libqt4-designer:i386
libqt4-network:i386
libqt4-opengl:i386
libqt4-qt3support:i386
libqt4-script:i386
libqt4-scripttools:i386
libqt4-sql:i386
libqt4-svg:i386
libqt4-test:i386
libqt4-xml:i386
libqt4-xmlpatterns:i386
libqtcore4:i386
libqtgui4:i386
libqtwebkit4:i386
libraw1394-11:i386
librsvg2-2:i386
librtmp0:i386
libsamplerate0:i386
libsdl-image1.2:i386
libsdl-mixer1.2:i386
libsdl-net1.2:i386
libsdl-ttf2.0-0:i386
libsdl1.2debian:i386
libshout3:i386
libslang2:i386
libsndfile1:i386
libsoup-gnome2.4-1:i386
libsoup2.4-1:i386
libspeex1:i386
libspeexdsp1:i386
libssl0.9.8:i386
libstdc++5:i386
libtag1-vanilla:i386
libtdb1:i386
libthai0:i386
libtheora0:i386
libudev0:i386
libunistring0:i386
libvisual-0.4-0:i386
libvorbis0a:i386
libvorbisenc2:i386
libvorbisfile3:i386
libwavpack1:i386
libwrap0:i386
libxaw7:i386
libxcb-render0:i386
libxcb-shm0:i386
libxft2:i386
libxmu6:i386
libxp6:i386
libxss1:i386
libxtst6:i386
libxv1:i386
odbcinst1debian2:i386
xaw3dg:i386

Patrick Leliveld (p-leliveld) wrote :

I don't have ia32 libs installed on my Xubuntu laptop, but the machine is definitely affected by this bug.
I am almost sure it is a LightDM-related issue, because logging in via a terminal and "startx" works as an acceptable workaround.
Does anyone already tried reinstalling GDM?

On 06/17/2012 11:40 PM, Patrick Leliveld wrote:
> I don't have ia32 libs installed on my Xubuntu laptop, but the machine is definitely affected by this bug.
> I am almost sure it is a LightDM-related issue, because logging in via a terminal and "startx" works as an acceptable workaround.
> Does anyone already tried reinstalling GDM?
>

For me problem disappears after:

1. Create $HOME/.profile if dosen't exists
2. Check "Language Support" (Menu Start/Settings/Language Support) and install missing elements

(deamon checks this before hangs / checked by strace )

Regards

--
NC

Thomas82 (tommo1982) wrote :

I'd hope this bug to be already fixed. It's definitely not good publicity for ubuntu and it's derivatives. I can handle slower boot, but hangs during boot get on my wig :(

metux (weigelt) wrote :

Confirmed the issue.

Seems a very good example why the asynchronous nature of dbus is really a bad idea when it comes to operations stability.
(the typical kind of problem which regularily brings ESB environments to fall).

My strong advise: do NOT use dbus at all, unless you're _absolutely_ sure you are really sure you _want_ some asynchronous message passing (i mean: asynchronous like, eg., a mail robot).

Thomas82 (tommo1982) wrote :

OMG! Is no one paying attention to this bug? Where is this so called 'linux fast update' I read everywhere? This is so bloody frustrating and no xfce or ubuntu developer is paying attention? This is similar to microsoft, oh wait, they started to pay attention since everyone is complaining and watching what they do.

Patrick Leliveld (p-leliveld) wrote :

Installing all missing Language Support packages doesn't solve the issue here. It is becoming rather frustrating that this bug still isn't assigned to anyone.

metux (weigelt) wrote :

For me, it got even worse: couldn't even log in, the session simply dropped and it jumped back to login screen.

So, I finally decided to make my hands dirty and had a look at the code. The problem seemed to come from a utterly useless dbus call in accounts.c. The attached patch removes that silly stuff, seems to work for me now.

(Most likely, I'll remove all the remaining useless dbus stuff).

The attachment "Remove silly dbus call to the "account-service"" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Ray Ingles (sorceror171) wrote :

Didn't notice it the first few logins after upgrading to 12.04, but sure notice it now. Intel I7, Xubuntu 12.04, Encrypted home drive.

It should be noted that the patch metux made is actually against lightdm, not accountsservice. I don't know if it's a proper fix for this issue, but I'm also affected by this bug and his fix works for me so as of now I'm running a patched lightdm. Thanks.

I created a package lightdm using the patch of metux (weigelt). It works for me too.

Download it here: (Installing lightdm_1.2.1-0ubuntu3_amd64.deb is enough).
https://launchpad.net/~andreas-diesner/+archive/lightdm-fix-temporary

The next official lightdm package will overwrite the patch again, so you should be save.

Nichita Uțiu (nikita.utiu) wrote :

I investigated this a little on a clean install and the way I reproduced the bug was by installing wine1.5. As expected removing wine and all its dependencies solved the problem. Have only tried it on 64bit, not on 32, but this may be an architecture-specific bug.

Mark Dammer (mark-dammer) wrote :

Many more system parts are affected by this problem on my machine:
- I get the same delay when I start synaptic from the menu - about 90 seconds until I am asked to enter my password.
- Enabling Gnome services in XFCE settings completely messes up the system on logout:
At first I get a black screen for about 90 seconds.
Then I get a black screen with mouse cursor for a further 90 seconds
Then I get a lightdm login screen WITHOUT MY USER LISTED

I am having the same symptoms as Mark Dammer is having, particularly that the login/display manager takes forEVER to actually show the XFCE desktop, and that launching Synaptic from the XFCE menu takes forever before I receive a password prompt.

/me suppresses a number of angry comments regarding the quality of Linux lately.

pen name (newcontact8) wrote :
Download full text (9.2 KiB)

I just installed xbuntu on a new netbook (acer ao756) and I believe I run into this exact same problem: After I enter my password and hit return, it takes a long time to start xfce. I checked /var/log and found some strange error messages in three log files, all seeming related to lightdm. Note in particular log file #3, the warning at 36sec and at 86sec (and more to the point, the time gap preceeeding these two).

I run xubuntu 12.04 on my desktop as well and I have never experience this delay between login and xfce starting. The desktop does have higher spec and to my surprise I have the same x-0-greeter.log error (log file #1) before, but lightdm on the desktop has no warning message (log file #3). All, this slow-login problem on the netbook happens often but not always -- 50-60% of the time?

One more thing: the directory /usr/share/themes/Greybird-lightdm has a lot few files/folders than other themes (e.g. Default). I wonder if this is an xfce thing or it is a general lightdm problem (see log #1 for example).

Other than this problem I really love this little netbook. Thanks for your help!
--------------------
Error log #1: /var/log/lightdm/x-0-greeter.log

(lightdm-gtk-greeter:1381): Gtk-WARNING **: Theme parsing error : gtk-widgets.css
:1175:60: Failed to open file '/usr/share/themes/Greybird-lightdm/gtk-2.0/resize
_grip.png': No such file or directory

(lightdm-gtk-greeter:1381): Gtk-WARNING **: Theme parsing error: gtk-widgets.css
:1240:50: Failed to open file '/usr/share/themes/Greybird-lightdm/gtk-3.0/progre
ssbar.png': No such file or directory

(lightdm-gtk-greeter:1381): Gtk-WARNING **: Theme parsing error: gtk.css:76:29:
Failed to import: Error opening file: No such file or directory

(lightdm-gtk-greeter:1381): Gtk-WARNING **: Theme parsing error: gtk.css:77:33:
Failed to import: Error opening file: No such file or directory
-----------
Error log #2: .x-session-errors

openConnection: connect: No such file or directory
cannot connect to brltty at :0
xfce4-settings-helper: Another instance is already running. Leaving...

(polkit-gnome-authentication-agent-1:1828): GLib-CRITICAL **: g_variant_new_stri
ng: assertion `string != NULL' failed

(polkit-gnome-authentication-agent-1:1828): polkit-gnome-1-WARNING **: Failed to
 register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The nam
e org.gnome.SessionManager was not provided by any .service files
** Message: applet now removed from the notification area
** Message: using fallback from indicator to GtkStatusIcon
** Message: applet now embedded in the notification area

(xfce4-indicator-plugin:1887): libindicator-WARNING **: IndicatorObject class do
es not have an accessible description.

(xfce4-indicator-plugin:1887): libindicator-WARNING **: IndicatorObject class do
es not have an accessible description.
** Message: moving back from GtkStatusIcon to indicator
** Message: applet now removed from the notification area

(xfce4-indicator-plugin:1887): LIBDBUSMENU-GLIB-WARNING **: Getting layout faile
d: Operation was cancelled

(xfce4-indicator-plugin:1887): GLib-GIO-CRITICAL **: g_dbus_proxy_call_internal:
 assertion `G_IS_DBUS_PROXY (proxy)' fa...

Read more...

Mark Dammer (mark-dammer) wrote :

It is now over a quarter of a year and this bug is still status Importance undecided and unassigned. Is no one of the package maintainers for "accountsservice" paying any attention to this problem ?

Pappy Jack (wgregor3) wrote :

I got tired of Unity and added/switched to Xubuntu-desktop months ago (12.04 x64 fully patched). The system has been working fine until I decided to remove zeitgeist and all its libraries and such (more items than suggested, and whacked Unity in the process). As a bonus I now have the same symptoms Mark Dammer describes. I followed PsycoCats guide and switched to Pure Xubuntu. It did not correct the issue. I found this thread and I am adding my 2-cents and wondering like Mark where the package maintainers are? I'm trying to figure out how to apply the patch, maybe its on the forum that sent me here.

Great job tracking this down guys!

Ciao

http://linuxaria.com/howto/how-to-remove-zeitgeist-in-ubuntu-and-why?lang=en
http://www.psychocats.net/ubuntu/purexubuntu

Adolfo R. Brandes (arbrandes) wrote :

@Pappy Jack, I am in the exact same situation. Removed ubuntu-desktop packages as per psychocats' purexubuntu, and suddenly poopies, whereas before there was no such problem login in to xfce.

At some point I'm going to try out installing unity-greeter to see if it helps, but there are too many gnome dependencies I don't want. For now, I'm just using the hack described by Orbital_sFear in this post:

http://ubuntuforums.org/showpost.php?p=11921373&postcount=20

Are you sure this is an Xubuntu problem? I have a normal Ubuntu with gnome-shell and have the same problem...

Thomas82 (tommo1982) wrote :

This problem is not fixed. It was supposed to be fixed with 12.04.1, but I still have it. Looks like someone doesn't really care. I'm sorry to say this, but if it was Windows they would fix it quickly. Their income depends on it, afterall.

I have the same issue and tried installing the missing language support.
Now I don't have just the minute-long wait between login screen and desktop startup, I have a minute of a black screen after it, another minute of a black screen with a mouse cursor, then another minute until the desktop appears.

I have also been having minute-long hangs in Firefox and Thunderbird where they would stop redrawing; afterwards, they'd return to normal. I don't know whether this is related, nor do I know how to verify what exactly is causing this bewildering array of malfunctions.

The startx trick doesn't help. Which isn't too surprisinig because I'm experiencing the hangs after X has started.

This means that Xubuntu is currently unacceptable for working with it on a daily basis - here's a critical bug that isn't even being triaged, much less fixed.

I'm also getting a black screen, then a black screen with a mouse cursor, then the login screen after a logout.

I forgot to mention that my user account isn't shown on the login screen, I have to type the user name manually.
This happens both after reboot and after logout.
Just noting that for completeness, this effect is a negligible annoyance for me.

System: Xubuntu Precise 64-bit with nvidia-current-update.

More info on request, or as it becomes available.
Though I'm off trying to install KDE now... and if that doesn't help, some other distro.

Some more info... installing kde-desktop solved the issue for me. I had KDE activated as default system, so it's doing the KDE login box, but I didn't change the login mode so I still have a Xubuntu desktop.

Mark Dammer (mark-dammer) wrote :

 Interesting are the things (at least in my situation) that make the problem NOT happen:

- logging in with an account that is not having an encrypted homedrive.
- no network connection during login. This one is interesting:
Usually applications like Synaptic that need a root password show the same annoying delay before the "enter password" dialog show up. But when I unplug the network I cannot only login to my encrypted account without a delay, but applications like Synaptic show no delay, even when I have connected to the network again.
My conclusion is that something goes wrong during login. If that goes wrong the whole session is suffering - including logout. If the login is o.k. everything is fine - regardless of network connection etc.

gumpish (launchpad-5-gumpish) wrote :

I guess we all get what we pay for, huh? Now that Shuttleworth isn't propping up the operation anymore they must not have the resources to even look at bug reports anymore. Guess I'll be heading back to good old (stale) Debian, especially now that the default DE in wheezy is xfce.

It was good while it lasted, [xk]?ubuntu!

Ian Chard (ian-chard) wrote :

I upgraded to quantal a few days ago and haven't been able to reproduce this bug since then.

@Ian: have you upgraded or reinstalled? Because I did the upgrade and still have a 60+ seconds wait at the login.

Ian Chard (ian-chard) wrote :

I upgraded, and the problem is definitely fixed for me.

daniel CURTIS (krikras) wrote :

Hello, today after logging in via LightDM, Xfce does not appeared. I do not know if after a few seconds desktop appears, because after a short time I switched to another terminal with 'ctrl + alt + Fx' command and reboot Xubuntu. I noticed that after GRUB loading and selecting the new 3.2.0.33 kernel (update today) system is also freezing (only 'reset' button helps). At the second attempt to log into the system, everything works okay.

I can not find any information, in the logs file (e.g. 'Xorg.log', 'kern.log', 'syslog' etc.), that might help.

Jaakko Korkeaniemi (jkorkean) wrote :

Installing accountsservice packages from quantal fixed the problem for me:

http://packages.ubuntu.com/quantal/accountsservice
http://packages.ubuntu.com/quantal/libaccountsservice0

daniel CURTIS (krikras) wrote :

Hi Jaakko. From what I see I have already installed 'accountsservice' package;

,------[dpkg -l |grep accountsservice]
| ii accountsservice 0.6.15-2ubuntu9.4
| ii libaccountsservice0 0.6.15-2ubuntu9.4
`------

I wonder if the version from the 'quantal' (0.6.21-6ubuntu5) - mentioned by you - would solve this problem.

@daniel: I don't think it helps... I have upgraded to quantal, and I have all the packages up-to-date, but still the same problem. I suspect a configuration problem from the upgrade, because in another PC, with a new install, it didn't happen.

daniel CURTIS (krikras) wrote :

Hi Romano. Thank You for the answer. I suppose that In my case, the problem with slow login occurred after removing default bootsplash and/or change default login manager theme. But I do not know whether these changes, have any relevance to this problem. So at least it seems to me, because before I made ​​these changes I never had a problems with slow Xfce pulpit showing after login. Now, but only accidentally (let say once on several logins), after login Xfce pulpit etc. appears after about... 60 seconds.

For now, I do not have opportunity to restore "default" settings - bootsplash and login manager wallpaper/theme, so I do not know if it will be a solution for this problem.

Best regards!

xSAPPYx (xsappyx) wrote :

@krikras: I'm using the default bootsplash and login manager theme.. I've never changed them from this clean 12.04 install and still have the slow login problem.

Thomas82 (tommo1982) wrote :

Not sure if it helps anyone above ... I had the slow login issue, but since I updated to 12.04.1 it doesn't happen anymore. I install updates every time there is one so I can't pin point which update fixed the problem.

daniel CURTIS (krikras) wrote :

Hi Sappy. Your answer tells me, that changing bootsplash and LightDM wallpaper, had no effect on this problem. Now I'm sure, that something else caused the problems with slow logging. That's something, thank You very much.

Hi Thomas. I am also using 12.04.1 version, with all available updates. So in my case, it is not a solution of the problem, but I have disabled the 'proposed-updates' installation. Maybe future updates will helps.

Gael (surabaya) wrote :

Hello,

Like many others I have this bug. I had it under Mint Mate 13, Mint XFCE 13, and Mint 14 Mate and Ubuntu 12.04. Everytime this bug appears after the first big update. Before the boot was crazy fast.
All solution here and in others places did not worked for me.
The only trick I found: installing Preload. And my boot is faster but not amaising.

The simple question is: when will you, Guys from Ubuntu, really take care of this huge bug in lauch pad? What are you waiting for?

Now I am an happy user of Mandriva, and there is nooooooooo slooooooow login problem.

Really a shame...

Norbert Valder (chat-valder) wrote :

I had the same issue with Xubuntu 12.10. Suddenly after adding some applications and updates, I notice a slow login. I got a black or grey screen for some 20 seconds before the desktop showed up. Once the desktop appeared and say a terminal window was launched, it took about a minute for it to pop up and be useful.
For my configuration, removing the XFCE config file resolved the issue.
I followed the instructions given somewhere here or in another forum :
1) Ctrl-Alt-F2 to get out of X onto a command line
2) login there
3) sudo rm -rf ~/.cache
4) sudo rm -rf ~/.config/xfce4 ## this kills your desktop setup, i.e. background picture !
5) Ctrl-Alt-F7 to get back into X
6) reboot

Credits to the author of post, I can't find anymore! :-)

daniel CURTIS (krikras) wrote :

Hi, this problem still occurs in Xubuntu 12.04.2! Norbert your solution seems to be okay, but I'm wondering about 3. and 4. steps. Does it means, that all settings e.g. Wallpapers, icons etc. will be missing and I have to set it again?

pen name (newcontact8) wrote :

The patch in the OP worked for me (12.04.01, x64) until two days ago; after performing a regular system update the slooow login returned. I tried the fix in post #48 in this thread; it worked once (after I rm both directories) but no more (even after I tried to rm the directories again). I went back to the ubuntuforms link in the OP and the fix in post #40 there works (for now): After lightdm comes on, switch to tty1 and 'sudo pkill accounts'. This survives logout (so far) but not restart/reboot.

I have sent along several logs in case this would help squash this veeery annoying bug.

pen name (newcontact8) wrote :

A few more log files, as related to my post #50 (note: these log files are all for the system BEFORE I came upon the 'sudo pkill' fix).

pen name (newcontact8) wrote :

Here is my .xsession-errors plus one more log (as attachment):
---------------------------------------------------------------------------------------------------------------------------
openConnection: connect: No such file or directory
cannot connect to brltty at :0

(x-window-manager:1825): Gtk-WARNING **: cannot open display: :1.0

(x-window-manager:1824): Gtk-WARNING **: cannot open display: :3.0

(x-window-manager:1827): Gtk-WARNING **: cannot open display: :3.0

(x-window-manager:1826): Gtk-WARNING **: cannot open display: :1.0

(x-window-manager:1828): Gtk-WARNING **: cannot open display: :3.0

(x-window-manager:1829): Gtk-WARNING **: cannot open display: :1.0

(x-window-manager:1831): Gtk-WARNING **: cannot open display: :3.0

(x-window-manager:1832): Gtk-WARNING **: cannot open display: :1.0

(x-window-manager:1833): Gtk-WARNING **: cannot open display: :3.0

(x-window-manager:1834): Gtk-WARNING **: cannot open display: :1.0

(x-window-manager:1835): Gtk-WARNING **: cannot open display: :3.0

(x-window-manager:1836): Gtk-WARNING **: cannot open display: :1.0
xfce4-settings-helper: Another instance is already running. Leaving...

(polkit-gnome-authentication-agent-1:1863): GLib-CRITICAL **: g_variant_new_string: assertion `string != NULL' failed

(polkit-gnome-authentication-agent-1:1863): polkit-gnome-1-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(xfce4-indicator-plugin:1976): libindicator-WARNING **: IndicatorObject class does not have an accessible description.

(xfce4-indicator-plugin:1976): libindicator-WARNING **: IndicatorObject class does not have an accessible description.
** Message: applet now removed from the notification area

(xfce4-indicator-plugin:1976): Gtk-CRITICAL **: IA__gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)' failed
Exception in thread Thread-5:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 551, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/bin/jupiter", line 379, in update_screen_orientations
    rotation = self.jupiter.current_rotation(display)
  File "/usr/bin/jupiter", line 165, in current_rotation
    return self.get_device('/rotation_saved_'+args, 'rotate', ['normal',args]).split(' ')[0]
AttributeError: 'bool' object has no attribute 'split'

Allen Otis (aaotis) wrote :

My situation is similar to post 50.

I had originally used workaround from http://ubuntuforums.org/showthread.php?p=12170217
  sudo add-apt-repository ppa:andreas-diesner/lightdm-fix-temporary
  sudo apt-get update
  sudo apt-get upgrade

Then later updated the system with synaptic on 21jan2013 probably
overriding above fix, but xfce login was ok.

Updated system today and slow xfce login returned, update included
  liblightdm-gobject-1-0 (1.2.1-0ubuntu3) to 1.2.3-0ubuntu1
  lightdm (1.2.1-0ubuntu3) to 1.2.3-0ubuntu1

After these changes
  Downgraded lightdm to (1.2.1-0ubuntu3)
  Downgraded liblightdm-gobject-1-0 to (1.2.1-0ubuntu3)
and now xfce login is ok again.

uname -a shows
Linux allenlap 3.2.0-37-generic #58-Ubuntu SMP Thu Jan 24 15:28:10 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

@aaotis: I just updated my repository lightdm-fix-temporary with a new version of "lightdm 1.2.3-0ubuntu1" with the previously applied patch. The build should be finished 2013-02-07 8pm CEST. After that this should be working again:

    sudo add-apt-repository ppa:andreas-diesner/lightdm-fix-temporary
    sudo apt-get update
    sudo apt-get upgrade

Frederik Himpe (fhimpe) wrote :

This patch (and the packages including this patch) work around the slow log in, but introduce a serious regression: the first time lightdm is started after boot, the Shutdown menu in lightdm is empty.

We reverted to the lightdm package in ubuntu and rebuilt the accountsservice package from 12.10 on 12.04. Now the problem is fixed and this regression does not happen.

(It's indeed deceiving that such a common and well analayzed bug is being ignored for almost a year. We are currently using Xubuntu on all our systems in students' class rooms. The fact that such highly annoying and common bugs are totally ignored, is making us think to switch another distro).

pen name (newcontact8) wrote :

Today's xubuntu 12.04 update contains an update for lightdm, and after I clicked "yes" and reboot, the slooooow login returns ;_;

Same here, it takes a lot of time to display the login screen, both with lightdm and gdm. Where can I find log information about what appens during that period of time?

EricDHH (ericdhh) wrote :

Adding two IBM subnotes, x41 with 12.04-2i386 and x61 with 12.04-2amd64. Both suffer from this ugly ugly login wait, when will a bugfix be available?

Brendan Miller (brmiller) wrote :

Re: Comment #41

> I wonder if the version from the 'quantal' (0.6.21-6ubuntu5) - mentioned by you - would solve this problem.

After trying several things in this thread, I installed the accountsservices .debs from quantal and do not have the slow lightdm startup nor slow xubuntu session startup any more. FWIW.

$ dpkg -l |grep accountsservice | awk '{print $2" "$3}'
accountsservice 0.6.21-6ubuntu5
libaccountsservice0 0.6.21-6ubuntu5

I upgraded to 13.04 now. I still have the slow login. On the other hand, on a newly installed 13.04 machine, it doesn't happen.

I tried to reinstall and reconfigure accountsservice and libaccountsservice0, to no avail.

It should be some lingering configuration; anyone has an idea of what could be?

Thanks!

Changed in accountsservice (Ubuntu):
importance: Undecided → Medium
rayj (rayjhendricks) wrote :

I have switched to gdm...

daniel CURTIS (krikras) wrote :

Hi. Still there are problems with randomly slow login on Xubuntu 12.04.3, with all updates.

JStMartin (jrstmartin) wrote :

I can confirm that slow login DOES NOT happen on i386 (x86). It only happens on 64bit Xubuntu.

I since upgraded to 13.04, with an x86 arch (32bit), and still have 60+ seconds wait for the login. I still think that there is something that got stale during a past upgrade and causes this, and the arch (64 or 32 bit) doesn't seems to matter.

Richard (rimcaw) wrote :

Hello,

Without trying the lightdm temporary fix, I still have the slow login on Xubuntu 12.04.3 LTS on a 32-bit machine:

$ uname -a
Linux host 3.2.0-52-generic #78-Ubuntu SMP Fri Jul 26 16:23:24 UTC 2013 i686 i686 i386 GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers