Ubuntu

OpenDocument plugin should be shipped with Abiword, not -plugins

Reported by Daniel d'Andrada on 2005-10-18
32
Affects Status Importance Assigned to Milestone
AbiWord
Fix Released
Undecided
Unassigned
abiword (Baltix)
Undecided
Unassigned
abiword (Ubuntu)
Medium
Unassigned
xubuntu-meta (Ubuntu)
Medium
Jani Monoses

Bug Description

AbiWord 2.4 has a new plugin to import OpenDocument files, it's called,
unsurprisingly, "OpenDocument".
But on the file types list box of the open file dialog you just see "Open Writer
(.sxw, .odt)", which is the old plugin.

Having the new version of the OpenWriter plugin and the new OpenDocument plugin
you should see both "Open Writer (.sxw)" and "OpenDocument (.odt)" among the
file types.

Corey Burger (corey.burger) wrote :

Not shipping any format plugins as part of the base package is broken, as regular users who install this through gnome-app-install are never going to see the plugin package and thus don't even know it exists.

Lukas Sabota (punkrockguy318) wrote :

I agree. If not all, the OpenDocument plugin should be shipped. Abiword is the default word processor of Xubuntu. It should be compatible with Ubuntu.

Changed in abiword:
status: Unconfirmed → Confirmed
Daniel Holbach (dholbach) wrote :

xubuntu-desktop can add abiword-plugins to it's dependencies. The abiword split makes much sense, as others might have to cope with space and bandwidth constraints.

Changed in abiword:
status: Confirmed → Rejected
Matt Zimmerman (mdz) on 2006-04-11
Changed in xubuntu-meta:
assignee: nobody → jani
Jani Monoses (jani) wrote :

oh, so this is the reason abiword just hangs and chews CPU even after closed if told to open an ODF :)
changing the seeds now, and will upload a new xubuntu-meta with it.

Jani Monoses (jani) wrote :

plugins are installed in xubuntu-desktop now. I am not sure what to do with this bug report as it is not just xubuntu related.

Lukas Sabota (punkrockguy318) wrote :

Closing this bug. Now, the opendocument file type is support across Ubuntu, Kubuntu, and Xubuntu. Good :)

Changed in xubuntu-meta:
status: Unconfirmed → Fix Released
Lukas Sabota (punkrockguy318) wrote :

Eh, reopening. Sorry about that, you are right the first comments don't only apply to Xubuntu.

Changed in abiword:
status: Rejected → Confirmed
fubarbundy (launchpad-mailtic) wrote :

With reference to http://bugzilla.abisource.com/show_bug.cgi?id=8388 , please DO ship the ODT plugin with abiword (or at least in a separate package from most of the other plugins) as Abiword can't selectively load plugins at the moment, so you either get no plugins, or the overhead of all the other plugins that 99% of abiword users don't need.

Recommended 'essential plugins':

HTML Importer
PDF Import Filter
OpenDocument Filter
AbiMathView
JPEG Import Plugin
AbiGOChart
AbiGimp

Hubert Figuiere (hub) wrote :

PDF import is not mature / usable.
JPEG import is useless: we do it with gnome already.

William Lachance (wrlach) wrote :

Beh, I get bitten with this every time I install Ubuntu. Barring a better fix, couldn't we just make an installation of abiword from the app installer automatically install abiword-plugins as well? The former does "recommend" the latter after all. Better to waste a bit of memory than have a completely broken default.

James (chiisu81) wrote :

Is this really a bug or more just the choice of the AbiWord developers? OpenOffice and KOffice have committed to the OpenDocument file format, but so far the Abiword team seems to be sticking with RTF as their default. Hard to tell since their website is rarely updated, and I haven't been keeping track of the 2.3.x development series. I personally would like to see the OpenDocument support moved into the Abiword package, even if it must be done by Debian/Ubuntu developers after-the-fact.

Hubert Figuiere (hub) wrote :

In order to be modular, it has been made a decision in AbiWord to make import/export filter to be plugins. These plugins are in a separate tree, BUT they are shipped in the same tarball, hence they are part of the abiword source package in Debian/Ubuntu.
OpenDocument itself appeared around 2.4.1/2.4.2.

The problem lies that Debian/Ubuntu actually split the package and so the ODT plugins isn't part of the main abiword package.
To fix the problem, the package building scripts should just be modified to include the plugin directly in the abiword binary package.

Note that the AbiWord developer are planing to eventual merge the plugin tree in the abi tree (without changing the result). But that's just for the convenience of people building from source.

Changed in abiword:
assignee: desktop-bugs → nobody
James (chiisu81) wrote :

I would like to thank Jani for fixing this issue in Xubuntu. If I could get Xubuntu Feisty to install, I would switch over :\

Still present in Gutsy. This is very annoying since anybody installing Abiword and trying to open an OpenDocument text will get Abiword hang. It's hard to figure that you need to install a plugins package.

The 'abiword' package should definitely ship with base plugins (ODT, SXW, HTML...), since they don't require much and are almost in any case needed, one day or another.

I think it's essential that the OpenDocument plugin be included by default with AbiWord. This means either making abiword depend on abiword-plugins, or moving the OpenDocument plugin to the abiword package. Though OpenDocument isn't Abiword's native format, it's an open ISO standard that AbiWord does support. Users should have access to it by default.

Changed in abiword:
status: Confirmed → Triaged

 Lukas Sabota wrote on 2006-03-22:
> Abiword is the default word processor of Xubuntu. It should be compatible with Ubuntu.

If we really wanna be compatible across Ubuntu, Kubuntu, and Xubuntu then we should set default save format in AbiWord to OpenDocument. There are no applications in Ubuntu or Kubuntu, which supports .abw format, so, documents, made by Xubuntu users are not readable with Kubuntu or Ubuntu :(
KDE KOffice/KWord already uses OpenDocument as default file format, so, just set AbiWord to OpenDocument as default and all users will be happy, none wanna care about file formats these days :)

Of course, we should check how OpenDocument export/import plugin works with latest AbiWord version (it seems ver. 2.6 soon will be released) - if the quality of OpenDocument export/import plugin is good enough - then we can set default save format to OpenDocument, if there are too many problems - then we should give some information for users, how to change default file format (most of users wanna set RTF to default save format of Abiword). It's too hard to change default file format in AbiWord for most of Desktop users - the only way to do this is editing of config file, see http://bugzilla.abiword.org/show_bug.cgi?id=3325 :

You can go edit your AbiWord.Profile file and add the following line to the _custom_ scheme

DefaultSaveFormat=".rtf"

where .rtf is the common extension of the format you want...

Changed in abiword:
status: Unknown → Fix Released

Using ODT as a default may be an issue bringing about layout bugs (see upstream bug for these fears). If we were to do this (which could be good it it works well), many tests should be done about working on ODT files directly in Abiword: a single unwanted layout modification during save/open would be really problematic - more than simply at export time when the document is finished.

Upstream has it. Will it enter Hardy?

Changed in abiword:
status: Triaged → Fix Committed

On Thu, 2008-02-14 at 01:41 +0000, Mantas Kriaučiūnas wrote:
> If we really wanna be compatible across Ubuntu, Kubuntu, and Xubuntu
> then we should set default save format in AbiWord to OpenDocument.
> There are no applications in Ubuntu or Kubuntu, which supports .abw
> format, so, documents, made by Xubuntu users are not readable with
> Kubuntu or Ubuntu :(
> KDE KOffice/KWord already uses OpenDocument as default file format,
> so, just set AbiWord to OpenDocument as default and all users will be
> happy, none wanna care about file formats these days :)

I don't want to sound rude, but you don't know what you are even talking
about and what are the problems that would be caused by this. Now we
welcome you to submit any patch to address the problem in AbiWord.

ODT is not a golden hammer, and AbiWord hasn't been designed to map ODT,
nor has ODT been designed to map AbiWord. That mean perfect round trip
conversion is not happening.

On Thu, 2008-02-14 at 15:44 +0000, Milan wrote:
> Upstream has it. Will it enter Hardy?
>
> ** Changed in: abiword (Ubuntu)
> Status: Triaged => Fix Committed
>

It is a packaging bug. it will enter Hardy if the package maintainer fix
the package to put the OpenDocument plugin in the abiword binary package
instead of the abiword-plugins.

As for upstream: 2.4 already came with the plugin in the main source
tarball. 2.6 will stick to that. trunk now has only one tree. That does
not mean packaging will be fixed automatically.

That does sound kind of rude. Mantas has plenty of valid points,
avoiding user confusion and making software compatible and easy to use
is one of the goals of Ubuntu. Of course there is not exact
compatibility between abiwords default format and odt but at least
Mantas has brought the (important) issue to the forefront, we welcome
you to submit a patch that addresses the problem as well.

On Thu, Feb 14, 2008 at 5:25 PM, Hubert Figuiere <email address hidden> wrote:
>
> On Thu, 2008-02-14 at 01:41 +0000, Mantas Kriaučiūnas wrote:
> > If we really wanna be compatible across Ubuntu, Kubuntu, and Xubuntu
> > then we should set default save format in AbiWord to OpenDocument.
> > There are no applications in Ubuntu or Kubuntu, which supports .abw
> > format, so, documents, made by Xubuntu users are not readable with
> > Kubuntu or Ubuntu :(
> > KDE KOffice/KWord already uses OpenDocument as default file format,
> > so, just set AbiWord to OpenDocument as default and all users will be
> > happy, none wanna care about file formats these days :)
>
> I don't want to sound rude, but you don't know what you are even talking
> about and what are the problems that would be caused by this. Now we
> welcome you to submit any patch to address the problem in AbiWord.
>
> ODT is not a golden hammer, and AbiWord hasn't been designed to map ODT,
> nor has ODT been designed to map AbiWord. That mean perfect round trip
> conversion is not happening.
>
>
>
> --
> OpenDocument plugin should be shipped with Abiword, not -plugins
> https://bugs.launchpad.net/bugs/24195
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Hubert Figuiere: Thanks for your point - I did not know the plugins were already included in trunk upstream in 2.4. So this is an Ubuntu-specific bug that could be fixed without too much problems.

Concerning ODT by default, this is a real problem (in both ways), but anyway this won't be fixed here. A developer discussion would be a start, and then maybe something could be done (or not). Please don't fight over this. :-)

Changed in abiword:
status: Fix Committed → Confirmed
Changed in abiword:
milestone: none → later
milestone: later → none
Ryan Pavlik (abiryan) wrote :

Note that this is a packaging bug now. It will be fixed by the fix to bug #202174. (The upstream "bug fix" doesn't really relate to this bug.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 2.6.3-0ubuntu2

---------------
abiword (2.6.3-0ubuntu2) intrepid; urgency=low

  [ Ryan Pavlik ]
  * New upstream version and associated packaging changes.
    (LP: #202174) (LP: #36807) (LP: #56694) (LP: #3197)
  * Updated build dependencies.
  * Move all plugins without unreasonable dependencies into main
    abiword package (LP: #24195)
  * Merge abiword[-gtk], abiword-gnome, abiword-common (LP: #58662)
  * Use upstream build system to handle installation during package
    creation.
  * Eliminated duplicated "desktop" file and icon in debian/misc in
    favor of upstream.
  * Copied manpage into debian/misc due to elimination from upstream
    source.
  * Ubuntu changes dropped:
    - debian/patches/01_aaa_fix_plugins_m4.dpatch: not actually
      applied in previous package, obsoleted by upstream build system.
    - debian/patches/01_relibtoolize.dpatch: change obsoleted by
      improvements to upstream build system.
    - debian/patches/02_no_pedantic_configure.dpatch: change obsoleted
      by improvements to upstream build system.
    - debian/patches/09_bad_MANIFEST_omission.dpatch: change obsoleted
      by improvements to upstream build system.
    - debian/patches/13_base_strings.dpatch: upstream build system
      handles strings properly.
    - debian/patches/15_pt_BR_string_fix.dpatch: obsoleted by upstream
      string updates.
    - debian/patches/17_de_string_fix.dpatch: obsoleted by upstream
      string updates.
    - debian/patches/03_workaround_for_ots.dpatch: obsoleted by
      upstream.
    - debian/patches/10_browser_handling.dpatch: a better, simpler fix
      is upstream.
    - debian/patches/11_history_fullpath.dpatch: better, simpler fix
      is upstream.
    - debian/patches/18_new_poppler.dpatch: patch no longer applies -
      plugin rewritten to use poppler binaries at runtime.
    - debian/patches/poppler06-api.dpatch: patch no longer applies -
      plugin rewritten to use poppler binaries at runtime.
  * Added patches:
    - debian/patches02_add_mimetypes_to_desktop.dpatch: account for
       import/export support included in the main package now.
    - debian/patches/03_modify_extras_pkgconfig.dpatch: fix configure
      of abiword-extras source sub-package against a non-installed
      AbiWord
  * Add dh_desktop to register MIME types.

  [ Martin Pitt ]
  * Minor adjustments for intrepid upload, merged changelogs from all PPA
    uploads.
  * Dropped abiword-plugins-gnome package, since it is empty since edgy. Add
    appropriate transitional dependencies.
  * Skip -0ubuntu1 version number, since PPA has a higher version already.

 -- Ryan Pavlik <email address hidden> Fri, 30 May 2008 09:34:12 +0000

Changed in abiword:
status: Confirmed → Fix Released
James (chiisu81) wrote :

Adding the PPA to use 2.6 under Hardy, this does seem to be fixed. However under "File->Save As", you can clearly see that ODT is nowhere near the top. I'm not criticizing AbiWord, as I love it and tend to use RTF for the most part. I'm just saying for ODT creation and editing it seems to make more sense to stick with OpenOffice and KOffice...

Ryan Pavlik (abiryan) wrote :

I'm not really sure how the (probably alphabetical) positioning of the file format in the list of possible formats is any reflection of our compatability. If you think you've found an actual bug, then please report it separately - however, it seems to be a case of unusual logic.

Ryan Pavlik (abiryan) wrote :

This is fixed in Debian, so all projects taking those packages should have it fixed. It was never an AbiWord bug.

Changed in abiword:
status: New → Fix Released
Changed in abiword (Baltix):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.