source packages in oneiric without binaries

Bug #798195 reported by Matthias Klose on 2011-06-16
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned

Bug Description

the attached list of source packages doesn't build binary packages in oneiric. reasons are:

 - ftbfs, a separate bug report should be available (TODO: check the ftbfs reports)
 - never built due to dep-wait
 - not built on an ubuntu primary arch
 - not built on an ubuntu arch

to check
--------

4store
abuse-lib
acoustid-fingerprinter
activemq-activeio
activemq-protobuf
afbinit
amrita
apng2gif
audacious-dumb
aufs-tools
basilisk2
binutils-m68hc1x
brickos (builds but recommends gcc-h8300-hms which FTBFS)
c-icap-modules
cairo-dock-plugins
cctools
chromium-codecs-ffmpeg
clonalframe
debian-installer-netboot-images
dict-en-za
dsc-statistics
easytag-aac
efi-reader
expeyes
facturlinex2
fastx-toolkit
felix-bundlerepository
felix-shell
felix-shell-tui
fillmore-lombard
firmware-free
fonts-oldstandard
foo-plugins
forked-daapd
freebsd-utils
g15daemon-audacious
gcc-m68hc1x
geanydoc
gridsite
haskell-cprng-aes
herculesstudio
jmol
k8temp
kubuntu-konqueror-shortcuts
libaddressable-ruby
libalgorithm-diff-ruby
libbarby-ruby
libbio-das-lite-perl
libchamplain-0.8
libcolor-tools-ruby
libdaemons-ruby
libdb-ruby
libdbd-informix-perl
libdbd-interbase-perl
libdfp
libdifflcs-ruby
libdispatch
libfeedparser-ruby
libgems-ruby
libgimp-perl
libgit-ruby
libglobalhotkeys-ruby
libgnuplot-ruby
libgrapple
libgtextutils
libhbalinux
libhmac-ruby
libjboss-buildmagic-java
libjempbox-java
libjson-ruby
libmaruku-ruby
libmecab-ruby
libmime-types-ruby
libmocha-ruby
libnarray-ruby
libncursesada
libnet-scp-ruby
libnet-sftp-ruby
libnet-sftp2-ruby
libnet-ssh-gateway-ruby
libnet-ssh-multi-ruby
libnet-ssh-ruby
libnet-ssh2-ruby
libnss-gw-name
libole-ruby
libpadre-plugin-javascript-perl
libqzeitgeist
librestclient-ruby
librspec-ruby
libsetup-ruby
libshoulda-ruby
libspreadsheet-ruby
libspring-java
libtermios-ruby
libtmail-ruby
libtransaction-simple-ruby
libwill-paginate-ruby
libwirble-ruby
lilv
lpia-linux-restricted-modules
lpia-wrapper
lv2file
maven-bundle-plugin
mbtserver
mig
mocka
mod-gearman
mscore
ncbi-blast+
ncurses-ruby
nemerle
netqmail
nordugrid-arc
oaklisp
openhackware
partitioner
partman-ext2r0
plt-scheme
prep-installer
proll
python-poster (in New queue)
quik-installer
rcalc
rdiff-backup-fs
ruby-bcrypt
ruby-event-loop
ruby-highline
ruby-log4r
ruby-rails-2.3
ruby-rspec-core
ruby-rspec-expectations
ruby-rspec-mocks
ruby-sinatra
ruby-tilt
ruby-tioga
salinfo
sformat
sigviewer
sikuli
slgtk
squeak-image
stage
sysconfig
tabix
termit
timblserver
timeago
tokyocabinet-ruby
uboot-envtools
underscore
undertaker
wiican
wireless-regdb
xen-qemu-dm-4.0
zipl-installer
zzuf

ftbfs
-----
bsaf (failed buildtest, perhaps try syncing Debian's 1.9-3)
darktable perhaps try syncing Debian's 0.9-1, previous bug was http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=625315
pygrace
python-django-threadedcomments (FTBFS should be fixed if Debian's 0.5.3-2 is synced)

gcc-h8300-hms (bug 755975)
gcc-mingw-w64 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=625406
gradle (bug 796769, needs manual build)

pycg (bug 755990)
splashy http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=625406

needs to be removed
-----
glade-3 (replaced by https://launchpad.net/ubuntu/+source/glade)
ubuntume-gdm-themes (bug 814970)
ubuntume-themes
usplash-theme-ubuntume
wine-gecko (bug 814975)
geanyprj (replaced by https://launchpad.net/ubuntu/+source/geany-plugins)
mplayer-blue (replaced by https://launchpad.net/ubuntu/+source/mplayer-skins)
python-pybabel (https://launchpad.net/ubuntu/+source/python-babel)
xf86-video-displaylink (replaced by https://launchpad.net/ubuntu/+source/xserver-xorg-video-displaylink)

The below conflict with mythtv 1:0.24.0+fixes27162-0ubuntu1 and later:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/mythtv/oneiric/view/head:/debian/control#L456
mythtv-theme-blootube
mythtv-theme-blootube-osd
mythtv-theme-blootube-wide
mythtv-theme-blootubelite-wide
mythtv-theme-neon-wide
mythtv-theme-projectgrayhem
mythtv-theme-projectgrayhem-osd
mythtv-theme-projectgrayhem-wide

removed
-------
bse-alsa
language-pack-gnome-zh
language-pack-gnome-zh-base
language-pack-kde-zh
language-pack-kde-zh-base
language-pack-zh
language-pack-zh-base
kcm-tablet
lightspark
virtualbox-guest-additions

architecture specific (ports)
-----------------------------

cell-gdb
openbios-ppc
partman-newworld
partman-prep
partman-uboot
yaboot-installer

architecture specific (not in Ubuntu)
-------------------------------------

arcboot
arcboot-installer
arcload
colo
colo-installer
gnumach
kboot-installer
kfreebsd-kernel-di-amd64
kfreebsd-kernel-di-i386
kfreebsd-kernel-headers
openbios-sparc
openoffice.org-ia64-dummy
s390-dasd
s390-netdevice
s390-sysconfig-writer
s390-tools
sibyl
sibyl-installer
silo-installer
silo-llnl
sparc-utils
xserver-xorg-video-suncg14
xserver-xorg-video-suncg6
xserver-xorg-video-sunffb
xserver-xorg-video-suntcx
zfsutils

Related branches

Matthias Klose (doko) on 2011-06-16
Changed in ubuntu:
importance: Undecided → Medium
milestone: none → oneiric-alpha-3
status: New → Confirmed
Martin Pitt (pitti) on 2011-06-16
description: updated
Martin Pitt (pitti) on 2011-07-07
description: updated
Jeremy Bicha (jbicha) on 2011-07-23
description: updated
Jeremy Bicha (jbicha) on 2011-07-23
description: updated
Jeremy Bicha (jbicha) on 2011-07-24
description: updated
description: updated
Jeremy Bicha (jbicha) on 2011-07-31
description: updated
Jeremy Bicha (jbicha) on 2011-08-12
description: updated
Colin Watson (cjwatson) on 2012-04-25
no longer affects: Ubuntu Oneiric
Colin Watson (cjwatson) wrote :

I've added an orphaned-sources tool to lp:ubuntu-archive-tools, which does most of the work of figuring this out. I've removed the vast majority of the orphaned source packages, although there are still a few left; I doubt I'll get it down to zero for raring, but hopefully for S.

Mathew Hodson (mhodson) on 2016-06-17
Changed in ubuntu:
milestone: oneiric-alpha-3 → none
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers