No mouse cursor after resuming from suspend during the graphical login prompt.

Bug #552214 reported by SAL-e on 2010-03-31
108
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Nominated for Lucid by mschaeffler
Nominated for Maverick by mschaeffler

Bug Description

Binary package hint: gdm

I am using Lenovo T400. The bug is reliably reproduced. Steps to repreduce:
1. Boot the notebook.
2. Wait until graphical login prompt is displayed.
3. Suspend the computer. (any method of the methods will work: close the lit, press Fn+F4, or select the 'Suspend' option from the power button on the right-bottom corner.
4. Wait until the notebook suspends ( a.k.a Stand-by )
5. Start the notebook again. (open the lit if it was closed, or press the power button)
6. Wait until the login prompt appears again.
7. You can notice that there will be no mouse cursor shown, but if you try to move it you will notice that mouse is working. Just move to the bottom-right corner were the power button is located and you will notice that button will be activated. If you press the left mouse button the power menu will appear. So the mouse is working, but no cursor is displayed.

Let me know how I can help to resolve the problem.

Description: Ubuntu lucid (development branch)
Release: 10.04
gdm:
  Installed: 2.30.0-0ubuntu2
  Candidate: 2.30.0-0ubuntu2
  Version table:
 *** 2.30.0-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gdm 2.30.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic i686
Architecture: i386
Date: Tue Mar 30 17:46:45 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gdm

SAL-e (sal-electronics) wrote :
Onno Steenbergen (osteenbergen) wrote :

Happens to me when suspending in Gnome Itself.
Mouse isn't working during entering password (locked screen) and after, mouse button does work.

In essence the mouse stays locked and the rest of the PC works.

Onno Steenbergen (osteenbergen) wrote :

Not just GDM

affects: gdm (Ubuntu) → ubuntu
Onno Steenbergen (osteenbergen) wrote :

Found the problem (at least it is with my Macbook Pro 4,1):

in /var/log/dmesg

bcm5974: bad trackpad package, length: 8

Onno Steenbergen (osteenbergen) wrote :

Fixed it by creating /etc/pm/sleep.d/98bcm

#!/bin/bash

# Only run on resume/thaw
if [[ ${1} =~ (thaw|resume) ]] ; then

 rmmod bcm5974
 modprobe bcm5974
fi

Don't know what driver your touchpad uses, but reloading seems to triage it.

SAL-e (sal-electronics) wrote :

Hi Onno,

I think we are having different problems.

In my case only the mouse cursor is not displayed after suspend in GDM. I just found workaround for my problem. I just switch to virtual console by pressing <ctrl> + <alt> + <F1> and then back to GDM by pressing <ctrl> + <alt> + <F7> and the mouse cursor is visible again.

As I have notice in my previous comments the actual mouse is working, but cursor is not visible. Also I have no problems when I resume in GNOME session.

Best regards,
SAL-e

SAL-e (sal-electronics) wrote :

I just run;

sudo lsmod | grep bcm5974

and no result was displayed so I guess my Thinkpad is using different driver.

Jonas Jasas (jon-stekas-lt) wrote :

This happens also on Compaq Presario X1000 . If I remove authentication after suspend, mouse pointer do not appear after suspend.

feffemannen (fredrik-ellborg) wrote :

This is happening to me too. I'm using a Thinkpad T42. (I've removed the authentification after resume as well.)

Paul R (paul-r) wrote :

Same here, no cursor displayed although interface reacts to mouse movements. Switching to VT then back to X makes it appear.

Thinkpad T42, no GDM at all (running Xmonad from startx)

lspci :

00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
02:00.0 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
02:00.1 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
02:01.0 Ethernet controller: Intel Corporation 82540EP Gigabit Ethernet Controller (Mobile) (rev 03)
02:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

RZCashman (rzcashman) wrote :

Same problem. I'm running Ubuntu Linux 10.04 on an IBM X41 Tablet.

@SAL-e: When I typed "sudo lsmod | grep bcm5974" and hit enter, nothing happened.

karl dietrich bamler (kadi) wrote :

Same here, I also experience an invisable mousepointer after suspend on my compaq 615.

If I switch my ATI card to the proprietary FGLRX driver this problem does not happen. But i don't like that, because i experience some other issues with this driver. Back into the open source driver the same mousepointerproblem again.

lspci

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:07.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 3)
00:09.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 4)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] HyperTransport Configuration (rev 40)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h [Turion X2, Athlon X2, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Mobile K10 [Turion X2, Athlon X2, Sempron] Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]
02:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 4357 (rev 10)
06:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)

marekm (marekm) wrote :

I can confirm this bug with 10.04 32-bit on another machine (old Athlon64 desktop with ATI Radeon 9250 AGP card, open source ATI driver), mouse cursor disappears after suspend to RAM and resume (which appears to work fine otherwise).

Workaround: use "X -configure" to generate /etc/X11/xorg.conf (which doesn't exist by default) and specify the option below:

Option "SWcursor" "on"

It seems the HW cursor state is not restored across S3 suspend/resume. The cursor probably appears again when its shape is changed (for example, to a little wheel which indicates "please wait"), entering the screensaver password is one such situation. I knew the "SWcursor" option as it has already helped me a few times to work around graphics HW/driver bugs in the past years.

VT switch to text console and back is another fix. Perhaps such VT switch could be invoked automagically as part of suspend/resume - switch to text console then suspend, resume then switch back to X (it doesn't take very long, and should restore all of the graphics state, not just the cursor, avoiding potential similar bugs in non-ATI drivers as well - VT switching is decades old and much better tested on a lot of hardware, than the relatively recent and still fragile ACPI S3 support)?

marekm (marekm) wrote :

Bug probably affects many ATI graphics cards - happens on RV370 [Sapphire X550 Silent] on a newer box (Intel E6600, Foxconn P35A-S mobo, PCI-E) too.

marekm (marekm) wrote :

I've just tried the latest 2.6.34-rc kernel snapshot:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc7-lucid/linux-image-2.6.34-020634rc7-generic_2.6.34-020634rc7_i386.deb

and it seems the ATI driver has improved in the meantime - I can't reproduce this bug anymore (at least on the RV370). I've tried suspend to RAM a few times, both from the login screen and from the active X session while typing this comment, and the mouse pointer always came back correctly after resume.

Now it might be a good idea to try binary search to see exactly which kernel (after 2.6.32-22.33) fixed it, and backport the fix.

Vernon Mauery (vernon-mauery) wrote :

I am seeing this bug on an IBM ThinkPad R50p, with ATI video. I noticed that while doing a VT switch would bring back the mouse, so does merely switching workspaces (ctrl-alt-left/right). This is much faster and easier to do than a full VT switch.

Same bug on HP tx2020eo with Nvidia card. Seems to only happen when there is login after suspend.

SteveLoughran (steve-loughran) wrote :

I see this on a compaq nc6000 w/ ATI graphics card, fglrx drivers

The switch workspace trick doesn't work for this card, but C-A-F2 and C-A-F7 back does

I had a similar (if not same) bug on my Thinkpad T43 running Ubuntu 10.04 (upgraded from 9.04) and I may have a sort of work around.

For me anytime the screen was blanked, such as when I closed the laptop lid OR whenever I hibernated/suspended the pointer was hidden on resume but the mouse still functioned.

Under the System->Preference->Appearance->Theme->Customize->Pointer setting I selected the "redglass" theme and adjusted "Size:" to the largest setting. I now have a comically large mouse pointer but it appears after a screen blank or suspend/hibernation when I move the mouse around a bit.

It seems like whatever is going on is still happening because immediately after coming out of suspend/hibernate the pointer is still hidden but after moving the mouse around for a second the pointer appears.

Update: Pointer Theme workaround

Apparently the workaround does not work all the time. Since my initial post I've had three instances where the pointer stayed hidden after closing then opening my laptop lid. I haven't been hibernating or suspending my machine other than a few tries to test the work around so I don't know if it's more reliable there. Perhaps someone more savvy can provide an explanation for the inconsistency and hopefully make a suggestion. All in spite of an actual fix, I guess.

Same issue, sounds like a video driver issue with ATI cards. I can get the mouse to display again by doing a Ctrl-Alt-F1 then Ctrl-Alt-F7. Might try a different video driver to see if it helps.

ThinkPad T60 with ATI video.
Same issue as everyone else.
Used gconf-editor so suspect/resume does not ask for password on resume.

Workaround listed in a duplicate linked off of this bug (look for 99_mousecursor) works for me.

Urs Fleisch (ufleisch) wrote :

Same issue on Compaq Evo N610c (ATI Mobility Radeon) with Lubuntu 10.04. It works again if I disable KMS (which also fixes Bug #567957). You can add "nomodeset" to the kernel command line in Grub or make it permanent in GRUB_CMDLINE_LINUX_DEFAULT of /etc/default/grub and then run update-grub.

thewk (theewk) wrote :

Same type of issue with Acer Travelmate 5520 which has Radeon X 1250. When I put the machine to suspend by using keyboard shortcut, mouse cursor has disappeared after waking up. If I put the machine to suspend via the menu in the upper right corner, I get the password prompt (I have tried to disable all password prompts but somehow this is still present) and the mouse does work.

There is problem with brightness settings not staying what they were before suspend but that's another story...

Same problem with desktop pc (asus EAH4350 ATI Radeon HD 4350 / motherboard asus P7P55D).

The cursor comes back with a xrefresh command.

on ubuntu with used pppoe to the internet connection the fix to this problem is to turn the pppoe off by typing in console poff and then pppoeconf and processing the setup

Otto Kekäläinen (otto) wrote :

This is likely to be a duplicate of #492782, since the symptoms are the same: in some situations the cursor carret disappears but when you move the mouse you can still see icons highlited etc (invisible mouse).

Jumping to a console and back usualy makes the carret reapper (Ctrl+Alt+F1, Ctrl+Alt+F7).

DBooth (david-dbooth) wrote :

Same problem on Dell Studio 15, Intel, Ubuntu 10.04. Work-around at https://bugs.launchpad.net/ubuntu/+bug/554438/comments/21 works for me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions