Lucid-No mouse pointer after suspend or hibernation

Bug #554438 reported by tdt34 on 2010-04-03
138
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Ubuntu
Low
Unassigned

Bug Description

Binary package hint: xorg

i choose "no password required" after supsend or hibernation.
Pointer mouse is ok when password is required after suspend or hibernation

The mouse pointer disappears after suspend or hibernation when no password is required to unlock the screen.
On the other hand, pointer mouse is present after suspend or hibernation when password is required to unlock the screen.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+3ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
Architecture: amd64
CheckboxSubmission: 242fcfcfab4c183d918cbef9eacade63
CheckboxSystem: b5acb6c9ca4017b1d44043910f45329d
Date: Sat Apr 3 08:31:54 2010
DkmsStatus: Error: [Errno 2] Aucun fichier ou dossier de ce type
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: Acer Aspire X1700
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=82379233-4fe7-4856-be5b-40c8e4a6b17a ro quiet splash
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
dmi.bios.date: 02/26/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R01-B4
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: Aspire X1700
dmi.board.vendor: Acer
dmi.chassis.type: 3
dmi.chassis.vendor: Acer
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR01-B4:bd02/26/2009:svnAcer:pnAspireX1700:pvr:rvnAcer:rnAspireX1700:rvr:cvnAcer:ct3:cvr:
dmi.product.name: Aspire X1700
dmi.sys.vendor: Acer
glxinfo: Error: [Errno 2] Aucun fichier ou dossier de ce type
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-19-generic

[lspci]
02:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f]
     Subsystem: PC Partner Limited Device [174b:e990]

tdt34 (cyrilchristal) wrote :
Bryce Harrington (bryce) wrote :

Hi cyrilchristal,
Hmm... I'm not sure I totally understand your description of the problem. Could you please elaborate and clarify? In particular, I don't know what "pointepauser" means.

Changed in xorg (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2010-04-03
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
tdt34 (cyrilchristal) wrote :

Sorry Bryce, i made a mistake in the title.

I would mean, that the mouse pointer disappear after suspend or hibernation when no password is required to unlock the screen.

On the contrary, pointer mouse is present after suspend or hibernation when password is required to unlock the screen.

Best regards.

summary: - Lucid-No pointepauser mouse after suspend or hibernation
+ Lucid-No mouse pointer after suspend or hibernation
Bryce Harrington (bryce) on 2010-04-05
description: updated
Bryce Harrington (bryce) on 2010-04-05
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Are you able to restore the mouse cursor through some means, such as vt switching (ctrl+alt+F1 / ctrl+alt+F7) or some other mechanism? Or does it simply never come back?

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
tdt34 (cyrilchristal) wrote :

-i've tried to wait some minutes but it didn't come back

-Yes, the mouse cursor is restored with ctrl+alt+F1 / ctrl+alt+F7

-I found something else:
this problem appears only when i choose "suspend" with the "Log Out Button"
this problem doesn't appear when the system go to status "suspend" automatically

Bryce Harrington (bryce) wrote :

wow that's weird.

Sounds like something (maybe not X) is hiding the mouse cursor and not restoring it on resume.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Low
Bryce Harrington (bryce) on 2010-04-07
description: updated
Bryce Harrington (bryce) wrote :

Given that it only reproduces when suspending using the menu, I think it's not an X.org bug. My guess is something in the power management stuff is hiding the mouse but not re-enabling it on resume. I'm not sure what package is responsible for that though.

affects: xserver-xorg-video-ati (Ubuntu) → ubuntu
tdt34 (cyrilchristal) wrote :

The most important on my side is that the automatic supsend is ok. I will not investigate further.
Thanks for your help ^^.

Cristian Klein (cristiklein) wrote :

I have the exactly same symptoms. Running mplayer or switching to console and back restores the mouse.

Sébastien Giguère (samoul) wrote :

Same exact bug here. No cursor after resuming from suspend when password protection is off. Need any log file?

Jens Bayer (jb300180) wrote :

Can confirm that behaviour for Kubuntu.
When system is going in suspend mode I can see that the pointer gets moved to upper left corner (but is still visible).
The "Jumping Cursor" when I launch an application is yet visible anyway.

Dave (davem99) wrote :

I have the same problem on Xubuntu Lucid. It happens when my laptop battery dies and the machine auto-hibernates.

Suspend doesn't work properly on this old machine (Sony VAIO VGN-A150) so I can't test that.

Ctrl+Alt+F1 / Ctrl+Alt+F7 does un-hide the cursor.

Cyril Buquet (cyril11) wrote :

I have the same problem with kubuntu
Mouse is present and work correctly. Only cursor is invisible. CTRL+ALT+F1...F7 restore cursor

PS:
Lucid is for me the first ubuntu version with correct suspend / resume on Samsung R60. Thanks all.

Cyril Buquet (cyril11) wrote :

Duplicated with bug #552214 ?

Cyril Buquet (cyril11) wrote :

an other duplicate ? bug #568481

Confirmed on 10.04 32-bit with ATI video.

I'd like to add that the cursor is there and works, but is not visible.

You can move the mouse to the upper left corner and click the Ubuntu icon, or to the upper right and click the power icon.

This happens for me when I use gconf-editor to disable password prompt for Hibernate / Standby. The work-around is to re-enable password prompt, which is not ideal, but works every time.

-Tres

Ron Aaron (ron-ronware) wrote :

Also happens for me, 10.04 32bit, ATI video (Acer laptop)

eigenman (eigenman96) wrote :

comment #14 for bug #552214 might be related to the answer.

velo (velo-br) wrote :

FWIW, I'm affect also, using ubuntu netbook edition on a HP zv6000, also ATI driver.

Mine is set to suspend when closed, once it resume no mouse. Going back and forward console makes it appears again

VELO

eigenman (eigenman96) wrote :

The workaround for bug #552214 (comment #16) worked for me. This seems to be an issue with the ATI driver that has been resolved in newer kernels.

Jari Tulilahti (jartza) wrote :

Confirmed also on 32bit 10.04 with HP Pavilion, using ATI graphics.

This workaround works for me before the fix is released:

Create file /etc/pm/sleep.d/99_mousecursor

#!/bin/sh

case "${1}" in
  hibernate)
    #nothing
    ;;
  resume|thaw)
    /bin/chvt 1
    /bin/chvt 7
    ;;
esac

--- >8 ---

Effectively this script changes virtual terminal to 1 and back to 7 (supposing that your X is running on VT7).
Of course, remember to chmod +x 99_mousecursor

francoisd (francois-drolet) wrote :

Confirmed on 32bit with hp compaq nx7000. I suspend using "pm-suspend". Most of the time tough, everything is fine. I don't use gnome.

Putting screen in DPMS (xset dpms force suspend) or executing "slock" from wmii and coming back also makes the cursor reappear.

Confirmed on HP tx2020eo with Nvidia card.

maticmatija (maticmatija) wrote :

confirmed on thinkpad r50e

I have similar problem with suspending from the shut-down button... the mouse just don't show up after restore from suspending

Colin Slater (c-t-slater) wrote :

This looks like a gnome problem. Suspending from the shutdown menu causes the cursor to disappear on resume on my thinkpad T43, but suspending with a keyboard shortcut (presumably handled by ACPI) does not reproduce the bug. Upgrading the kernel to 2.6.34 also did not fix the bug.

I can confirm this bug on thinkpad R60. In my case suspend/hibernate from keyboard (Fn+F12) also causes the pointer to disappear. I have disabled "gnome_keyring_hibernate" and "gnome_keyring_suspend" via gconf-editor. Switching from the last used workspace to another and back brings the pointer up again.

ThinkPad T60 with ATI video.
Same issue as everyone else.
Used gconf-editor so suspect/resume does not ask for password on resume.

Workaround listed above (99_mousecursor) works for me, thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers