Resolution problem with double screens on boot

Bug #446412 reported by Simon Baconnais on 2009-10-08
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
Undecided
Unassigned
gdm
Confirmed
Undecided
Unassigned
Nominated for Main by Simon Baconnais
grub
Invalid
Undecided
Unassigned
usplash
Undecided
Unassigned
xsplash
Wishlist
Unassigned
Ubuntu
Undecided
Unassigned
Declined for Intrepid by Robert Collins
Declined for Jaunty by Robert Collins
Nominated for Karmic by Simon Baconnais
Nominated for Lucid by Simon Baconnais
unity-greeter (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Robert Collins
Declined for Jaunty by Robert Collins
Nominated for Karmic by Simon Baconnais
Nominated for Lucid by Simon Baconnais

Bug Description

Ubuntu Maverick Meerkat 10.10 (64 bits), fully upgraded.

With double (multi ?) screen, there is screen resolution problems.

Configuration -> I configured Ubuntu to disable the screen on my laptop (1280x800), to use an external sreen (1280x1024).

Grub2 : Laptop screen isn't disabled, external screen isn't enabled..

GDM :
   - Rresolution is 1024x768 on both screens.
   - On laptop screen that should disabled, image is stetched to fit with the screen resolution (1280x800).
   - On external screen (1280x1024), image is stetched to 1280x800 resolution, and there is black strips on top and bottom.

Gnome loading : during first part of Gnome loading, resolution problem remains, but after a few seconds laptop screen is disabled and external screen is finally in 1280x1024 resolution.

You can also see the attached video (3gp).

Hardware :
    - VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
   - Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller

Simon Baconnais (smon) wrote :
Simon Baconnais (smon) wrote :

Xsplash has been upgraded, but the resolution problem remains ...

I have similar observations on a notebook with an additional monitor attached on Ubuntu 8.10, ATI graphics card with different drivers.

Laptop Screen size is 1330x768, the other monitor is a CRT at 1024x768.

Resolutions on both screens change several times from boot to Gnome startup. Also linux seems to switch randomly between using the screens as primary output - the laptop and crt screen flicker on and off several times. Also the brightness of the laptop monitor is way to dark on the gdm login screen.
To add insult to injury I can't get the CRT to work with more than 60HZ.

I observe this problem as well: "Dualheadsetup - invalid notification position" -> https://bugs.launchpad.net/bugs/370380

Simon Baconnais (smon) on 2009-10-10
Changed in ubuntu:
status: New → Confirmed
Simon Baconnais (smon) wrote :

4 days before the RC, the resolution problem remains ...

Simon Baconnais (smon) wrote :

The RC is here, the resolution bug remains ...

Simon Baconnais (smon) on 2009-11-02
summary: - Resolution problem with double screens on Karmic's boot
+ Resolution problem with double screens on boot
Changed in ubuntu:
assignee: nobody → Tom Haddon (mthaddon)
Simon Baconnais (smon) wrote :

Problem not fixed in Karmic, reported for Lucid.

tags: added: lucid
removed: karmic
Changed in ubuntu:
status: Confirmed → New
Simon Baconnais (smon) on 2009-11-02
Changed in xsplash:
assignee: nobody → Ken VanDine (ken-vandine)
Simon Baconnais (smon) on 2009-11-02
description: updated
description: updated
tags: added: grub
Simon Baconnais (smon) on 2009-11-02
description: updated
Simon Baconnais (smon) on 2009-11-08
Changed in usplash:
assignee: nobody → Scott James Remnant (scott)
Changed in usplash:
assignee: Scott James Remnant (scott) → nobody
Maciej Strzelecki (mstrzele) wrote :

Confirming. Most annoying is that GDM uses 1024x768, not maximum common resolution for both screens.

Robert Collins (lifeless) wrote :

There are multiple different issues here. Very early in the boot process there is no configuration data or screen drivers to deal with different screen needs. We should be able to do better once xsplash starts so...
I'm going to assign this to Cody, the main xsplash author for commentary.

If you wish to file a separate bug about the behaviour leading up to xsplash, thats fine with me, but I'm not at all sure its tractable.

Changed in xsplash:
assignee: Ken VanDine (ken-vandine) → nobody
Changed in ubuntu:
assignee: Tom Haddon (mthaddon) → nobody
Changed in xorg-server:
status: New → Invalid
Changed in gdm:
status: New → Invalid
Changed in grub:
status: New → Invalid
Changed in usplash:
status: New → Invalid
Changed in xsplash:
assignee: nobody → Cody Russell (bratsche)
status: New → Confirmed
Robert Collins (lifeless) wrote :

@Cody, I'm not expecting it to stay assigned to you, I would just like to kickstart the bug a little is all ;).

Simon Baconnais (smon) wrote :

This bug is finally officially assigned \o/

Thanks ! :D

screenshoot of the bug

Simon Baconnais (smon) wrote :

Ubuntu Lucid LTS 10.04 Alpha 2, fully updated on 02/02/2010.

Resolution problem remains ...

Simon Baconnais (smon) wrote :

Need a new video ?

joe richter (joe-r) wrote :

Hi,
in my humble opinion, this is just the matter of order and not a real bug:

the resolution should be set up at initialization time, so that not each boot task has to check if the screen resolution changes while it draws on it.

For me adding the lines:
xrandr |grep -q "VGA1 connected" && \
 xrandr --output VGA1 --auto --output LVDS1 --off
to:
/etc/gdm/Init/Default
did the trick.

best regards - Joe

Simon Baconnais (smon) wrote :

It works ! :)

There still some problems on xsplash loading, but as soon as xsplash is totally loaded, the resolution is ok.

Do you think it can be fixed by ubuntu devs, or is it too complicated to do it automatically ?

Simon Baconnais (smon) wrote :

3 days before feature freeze. I hope this is not a feature problem, because bug remains ... I still have to fix this bug manually.

On Mon, 2010-02-15 at 10:57 +0000, Simon Baconnais wrote:

> 3 days before feature freeze. I hope this is not a feature problem,
> because bug remains ... I still have to fix this bug manually.
>
Feature Freeze means we stop developing features and mostly work on
fixing bugs.

Scott
--
Scott James Remnant
<email address hidden>

Simon Baconnais (smon) wrote :

Ok, thanks for your work :)

rent0n (rent0n) wrote :

Same problem here. And the fix proposed doesn't work.
Moreover, I think this is related to another bug: gdm loops back to gdm after login: https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/454437

rent0n (rent0n) on 2010-02-25
Changed in gdm:
status: Invalid → Confirmed
rent0n (rent0n) wrote :

EDIT:
I'm sorry, I noticed now that adding the lines:
xrandr | grep -q "VGA1 connected" && \
xrandr --output VGA1 --auto --output LVDS1 --off
at the beginning (and not at the end) of /etc/gdm/Init/Default works perfectly and also solves the bug of gdm that loops back to gdm after login.

Simon Baconnais (smon) wrote :

Alpha 3; problem remains :)

Cody Russell (bratsche) on 2010-03-10
Changed in xsplash:
importance: Undecided → Wishlist
Cody Russell (bratsche) on 2010-03-11
Changed in xsplash:
assignee: Cody Russell (bratsche) → nobody
Simon Baconnais (smon) wrote :

Beta 2 coming in three days, but resolution problem remains ...

Cody Russell (bratsche) on 2010-04-05
Changed in xsplash:
status: Confirmed → Won't Fix
Changed in ubuntu:
status: New → Invalid
Simon Baconnais (smon) wrote :

Maverick Beta, problem remains.

Guys, it's just a configuration problem, you could do something easily ...

description: updated
tags: added: maverick
removed: boot grub lucid xsplash
Simon Baconnais (smon) wrote :

Oneirc, new login screen, same problem ...

tags: added: lightdm oneiric
removed: gdm maverick
affects: lightdm → unity-greeter
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: unity-greeter → unity-greeter (Ubuntu)
Changed in unity-greeter (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers