Recording volume is very low

Bug #391926 reported by hielos on 2009-06-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Ok, this is my first bug report, so be gentle, please :P :D . I have browsed and haven't found precisely what is going on with my case. By the way, I already reported this on: Bug 578174 – gnome-volume-control mutes my audio (http://bugzilla.gnome.org/show_bug.cgi?id=578174)

I am actually using a USB hard-drive on a Dell Optiplex 755 (I may use some other
configuration). My OS is Ubuntu 9.04 (Jaunty) with 2.6.28-13 kernel This
computer has the intel 82801I (ICH9) sound card. I haven't updated anything
regarding sound (only the codecs).
The issue is that whenever I try to record with the gnome-sound-recorder (from Audacious), I get a VERY low volume. At first, I was not even able to record anything, so I started to play around with the sound configuration. This is what I have found out that by:
(1) going to Volume Control (the little speaker we all know)
(2) clicking on Preferences and set Front Mic, Front Mic Boost, Mic, Mic Boost, Capture and Capture1
(3) closing
(3) going to System > Preferences > Sound
(4) set everything to ALSA (even the last option; the mixer)
(4.a) you can set everything to PulseAudio, but make sure to change your configuration at Audacious as well
(5) going back to the Volume Control
(6) turning up Mic and Mic Boost all up
(7) turning up Front Mic and Front Mic Boost all down (if you don't, you get white noise or even a horrendous BEEEP)
(8) going to the Recording tab and turning up Capture and Capture1 all up (the little X will never go away)
(9) open gnome-sound-recorder (from terminal or the Sound/Video menu in Applications)
(10) start playing anything on Audacious
(11) start recording from gnome-sound-recorder

Then you'll get a very faint reproduction of what you were playing. I have seen that most people have problems with their microphones, but I think it is not just a Mic issue. I think this bug can be related to PulseAudio, ALSA or some other multimedia package. By the way, if you would like to try using Audacity and giving a fix for that as well, please?
I don't know how to get my ALSA version nor PulseAudio, but I am pretty sure they are the default ones for Ubuntu 9.04 (Jaunty).
I obviously like the sound to be recorded at a decent level, and it is evident by now what happened (following the guidelines, only)

description: updated
tags: added: gnome-media
description: updated

I tried applying the patches in here: http://bugzilla.gnome.org/show_bug.cgi?id=578174. The outcome is (as I already posted there) that the situation got worse. I can't record anything. I guess that I'll go back to my previous configuration. By the way, this also happens when I try to record from Rhythmbox :) . Now I am almost sure this has to do with gnome-media. I hope there is a solution soon. Cheers.

Ok, I would like to say I fixed it, but I only got out of my own ignorance: I completely removed gnome-media from Synaptic. Then, I installed almost everything there is from pulseaudio and alsa (mixers, guis, gtk, apps). I restarted the machine. After i opened the gnome-sound-recorder, I opened the Volume Control from PulseAudio (there is no little speaker anymore, YEEY) and selected the Recording tab. Then, I hitted the record button on gnome-sound-recorder.That was when the "gnome-sound-recorder: Record Stream" was enabled. I clicked on the little down-arrow to the right and moved the stream to Monitor blah, blah... So I started playing music with Audacious, and the reproduction was LOOOOVELY. I guess that is as far as I'll go with this. Again, sorry to bother any of you. I hope this helps someone :D . Greets

Changed in ubuntu:
status: New → Fix Committed

And by the way, I know everyone has problems with Audacity and Pulseaudio. I DON'T I just installed Audacity, configured it to work with Pulseaudio, and voilá, (following the same process as the last post), I was able to record my Audacity stream!! YEEY :) . (It may have something to do with the fact that I have the lastest Audacity v.1.3.7)

Changed in ubuntu:
status: Fix Committed → New
Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid packages ?
Tanks in advance.

Changed in ubuntu:
status: New → Incomplete

Fabio, thank you for answering. However, there have been some modifications in both pulseaudio and Audacity which have let me record very well. I lost my USB drive, and I am using a laptop now in which recording has no issues. We should close this as fixed

Fabio Marconi (fabiomarconi) wrote :

Thanks for the reply.
As the reporter cannot reproduce the bug, in accord with assignation policies I mark as invalid.
:)Fabio
Ubuntu is raising again.

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.