[West Lake] System detected display size does not match the actual physcial display dimension

Bug #367811 reported by David Chen on 2009-04-27
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

OS Version:
Intrepid, Jaunty

Environment:
Intel G41 graphic controller

Summary:
System can't detect correct display size. For example, a 19" display is detected as 17".

Steps to Reproduce:
Boot the system (19" system), open display property (System --> Preferences --> Display).

Expected result:
Display preferences detect 19" monitor.

Actual result:
Display preferences detect is as 17" monitor.

David Chen (david.chen) wrote :
  • vBIOS Edit (64.0 KiB, application/octet-stream)
Jerone Young (jerone) wrote :

David can you post xrandr output? What resolution do you expect?

David Chen (david.chen) wrote :

The resolution is correct (1440x900), the problem is the display dimension does not match the actually display. The system I have is a 19", but system detects it as a 17".

David Chen (david.chen) wrote :

I think the issue is related to EDID. EDIDs might not be written correctly into the device.

David Chen (david.chen) wrote :

Monitor firmware update solved the problem. 17" and 19" monitors can be detected as 17" and 19" from the OS, and 18.5" is detected as 18".

Changed in ubuntu:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments