jaunty livecd: gnome doesn't load after login

Bug #367638 reported by peni on 2009-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

booting from live-cd (ubuntu-9.04-desktop-i386.iso) works fine, but after login the screen is black, the welcome-jingle plays once and the mouse cursor is there and is movable. then nothing happens, no cpu/hdd activity, gnome doesn't appear (no background, no panels, nothing).

SOME LOGS:

/var/log/syslog:
Apr 26 12:01:08 ubuntu x-session-manager[4441]: WARNING: No required applications specified
Apr 26 12:03:06 ubuntu x-session-manager[4441]: WARNING: Failed to send buffer
Apr 26 12:03:06 ubuntu x-session-manager[4441]: WARNING: Failed to send buffer
Apr 26 12:03:06 ubuntu x-session-manager[4441]: WARNING: Running '/usr/bin/gconftool-2 --shutdown' at logout returned an exit status of '15'
...
Apr 26 22:38:33 ubuntu kernel: [ 133.681467] [drm:i915_getparam] *ERROR* Unknown parameter 6
Apr 26 22:38:35 ubuntu console-kit-daemon[4044]: WARNING: Couldn't read /proc/4043/environ: Failed to open file '/proc/4043/environ': No such file or directory
Apr 26 22:38:36 ubuntu kernel: [ 137.197388] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
Apr 26 22:38:36 ubuntu kernel: [ 137.199708] mtrr: no MTRR for c0000000,10000000 found
Apr 26 22:38:40 ubuntu acpid: client connected from 4691[0:0]
Apr 26 22:38:41 ubuntu kernel: [ 142.020782] [drm:i915_setparam] *ERROR* unknown parameter 4
Apr 26 22:38:41 ubuntu kernel: [ 142.020806] [drm:i915_getparam] *ERROR* Unknown parameter 6
Apr 26 22:38:42 ubuntu kernel: [ 143.186955] [drm:i915_getparam] *ERROR* Unknown parameter 6
Apr 26 22:39:21 ubuntu x-session-manager[4726]: WARNING: No required applications specified
Apr 26 22:39:41 ubuntu kernel: [ 201.561618] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
Apr 26 22:39:41 ubuntu acpid: client connected from 4691[0:0]
Apr 26 22:39:44 ubuntu kernel: [ 205.269388] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
Apr 26 22:40:01 ubuntu /USR/SBIN/CRON[5366]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)

Xorg.0.log ens with:
(II) intel(0): xf86UnbindGARTMemory: unbind key 0

daemon.log:
Apr 26 22:38:35 ubuntu console-kit-daemon[4044]: WARNING: Couldn't read /proc/4043/environ: Failed to open file '/proc/4043/environ': No such file or directory
Apr 26 22:38:40 ubuntu acpid: client connected from 4691[0:0]
Apr 26 22:39:21 ubuntu x-session-manager[4726]: WARNING: No required applications specified
Apr 26 22:39:41 ubuntu acpid: client connected from 4691[0:0]

what i tried:
- booting in fail safe mode
- chmod a+rwx /tmp
- killall pulse*
- apt-get remove compiz* nvidia* fglrx* pulse*
- installed kde (works fine, but need gnome here)
- rm -rf .gconf* .pulse*

nothin helps :(

test machine: Lenovo 3000 n100 notebook (works fine with 8.10):
$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
$ uname -a
Linux slick 2.6.27-14-generic #1 SMP Wed Apr 15 18:59:16 UTC 2009 i686 GNU/Linux

some similar bug reports:
 - http://ubuntuforums.org/showthread.php?t=1099631
 - http://ubuntuforums.org/showthread.php?t=1134920
 - http://ubuntuforums.org/showthread.php?t=1138134
 - https://bugs.launchpad.net/ubuntu/+bug/350426
 - https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/292600

peni (p-golik) on 2009-04-27
description: updated
peni (p-golik) wrote :

same thing while running livecd in qemu environment. after passing login - black screen, and only mouse cursor.

peni (p-golik) wrote :

sorry, the burnt cd was corrupted. everything's fine again!

Changed in ubuntu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers