missing key on german keyboard layout

Bug #216338 reported by svaens on 2008-04-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

1. Choose German Layout
2. open any editor
3. Attempt to type the @ key, which is on the german keyboard entered using a combination of ctrl-alt-Q

Nothing happens, no key is written.

Using Ubuntu, Gutsy, 7.10

sean@svUbuntuX:~$ uname -a
Linux svUbuntuX 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux
sean@svUbuntuX:~$

Marcus Asshauer (mcas) wrote :

Thank you for reporting this bug. Please try to type the @ with AltGr+ q.

Kjell Braden (afflux) wrote :

Marking as wontfix, since @ is intended to be entered using AltGr+q.

svaens (svaens) wrote :

hmmmm "Marking as wontfix" ???

Well, Since I am NOT german, and have an american keyboard on my notebook,
I don't have any AltGr key.
This is specific to the German keyboard correct?
I DO have of course an 'alt' key on the right of the spacebar, in roughly the same position
as would be the AltGr key. However, when I tried using this right side Alt key to get the @ character,
my editor simply quits, as if i have typed the 'quit' short-cut.

Are you telling me that I cannot use the German keyboard layout on an American keyboard?

svaens (svaens) wrote :

And by the way,
I just tested on our second computer,
which DOES have an actual German keyboard layout, and
BOTH Alt and AltGr keys with the ctrl-q combination work.
Please reconsider this problem.

svaens (svaens) wrote :

Please reconsider.
On german keyboards, both Alt, and AltGr keys successfully are used.
And most people use the left hand side Alt key for this keyboard combination.

Kjell Braden (afflux) wrote :

Only mark a bug as incomplete if you think some information is missing to fix it.

Kjell Braden (afflux) wrote :

svaens, the Alt+Q does definetly not produce @. I'm a german user on a german keyboard layout, the only way to get @ is by pressing AltGr+Q.

Kjell Braden (afflux) wrote :

svaens: do you have a US or US-International keyboard? See http://en.wikipedia.org/wiki/Keyboard_layout#US for the differences.
Also what type of model and layout do you have selected on your two computers? You can check these values in gnome-keyboard-properties in the second tab ("layouts").

svaens (svaens) wrote :

Hi,
Either way, thank you for the swift replies. It is encouraging to see bugs are so quickly looked at on Ubuntu.
Firstly, I just asked my gf (a german) how she writes the @ symbol. She used ctrl-alt-q.
Secondly, while I hate using this argument, and it is largely a stupid argument, ctrl-alt-q works fine on windows.

Question: Did you mean 'Ctrl+AltGr+Q' ??
or did you mean 'AltGr+Q' ?

On my computer, 'Ctrl+Alt (the right alt) + Q ' causes the focused window, eg gedit, to quit.
On my computer, 'Alt (the right alt) + Q' gives me a lower case 'q'.

I did check my German keymap file at '/usr/share/X11/xkb/symbols' and, it looks to be
like it should work:
    key <AD01> { [ udiaeresis, Udiaeresis, at ] };

Perhaps then, am I experiencing a symptom of a different exact bug, namely, that my AltGr is missing?

Incidentally, the layout of my keyboard looks like this (lower row)

ctrl/Fn/Alt/Tilda/space bar/Ins/Del/Alt

svaens (svaens) wrote :

didn't see your last reply until after i'd sent my last..
still working out if i have US or US International,

But here is what the layout tab says my keyboard is:

keyboard model: Generic 105-key (Intl) PC

svaens (svaens) wrote :

ok, so I read what is described on the wiki page.

From this, I can only assume I have a US keyboard, and NOT a US International.
The specs of this machine don't even say.... i have attached the pdf specs...
has a nice picture of this nasty old toshiba.

So, What are my options if i do have a US keyboard (non-international) ??

Kjell Braden (afflux) wrote :

I asked greg-g who has a plain US keyboard to change his layout to German and he reported that R_Alt+Q produced an @.

The line you're quoting from /usr/share/X11/xkb/symbols/de is something completely different, namely dvorak layout.

Please provide:
1. Which keyboard layout you're using (the one listed in the keyboard preferences layout, should be similar to "German no dead keys")
2. the file /tmp/xmodmap-pke.log as created from: xmodmap -pke > /tmp/xmodmap-pke.log

Thanks

svaens (svaens) wrote :

hmmmm (i say to myself, possibly red with embarrassment).

What a funny thing.

Firstly,
I had been under the impression you mean 'ctrl-AltGr-Q'
But having just now tried RightAlt-Q alone (with no ctrl involved) , I managed to get an at symbol '@' working.
I will... *cough* not ask my german girlfriend anything about germany ever again ;)

My deepest apologies for having wasted your time.
And thanks for looking at my problem with me.

svaens.

It does, after all, work.

  • unnamed Edit (189 bytes, application/pgp-signature; name=signature.asc)

Thanks for your efforts, feel free to report any bugs you may find :)

svaens (svaens) wrote :

Hi again,
Just shortly, once again, regarding the behaviour functionality of the
german keyboard, specifically , achieving the @ character using character
combinations:
AltGr+q, or
Ctrl+Alt+q
 Before I had entered this bug, I had (once again, wrongly.. i am new
here...) mentioned it in relation to another bug that is going around.
I felt the issue was for me, closed, and mentioned it as such that that
thread.
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/95886
However, it was of at least one other persons opinion that:
"If the keyboard behaves differently under Windows and Linux, I'd consider
that as a bug. People should be able to type how they have used to. That's
what people want. And if it's not possible people consider the system as
faulty (and will stick in Windows)."

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/95886

While I am happy with the solution of the correct key combination, I just
thought I would mention it, so as you can decide on your good judgement,
whether or not there are indeed grounds for further consideration of this
behaviour difference between linux and windows (regardless of if the windows
behaviour is correct or not).

As I said, I am happy as it is, and do not mind if the functionality is
provided or not. But there is at least one argument for the case. As I am
sure there are arguments against.

Kind Regards,

svaens

Bernhard (b.a.koenig) wrote :

I can confirm this bug when I use "Germany eliminate dead keys". I have no "at symbol" after hitting AltGR-Q (which is RightAlt-Q).

It does work with "Germany" keyboard but not with "Germany eliminate dead keys".

Changed in ubuntu:
status: Invalid → Confirmed
Bernhard (b.a.koenig) wrote :

This is fixed for me since karmic. Anybody else still having the issue? Otherwise we might close the bug....

R. Diez (rdiezmail-ubuntu) wrote :

I am using Ubuntu 16.04.1 and my keyboard layout is "German". AltGr+q does produce the @ character, but Ctrl+Alt+q does not. I just realised because somebody new to Ubuntu and accustomed to Windows just asked me how to enter @ symbol on Ubuntu.

If Ctrl+Alt+q also produced the @ character, that would be one little issue less to worry about.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers