Wrong keyboard layout after installation (US instead of FI)

Bug #95886 reported by Mikko Ohtamaa on 2007-03-25
44
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Unassigned
Declined for Feisty by Henrik Nilsen Omma
Declined for Gutsy by Henrik Nilsen Omma

Bug Description

I just installed Feisty Fawn beta. I chose Finnish keyboard layout for myself, but after booting up the system only US English was available in Keyboard management application.

The workaround was to (re)set Finnish keyboard layout in Keyboard management application.

I installed ATI drivers before checking keyboard layout.

Timmie (timmie) wrote :

I had the same with Xubuntu. German Layout was missing and there is still no graphic uitlity to change it:
https://help.ubuntu.com/xubuntu/desktopguide/C/switch-keyboard-layout.html

How would a computer user then change the keyboard layout?

I can confirm a similar problem with Gutsy.

After performing a fresh install, and selecting a British keyboard layout the system boots up with a US layout instead.

Henrik Nilsen Omma (henrik) wrote :

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined.
According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates .
The bug is not being closed as work will continue on fixing it for the next release, Hardy Heron (8.04). If the state of this bug should change such that it qualifies for the SRU process, please contact the person who originally declined it and ask them to re-evaluate it. To help improve the state of this bug see: https://wiki.ubuntu.com/Bugs/HowToTriage .

Changed in ubiquity:
importance: Undecided → Low
Henrik Brink (henrikbrink) wrote :

Upon installation of Hardy Heron Test 1, this is still a problem for me.

Tell me if you need some information or output.

This is still a problem (US keyboard enabled despite selecting UK keyboard during setup) in Hardy Beta.

Can we this the importance bumped up for Heron?

1) This affects all international users

2) It has been hanging here over two releases

Ricardo Pérez López (ricardo) wrote :

As an Spanish user, I really would like to see this bug fixed before Hardy release... moreover if you remember that Hardy will be an LTS release!

Pablo Ortuzar (portuzarster) wrote :

Importance is not "low": it affects *all* non-US users.
I run Hardy Heron with all the latest updates, with English locale and Spanish keyboard. After each boot, keyboard layout is US: I must do a System>Preferences>Keyboard>Layouts>Add>Layouts>Spain, make it default, and then remove the prior keyboard layout (also Spain). Throughout, Scim/global reads /DefaultKeyboardLayout = Spanish.
This was not so before the updates.

Also this totally destroys out-of-box experience e.g. one is unable to type native text, type emails (can't type @)

Henrik Nilsen Omma (henrik) wrote :

This works fine for me installing a Norwegian Hardy system. I've also done countless installs with UK layout without problems.

Arne, do we have any idea of the impact of this bug -- how many languages/people does it affect?

If someone can provide me with a test case I can try to reproduce it with a Hardy install. i.e.: A keyboard layout to use, which key to press (like shift+3) and what symbol to expect. Thanks.

Changed in ubiquity:
assignee: nobody → arnegoetje
to be removed (liw) wrote :

I've done several installations with gutsy and hardy, in KVM and on real hardware, using the Finnish keyboard layout, without any problems. I've chosen English as the language on some systems, and Finnish on others.

(Not denying that the problem exists, just remarking that I haven't seen it myself.)

Henrik Nilsen Omma (henrik) wrote :

Attaching ubiquity logs of a problem case would also help. Specifically it would be good to know what combinations of localisation, kb layout and timezone was used.

See: https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs

Thanks Henrik!

I think I am able to revalidate this before the weekend.

german (gvaccani) wrote :

I have the same problem, I use es_ar_utf8 locale, and spain keyboard layout, and I have the same problem but I can't change the layout in system -> preferences -> keyboard
In fact I only have 1 layout to choose: us
In the xserver log I have this message:

(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap

I try to make symlinks to the location where the files must be in, but nothing change.
I hope this problem will be fix soon
thank you

Frank Harper (frank-harper) wrote :

During login my keyboard layout is US.

After logging in the layout is France, which is what I have configured via System/Preferences/Keyboard

The following sequence of events led to this problem
- Installed 8.04, keyboard layout was fine
- installed NVIDIA drivers using EnvyNG, forcing manual install because Hardy/EnvyNG didn't recognize the card
- keyboard layout still fine
- tried to configure my location in Clock Preferences, but that seemed to lock up X server at least partially
- after fiddling around a bit, I rebooted (sudo reboot now)
- A blue screen appeared giving me 3 options, one of which was to repair my x-server or something like that.
- Big mistake here; I chose the repair option instead of just rebooting
- Ubuntu replaced my xorg.conf and apparently did some other things also
- the keyboard layout was now set to USA
- I reset it to France via System/Preferences/Keyboard
- But the layout during login remains USA

svaens (svaens) wrote :

Hi,

I also notice this problem.

I am currently working in Germany, and so have had the need to open up the German keyboard layout from time to time.

umlaut characters work, but one that I have noticed is not available, is the @ symbol.
the key combination to get this on standard german keyboards is ctrl-alt-Q
When I use this key combination, nothing happens. No character at all is written.

I haven't tested others.

I am using Gutsy 7.10

Svaens: I think that's a separate bug so please open a new bug report for it

I failed to reproduce this with following

1. Ubuntu Hardy Heron Beta
2. Guided partition, use full disk
3. English language
4. Finland - Finland keyboard

Machine:

PS/2 keyboad
Old AMD 2600 XP processor

After the initial boot the keyboard was working ok.

I have exactly the same problem having installed Hardy, had to use EnvyNG to get my Nvidia graphics card working. Now whilst logging in, I get a US keyboard, and afterwards the German one that I have set.

I fixed this by editing /etc/X11/xorg.conf and changing

Option "XkbLayout" "us"

to

Option "XkbLayout" "de"

In regards to my supposed problem with the german keyboard layout.
This was due to wrong information about how the german keyboard officially
works.
My girlfriend (a native german even!) had been using, and told me, the
keyboard combination
Ctrl+Alt+q
would give one the @ symbol.
For some reason this works on windows, which she uses, and so has had no
problems.
But apparently the correct key combination is:
AltGr+q

which is even easier anyway. Only 2 keys to push,and not 3.
As soon as I tried this, I have no problem.

On Thu, Apr 17, 2008 at 8:53 PM, Jeffrey Ratcliffe <
<email address hidden>> wrote:

> I fixed this by editing /etc/X11/xorg.conf and changing
>
> Option "XkbLayout" "us"
>
> to
>
> Option "XkbLayout" "de"
>
> --
> Wrong keyboard layout after installation (US instead of FI)
> https://bugs.launchpad.net/bugs/95886
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Svaens: That is different bug. Please open a new bug report for it. Also, you can report it to upstream to freedesktop.org where XKB maps are managed, unless Ubuntu has created a hack of its own.

https://bugs.freedesktop.org/buglist.cgi?quicksearch=xkeyboard-config

svaens (svaens) wrote :

Sorry.
I had thought that Jeffrey Ratcliffe was referring to my complaint that the
german keyboard wasn't working.
I sought to clarify that I had discovered the cause of my problem. It is no
bug.
Or perhaps I misunderstood.
I did open a bug for it, but as the behaviour IS as required, it was shortly
closed.
Sorry for the inconvenience.

svaens.

If the keyboard behaves differently under Windows and Linux, I'd consider that as a bug. People should be able to type how they have used to. That's what people want. And if it's not possible people consider the system as faulty (and will stick in Windows).

For example, see this bug report for differences between native OSX and Linux:

https://bugs.freedesktop.org/show_bug.cgi?id=12441

However, this bug is about wrong keyboard layout after install, not about a missing character in keymap.

Thanks!
Mikko

Das Auge (0815jo) wrote :

Probably I am also affected by this bug:
But not since the first use. Now at every boot I get a message:
"
Error activating XKB configuration
It can happen under various circumstances:
- a bug in libxclavier library
- a bug in X server (xkbcomp, xmodmap, xmodmap utilities)
- X server with incompatible libxkbfiles implementation

X server version data:
The X.Org Foundation
10300000

If you report the situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
"
Here is the asked output:
:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "base", "pc101", "us", "", ""

:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 model =
 overrideSettings = true
 options = []

Nicolay Korslund (korslund) wrote :

Another confirmation. I have used Ubuntu since Hoary and never encountered this bug until now (after upgrading gutsy to heron.) I have selected a Norwegian layout (no), but start with a us layout after boot. Like someone said above, adding the Norwegian layout again and removing the old layout fixes the problem, but only for the current session.

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "no", "", "grp:alts_toggle"

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [no]
 model =
 overrideSettings = false
 options = [grp grp:alts_toggle]

Even if this bug is not fixed in the near future, I would very much appreciate if any of the gurus here can suggest a command-line workaround. It's pretty cumbersome to fix this through the gui after every boot. If you can suggest any logs or commands I should poke around with to try to fix this then I would be glad to help. Thanks.

Nicolay Korslund (korslund) wrote :

Sorry for spamming. I found a quick workaround myself,

$ setxkbmap no

(here 'no' means Norwegian, not the opposite of 'yes'. Use eg. 'fi' for Finish.) This works like a charm, so it's strange that the automatic layout configuration fails.

Laco Gubík (laco) wrote :

Hi

I got same problem, I use Ubuntu for two years but this problem appeared only after last upgrade to 8.04. Before I have never needed to configure keyboard. Now even when I set it in System -> Preferences -> Keyboard exact model and wanted layout (GB), it does not change it, also it does not even shows preview of layout, when I try to add layout. However when i run

$ setxkbmap gb

layout is ok and when I go into System -> Preferences -> Keyboard and click on Add it now shows layouts.
Output before running setxkbmap (also it is same even after running setxkbmap)
:~$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "microsoftmult", "gb", "", "grp:alts_toggle"
:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [gb]
 model = microsoftmult
 options = [grp grp:alts_toggle]
 overrideSettings = true
IMO it does not look like bug in X, as you can set the layout with setkxbmap with no problems.

I had to change the keyboard setting in xorg.conf and it was fixed.

I have a HP notebook with a french keyboard. The strange thing is that when you change the keyboard setting in System>Pref>Keyboard, the change is not applied or not applied completely.

Origanly in xorg.conf the keyboard layout was set on "be" (because I live in belgium and I chose belgium keyboard on the liveCD)
Then I fond out that my keyboard is french so I chose that in system>pref>keyboard. But gnome didn't applied al the keys to the french keyboard.

After changing my xorg.conf the correct keyboard-layout is used. Of course I still can not change the keyboard layout in the systems>pref>keyboard settings menu.

Greatings,

Dadio

Luís Louro (lapisdecor) wrote :

I had the same problem after upgrading to hardy from dapper, with the upgrade manager on a no CD-ROM PIII HP vectra:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
10400090

I did:

setxkbmap pt to solve it

here is my:
xprop -root | grep XKB

_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "PT-pt", "pt-pt", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "pt", "", ""

and my;
gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

 layouts = []
 model =
 options = [eurosign eurosign:e,compat numpad:pc]
 overrideSettings = true

---

setxkbmap pt

worked for my portuguese 105 keyboard.

(I'm also removing English language support from languages support, and also SCIM)

ç ã ú ª º - | { @ working ok at the moment.
(have to reboot after this post)

Blempis (mikko-lempola) wrote :

I use version 8.04 and for some reason this bug didn't occur immeaditly. Keyboard settings are lost in every reboot and have to be reset every time which is somewhat annoying user experience.

Somewhat peculiar detail was that my other computer (ubuntu 8.10) recognize this keyboard as 105 while ubuntu 8.04 says it is 104.

This rather easy to solve bug has now two candles on it's cake. Congratulations!

to be removed (liw) wrote :

Is anyone seeing this bug anymore? I still haven't seen it myself, so if no-one can say anything to the contrary, I will consider it fixed, and am marking it accordingly. If you do see it, please a) reopen and b) leave a comment. Thanks.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
suki123 (sukisistem) on 2009-12-11
Changed in ubiquity (Ubuntu):
assignee: Arne Goetje (arnegoetje) → nobody
Lucien (l-bergamin) wrote :

I just discovered this interesting topic.
I am using Ubuntu. After using another keyboard (which I did several times before without a problem) my own keybord switches to Netherlands (NL) setting after every restart. I want to use 'USA international with dead keys'. The icon to switch between the 2 does not react anymore. When I look in System>Choises>Keyboard I see USA on top (with red lining) as active and NL second as not active, but the keyboard works in NL! I can only swich to USA by completely removing NL from System. But after a restart the keyboard works in NL again and NL is back in Systems again (with on top USA as active!).
I am not a whizkid and I have tried everything, including other keyboards, but no solution.
Lucien, Netherlands

I think this problem still exists in Ubuntu 10.10. I chose to add both standard Norwegian and Norwegian Dvorak layouts when installing, and chose at first to use Dvorak as default. I later decided to use standard as default. The problem is that after boot, Dvorak is always selected as default, no matter what I do.

This problem is really annoying.

Another thing that is strange, is that it seems like both the keyboard layouts are selected - when typing, I randomly write in standard and Dvorak mode. For instance, if I type "asdf" fast on my keyboard, it would turn out for instance as "aoef" or "aseu". The problem is solved until next boot by removing Dvorak or the standard layout from the preferences menu.

Xsaron (cfjvds) wrote :

Hi all

I've just installed Ubuntu Server 11.04. I live in Belgium and here we use AZERTY in stead of QWERTY, the setup automatically recognised Belgium AZERTY (when pressing the + on the keyboard in the recognize tool).

After the installation was finished it appeared that QWERTY was being used and not AZERTY ...

I've been googling for a solution, everywhere people told to run dpkg-reconfigure console-setup, but there's nothing in there to change the keyboard lay-out, pretty useless..

So you can conclude that this bug still exists. It's not the first time that I experience this problem.

John Grey (john-thegreys) wrote :

Hi Folks,

Same problem here I think with 11.10 - I have just upgraded to Oneric - I have the English (UK) keyboard set in the system settings (the only option I have ever had set) but the keyboard is responding as if it were (I assume) the US layout - double quotes gives @ , pound gives #, hash gives \ and backslash < .

John Grey (john-thegreys) wrote :

sorry, just noticed #20 above

querying key map looks ok - but it isn't working

john@sony:~$ setxkbmap -query
rules: evdev
model: pc105
layout: gb

setting it to gb - which is claims to be already fixes it (for this session at least)

john@sony:~$ setxkbmap gb

now I have the uk layout

Øsse (oystwa) wrote :

I have noticed this with 12.04, for the first time. The problem didn't go away after reinstalling. I wonder if whatever you choose as the layout during installation is the one that will not work properly.

Øsse (oystwa) wrote :

After boot the layout is US Englsih ( I think), when I run 'setxkbmap no' everything is fine. The output of both 'setxkbmap -query -v' and xprop -root | grep XKB' are the same before and after.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.