KDM hangs upon logout in Kubuntu 8.04

Reported by Jon Wooten on 2008-04-03
This bug report is a duplicate of:  Bug #181343: [hardy] logout ends in blank screen. Edit Remove
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

When logging out instead of dropping back to the log in screen - as it should - the screen goes black. The keyboard works .. you can type letters. But will stay that way until you Ctrl-Alt-Delete. An error message about KDM shutting down is briefly displayed, then the system reboots.
System performance does not seem to be affected. I've tried this with all three desktop effect settings. Same results.

Potentially, this is an issue with my particular system and not Ubuntu/Kubuntu problem....don't know yet.

If there is a log somewhere I can pull to speed analysis of the problem, let me know.

Jon Wooten (jmwooten) on 2008-04-04
description: updated
description: updated

(Poor english, sorry)

Confirmed.

OS: Kubuntu 8.04 (compiz installed but dissabled)
Video: Ati X1250 (on-board, Asus m2a-vm HDMI)
drivers: ATI and fglrx (not vesa)

To reproduce i just need to select logout, restar, shutdown or ctrl+alt+backspace.

If I press ctrl+alt+F1 just after click on logout (very quickly), i can access a terminal, and login on a text console. I cant get back to F7, and top shows xorg eating 100% of the cpu. I cant kill xorg (sudo kill -9 PID, sudo killall Xorg dont kill the proccess) but i can do a reboot or a shutdown (with reboot, shutdown -h now, ctrl+alt+del, etc).

With a clean install, without ATI or fglrx, and up tu date, all work OK. If ATI driver or Restricted drivers are enable, the problem appears.

If i can provide more info, please tell me what (and how)

(Im reposting this from BUG #119635)

Mhatz (hatzimiltos) wrote :

I have the same problem (and it really annoys me a lot!) on a laptop LG P1 Express with an ATI Mobility X1400.

When there is a clean install everything work fine. When the driver is installed, then the whole system is ruinned.

Dragomir Minkovski (dejuren) wrote :

Confirmed.

OS: Kubuntu 8.04 after upgrade form 7.10
Video: Nvidia MX440-SE
driver: nvidia

The system freezes with compyz enabled and disabled. The problem is kdm with 3D drivers, compyz is out fo scope here. Now testing with "nv" driver, and later will test with "vesa".

Remark: if you can get to the console ( via network or pressing Ctrl-Alt-F1 ), restarting kdm (sudo /etc/init.d/kdm restart) let you work until next logout.

Angel Aguilera (angel-aguilera) wrote :

Confirmed.

OS: Kubuntu 8.04 after upgrade from 7.10
Video: ATI Radeon X700
Driver: fglrx

Compiz disabled (in fact, I have not yet been able to run compiz with my computer).
During the shutdown process, the screen becomes black.
I cannot switch to console via Ctrl+Alt+Fn.
I just can continue the shutdown process by pressing ctrl+alt+del.

nikita (nikita-mail) wrote :

The same here.

OS: Kubuntu 8.04 (also a had this bug at 7.10, after upgrading my fglrx video driver to the latest with envy)
Video: ATI Radeon 9600pro
Driver: fglrx

ubergeeknz (dan-capper) wrote :

Same issue here.

Hardware: HP Compaq nx8220 notebook
OS: Kubuntu 8.04
Video: ATI Radeon X600
Driver: fglrx

Dragomir Minkovski (dejuren) wrote :

No freezes with "nv" driver so far, so the problem is related to 3D drivers. Next step for me is to test this with "vesa" driver for couple of days. As a workaround everyone can use non-3D driver for X-server. If there is an issue with non-3D driver please update the bug.

Dragomir Minkovski (dejuren) wrote :

There was an update today including kdm. Can all of you already faced this problem test was the problem fixed after upgrade. I will do this in the next few days.

I applied the upgrades (kdm is now version 4:3.5.9-0ubuntu7.1)
The problem still remains, though. :-(

nikita (nikita-mail) wrote :

After update the bug is still there

Chris (kurisu-rs) wrote :

Same problems. Should be noted that when booting up and immediately doing log out/restart/shutdown from login screen same problem occurs.

Hardware: Asus A8R32MVP, Athlon 64 3700
OS: Kubuntu 8.04
Video: ATI Radeon X300SE
Driver: fglrx

Chris (kurisu-rs) wrote :

Seems to be a duplicate bug of https://bugs.launchpad.net/ubuntu/+source/kdebase/+bug/181343 where a fix (http://ati.cchtml.com/show_bug.cgi?id=992#c26) is posted, included here for quickness:

In /etc/ati/authatieventsd.sh locate XDM_AUTH_MASK variable and ensure it is set as:

XDM_AUTH_MASK=/var/run/xauth/A$1*

nikita (nikita-mail) wrote :

That worked! Thank you :)

Confirmed, this change works for me.

Kubuntu 8.04
Onboard Ati X1250 (fglrx driver)

Thanks for the tip.

Joe Burgess (joemburgess) wrote :

The ATI fix is for ATI cards only, and for me I am having I think the same problem. On logout and shutdown the system leaves Kde and goes to a black screen with just my mouse cursor. I can get to the Function Key terminals, I generally go to a terminal and restart kdm. Is this the same problem?

Kubuntu 8.04 64 bit
Video: Nvidia Geforce 8800GT
Driver: nvidia proprietary drivers 169.12

carlos (aa96319) wrote :

How to get to the ¨/etc/ati/authatieventsd.sh locate XDM_AUTH_MASK variable¨
In Konsole typed : ¨ cd /etc/ati ¨ but that how far it got to.

ubergeeknz (dan-capper) wrote :

carlos:

type:

sudo kate authatieventsd.sh
and enter your user password.

then in kate, search for XDM_AUTH_MASK .... change the line as per the comment above.

Joel (yoeldk) wrote :

confirmed bug.

OS: Kubuntu 8.04 after upgrade form 7.10
Video: Geforce 6600 LE
driver: nvidia

The system freezes with compyz enabled and disabled when trying to logout/shutdown the system (a black screen shows up).

once the black screen appears i can shut down the system by logging into virtual terminal using ctrl+alt+f1, and writing

   sudo shutdown -P now

anddy (anddyper) wrote :

Confirmed in my desktop system with nvidia and my laptop with ati

anddy (anddyper) wrote :

Reproduced with compiz enabled /disabled, installed/uninstalled... Editing authatieventsd.sh not working for me.

My systems, Kubuntu 8.04:
Desktop
GeForce 6800, nvidia 169.12

Laptop
ATI radeo Xpress 1100, ati 8.47.3

Swift (odebon) wrote :

Confirmed.

Kubuntu 8.04 (freshly installed)
Using nvida-glx with GeForce4MX. If I remember it didn't happen with "nv" driver.
Display size is 1600x1200 where usplash tries to display something at max res (over 1900x1400), this corrupts all consoles.
Tried with basic KDE4 settings (no .kde4) it's ok, any new settings that creates a .kde4 directory will eventually lead to a crash
of knotify4 (quickly disappears). Notification sound is delayed by 5 to 10 secs before crash.
This doesn't happen with KDE3.5

Both kdm and kdm4 were used with same results.

Same here.

ATI Radeon 1600Pro with AMD cpu.
Kubuntu 8.04

Sergio Callegari (callegar) wrote :

Please provide package with nvidia driver downgraded to 96.43.01 as a fix, since it is said to work correctly.

RickyS (rickys) wrote :

Confirmed happening with Asus M2A-VM HDMI (ATI Radeon 1250), with Compiz and restricted drivers, in Ubuntu 8.04.1
The authatieventsd.sh solution is not working. As with others, closing the session with Ctrl-Alt-Backspace does the trick.

joshua (joshm-farmer) wrote :

I can confirm that this issue still exists in Intrepid Ibex 8.10 with the latest FLGRX drivers installed. Editing the XDM_AUTH_MASK to XDM_AUTH_MASK=/var/run/xauth/A$1* fixes the issue again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.