[hardy] logout ends in blank screen

Bug #181343 reported by Emanuel Goscinski on 2008-01-08
72
This bug affects 4 people
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdm

I experienced the following on a up-to-date kubuntu hardy heron:

When I try to logout from my KDE 3.5 Session (for example to login to a 4.0 Session) all I am left with is a blank screen, with a cursor blinking.

I had no chance switching to tty1-tty6. All I could do was to reset via ctrl+alt+entf

This happens also when I logout from a KDE 4 Session.
I don`t really know if its a bug in kdm or elsewhere....

Greetings emu

After reinstalling gutsy and upgrade to hardy the problem disappeared.

Changed in kdebase:
status: New → Invalid
Elias Grinias (grinias) wrote :

The same holds for me after upgrade from gutsy to hardy.
I would like not to re-install anything, so I ll wait for a solution.
Specs:
Acer TM4101
ATI Mobility X600

seagle (seagle0128) wrote :

Yes, same issue after upgrade from gutsy to hardy.

IBM Thinkpad T42
ATI Mobility 9600 64M

How to solve it?

PascalC (p92) wrote :

can you ssh into the box when the problem appears ?

attach
/var/log/Xorg.0.log
/var/log/Xorg.0.log.old

OK.

On Sun, Mar 30, 2008 at 5:35 AM, PascalCavy <email address hidden> wrote:

> can you ssh into the box when the problem appears ?
>
> attach
> /var/log/Xorg.0.log
> /var/log/Xorg.0.log.old
>
> --
> [hardy] logout ends in blank screen
> https://bugs.launchpad.net/bugs/181343
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "kdebase" in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: kdm
>
> I experienced the following on a up-to-date kubuntu hardy heron:
>
> When I try to logout from my KDE 3.5 Session (for example to login to a
> 4.0 Session) all I am left with is a blank screen, with a cursor blinking.
>
> I had no chance switching to tty1-tty6. All I could do was to reset via
> ctrl+alt+entf
>
> This happens also when I logout from a KDE 4 Session.
> I don`t really know if its a bug in kdm or elsewhere....
>
> Greetings emu
>

Tim Holy (holy-wustl) wrote :

Same problem here on a T60. I'd upgraded feisty->gutsy->heron beta over the course of a couple of days.

Tim Holy (holy-wustl) wrote :
Tim Holy (holy-wustl) wrote :

Oh, and yes, I can ssh into the box when it is in the "blank screen" mode. I can even start konqueror and have it pop up on the remote screen.

Tim Holy (holy-wustl) wrote :

I wondered whether it was a problem with the fglrx driver. So, I went to the "Hardware Drivers Manager" and disabled fglrx. It removed the package, then briefly said something scary like "disabling libc6" (but it was so brief I'm not sure I saw it properly). When I tried rebooting, the machine never came all the way up. I then rebooted and tried to enter a console mode ("recovery mode"?) and it didn't work with the current kernel (hung on something like "waiting for root filesystem"). Fortunately, an older kernel (2.6.20-15) worked for me. From the console, I reinstalled the xorg-drivers-fglrx module and rebooted. X came back up; now I'm back to where I started, presumably.

Tim Holy (holy-wustl) wrote :

Here's dmesg in case any of those shenanigans are useful.

Tim Holy (holy-wustl) wrote :

And an older one.

seagle (seagle0128) wrote :

Additonal, I use ubuntu/gnome, not Kubuntu/KDE.

IBM Thinkpad T42
ATI Mobility 9600 64M
Ubuntu hardy beta

I think maybe X and Graphic card driver are mismatch or driver's bug.
It's unsavory!
Every time I have to restart or power off.

So I reopen this bug and set to confirm, because it seems a real Upgrade Issue.

I`m real sorry, I`m not the only one affected.

Changed in kdebase:
status: Invalid → Confirmed
seagle (seagle0128) wrote :
  • unnamed Edit (1.5 KiB, text/html; charset=ISO-8859-1)

You mean I need to use an older kernel?
Oh, My god!
Is there bug in kernel or driver?
Should fix it.

On Tue, Apr 1, 2008 at 7:49 PM, Tim Holy <email address hidden> wrote:

> And an older one.
>
> ** Attachment added: "dmesg.0"
> http://launchpadlibrarian.net/13016441/dmesg.0
>
> --
> [hardy] logout ends in blank screen
> https://bugs.launchpad.net/bugs/181343
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "kdebase" in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: kdm
>
> I experienced the following on a up-to-date kubuntu hardy heron:
>
> When I try to logout from my KDE 3.5 Session (for example to login to a
> 4.0 Session) all I am left with is a blank screen, with a cursor blinking.
>
> I had no chance switching to tty1-tty6. All I could do was to reset via
> ctrl+alt+entf
>
> This happens also when I logout from a KDE 4 Session.
> I don`t really know if its a bug in kdm or elsewhere....
>
> Greetings emu
>

Tim Holy (holy-wustl) wrote :

Sorry, the need to use a different kernel was solely to get the "recovery mode" (or whatever it's called, I forget) to work, so that I could be presented with a console and reinstall fglrx. (In other words, it's another, different, problem that cropped up while I attempted to understand this one better.) I'm back to using the current kernel. I haven't tried to see if booting into an older kernel fixes the blank screen problem, but I suspect that it's an X/driver issue.

seagle (seagle0128) wrote :
  • unnamed Edit (134 bytes, text/html; charset=ISO-8859-1)

Yes, I got it.
If use another version kernel to install fglrx driver, it works.
I am sure it is a driver's issue.

Tim Holy (holy-wustl) wrote :

After the updates of 2008-04-03, this is no longer a problem for me.

seagle (seagle0128) wrote :
  • unnamed Edit (223 bytes, text/html; charset=ISO-8859-1)

Oh? You use gnome or kde? Ati or nVidia?
I upgrade linux kernel to 2.6.14, but there is same problem.
I use another kernel to install ati driver, but this time I cannot use
compiz (After login, white screen).

Elias Grinias (grinias) wrote :

The problem appears for me only when I use fglrx for my ATI X600. Also, can't reboot or turn off the machine, without pressing the power-button. When using mesa driver all the problems dissappear.

seagle (seagle0128) wrote :

I am sure that the issue is about fgrlx driver.I upgrade the kernel
but same. I close compiz or use mesa driver it's ok!
Help!

On 4/9/08, Elias Grinias <email address hidden> wrote:
> The problem appears for me only when I use fglrx for my ATI X600. Also,
> can't reboot or turn off the machine, without pressing the power-button.
> When using mesa driver all the problems dissappear.
>
> --
> [hardy] logout ends in blank screen
> https://bugs.launchpad.net/bugs/181343
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "kdebase" in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: kdm
>
> I experienced the following on a up-to-date kubuntu hardy heron:
>
> When I try to logout from my KDE 3.5 Session (for example to login to a 4.0
> Session) all I am left with is a blank screen, with a cursor blinking.
>
> I had no chance switching to tty1-tty6. All I could do was to reset via
> ctrl+alt+entf
>
> This happens also when I logout from a KDE 4 Session.
> I don`t really know if its a bug in kdm or elsewhere....
>
> Greetings emu
>

--
Sent from Gmail for mobile | mobile.google.com

Geoffrey (geoffrey-metais) wrote :

I have this issue too.

I upgraded from gutsy to hardy alpha6 and I experienced it.
Now with a fresh install of kubuntu hardy beta it's the same problem.

But when I get the blank screen, I can switch to tty1-6

I use compiz and nvidia-glx driver, and i'm up-to-date

wieman01 (wieman01) wrote :

Same issue here on 2.6.24.16 kernel with nVidia graphics card. Blank screen after log-out with some artifacts displayed on the screen. I usually switch to tty1-6 and kill KDM, then restart it manually.

Any other info I can provide?

wieman01 (wieman01) wrote :

My KDM log which confirms something is wrong.

Same issue with Kubuntu Hardy Release Candidate with all updates and using fglrx from the repositories. Logging out or killing X server with Ctrl+Alt+Backspace do not work. I cannot even switch to tty1-6 after doing these. I have to do Ctrl+Alt+Del to reboot.

I removed fglrx and the problem is gone. I attach my kern.log.

The problem still exists in fglrx 8.3. But killing atieventsd before logoff or shutdown, or disabling it from /etc/rcX.d/ folders solves it.

More info at http://ati.cchtml.com/show_bug.cgi?id=992

seagle (seagle0128) wrote :
  • unnamed Edit (1.5 KiB, text/html; charset=ISO-8859-1)

I use ATI mobility 8.4, same issue.
How to solve it? It's so noissy!

On Tue, Apr 22, 2008 at 5:44 AM, Keptile <email address hidden> wrote:

> The problem still exists in fglrx 8.3. But killing atieventsd before
> logoff or shutdown, or disabling it from /etc/rcX.d/ folders solves it.
>
> More info at http://ati.cchtml.com/show_bug.cgi?id=992
>
> --
> [hardy] logout ends in blank screen
> https://bugs.launchpad.net/bugs/181343
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "kdebase" in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: kdm
>
> I experienced the following on a up-to-date kubuntu hardy heron:
>
> When I try to logout from my KDE 3.5 Session (for example to login to a
> 4.0 Session) all I am left with is a blank screen, with a cursor blinking.
>
> I had no chance switching to tty1-tty6. All I could do was to reset via
> ctrl+alt+entf
>
> This happens also when I logout from a KDE 4 Session.
> I don`t really know if its a bug in kdm or elsewhere....
>
> Greetings emu
>

awidegreen (awidegreen) wrote :

Keptiles link solved my issue:
wrong XDM_AUTH_MASK path in /etc/ati/authatieventsd.sh - should be set to /var/run/xauth/A$1*

i'm running: hardy heron, ati (restricted-modules)

reference: http://ati.cchtml.com/show_bug.cgi?id=992#c26

Elias Grinias (grinias) wrote :

...and my issue too...

Dragomir Minkovski (dejuren) wrote :

The problem still stays with nvidia driver. One should restart kdm to get login screen back.

Geoffrey (geoffrey-metais) wrote :

This problem is solved for me
Probably due to recent updates.

No problem now with kernels 2.6.24-16-generic and 2.6.24-17-generic

anddy (anddyper) wrote :

I'm using 2.6.24-16 generic and the problem is present, in nvidia and ati

flaccid (chris-xhost) wrote :

Problem still persists for me when restarting the X server.

I've an Ati 9700 (mobile) and I'm using Hardy: the problem seems resolved after the last update of xorg-driver-fglrx (1:7.1.0-8-3+2.6.24.12-17.36)

same problem on Kubuntu 8.04 after upgrade from gutsy
I solved it as stated above by Keptile by moving aside the /etc/init.d/atieventsd script
( I tried fixing it with the XDM_AUTH_MASK thing, but that didn't work)

Praxis (ebiow) wrote :

Same issue on a fresh Hardy Ubuntu install using KDM when logging off from Ubuntu. Using proprietary Nvidia driver.

Swift (odebon) wrote :

Confirmed.

Kubuntu 8.04 (freshly installed)
Using nvida-glx with GeForce4MX. If I remember it didn't happen with "nv" driver.
Display size is 1600x1200 where usplash tries to display something at max res (over 1900x1400), this corrupts all consoles.
Tried with basic KDE4 settings (no .kde4) it's ok, any new settings that creates a .kde4 directory will eventually lead to a crash
of knotify4 (quickly disappears). Notification sound is delayed by 5 to 10 secs before crash.
This doesn't happen with KDE3.5

Both kdm and kdm4 were used with same results.

Swift (odebon) wrote :

continued from Swift:

*** Running kdm from KDE4 ***
The Nvidia module crashed and reports backtrace in /var/log/kdm.log
(Driver 96.43.05). Sorry I don't have it anymore.

Found a workaround I've read somewhere else:
Add the following line in [X-*-Core] stanza in /usr/lib/kde4/etc/kde4/kdm/kdmrc file
TerminateServer=true
(You'll get X fully restarted, kill + restart, and the Nvidia Logo that you can remove
in xorg.conf file)
Logout still has a weird delay, but eventually works and gets back to Welcome screen.

IgnorantGuru (ignorantguru) wrote :

Confirmed on up-to-date Kubuntu Hardy with KDE3 and nvidia-glx driver. Logout produces a blank screen. If I press Ctrl-Alt-F1 that terminal appears blank, but if I press enter the Login: prompt does come up. ps -Af reveals that the user was logged out. No errors in the X log. Ctrl-Alt-F7 reveals a blank screen.

Sergio Callegari (callegar) wrote :

Same problem here with an nvidia board.

A funny thing happens that make me think that it might not be due to the nvidia drivers, but to kdm itself or to how kde interacts with it:

if I switch to the free nv driver from the nvidia one, the black screen issue seems to be resolved, but another issue appears: the kdm welcome screen now appears at a wrong resolution/screen size.

To explain better: I work at 1280 x 1024. When I log out, the kdm screen appears at a much lower resolution (likely 1024 x 768 or even lower) and the window is uncentered, because the whole screen can be panned left and right, up and down, moving the low resolution view over the 1280x1024 real screen size.

Most definitively all caused by a kdm problem.

Sergio Callegari (callegar) wrote :

People using archlinux seem to be sharing the same problem (http://bbs.archlinux.org/viewtopic.php?id=43799).

I have found a provisional solution for NVIDIA users, the restricted manager installs the package named nvidia-glx-new (ver. 169.12), you must remove this package and install nvidia-glx (96.43). OK it's the old driver but it works!!!

Sergio Callegari (callegar) wrote :

Please ignore my post of 05-24.

Funny resolution with kdm is just caused by xorg.conf listing screen modes in the wrong order.

For what concerns the possibility of using nvidia-glx rather than nvidia-glx-new as in the previous post, note that I am experiencing the bug, precisely with nvidia-glx. Indeed I have a geoforce 2 that is not supported by the nvidia-glx-new module.

Yet, the bug effectively disappears with nvidia-glx-legacy.

jimmywilliam (jimmywilliam) wrote :

I can confirm the same error on my laptop. I'm using a Lenovo Thinkpad X40, with on-board Intel Integrated graphics. Upon logout/restart/shutdown, the screen will go black. This is a fresh install (not upgrade) with all updates applied as of July 11th 2008.
This bug was not present in Gutsy, and it's really frustrating.

RickyS (rickys) wrote :

Folks, are you using Keytouch? If you are, you may be suffering from a bug that makes gdm/kdm hang... See https://bugs.launchpad.net/ubuntu/+source/keytouch/+bug/186713 for the fix (at the bottom of the page)

Same problem (keytouch not installed):

Most of the time my system hangs on logout.
With patience and lots of efforts I can most times switch to tty1 (certainly not direct) and press Ctrl-alt-del to restart.
Alt-backspace does nothing.

My system:
Ubuntu 8.04
the nvidia driver on a geforce4 MX 440
system AMD Athlon XP (nforce motherbord (Epox)) 2500+

My laptop (Toshiba Satelite A110-225 with a intel 810? card/driver?) with about the same software, does not hang but "doubts" sometimes more then a minute before really shutdown of logout (even when nothing has been done). Wonder if this is related.

No problems with gnome GDM on 8.04 what I used before

Jeremy (stoker2002) wrote :

Confirmed:

Kubuntu 8.10 (upgrade from 8.04 LTS)
Graphics card: nVidia GeForce MX 4000
Kernel: 2.6.27-9-generic

And after some Googling I have found the following workaround. Not an ideal solution, by any means, but it saves me a lot of trouble.

In the file kdmrc, which under 8.10 is found in /etc/kde4/kdm/, uncomment the following line:

#TerminateServer=true

This will cause kdm to restart (and restart X also, I think) on logout, which keeps you from having to restart it manually.

This solves also my problem under Ubuntu 8.04 (Long time suport) version:

In 8.04 add under [X-:*-Core] in the file "/etc/kde3/kdm/kdmrc" the following line:
TerminateServer=true

In KDE 3 there is no line to comment out, so you 've to add this line. I see X and kdm restarting at logout.

Igor Tarasov (tarasov-igor) wrote :

I do experience this on fresh, fully updated kubuntu 8.04 installation, with 2.6.24-23-generic kernel.

TerminateServer trick worked, but this bug is very annoying, esp. for not experienced users.

Igor Tarasov (tarasov-igor) wrote :

Okay, I think I've found out the solution. Here is the story: I have 2 kubuntu 8.04 installations on the same machine, but one of these installations have this bug, the other - have not. So, I've starting comparing configurations and started with apm-related stuff, but it was quite similar, and then with nvidia-related settings. So, installation with the bug had the following lines in xorg.conf:

Section "Device"
 Identifier "Configured Video Device"
 Boardname "NVIDIA GeForce4 (generic)"
 Busid "PCI:1:0:0"
 Driver "nvidia"
 Screen 0
 Vendorname "NVIDIA"
 Option "NoLogo" "True"
EndSection

The other machine (without bug) had these lines:

Section "Device"
 Identifier "Configured Video Device"
 Boardname "NVIDIA GeForce4 (generic)"
 Busid "PCI:1:0:0"
 Driver "nvidia"
 Option "NvAGP" "1"
 Option "AllowGLXWithComposite" "True"
 Option "AddARGBVisuals" "True"
 Option "AddARGBGLXVisuals" "True"
 Option "NoLogo" "True"
 Option "RenderAccel" "True"
 Screen 0
EndSection

I've copied all Options and it fixed this bug and the one related and it did the trick. Also, it has fixed another bug: this new installation could not resume from STR. But now all bugs are gone.

So, NvAGP option did the trick I think. Or maybe other options have worked, I don't know. Maybe it should be added to nvidia cards config by default?

Igor Tarasov (tarasov-igor) wrote :

See this bug: https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/34043

So, I think these bugs are related.

Mehul J. Rajput (mehulrajput) wrote :

I too have this bug on asus m51ta, hd3200 and hd3650 card on the laptop. running latest jaunty. seems ati has this problem.

Jonathan Thomas (echidnaman) wrote :

The login manager not starting after a login is a quite generic issue. It is usually the result of X crashing on logout. These are all video driver bugs, and users of each driver (nvidia, fglrx, etc) should file their own bug reports about it against the driver packages, including a copy of the /var/log/Xorg.0.log.old file after a failed logout, as well as a copy of the output of the command lspci -vvnn. I am closing this report as it has grown too large due to many people experiencing the same symptom (but not the same bug) commenting. This is also not a kdm issue anyway.

Changed in kdebase (Ubuntu):
status: Confirmed → Invalid

I'm using Kubuntu 8.04 and "TerminateServer" seems to fix my problem. I also have an Nvidia FX 5200card.
This is on a secondary Kubuntu desktop with a CRT.

Paul White (paulw2u) wrote :

I'm seeing this with Kubuntu 11.04 and I've just seen a forum post to say that it is still present with Kubuntu 11.10.

tags: added: i386 natty oneiric
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.