Lots of seemingly redudant fonts

Bug #18666 reported by Tuomas Salo on 2005-07-04
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Unassigned
Nominated for Karmic by Ryan Prior
Nominated for Raring by Adolfo Jayme
ubiquity (Ubuntu)
Wishlist
Unassigned
Nominated for Karmic by Ryan Prior
Nominated for Raring by Adolfo Jayme

Bug Description

The font selection list shows about 84 "families", most of which seem to be
local versions of the same few fonts. For example, there are 38 fonts whose name
starts with "ae_" that all look like Bitstream Vera Serif/Sans, Roman/Bold.
(BTW, why aren't the normal versions named "Regular" but "Roman"?). In fact,
there seem to be even more fonts that look like them.

The large number of similar-looking fonts makes it ridiculously hard to really
choose a font.

How to reproduce:
1. Open gnome-font-properties
2. Choose eg. "Application font"
3. A very long font list appears

Wouter (woutervanwijk-netscape) wrote :

I can confirm this. There are way to many fonts (and dubplicates) in the
font-selection-boxes for me. I use the dutch local.

Dennis Kaarsemaker (dennis) wrote :

*** Bug 25490 has been marked as a duplicate of this bug. ***

Phil Bull (philbull) wrote :

vfs-ls fonts:/// lists 166 available fonts. I use maybe 6 of them; finding an
appropriate font takes ages if you don't know the name.

Maybe the way fonts are handled should be changed? I.e, have <10 favourite/most
frequently used fonts, then provide some way of accessing a wider selection.
AFAIK this would be a GTK change.

In the mean time, I'd settle for installing far fewer by default. 30 is pushing
it, really.

Frank Niedermann (fbn) wrote :

I can confirm this bug. On a brand new Feisty installation there are a lot of (similar?) ae_... fonts

Chris Beaven (smileychris) wrote :

Regarding the ae_* fonts, they are part of the ttf-arabeyes package. Remove them with the following command:

sudo apt-get remove ttf-arabeyes

Mat Tomaszewski (mat.t.) wrote :

Not really a papercut, although it it a valid issue. We're looking at changing it for Karmic separately.

Changed in hundredpapercuts:
status: New → Invalid
Mat Tomaszewski (mat.t.) wrote :

Just to explain why it's not a papercut - the issue is too complex for a trivial fix. There are some localization issues that need to be considered as well as many other criteria (font categorizations etc). Still, it is a valid bug, targeting it for Karmic.

Adolfo Jayme (fitojb) on 2014-03-10
no longer affects: ubuntu
affects: hundredpapercuts → ubuntu
Ryan Prior (ryanprior) wrote :

Confirmed, still a problem for saucy. Software like "font manager" exists in repository and allows you to fix the problem for yourself, but the out-of-the-box experience of selecting fonts is really junk.

Changed in ubuntu:
status: Invalid → Confirmed
Ryan Prior (ryanprior) wrote :

This should probably be part of choosing your locale (along with time zone, language, and keyboard) in ubiquity.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Colin Watson (cjwatson) on 2014-04-17
affects: ubiquity → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2014-12-09
Changed in ubuntu:
importance: Undecided → Wishlist
Changed in ubiquity (Ubuntu):
importance: Undecided → Wishlist
Changed in ubiquity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers