LCD Brightness buttons do not work on ThinkPad R61/T61/X61

Reported by pullin on 2007-11-30
22
Affects Status Importance Assigned to Milestone
Fedora
Invalid
Undecided
Unassigned
Ubuntu
Undecided
Unassigned
Nominated for Hardy by Serge

Bug Description

Brightness up and down buttons (Fn + Home, Fn + End) don't work.
Running kubuntu, gutsy 7.10.
acpid catches events fine, and invokes /etc/acpi/video_brightnessdown.sh and /etc/acpi/video_brightnessup.sh

The scripts there run acpi_fakekey 224 or 225 , which doesn't seem to do anything.

Changing these to:
echo 4 > /proc/apci/ibm/cmos
and
echo 5 > /proc/acpi/ibm/cmos

Fixes the problem, although it may just be a bandaid. Shouldn't acpi_fakekey work?

-Andrew

Carlos Perelló Marín (carlos) wrote :

This is not KDE specific, the same happens with gnome

Carlos Perelló Marín (carlos) wrote :

I forgot to mention that it happens in my Thinkpad X61s.

pullin (pullin) wrote :

Does the fix work? Seems pretty straightforward & important, it'd be good to get it committed...

Jerone Young (jerone) wrote :

This is not a proper fix .. but a hack around the real issue. This also does not give the various brightness levels. This is not a good fix.

tyler (tyler-chickn) wrote :

My problem seemed to be because I was missing '/usr/share/acpi-support', which is provided by the package 'acpi-support'.

apt-get install acpi-support

and you should be good to go.

tyler (tyler-chickn) wrote :

Yea, acpi_fakekey is in 'acpi-support' as well, if you don't have that installed yer not gonna get very far. ;)

pullin (pullin) wrote :

I know it it is a pretty miserable fix, but:

1) I seem to get all the various brightness levels with this modifications on my X61 Tablet, model 7764-CTO
2) acpi-support is installed; I can run acpi_fakekey, but acpi_fakekey 224 or 225 does nothing, and does not generate any entries in /var/log/acpid

Ryan Sinn (ryan-sinn) wrote :

This is still an issue with Hardy... I did some reading and apparently the ACPI issue is due to Ubuntu developers messing around with Thinkpad ACPI calls / keys. The Thinkpad ACPI developer specific wrote about this (I'll try to find the link) and how this is a bad idea.

Jerone Young (jerone) wrote :

acpi fake key does not generate an acpi event. It generates a keyboard event. Now brightness is still broken in hardy and it is being worked. But using the thinkpad-acpi interface to change the brightness instead of the (currently broken) acpi interface is not recommended in the thinkpad-acpi notes.

KillerKiwi (killerkiwi2005) wrote :

I can adjust brightness on my r61, it actually hangs X if i try to move the brightness applet up or down

See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/198476 for lots of useful info that might be related. I have a T61 that I got working thusly.

It started to work again in my X61 laptop with GNOME and latest packages from Hardy.

Ryan Sinn (ryan-sinn) wrote :

Working here too.

KillerKiwi (killerkiwi2005) wrote :

Works now!

pullin (pullin) wrote :

Confirmed to work on X61 Tablet. Thanks to whoever fixed it!

Սահակ (petrosyan) wrote :

Does anybody also notices that the brightness goes down two times faster than it goes up?
I am seeing this on X61.

Fredrik Wendt (fredrik-wendt) wrote :

Ani: On my T61 the brightness always takes two steps, no matter if it's up or down (brighter/darker).

Kyle Lee (shrednine) wrote :

Works fine now on my T61 (Intel video).

thinkpad-acpi module causes a seconed event (sudo acpi_liste), you could disable the brightness events while doing:
sudo -s
echo 0xfF00FFF > /proc/acpi/ibm/hotkey

Remember: after every reboot hotkey-setup echos another mask into hotkey

if you want to hack further stop hotkey-setup from doing this or file a bug against hotkey-setup

Peter

status: enabled
mask: 0x00ffffff
commands: enable, disable, reset, <mask>

should i change it to 0xfF00FFF ?

Distributor ID: Ubuntu
Description: Ubuntu intrepid (development branch)
Release: 8.10
Codename: intrepid

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.