Ubuntu

[REGRESSION] Impossible to change LCD brightness on Thinkpad R61/T61/X61

Reported by Wiktor Grebla on 2008-03-04
74
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned

Bug Description

Binary package hint: hal

Ubuntu 8.04, today's updates applied.
hal version 0.5.10-5ubuntu8

Once of the recent updates (kernel maybe) broke something and now on my Thinkpad R61i i cannot change LCD brightness. Either power manager, or using brightness applet, or even directly echoing different values to /sys/class/backlight/acpi_video0/brightness doesn't change anything. If I press Fn+Home or End brightness indicator appears on the screen, but its reaction to keypresses is very slow and it doesn't affect brightness at all anyway.

The only thing i see in dmesg is:
thinkpad_acpi: unknown LID-related HKEY event: 0x5010

My problem is that in 8.04 power consumption was unfortunately increased and with max. LCD brightness I'm still unable to get close to battery operation time I had on Gutsy.

I can confirm this is also the case on the T61. Brightness worked fine until an update within the past couple of days.

Jerone Young (jerone) wrote :

Could you try updating your firmware and see if this problem still persist. Latest firmware can be found here:
http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-67989

As for the dmesg message you see is unrelated. This just an event that the version of thinkpad-acpi in hardy does not know about. Newer versions of thinkpad-acpi kernel module handle this event.

Jerone Young (jerone) wrote :

Just verified .. it is working on my Thinkpad T61 .. it's slow to update though (could be the two acpi events it generates slowly)... You can see this by running the command "acpi_listen". But it does work .. it's just slow about. Try updating hardy & your firmware.

Jerone Young (jerone) wrote :

something screwy is going on is going on .. the acpi events though. It is not giving one to one raito on the event generated.
The key generates 2 events:
vidoe LCD0 0000086 00000000
ibm/hotkey HKEY 0000080 00005010

The problem is when you use acpi_listen these are not coming in one to one. The one we care about is
ibm/hotkey HKEY 0000080 00005010

I will try to build a gutsy kernel with thinkpad_acpi v.0.20 later .. the version that comes with gutsy is v0.17.

Wiktor Grebla (greblus) wrote :

Jerone. Thanks for your hints. I've updated my bios to this version using Lenovo Care system update tools. Unfortunately I still cannot adjust LCD brightness on R61i.

This problem was introduced by the -11 kernel update. Reverting to the -10 kernel fixes the problem without changing any userspace tools.

Changed in hal:
status: New → Confirmed

This is a problem with the kernel package so let's put this to the right package.

Changed in hal:
status: New → Invalid

This bug is also present with X61 on latest Lenovo BIOS and latest Hardy.

Jerone Young (jerone) wrote :

Confirmed on my Thinkpad T61 14".

Kernel 2.6.24-11-generic <-- broke it

Kernel 2.6.24-10-generic <-- works fine

This apparently affects all Lenovo T/R/X 61s.

Daniel Hahler (blueyed) on 2008-03-09
Changed in linux:
importance: Undecided → Medium
status: Confirmed → Triaged
Serge (serge-de-souza) on 2008-03-10
Changed in linux:
assignee: nobody → ubuntu-kernel-team
Jerone Young (jerone) wrote :

Problem is also in Kernel 2.6.24-12-generic.

Wiktor Grebla (greblus) wrote :

I confirm, it's still present on my R61i and the 2.6.24-12-generic kernel.

Raja (rajajs) wrote :

Had same problem on Thinkpad X61s with Hardy alpha 6. The fix reported in https://bugs.launchpad.net/ubuntu/+bug/172985 worked for me.

Wiktor Grebla (greblus) wrote :

Thanks Raja, solution suggested in the link above works with the latest kernel, however the problem of slow reaction to keypresses remains.

Jerone Young (jerone) wrote :

Thank Raja, but the solution is not a proper fix for the issue and is more of a hack around the issue (that isn't optimal).

Raja (rajajs) wrote :

Thanks Jerome,
I hope this issue gets fixed. I agree this is a temporary fix and not really a solution, so I will be waiting for this to be resolved!

cdiggity (craig-nzenergy) wrote :

When I change brightness with fn+home/end on hardy alpha 6 the brightness does not actually change and the following errors appear in kern.log.
Mar 15 22:23:34 kernel: [30381.978982] thinkpad_acpi: unknown LID-related HKEY event: 0x5010
Mar 15 22:23:34 kernel: [30382.025956] thinkpad_acpi: unknown LID-related HKEY event: 0x5010
Mar 15 22:23:35 kernel: [30382.978628] thinkpad_acpi: unknown LID-related HKEY event: 0x5010

This worked fine in gutsy

Aren Olson (reacocard) wrote :

I have also had this problem on my T61 (X3100 graphics), the fix is to add 'options thinkpad_acpi brightness_enable=1' to /etc/modprobe.d/options. brightness changing is very laggy/slow, but it works perfectly.

Tom Vetterlein (smbm) wrote :

For me the opposite has happened;

Before I was getting a laggy Gnome brightness indicator but no brightness changes happening.

Then I added 'options thinkpad_acpi brightness_enable=1' to /etc/modprobe.d/options and now I'm getting a non laggy Gnome brightness indicator but still no brightness changes actually taking place.

kakukri (kakukri) wrote :

Seems I am the most fortunate, for me adding 'options thinkpad_acpi brightness_enable=1' to /etc/modprobe.d/options helped, it made brightness changing working and also the Gnome brightness indicator non laggy. For the record I have an R61-8935. The only glitch remaining is that Fn+End changes the brightness down in around twice as big steps as Fn+Home up, more precisely it requires 8 steps from 100% down to 0, and 15 steps from 0 to 100%.

Jerone Young (jerone) wrote :

This appears to only effect thinkpads using the Intel x3100 graphics.

I have a Thinkpad 61p with Nvidia Quadro and the brightness control works (updating today's packages), using the proprietary nvidia driver. But when I try my other Thinkpad T61 with Intel x3100 it does not work.

Also using thinkpad acpi option is a bad work around for the real issue. This worked and then broke with an ubuntu kernel update (see my other comments).

noah dain (noahdain) wrote :

Brightness keys never worked here with 7.10 (so not a regression). Still does not work with 8.04beta1, kubuntu, amd64.

Following the instructions here https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch
I stopped hotkey-setup and then ran "sudo showkey -u | tee -a hotkey-log.txt". I then pressed the brightness-increase (Fn+Home) and then the brightness-decrease (Fn+End). The results are:
'''
kb mode was UNICODE

press any key (program terminates after 10s of last keypress)...
0xe0 0x54 0xe0 0xd4
0xe0 0x4c 0xe0 0xcc
'''

other system info:
dmidecode -s system-manufacturer: LENOVO
dmidecode -s system-product-name: 6465CTO
dmidecode -s system-version: ThinkPad T61

video is intel x3100.
uname -a: Linux ganymede 2.6.24-12-generic #1 SMP Wed Mar 12 22:31:43 UTC 2008 x86_64 GNU/Linux

John Leach (johnleach) wrote :

Same here on my R61. Worked with Feisty and Gutsy, worked for a while with Hardy but stopped after an upgrade last week.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

Linux version 2.6.24-12-generic (buildd@palmer) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu4)) #1 SMP Wed Mar 12 23:01:54 UTC 2008

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

dmidecode -s system-product-name: 77321EG
dmidecode -s system-version: ThinkPad R61/R61i

I get the follow in the ring buffer when I hit the brightness keys:

[ 719.532973] thinkpad_acpi: unknown LID-related HKEY event: 0x5010
[ 719.603904] thinkpad_acpi: unknown LID-related HKEY event: 0x5010

gallir (gallir-gmail) wrote :

I can confirm the regression in my Lenovo Thinkpad X61_s.

Brightness buttons worked in Gutsy and stopped working in Hardy. However brightness buttons do work if I boot with Gutsy kernel (2.6.22-14-generic). So I think is a kernel package related problem.

Neal Belair (nbelair) wrote :

As with kakukri, I can confirm that Aren Olson's easy to implement fix has my Lenovo Thinkpad X61 Tablet brightness working perfectly, now. He suggested adding the following line:

   options thinkpad_acpi brightness_enable=1

 to the end of the following file:

    /etc/modprobe.d/options

Once I made this change, and rebooted, the think pad brightness keys starting actually changing the brightness. The applet was already working before the change, as other's have mentioned. This is under Ubuntu hardy alpha6 with all the updates, which puts me on kernel 2.6.24-12-generic

Douglish (dal-horinek) wrote :

Brightness works almost fine on my ThinkPad R61, but there are problems when level reaches 0, than another acpi event ( ibm/hotkey HKEY 00000080 00005010 ) occurs. Also there is a problem with brightness when system is booted with lower level and than in X or console changed, after switch it restores the previous low level. Also this happens with mplayer. Disabling brightness up/down (and using only video module for this) hotkeys didn't help.

There is Mobile GM965/GL960 Integrated Graphics Controller

System Product-name: 8943DRG
System Version: ThinkPad R61
Bios Version: Version: 7QET28WW (1.10 )

Jerone Young (jerone) wrote :

So going through the kernel log at
https://launchpad.net/ubuntu/+source/linux/

This appears to broke in 2.6.24-11.17 with one of the following entries that was pulled from upstream:
  * ACPI: video: Rationalise ACPI backlight implementation <-- "This is most likely the culprit"
  * ACPI: video: Ignore ACPI video devices that aren't present in hardware

This is currently broken in 2.6.25 (which I assume where these patches were pulled from).

Now remember it "works" with 2.6.25-10.16.

So what we know:

     - This effects only Thinkpads with Intel x3100
     - This broke with 2.6.24-11.17 update
     - There is a really bad work around using thinkpad acpi ...
        please read <kernel source>/Documentation/thinkpa-acpi.txt
         It says and I quote .. " When display backlight brightness controls are available
         through the standard ACPI interface, it is best to use it instead of this direct
         ThinkPad-specific interface."
        * So you should not be using backlight= thinkpad_acpi option
        * The problem is the ACPI interface is broken, so please stop mentioning it in this bug
     - Also even though you see the Gnome backlight indicator slowly going up and down, the actual backlight is not changing.

morinpatmorin (morinpatmorin) wrote :

> It says and I quote .. " When display backlight brightness controls are available
> through the standard ACPI interface, it is best to use it instead of this direct
> ThinkPad-specific interface."

But right now they're not (available) and the thinkpad_acpi option is easy to implement, works in the meantime, and is easy to reverse once a real fix comes along. I'm glad I found this report.

Pat

Qianqian Fang (fangq) wrote :

I have experienced exactly the same problem for my T61 (have been struggling for days), all Fn combination for acpi are not working. Before the new fixes being committed, is there a way to downgrade my kernel back to 2.6.24-10 on Hardy? synaptic only has 2.6.24-11 and 2.6.24-12.

aherr1 (aherr1) wrote :

Same problem here. Lenovo T61 8895-A24 (with x3100 graphics). Brightness worked until update a few days ago. This stinks.

Jerone Young (jerone) wrote :

Tried kernel 2.6.25-rc8 and brightness works! So there are fixes upstream. Also it's very quick too (unlike it being slow and sluggish). One thing is the thinkpad-acpi probably neededs to be moved up to 0.19. I'll try and fine the hardy kernel git tree and see if I can find the right upstream patches to fix this problem.

aherr1 (aherr1) wrote :

Sorry I only just installed Linux on my T61 for the first time yesterday. How do I update the kernel to the new 2.6.25-rc8 patch. I downloaded and upzipped the patch to the desktop, but I can't seem to copy it to the usr/src directory, something most of the online directions find say I need to do. How would I go about that? Any help would be great. Thanks in advance.

Guilherme Salgado (salgado) wrote :

The recently uploaded kernel (2.6.24-14) seems to have fixed this for me. I guess the patch attached in bug 205261 is the actual fix.

Jerone Young (jerone) wrote :

Works again with kernel 2.6.24-14

Changed in linux:
status: Triaged → Fix Released

Is this fix going to be in mainline kernel or it's just only ubuntu's?

--
Dalibor Horinek
http://www.horinek.net

mobile: 776 687 523
jabber1: <email address hidden>
jabber2: <email address hidden>
ICQ: 178217372 (Preferuji jabber)

/***************************
* be free with Open Source *
* http://www.linux.cz *
* http://www.gnu.cz *
****************************/

FIXED - sort of.

I just upgraded BIOS and kernel, and was still having trouble. I discovered the following restores FN-Home/End functionality as long as it's run _after_ X starts... No dice if I put it in /etc/rc.local, and I can't change permission of a /proc file to let .xinitrc do it:

# Happy times are here until reboot!
sudo /etc/init.d/acpid restart

It looks like this has been around a while:
http://friend-of-misery.blogspot.com/2007/07/me-and-thinkpad-r61.html

self() <- {
  uname -a = Linux ravel 2.6.24-14-generic #1 SMP Thu Apr 3 04:49:29 UTC 2008 i686 GNU/Linux
  bios = 7LETB0WW (2.10-1.08)
  model = T61, Intel graphics, 14" WXGA+
  dist = Hardy, freshly updated
  wm = openbox+nautilus
}

Սահակ (petrosyan) wrote :

this is a duplicate of bug #172985

noah dain (noahdain) wrote :

Just noticed a strange issue with kubuntu/8.04b1. brightness-up works as expected, but brightness-down seems to trigger multiple events, 4 in fact. The event popup indicator from 'power manager' appears to show it stepping through the skipped brightness levels, although it happens very quickly so it's difficult to be sure.

I noticed that too and I think someone mentioned it previously. Is anyone else noticing this issue now that the brightness buttons have been fixed:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/211687

I'm with the same problem. My system is updated and this bus returns to happens. My machine is a Thinkpad R61.

noah dain (noahdain) wrote :

On Wed, Apr 16, 2008 at 9:10 PM, Davi Vercillo C. Garcia
<email address hidden> wrote:
> I'm with the same problem. My system is updated and this bus returns to
> happens. My machine is a Thinkpad R61.
>
>

my output from acpi_listen:
brightness-up:

video LCD0 00000086 00000000

brightness-down:
ibm/hotkey HKEY 00000080 00001011
video LCD0 00000087 00000000

# grep -R "HKEY 00000080 00001011" /etc
/etc/acpi/events/thinkpad-brightness-down:event=ibm/hotkey HKEY
00000080 00001011

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers