wireless option had gone from network settings

Bug #164217 reported by zerosentiment on 2007-11-21
8
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

My Wireless connection is missing from the Network settings, i only have the wired connection and modem connection.
It was working when i first installed Ubuntu a few days ago.

ProblemType: Bug
Architecture: i386
Date: Tue Nov 20 23:53:52 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/gnome-panel
Package: gnome-panel 1:2.20.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: gnome-panel --sm-client-id default1
ProcCwd: /home/arun
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
Uname: Linux zerosentiment 2.6.22-14-server #1 SMP Sun Oct 14 23:34:23 GMT 2007 i686 GNU/Linux

zerosentiment (zerosentiment) wrote :
Hans Stoffels (jstoffels) wrote :

Have the same problem.

I tried replacing ndiswrapper 1.49 by 1.50 but that did not help.
I wonder, could a case conflict between driver file name [capitals] and internal name shown by ndiswrapper -l [small caps] cause this?
modprobe ndiswrapper froze the system with the case conflict, but didn't do that anymore after I renamed the driver file from BG4501T.inf to bg4501t.inf. Still, the wired connection option is gone from the network settings menu.
I must say it also disappeared with Ubuntu 6.06, that's why I tried Ubuntu 7.10. But alas...

Hans Stoffels (jstoffels) wrote :

I come back on my comment...
I tried a clean install of Ubuntu 7.10 alternate i386.
Right after that, no wireless connection visible under Network settings. [Should there have been one???]
Then, on reading http://ubuntuforums.org/showthread.php?t=112526,
I installed ndiswrapper 1.50 not the native 1.49 according to the steps described.
In ndiswrapper-1.50 directory:

sudo make uninstall
sudo make uninstall
make
sudo make install

I had to remove ^M from /etc/sbin/ndiswrapper to get it to run.

Then, I modified the filenames for my driver to small caps.
in the same directory:
sudo ndiswrapper -i bt4501g.inf

sudo ndiswrapper -l
replied correctly.

sudo ndiswrapper -m

all right

sudo modprobe ndiswrapper

returns properly, and then
system hangs

I guess I'll have to wait until some new version of Ubuntu, or until some kind angel solves this issue. I only have a wireless dongle, and without internet access I can't use this Ubuntu 7.10.
I will go back to windows 98 which I just tried to escape. Sorry.

Thanks for taking you time in reporting this but this bug has remained idle for some time. Can you still confirm this bug? does the issue persist?

Please, don't forget to answer.

Marlon Cisternas Milla wrote:
> Thanks for taking you time in reporting this but this bug has remained
> idle for some time. Can you still confirm this bug? does the issue
> persist?
>
> Please, don't forget to answer.
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
>
Thanks for your follow up!
I have noticed a few [three or so] complete and unrecoverable session
crashes with use of the ndiswrapper usage of the Bt4501g driver. They
made me fully reinstall Ubuntu. I therefore abandoned using Ubuntu with
wireless and move to using a Netgear Xe102 powerline adapter. With this
I have an Ethernet connection through the powerline all trhough my
house. Ubuntu then does not need wireless anymore for me, and has
operated great since then.

So, I guess the issue still exists, but I worked around it.

Many regards,
Hans Stoffels

ferdi (ferdi-xs4all) wrote :

To confirm the bug is still there.
After a fresh install of Intrepid Ibex (8.10) I tried establishing a wireless connection using my speedtouch 121g usb dongle via ndiswrapper (and bt4501g driver).
The system completely freezes after the modprobe.
If the modprobe is done before plugging in the dongle the system freezes when plugging it in.
The system also freezes when booting up when hardware and ndiswrapper are present.

ferdi (ferdi-xs4all) wrote :

Just a quick follow up on my previous post.
I downloaded the new Vista Driver from http://www.speedtouch.nl/software.html#121g (seem to have missed that yesterday) and am typing this message using that driver under ndiswrapper on the same system.
This suggests the bug is in fact in the Windows XP driver and not in ndiswrapper.

Dimitrios Symeonidis (azimout) wrote :

closing as per your last comment

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers