'World Weather Online' does NOT work

Bug #1112214 reported by thomas janssen on 2013-02-01
102
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Ubuntu
High
Lorenzo Carbonell

Bug Description

'World Weather Online' doesn't work. See screenshots.

Revision history for this message
thomas janssen (janssenth) wrote :
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

Run from terminal:

~$ my-weather-indicator
<gettext.GNUTranslations instance at 0x1dade60>
No LSB modules are available.
#####################################################
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Version: x86_64
#####################################################

My-Weather-Indicator version: 0.6.1.0.precise.1
#####################################################
('/home/amr/.config/my-weather-indicator/my-weather-indicator.conf', True)
{"time":"2013-02-01 11:09","countryName":"Egypt","sunset":"2013-02-01 17:31","rawOffset":2,"dstOffset":2,"countryCode":"EG","gmtOffset":2,"lng":31.25,"sunrise":"2013-02-01 06:45","timezoneId":"Africa/Cairo","lat":30.05}
<?xml version="1.0" encoding="UTF-8"?><Response><Ip>41.233.159.150</Ip><Status>OK</Status><CountryCode>EG</CountryCode><CountryCode3>EGY</CountryCode3><CountryName>Egypt</CountryName><RegionCode>11</RegionCode><RegionName>Al Qahirah</RegionName><City>Cairo</City><ZipPostalCode></ZipPostalCode><Latitude>30.0500</Latitude><Longitude>31.2500</Longitude><AreaCode>0</AreaCode><TimeZone>Africa/Cairo</TimeZone></Response>

WorldWeatherOnline Weather Service url:http://free.worldweatheronline.com/feed/weather.ashx?q=30.05,31.25&format=json&num_of_days=5&key=5aa718e771170840121008
(<type 'str'>, u'-18 \xb0C')
<?xml version="1.0" encoding="UTF-8"?><Response><Ip>41.233.159.150</Ip><Status>OK</Status><CountryCode>EG</CountryCode><CountryCode3>EGY</CountryCode3><CountryName>Egypt</CountryName><RegionCode>11</RegionCode><RegionName>Al Qahirah</RegionName><City>Cairo</City><ZipPostalCode></ZipPostalCode><Latitude>30.0500</Latitude><Longitude>31.2500</Longitude><AreaCode>0</AreaCode><TimeZone>Africa/Cairo</TimeZone></Response>

WorldWeatherOnline Weather Service url:http://free.worldweatheronline.com/feed/weather.ashx?q=30.05,31.25&format=json&num_of_days=5&key=5aa718e771170840121008
(<type 'str'>, u'-18 \xb0C')
start now

summary: - Online Weather Service don't work
+ 'World Weather Online' does NOT work
description: updated
Revision history for this message
Tolchi (sehoon-park) wrote :

Seems need api key now according worldweatheronline.com (can freely generate after creating account)

Revision history for this message
thomas janssen (janssenth) wrote :

some additional Information:
<gettext.GNUTranslations instance at 0xa10394c>
No LSB modules are available.
#####################################################
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Version: i686
#####################################################

My-Weather-Indicator version: 0.5.3.2
#####################################################
WorldWeatherOnline Weather Service url:http://free.worldweatheronline.com/feed/weather.ashx?q=50.732422,7.10186&format=json&num_of_days=5&key=5aa718e771170840121008
^CTraceback (most recent call last):
  File "/usr/share/my-weather-indicator/myweatherindicator.py", line 121, in work
    def work(self):
KeyboardInterrupt
WorldWeatherOnline Weather Service url:http://free.worldweatheronline.com/feed/weather.ashx?q=50.732422,7.10186&format=json&num_of_days=5&key=5aa718e771170840121008

Revision history for this message
Matthew (mh00h) wrote :

I am using 0.6.1.0.quantal.1, and it doesn't work either.

Revision history for this message
shan (holinuhi) wrote :

also gone down here on 12.04 -18 all the time

Revision history for this message
Lorenzo Carbonell (lorenzo-carbonell) wrote :

Hi all,

last thursday I received an email from "World Weather Online", that said the number of requests to its API were more than 4.148 request/hour, while the number of allowed are 500 request/hour.

They told me, that I must reduce the number of requests or to upgrade to their PREMIUM API.

I answered that My-Weather-Indicator is an free an open source application with no economic benefic, so I can't pay for ther PREMIUM API. I asked them if there is another solution for this kind of problem, and I'm waiting for their answer.

I think I will have to reduce the number of request to its API to 1 every 2 hour, or simply remove this weather service from My-Weather-Indicator. I don't know what to do.

Meanwhile I'm looking for other free services as Open Weather Map, that doesn't limit the request/number or where this limit will be higher.

Revision history for this message
shan (holinuhi) wrote :

hi there Lorenzo thanx for clarifying situation

it used to be that google weather was an option on the applet but that disappeared a while back; was that service no longer viable if you do not mind saying?

Revision history for this message
Paulo Novais (valeptb) wrote :

If the API has problems of access limitations, it may be a good idea to remove the World Weather Online options. Yahoo and has provision for only two days and the widget gets weird, with the remaining days unavailable. Open Weather Map lacks many of the locations, as Braga - Portugal.
Placie at least Google Weather again.
Thank you for your work
Paulo

Revision history for this message
Saikrishna Arcot (saiarcot895) wrote :

Google Weather no longer exists.

There is the NOAA's data feed (http://graphical.weather.gov/xml/rest.php), which provides less information than others in some areas and too much information in other areas.

drefhill (drefhill) on 2013-02-02
Changed in my-weather-indicator:
status: New → Confirmed
Revision history for this message
Tolchi (sehoon-park) wrote :

maybe it's better everyone get personal api key and enter it to use world weather online

Revision history for this message
Presianbg (presianbg) wrote :

ya , it will be the best :) Just make dialog window to enter the god damn key :)

Revision history for this message
Felix Dietzsch (felixdietzsch2) wrote :

I solved it by creating a new personal API key number (needs at least 1 min) and editing worldweatheronlineapi.py

Revision history for this message
shan (holinuhi) wrote :

excellent Felix

go to site sign in get number

gedit /usr/share/my-weather-indicator/worldweatheronlineapi.py

and number on line 34

Revision history for this message
Presianbg (presianbg) wrote :

Nicee :)

Revision history for this message
Tioz (tiozinoz) wrote :

@ Felix @ shan

Sounds great but as a novice I don't really know where to start. First of all is this the site on which I register to get my own API?
http://www.worldweatheronline.com/free-weather-feed.aspx
Second, once I have the number, where exactly do I edit gedit /usr/share/my-weather-indicator/worldweatheronlineapi.py. My file doesn't show line numbers and clearly I have to be sure. Any chance of a screen shot to help us novices through?

I really like MWI as the best Weather indicator and would love to get it working again.

Hope this request is in order. Thanks

Revision history for this message
shan (holinuhi) wrote :

hi Tioz install leafpad or mousepad they have line numbers

sudo apt-get install leafpad

then go

leafpad /usr/share/my-weather-indicator/worldweatheronlineapi.py

click options/line numbers now you have line numbers

go to line 34 and put your new personal API instead of other one

this should be clear ... if not ask for more info

shan

Revision history for this message
shan (holinuhi) wrote :

ps where it says free sign up http://www.worldweatheronline.com/

Revision history for this message
Tioz (tiozinoz) wrote :

Hi shan thanks for that. Got the API number and all seems clear except after editing and try to save was told that could not open the file and could not save. Same result in both gedit and leafpad. Checked permissions in properties which says that the file is owned by 'root' and I can't change permissions or open the file for editing. Any clues how I get around this? Do I have to use sudo to open the file? Don't want to chance that until I am sure.

Revision history for this message
Tolchi (sehoon-park) wrote :

edit worldweatheronlineapi.py is just workaround..

because if you update it, need to be edited again...

best way is provide way to enter personal api key and save it home folder.

Revision history for this message
Tioz (tiozinoz) wrote :

Hi shan...all fixed! I was able to open file as 'root', edit and save. After log out and in MWI is now working perfectly again. Just wonderful!

Great contributions by all! Still luvvin' Linux and all the great support! Thank You!

Tioz

Revision history for this message
shan (holinuhi) wrote :

yes fair point Tolchi only a quick fix while something more durable is worked out

Revision history for this message
Philipp Bielefeldt (p-bielefeldt) wrote :

@ Felix et. al.: I got my very own API-key, but still on launch, my-weather-indicator crashes:

~$ my-weather-indicator
<gettext.GNUTranslations object at 0x27b89d0>
No LSB modules are available.
#####################################################
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Version: x86_64
#####################################################

My-Weather-Indicator version: 0.6.1.0.quantal.1
#####################################################
/home/philipp/.config/my-weather-indicator/my-weather-indicator.conf True
'refresh'
'version'
'widget1'
'widget2'
'pressure'
'visibility'
'snow'
'rain'
'24h'
'weather-service'
b'{"status":{"message":"error parsing parameter","value":14}}'
Timezone Error 'rawOffset'
b'{"status":{"message":"error parsing parameter","value":14}}'
Timezone Error 'rawOffset'
<?xml version="1.0" encoding="UTF-8"?><Response><Ip>91.10.2.252</Ip><Status>OK</Status><CountryCode>DE</CountryCode><CountryCode3>DEU</CountryCode3><CountryName>Germany</CountryName><RegionCode>07</RegionCode><RegionName>Nordrhein-Westfalen</RegionName><City>Much</City><ZipPostalCode></ZipPostalCode><Latitude>50.9167</Latitude><Longitude>7.4000</Longitude><AreaCode>0</AreaCode><TimeZone>Europe/Berlin</TimeZone></Response>

b'{"time":"2013-02-05 10:15","countryName":"Germany","sunset":"2013-02-05 17:28","rawOffset":1,"dstOffset":2,"countryCode":"DE","gmtOffset":1,"lng":7.4,"sunrise":"2013-02-05 08:01","timezoneId":"Europe/Berlin","lat":50.9167}'
OpenWeatherMap Weather Service url:http://openweathermap.org/data/2.1/weather/city/2868936
Traceback (most recent call last):
  File "/usr/bin/my-weather-indicator", line 45, in <module>
    mwi=MWI()
  File "/usr/share/my-weather-indicator/myweatherindicator.py", line 135, in __init__
    self.load_preferences()
  File "/usr/share/my-weather-indicator/myweatherindicator.py", line 343, in load_preferences
    self.work()
  File "/usr/share/my-weather-indicator/myweatherindicator.py", line 195, in work
    self.set_menu()
  File "/usr/share/my-weather-indicator/myweatherindicator.py", line 437, in set_menu
    weather = self.weatherservice1.get_weather()
  File "/usr/share/my-weather-indicator/wopenweathermapapi.py", line 139, in get_weather
    weather_data['current_conditions']['wind_condition'] = weatherservice.get_wind_condition2(velocity,wind_direction[0],self.units.wind)
  File "/usr/share/my-weather-indicator/weatherservice.py", line 428, in get_wind_condition2
    wind_velocity = change_velocity(s2f(wind_velocity),wind_units)
  File "/usr/share/my-weather-indicator/weatherservice.py", line 508, in change_velocity
    if a in units_u.keys():
TypeError: unhashable type: 'dict'

Looks as if some references are invalid, doesn't it? Maybe my entire installation is corrupt? I installed via apt-get which should be very usual; Since then, I never made it work...
Any help is appreciated!

Revision history for this message
shan (holinuhi) wrote :

try

sudo apt-get remove --purge my-weather-indicator

then

sudo add-apt-repository ppa:atareao/atareao

sudo apt-get update && sudo apt-get install my-weather-indicator

see if more joy that way

Revision history for this message
Fusion (bornolbers) wrote :

shan,

I have also used this ppa, but I did also tried that you suggested. Unfortunatelly, same results came out:

yahoo: works fine
world weather online: doesn't work at all (no today: -18 , no forecast: N/A)
open weather map: works only for 'today' (no forecast: N/A)

ps. in case it helps, the previous edition of my-weather-indicator has only the issue:
world weather online: works only for 'today' (no forecast: N/A)

hope it helps

Revision history for this message
Lorenzo Carbonell (lorenzo-carbonell) wrote :

Open Weather Map should work. If you have problems with forecast it must be due to another question. Could you add here a screenshot of your forecast window?
Coud you tell me what location are you testing?

Thanks.

Changed in my-weather-indicator:
assignee: nobody → Lorenzo Carbonell (lorenzo-carbonell)
importance: Undecided → High
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

For Open Weather Map, refer to this bug https://bugs.launchpad.net/my-weather-indicator/+bug/1115455

Revision history for this message
sergiuniculescu (sergiuniculescu) wrote :

Generating an API key works perfect. Thanks!

Revision history for this message
Matthew (mh00h) wrote :

Works great for me too. What if there was somes sort of popup and/or href link to walk people through the process of generating their own api keys? Openweathermap will have ~10º temperature fluxuations for me, so thank you for providing this api key option. Just wanted to say that despite all these issues, thanks for everything!

Revision history for this message
shan (holinuhi) wrote :

it has now been fixed as you can enter your own API number by going to preferences
was just wondering how new users would know that
but maybe it is explained somewhere i have not seen

anyway fully functional now no need for editing anything and thanx for the fix it is still the best weather applet money cannot buy :::]]] excellent

Changed in my-weather-indicator:
status: Confirmed → Fix Released
George (gpeleka) on 2013-06-20
affects: my-weather-indicator → ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions