Dual Monitor Lock Screen Dialog Hidden

Reported by JCarver on 2012-10-04
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNOME Screensaver
New
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Ubuntu 12.04.1 LTS
Nvidia GTX 550-Ti
x-swat Nvidia driver 304.51-0ubuntu1~precise~xup1

Problem:

Using 2 monitors. When screen locks there is a blue box on top of the wallpaper and password dialog box that hides the field for entering your password or switching users.

Problem is on 2 systems with similar hardware (Nvidia card, x-swat driver, dual monitors)

You can still type your password in blindly and hit enter to login but it's irritating to not be able to see the dialog box.

https://lh6.googleusercontent.com/-slOE3M9ABEA/UGyt0TmoHlI/AAAAAAAADwU/QaqxfZjplzM/s800/photo.JPG

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1061787/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Mark Herbers (markah1) wrote :

I am also affected by this bug. My set up seems to be roughly the same as well, 2 monitors and an Nvidia card. Like stated above I just login blindly on the lock screen and very rarely do I see the actual login prompt and no blue box.

Mark Herbers (markah1) wrote :

Update: It seems the blue box has to do with the resolution of the second monitor. Recently updated my second display to the same size as my primary display, and the blue box now fills the entire screen. Im also currently running the two monitors in twinview and have not tried seperate x servers.

JCarver (justin-carver) wrote :

Issue doesn't exist using Gnome Classic only Gnome Shell

Mark Herbers (markah1) wrote :

after upgrade to ubuntu 12.10 x64, with Nvidia driver 310.14 problem presists except blue has turned black.

JCarver (justin-carver) wrote :

Workaround. Move mouse to secondary screen and hit escape. Password dialog will appear on that screen.

Guy Rutenberg (guyrutenberg) wrote :

I have the same problem. One screen turns entirely blue, while the other one is OK. At first I thought it's a problem with my screen, but I see others reporting it as well. It started happening about a month to 2 months ago. Using Ubuntu 12.04 64bit using nvidia-current 295.40-0ubuntu1.1 and Gnome3

lumbricus (lumbricus) wrote :

I think this problem is a bug in gnome-scrensaver. If I use xset to turn off the screen, there is no issue after turning it on again. I used the following command line:

for i in `seq 40`; do xset dpms force off; sleep 0.2; done; xset dpms force on

If the gnome-screensaver-daemon does not run (I simply killed it), there is still some kind of basic screen saver. The screen goes into standby mode after some while and turns on again normally afterwards (without password prompt).

Attached some debugging outbut, which I got by using:

gnome-screensaver --no-daemon --debug 2>&1 | tee ~/gnome-ss.log

I run the command and then waited some minutes. At 11:56:19 I moved the mouse again and saw the blue area.

My first (primary) monitor has the dimensions 1980x1200. My second monitor has the dimensions 1280x1024. As already mentioned, the blue rectangle is about the size of the second monitor and it is placed on the first monitor in the left upper corner.

lumbricus (lumbricus) wrote :

This bug is not present on another computer without a Nvidia graphic card. But I'm not sure if this the crucial difference. The bug can not be solved by using the nouveau driver.

Kapil Thangavelu (hazmat) wrote :

I get this on an intel graphic drivers as well, And even worse, if you try to enter your password twice, it will go to whatever the app in the foreground is. you can't see anything.. so there's no feedback if it comes back or not.. and sometimes it does when the screensaver goes away, sometimes not. i've revealed my login password to irc several times this way over the years. ouch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers