[needs-packaging] Eclipse Web Tools Platform

Bug #104986 reported by Andreas Schildbach on 2007-04-09
72
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
MOTU

Bug Description

The Eclipse Web Tools Platform (WTP) Project provides APIs for J2EE and Web-centric application development. In includes both source and graphical editors for a variety of languages, wizards and built in applications to simplify Web Service development, and tools and APIs to support deploying, running, and testing apps.

Ubuntu already contains packages for the Eclipse Platform and the JDT (Java Development Tools), but WTP is missing.

http://www.eclipse.org/webtools/main.php

I'd like to second this package needs to be added if not supported. It is a major tool for Web Developers.

As an example, here is the error output for the Update Manager when trying to install WTP:

Requested operation cannot be performed because it would invalidate the current configuration. See details for more information.
  WST Common UI (2.0.0.v200706041905-7C5EGzE9RvTVniSrwnf4TgOPe3e9) requires plug-in "org.eclipse.draw2d (3.2.0)", or compatible.
  WST Common Core (2.0.0.v200706041905-7C78EK9E_EkMNfNOd2d8qq) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
  Eclipse XML Editors and Tools (2.0.0.v200706182145-7A1ECBCnbckz0bZu9wHqAKN3mYpZ) requires plug-in "org.eclipse.emf.common (2.2.0)", or compatible.
  WST XML Core (2.0.0.v200706041905-787BE9zCYQCCz-CnUGLYQV) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
  WST Server Adapters (2.0.0.v200706041905-4--_kE77Y7QI7EEEQ) requires plug-in "org.mortbay.jetty (5.1.11)", or compatible.
  WST Web Services UI (2.0.0.v200706041905-791ECBAufYO8_EaomWE4Fe3uXjR1) requires plug-in "org.eclipse.emf.common (2.2.0)", or compatible.
  WST Web Services Core (2.0.0.v200706210215-7E7KE_QEC3wSU4TpiAiQ0r) requires plug-in "org.eclipse.xsd (2.3.0)", or compatible.
  WST Web UI (2.0.0.v200706041905-7A0EAeCiWfEJsCcbAj88SKfRX) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
  WST Web Core (2.0.0.v200706041905-42CI_kE77Y7TAMAVHH) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
  JST Server UI (2.0.0.v200706041905-77-Ao9yJX9kueNPfPjeUCMFH3648) requires plug-in "org.eclipse.jdt.debug.ui (3.2.100)", or compatible.
  JST Server Core (2.0.0.v200706041905-56CL9rC7EK_PAQ7G_92537) requires plug-in "org.eclipse.emf.common (2.2.0)", or compatible.
  JST Server Adapters (2.0.0.v200706041905-787KE8RDUUEF6ExNsAAAJ) requires plug-in "org.eclipse.emf.common (2.2.0)", or compatible.
  JST Web Core (2.0.0.v200706080101-7Q7ACQEHhHegvgW5YtoAO) requires plug-in "org.eclipse.emf.ecore.xmi (2.2.0)", or compatible.
  JST Enterprise UI (2.0.0.v200706200200-7b7_ErUEU6AXGM40HZCO6nkOjnZQ) requires plug-in "org.eclipse.emf.common (2.2.0)", or compatible.
  JST Enterprise Core (2.0.0.v200706041905-42Am_kE77Y7U9NAPH8) requires plug-in "org.eclipse.emf.ecore.xmi (2.2.0)", or compatible.
  WTP Web Page Editor (1.0.0.v200706110802-3--9oA55P5M98) requires plug-in "org.eclipse.emf.ecore (2.2.0)", or compatible.
  Java Persistence API Tools (1.0.0.v200706250000-77--CYQCCz-CoRPCCCH) requires feature "org.eclipse.datatools.connectivity.feature".

I just spent an hour figuring out how to install WTP, so I'm going to post this information here to help people searching for this in the future, even if the original poster is probably not interested any more.

Of course this is not directly relevant to the bug, since this method also uses Eclipse's update mechanism instead of apt-get.

The information is from here: https://help.ubuntu.com/community/EclipseWebTools

============================================================
WTP can be installed using Eclipse's own "Software Updates" mechanism: Go to "Help -> Software Updates -> Find and Install", select the "Callisto Discovery Site" and later the "Web and J2EE development" plugin group. Click "Select required" to automatically select all the dependencies.
============================================================

That's it, WTP is installed. Just don't use the "official" WTP update site.

Changed in debian:
status: Unknown → New

This method no longer works. The JDT and the Eclipse bundle shipping with Karmic is horribly broken. It is missing a buttload of plug-ins. Any attempt to use Help -> Software Updates -> Find and Install now results in the following:

Network connection problems encountered during search.
  Unable to access "http://download.eclipse.org/releases/galileo".
    Error accessing site stream. [Server returned HTTP response code: 503 for URL: http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd]
    Server returned HTTP response code: 503 for URL: http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd
    Error accessing site stream. [Server returned HTTP response code: 503 for URL: http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd]
    Server returned HTTP response code: 503 for URL: http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd
  Unable to access "http://download.eclipse.org/eclipse/updates/3.5".
    Unable to access site: "http://download.eclipse.org/eclipse/updates/3.5" [Server returned HTTP response code: "403 Forbidden" for URL: http://download.eclipse.org/eclipse/updates/3.5.]
    Server returned HTTP response code: "403 Forbidden" for URL: http://download.eclipse.org/eclipse/updates/3.5.
    Unable to access site: "http://download.eclipse.org/eclipse/updates/3.5" [Server returned HTTP response code: "403 Forbidden" for URL: http://download.eclipse.org/eclipse/updates/3.5.]
    Server returned HTTP response code: "403 Forbidden" for URL: http://download.eclipse.org/eclipse/updates/3.5.

If you download the Eclipse Java Development bundle directly from the Eclipse side and run it from a local directory you get a _lot_ more update sites listed, you also start out with all of the packages and plugins you are supposed to have. It's like they bundled the wrong version of Eclipse or simply left out 2/3rds of the Java development package. A person cannot run Mark Dexter's persistence tutorial with what got delivered for Eclipse with Ubuntu/KUbuntu.

George (kevin-brothaler) wrote :

Ubuntu's packaged Eclipse has no update sites as of Dec-07-09.

Jeffrey Finkelstein (jfinkels) wrote :

I can confirm this is still an issue in Ubuntu 10.04.1.

Here is the download page for the most recent release version of WTP: http://download.eclipse.org/webtools/downloads/drops/R3.2.1/R-3.2.1-20100730021206/

This page notes that the prerequisites are:

* EMF v2.6 Runtime Minimum executable code
* EMF XSD v2.6 Runtime Minimum executable code
* Graphical Editing Framework (GEF)
* Data Tools Platform (DTP) (required only for EJB or JPT development)

Changed in debian:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.