[needs-packaging] TV-Browser

Bug #102910 reported by Simon J. on 2007-04-04
58
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

Revision history for this message
In , Stefan Fritsch (sf-sfritsch) wrote : Re: RFS: tvbrowser -- TV-Browser is a java-based TV guide

merge 321230 265711
retitle 265711 ITP: tvbrowser -- TV-Browser is a java-based TV guide
thanks

Hi,

> I've packaged[1] tvbrowser[2], which cloeses #321230[3] and am now
> seeking for a sponsor.

Hint: Look for an existing "Request for package" bug and retitle it
instead of filing a new ITP bug.

Cheers,
Stefan

PS: I am not a DD and can't sponsor you.

Revision history for this message
In , Bastian Venthur (expires-2006) wrote : closing my ITP

close 321230
quit

Package contains non-free icons from sun and upstream is not willing to
replace them with free ones. I've offered my help and even gave them a list
of icons to exchange but they where not interested.

So I'm closing my ITP.

Revision history for this message
In , Bastian Venthur (expires-2007) wrote : new mail address

submitter 258377 !
submitter 266378 !
submitter 266398 !
submitter 266401 !
submitter 266428 !
submitter 266544 !
submitter 283349 !
submitter 286466 !
submitter 288221 !
submitter 302240 !
submitter 306183 !
submitter 309379 !
submitter 309682 !
submitter 316766 !
submitter 317054 !
submitter 317057 !
submitter 319387 !
submitter 320674 !
submitter 321102 !
submitter 321230 !
submitter 321733 !
submitter 322161 !
submitter 322225 !
submitter 322319 !
submitter 322334 !
submitter 322335 !
submitter 322356 !
submitter 322437 !
submitter 322543 !
submitter 324179 !
submitter 324849 !
submitter 325922 !
submitter 326755 !
submitter 327113 !
submitter 330607 !
submitter 331398 !
submitter 331646 !
submitter 332473 !
submitter 336775 !
submitter 337937 !
submitter 337938 !
submitter 340071 !
submitter 342784 !
submitter 342786 !
submitter 342788 !
submitter 345161 !
submitter 345194 !
submitter 347953 !
submitter 348083 !
quit

Changed address from expires-2006@... to expires-2007@...

Revision history for this message
In , Bastian Venthur (venthur) wrote :

submitter 302240 !
submitter 327113 !
submitter 348481 !
submitter 378975 !
submitter 342784 !
submitter 258377 !
submitter 286466 !
submitter 316766 !
submitter 317057 !
submitter 322543 !
submitter 347953 !
submitter 379561 !
submitter 317054 !
submitter 320674 !
submitter 337937 !
submitter 337938 !
submitter 356182 !
submitter 358979 !
submitter 266398 !
submitter 322334 !
submitter 348223 !
submitter 384106 !
submitter 309379 !
submitter 321102 !
submitter 330607 !
submitter 332473 !
submitter 336775 !
submitter 345161 !
submitter 360363 !
submitter 384962 !
submitter 266378 !
submitter 266544 !
submitter 283349 !
submitter 309682 !
submitter 319387 !
submitter 321733 !
submitter 326755 !
submitter 342786 !
submitter 342788 !
submitter 345194 !
submitter 350614 !
submitter 360360 !
submitter 380740 !
submitter 306183 !
submitter 331398 !
submitter 331646 !
submitter 340071 !
submitter 348083 !
submitter 348537 !
submitter 350305 !
submitter 379118 !
submitter 266401 !
submitter 266428 !
submitter 288221 !
submitter 321230 !
submitter 322161 !
submitter 322225 !
submitter 322319 !
submitter 322335 !
submitter 322356 !
submitter 322437 !
submitter 324179 !
submitter 324849 !
submitter 325922 !
submitter 358558 !
submitter 378892 !
quit

Revision history for this message
Simon J. (simonj) wrote : [need-packaging] TV-Browser
description: updated
Revision history for this message
Fabian Frank (schnitz) wrote :

Because I was told in #motu that uploading to REVU just before the gutsy release shouldn't be done i've built a tarball of everything dput would upload. You cand find that here:
http://www2.ba-horb.de/~i06015/tvbrowser_deb.tar.gz

I'd be glad to recieve any feedback and/or mentoring.

Revision history for this message
Fabian Frank (schnitz) wrote :
Revision history for this message
Fabian Frank (schnitz) wrote :

package for hardy uploaded to revu
http://revu.tauware.de/details.py?upid=405

Revision history for this message
Daniel Holbach (dholbach) wrote :

- packaging changes contains debian/patched/10_start_script_working_dir.dpatch and deployment/linux/tvbrowser.sh - broken unpatch rule?
- debian/copyright incomplete, no authors and no copyright holders
- some files don't contain copyright header, but there's at least ./txt/LICENSE.txt

Not buildable without user interaction:

Unpacking sun-java5-bin (from .../sun-java5-bin_1.5.0-13-0ubuntu1_amd64.deb) ...

sun-dlj-v1-1 license could not be presented
try 'dpkg-reconfigure debconf' to select a frontend other than noninteractive

:-(

Upstream issues, probably worth talking to the author:
- ./images/themes/tango looks like copied from tango, is there no possibilty to use the icons we have in the archive already? (not mentioned in copyright either)
- ./deployment/x11/autom4te.cache probably not necessary in the shipped tarball

Revision history for this message
Daniel Holbach (dholbach) wrote :
Revision history for this message
Daniel Holbach (dholbach) wrote :

Bumping back to Triaged for now. Set back to 'In Progress' once a new revision has been uploaded.

Revision history for this message
Daniel Hahler (blueyed) wrote :

I've talked to Fabian and he acknowledged that I can take over this package.
 - ./images/themes/tango is not exactly copied: it includes several files which are not in the tango-icon-theme(-extras) package, e.g. document-edit.png; also some files are different. I will talk to upstream about this though.

I've completed debian/copyright and changed it to use the proposed format at http://wiki.debian.org/Proposals/CopyrightFormat.

The new package has been uploaded to REVU.

Revision history for this message
Daniel Hahler (blueyed) wrote :

There are license issues, and I'm in the process of solving them together with upstream:
 - there are quite a lot of .jars used/included without source,
   license, and/or copyright!
   According to upstream those are all GPL/Apache, so I just need to work out what is what.

 - Incompatible licenses!
   At least src/tvbrowser/core/ValueCache.java and lib/junit.jar are
   licensed under "Common Public License Version 1.0" which is
   incompatible to GPL according to
   http://www.gnu.org/licenses/license-list.html!
   Upstream is working on fixing the ValueCache conflict and JUnit is only used for tests, so it looks like I have to create a dfsg-repacked source.

 - According to http://www.gnu.org/licenses/license-list.html the
   CC-BY-SA used by tango is incompatible to GPL, but it says
   so for 2.0 (we have 2.5 here) and "software or documentation",
   not "artwork".
   I'm not sure about this, but also http://people.debian.org/~evan/ccsummary says that things licensed CC-BY-SA should not get uploaded (according to debian-legal). Obviously we (and Debian) have tango-icon-theme though..!?
   I don't know what to do about this..

Anyway, the package is updated at http://revu.ubuntuwire.com/details.py?package=tvbrowser

Revision history for this message
Daniel Hahler (blueyed) wrote :

A package is now available at http://revu.ubuntuwire.com/details.py?package=tvbrowser - this includes the new upstream release, where all license issues should have been addressed.
The packaging is available on https://code.edge.launchpad.net/~blueyed/tvbrowser/ubuntu - feel free to branch and improve from there, or just leave a comment on REVU.

Revision history for this message
Maduser (maduser) wrote :

Intrepid FeatureFreeze is in 5 days. Is there hope that we see tvbrowser in 8.10?

Revision history for this message
Daniel Hahler (blueyed) wrote :

A new package is up for review at http://revu.ubuntuwire.com/details.py?package=tvbrowser now.

Revision history for this message
Daniel Hahler (blueyed) wrote :

The package has now been approved in REVU.

I've subscribed motu-release to get a FreezeException for this new package.

Because it's a new package, no other packages depend on it and it's a useful program, which I'd like to see in Intrepid.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: FFe: [need-packaging] TV-Browser

Part of the point of Feature Freeze is that the archive admins who do New review need to move on to other work later in the release cycle. What makes it so important we add to their workload for this particular package?

Revision history for this message
Lydia Pintscher (lydia-pintscher) wrote :

Summarising my conversation with Scott on IRC:
TV-Browser should go in because it is the only good TV schedule program on Linux I know that has German TV stations. It has a few very nifty features like favourite show lists, reminders, recording using external programs and integration of IMDB and Google search. It is widely used as far as I can tell.
Besides that it should have been included in Ubuntu a few releases ago but was not due to licensing issues which seem to be fixed now.
There was an unofficial repository for it which does not offer updates since hardy and I assume this will not change in the near future.

Thanks for taking this into consideration.

Revision history for this message
StefanPotyra (sistpoty) wrote :

+1 from me, based that it's still very early in FF, and that there is one advocation (apart from the self-advocation :P) on revu, so it looks like the package seems to be in good shape already.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Ack from me. Approved by motu-release. Please keep in mind that there are no guarantees that the archive admins will have time for New processing for packages uploaded post-FF.

In addition to the reasons given by others, I can see that upstream invested a lot of time in improving the licensing of the package and I would like to see that kind of behavior encouraged.

Revision history for this message
Fabian Frank (schnitz) wrote :

I would really love to see this one in the next Ubuntu release. +1 also from me. Thanks for continuing the work on this package Daniel!

Revision history for this message
Cesare Tirabassi (norsetto) wrote :

Package was rejected by archive for copyright problems:

https://lists.ubuntu.com/archives/ubuntu-archive/2008-September/021524.html

Revision history for this message
Daniel Hahler (blueyed) wrote : Re: [Bug 102910] Re: FFe: [need-packaging] TV-Browser

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Cesare Tirabassi wrote:

> Package was rejected by archive for copyright problems:
>
> https://lists.ubuntu.com/archives/ubuntu-archive/2008-September/021524.html

I've notified upstream about this and they're looking into it (e.g. if
libraries are included already in Ubuntu).

Jonathan wrote:

> Also full copies of the GPL and LGPL are important.

Isn't it enough to refer to the ones provided by Debian/Ubuntu? Or does
this only hold for debian/copyright and the source tarball needs them
anyway?

- --
http://daniel.hahler.de/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFIzuekfAK/hT/mPgARAjA2AKCSpNqGWRyU31zMWDBquWGWenmtHACdGQNT
6LMrPeRvRSpS1SDSXp3v5qk=
=D00I
-----END PGP SIGNATURE-----

Revision history for this message
Cesare Tirabassi (norsetto) wrote : Re: FFe: [need-packaging] TV-Browser

The tarball should contain a verbatim copy of the licenses (http://www.gnu.org/licenses/gpl-howto.html).
This is really an upstream problem though, which I believe our archive admins are trying to enforce.

Revision history for this message
Luca Falavigna (dktrkranz) wrote :

I'm unsubscribing motu-release for now, waiting for action by upstream.

Revision history for this message
Daniel Hahler (blueyed) wrote :

JFI: I've updated the package in my PPA to the 2.7.1 upstream release.
If you want to use it: https://launchpad.net/~blueyed/+archive?field.name_filter=tvbrowser

Changed in debian:
status: Unknown → Fix Released
Daniel Hahler (blueyed) on 2009-05-23
summary: - FFe: [need-packaging] TV-Browser
+ [need-packaging] TV-Browser
Daniel Hahler (blueyed) on 2009-07-21
Changed in ubuntu:
status: Confirmed → Triaged
summary: - [need-packaging] TV-Browser
+ [needs-packaging] TV-Browser
Revision history for this message
Benji (benjim) wrote :

I'd like to bring up this topic again... are there any chances to include tvbrowser to the ubuntu respositories?

Revision history for this message
papukaija (papukaija) wrote :

There haven't been any comments on this bug since ages so I'm not sure if the licensing issues are solved.

Aditya V (kroq-gar78) on 2012-03-19
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.