Changelogs not being uploaded to changelog server

Bug #1001609 reported by Brian J. Murrell on 2012-05-19
206
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

The changelog from the update to 3.2.0-5ubuntu0.12.04.1 is missing from the changelog server. The following URLs 404 for me:

http://changelogs.ubuntu.com/changelogs/pool/universe/p/pidgin-otr/pidgin-otr_3.2.0-5ubuntu0.12.04.1/NEWS.Debian
http://changelogs.ubuntu.com/changelogs/pool/universe/p/pidgin-otr/pidgin-otr_3.2.0-5ubuntu0.12.04.1/changelog

If users are to be informed of what they are updating instead of just blindly accepting updates they need to be published so that the update tool can report them.

ProblemType: Bug
DistroRelease: LinuxMint 12
Package: pidgin-otr 3.2.0-5
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Sat May 19 07:57:48 2012
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: pidgin-otr
UpgradeStatus: No upgrade log present (probably fresh install)

Ted (tedks) wrote :

I'm marking this confirmed because the changelog isn't up, and sometimes, for a variety of packages, it takes a little while for the changelogs server to be updated.

However, this isn't a bug in pidgin-otr.

affects: pidgin-otr (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Confirmed

Thanks for reporting this. Since this is a general problem, there is no need to file a bug report for every package. I've marked the others as duplicates.

summary: - changes not on changelog server
+ Changelogs not being uploaded to changelog server

Except that none of the previously missing entries is actually there (yet) and more continue to become missing. How difficult could this to be resolve? Certainly this must qualify as "low hanging fruit".

smiki (micouk) wrote :

I just want to emphasize the fact that this bug concerns not just some but ALL packages. Update-manager is not able to fetch any changelog, but provides a working (!) link to the changelog (as Bug #1004925 states)

I have 5 physical machines with various Ubuntu installations (lucid to precise) in different locations and all are affected.
If any log or test needed to be done to help troubleshoot this bug please let me know.

Alex Selby (launchpad-archduke) wrote :

It appears no changelogs have been uploaded to the changelog server since 4 May 2012.

I have a 12.04 at home that does receive the changlogs, for the same updates that my work computer (also 12.04) does not receive. If one of them is receiving them, wouldn't that mean there have been changelogs uploaded?

IMBJR (imbjr) wrote :

Confirmed. Not seeing any change logs in Update Manager in Xubuntu 12.04.

/me twiddles his thumbs with over a hundred updates to do but no
changelogs so that he can understand what's getting fixed in the updates.

I mean really. How long could it possibly take to fix what has got to
be some internal (i.e. infrastructure) error that should be correctable
without much red tape?

I just installed a VM (virtualbox) with 12.04 x64, and it does the same thing... but when upgrading a 11.10 x64 to 12.04, it does not. I didn't see a difference in /etc/apt/ . Is there somewhere else I should be looking for a explanation/fix ?

Jeremy Bicha (jbicha) on 2012-06-07
affects: ubuntu → launchpad
William Grant (wgrant) wrote :

This is managed by Ubuntu. It's unrelated to Launchpad.

affects: launchpad → ubuntu

On 12-06-07 06:08 PM, William Grant wrote:
> This is managed by Ubuntu. It's unrelated to Launchpad.
>
> ** Project changed: launchpad => ubuntu

Pass the hot potato.

I wonder if somebody will actually hold on to it at some point and take
ownership of this problem.

affects: ubuntu → extrace-changelogs
affects: extrace-changelogs → ubuntu
Doug McMahon (mc3man) wrote :

Just to note - around 5/19 there were some severe issues with some of the Canonical servers, most notably the Main & Us servers. That was fixed by the 22rd or so, but a least here that also when I stopped getting changelogs for updated/upgraded packages in update-manager & synaptic with only a couple of rare exceptions
(the latest apport* in quantal, ( Fri, 01 Jun 2012), do have the changelogs for some reason...

J B (scottie) wrote :

good thing we get the link though.
might even load faster than the changelog if the browser's already open.

though having the changelog there in update manager is still more intuitive.
been missing it for several update days already.

tags: added: precise quantal
Nicholas Skaggs (nskaggs) wrote :

This issue is being actively worked. The bug is dependent on getting new hardware in place for the server hosting these logs. As soon as it's fixed, the logs should be up and running again. The IS team has been asked to update the bug once the hardware is in place.

apsaras (c-launchpad1) wrote :

Thanks for the update Nicholas. Can you point to where you got this information, or was it "pers comm"? What is the "IS team". Thanks.

Doug McMahon (mc3man) wrote :

This seems fixed today, at least as seen on a 12.10 dev install

Running Ubuntu 12.04 LTS and I see it fixed here with today's updates, as well.

Ditto. Thanks much!

dino99 (9d9) wrote :

yes its fixed on Quantal now.

Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers