part of the website not up-to-date

Bug #237995 reported by Soul-Sing on 2008-06-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Website - OBSOLETE
Wishlist
Alan Pope 🍺🐧🐱 πŸ¦„

Bug Description

Unfortunately it's quite time consuming to make new screencasts, but it's certainly something that we need to do.

Changed in ubuntu-website:
assignee: nobody → alanpope
status: New → Confirmed
Matthew East (mdke) on 2008-06-07
Changed in ubuntu-website:
importance: Undecided → Wishlist
IKT (ikt) wrote :

It might just be me, but it appears that this project is dead in the water, is this correct or are there things happening that I just don't see ?

Thanks for the comment. What would you like to see on the screencasts site specifically?

IKT (ikt) wrote :

At the moment all the screencasts are in one big flash like media player, there is a playlist on the right but I can't make out what any of the titles say, in effect it has a horrible ui, the last update suggests: By Alan Pope at 2008-11-04 15:58 it hasn't been updated in over half a year, and the first video is from 2007, I can't tell if any of the videos are relevant.

I guess I was expecting something more like this:

http://www.youtube.com/watch?v=x_R_JSiupzo

updated on a more frequent basis, but if the screencast site is just for the basics, then I think just a better menu would be a lot better.

Matthew Nuzum (newz) wrote :

Someone in the community will have to take ownership of this project if it will move forward. I don't think it's horrible to have the site still there as the content is generally as valid now as it was when it was fresh. Of course new content would be even better.

Changed in ubuntu-website:
status: Confirmed → Won't Fix

The screencast website could run on the WordPress platform (GPL). WordPress has a 'podcast' plugin which makes it easy to set up multimedia RSS feeds and has a flash media playing interface which supports the creation/display of playlists. Each screencast can be tagged/categorized and WordPress also has a search function so that users can find screencasts specific to their need.

We can also embed applet code in WordPress posts so that we have the option of using third party hosting/streaming services such as Archive.org (Theora friendly with automated transcoding), blip.tv (Theora friendly with transcoding and cross-posting), Vimeo, and/or YouTube ;-) Basically, any screencast on the web can be posted on the website, allowing for distributed creation of media assets.

I will gladly install WordPress at the screencasts.ubuntu.org domain so that this community initiative may continue. All we need is a PHP enabled webspace and one MySQL database. If screencasts.ubuntu.org cannot meet these requirements then I will donate one year of hosting on a shared hosting provider to facilitate this important educational portal.

Changed in ubuntu-website:
assignee: Alan Pope (popey) → Brylie (brylie)
status: Won't Fix → Confirmed
EmmaJane (emmajane) wrote :

Brylie,

I don't think the container for the screencasts is the problem... I think it's the time involved in creating screencasts. Do you have any prepared that could be added to the site? I'd love to help you get them added if you're ready to do that.

regards,
emma

The current site appears to be powered by Drupal, which is very robust but a bit difficult for a decentralized community to administrate. This might be partly to blame for the lack of content updates, although registered members can be given permission to submit content nodes.

WordPress also has user access levels. Contributor status can be the bestowed upon any active member while Publisher and Editor statuses can be reserved for members who are more frequently active. It is very easy for administrators to install plugins, themes, and to update the core site.

I am not at all proposing that I be the sole administrator. I would simply like to implement WordPress and step aside as members contribute content and establish the community access and content structure. I offer to have this site migrated and functional within 3 days of gaining administrative access.

EmmaJane (emmajane) wrote :

It is a Drupal site and the videos are hosted on Blip.tv. But I don't think that Drupal is what's getting in the way of videos being posted. I think what's getting in the way is that we've NOT had submissions. Not on LP, not in the comments, not on the mailing list, not in the IRC channel... There is currently some momentum in the documentation mailing list and hopefully we will see some new videos generated from that energy. In the mean time though, I really don't think it's appropriate to create a new Web site. First we need the content and then we can change the container if it truly is getting in the way.

I didn't find registration link on the Drupal container. That might get in the way of users directly contributing to the site.

There aren't instructions on how one can contribute screencasts to the Drupal site on the ScreencastTeam wiki page.

There are already hundreds of Ubuntu screencasts on the web. Why not start indexing/linking to some of those? If we can open the door to user registration and implement some permissions with a possible moderation queue, users might be encouraged to submit to the site rather than using Launchpad or the wiki, or irc, &c as a proxy.

I use to record screencast about applications, tutorials and some tips,
always running Ubuntu. I would love to contribute with my videos, but the
main problem is that the sound and comments are always in Spanish. Maybe we
can use subtitles in English...

It would be great! I usuarlly upload my videos to my Vimeo/Youtube personal
channel and also publish some screencasts in the Genbeta.com's Yooutube
channel (I'm a Genbeta editor). Here you can see some:

   -
   http://www.youtube.com/results?search_query=guillermo-latorre&search=tag

Regards,
Guillermo

On Thu, Aug 20, 2009 at 5:35 AM, Brylie Oxley <email address hidden> wrote:

> I didn't find registration link on the Drupal container. That might get
> in the way of users directly contributing to the site.
>
> There aren't instructions on how one can contribute screencasts to the
> Drupal site on the ScreencastTeam wiki page.
>
> There are already hundreds of Ubuntu screencasts on the web. Why not
> start indexing/linking to some of those? If we can open the door to user
> registration and implement some permissions with a possible moderation
> queue, users might be encouraged to submit to the site rather than using
> Launchpad or the wiki, or irc, &c as a proxy.
>
> --
> part of the website not up-to-date
> https://bugs.launchpad.net/bugs/237995
> You received this bug notification because you are a member of Ubuntu
> Screencast Team, which is a direct subscriber.
>

I also don't believe there is any major reason for moving away from Drupal. All the necessary functionality is in Drupal already, including the RSS feeds which are in use in various places such as Miro.

Emma spent some time creating a fresh new look for the site (also on Drupal) which you can see here:-

http://screencasts.popey.com/

The reason the sign up / register page is missing is because there was no need for it to be there. Initially it was there and people could comment on videos. Most of the comments fell into one of four categories:-

* Spam (which is less of an issue in newer versions of Drupal)
* 'Thanks for this video'
* Technical support questions which don't belong on a screencast site
* Questions regarding when new videos would be available :S

The main intention of the screencasts site was to create original content, not just link to existing youtube videos. I wanted to encourage people to make high quality informative videos for Ubuntu. I didn't want to have a load of links to external sites and videos for numerous reasons:-

* We don't control the content so can't control the quality of those submitted videos
* Linking to youtube (for example) videos doesn't give the user the ability to download the videos using RSS (easily)
* Videos are not downloadable from youtube in a format which Ubuntu can play out of the box
* We are unable to put subtitles (and thus translated subtitles) on 3rd party youtube video sites.

I thus selected blip.tv simply because they will host and serve up .ogv files as well as flash and other formats suitable for other platforms. They can do the RSS feeds well. Before I uploaded anything to blip.tv the amount of work that I put in to make _one_ screencast available was tremendous. From the recording and editing to the video encoding and uploading multiple versions, and page creation. it's a very time consuming process. Using blip.tv removed the encoding, uploading of multiple versions and page creation. However it's not perfect, at the moment it's just a big flash blob. I'm working on that.

Whilst I am not dismissing linking to other videos on the site, I'd rather it wasn't the main focus. The big issue is getting people to create high quality screencasts for the team.

I have spent a little time updating some of the screencast pages on the wiki to tidy them up and have them make more sense. I still have many more pages to update/revise, and have also been tinkering with the drupal site behind the scenes.

Switching back to me as I am already working on it.

Changed in ubuntu-website:
assignee: Brylie Oxley (brylie) → Alan Pope (popey)

I have removed the flash blob for now, and am putting the site back to how it looked pre-blob.

"Most of the comments fell into one of four categories:-

* Spam (which is less of an issue in newer versions of Drupal)
* 'Thanks for this video'
* Technical support questions which don't belong on a screencast site
* Questions regarding when new videos would be available :S"

We shouldn't censor ourselves on account of spambots. What problem is there with viewers showing appreciation? A technical support disclaimer can direct people to the forums. If we syndicate publicly created videos, there would be newly created content on a regular basis. Syndication would not rule out the production of quality videos, it would just broaden the content base.

The more we let people participate, the more they will participate.

"I didn't want to have a load of links to external sites and videos for numerous reasons:-

* We don't control the content so can't control the quality of those submitted videos
* Linking to youtube (for example) videos doesn't give the user the ability to download the videos using RSS (easily)
* Videos are not downloadable from youtube in a format which Ubuntu can play out of the box
* We are unable to put subtitles (and thus translated subtitles) on 3rd party youtube video sites."

The desire for control might be an underlying issue as to why the screencasts site has not taken off. The reason that the Ubuntu forums and wiki are so dang great is that they are egalitarian/community controlled. I realize that Drupal is a bit tricky to administrate, but roles can be created for varying levels of access/control right?

I'm not advocating primarily for youtube. I don't much care for youtube. I had troubles playing youtube videos as well. I am glad that you are advocating for Archive.org and Blip.tv (and not dismissing other platforms), as those platforms are doing some great things. However, lets not limit the community's options based on the lack of specific features, people are what we need.

The more people we have participating, the less the burden will fall on one person.

"Before I uploaded anything to blip.tv the amount of work that I put in to make _one_ screencast available was tremendous. From the recording and editing to the video encoding and uploading multiple versions, and page creation."

Different workflows will have different time requirements and will produce varying quality, right? Here is a screencast of a guy explaining GTKRecord My Desktop:
http://video.google.com/videoplay?docid=1849528422672935564&ei=EyyNSqTBCp6yqgKMkPyACA&q=gtk+record+my+desktop&client=firefox-a

"I have spent a little time updating some of the screencast pages on the wiki to tidy them up and have them make more sense. I still have many more pages to update/revise, and have also been tinkering with the drupal site behind the scenes."

Thank you very much for your time and effort on this project Alan! This is an important initiative for community end-user training and knowledge dissemination. I am glad that we have a dedicated and experienced webmaster.

Also, great work on the look and feel of the site EmmaJane. Your design is clean and user-friendly, and brown :-)

Download full text (4.3 KiB)

"We shouldn't censor ourselves on account of spambots. "

Sure, but there's a finite amount of time one has for tagging and deleting spam. The install of drupal on the site is quite old, and has limited spam protection, so this will be resolved once we migrate to a newer version.

"What problem is there with viewers showing appreciation?"

I didn't say there was. I was merely grouping together at a high level the types of comments left on the site. However as the site doesn't support OpenID, and doesn't use the same logon as Ubuntu Forums, launchpad, brainstorm or any other Ubuntu resource I _was_ reluctant to have a whole new user database just for people to say "Thanks". It seems overkill. Yes we should allow feedback and yes there should be more/better ways to communicate, and yes I believe people should be able to leave comments on videos, it's just that the implementation in the version of Drupal we had at the time wasn't great.

"A technical support disclaimer can direct people to the forums."

I agree to some degree. A link under each video saying 'Discuss this in the forums' which takes you to (for example) screencasts.ubuntuforums.org would be great. That way people could use their existing logons, and we can use the existing infrastructure. Would this mean in addition to or instead of comments on the site though?

"If we syndicate publicly created videos, there would be newly created content on a regular basis. Syndication would not rule out the production of quality videos, it would just broaden the content base."

There's already a means for people to get publicly syndicated videos via whatever their favourite video site is, whether it's Miro, google video, youtube, blip.tv, vimeo or whatever. There's no value-add for us if all we're doing is pulling in videos from elsewhere. Indeed this feature already exists and existed before screencasts.ubuntu.com in the form of www.ubuntuvideos.com which used to pick out videos and syndicate them. There is no point us just replicating that.

"The more we let people participate, the more they will participate."

That I agree with. How we do that, is another matter.

"The desire for control might be an underlying issue as to why the screencasts site has not taken off."

That's a very valid concern.

"The reason that the Ubuntu forums and wiki are so dang great is that they are egalitarian/community controlled. I realize that Drupal is a bit tricky to administrate, but roles can be created for varying levels of access/control right?"

I dont think the admin of drupal is the main issue. It's creating the screencasts, encoding them in nice formats and uploading them. I'm the only one who has ssh access to static.screencasts.ubuntu.com so I had to upload them there. I am the only admin on the drupal page so I could create the pages. However if others created videos I did that work. Fact is not many people created videos.

Yes, it's not optimal to have one person having access like that, and I'm happy to give other access to the drupal site (once we upgrade it) and also to request shell access to the backend server, but I can't action that because that's canonicals domain - it being a canonical host...

Read more...

Richard Querin (rfquerin) wrote :

On Thu, Aug 20, 2009 at 9:33 AM, Alan Pope <email address hidden> wrote:

>
>
> In summary I want to revive the screencasts project, and want to ensure
> we maintain quality whilst we bring more people on board.
>

Couple of points:

1. I realize the recording procedure is well thought through, but it is very
rigid. Using xVidcap, recording video and audio separately.. etc, just isn't
how I do screencasts. Perhaps this is part of the reason that contribution
is low. Maybe a lower barrier of entry (yes, you may sacrifice a bit of
quality control) would improve participation.

2. With regards to quality, perhaps these things should be curated in a way.
So I produce a screencast meeting certain requirements (run in a VM with a
stock Ubuntu desktop install, specific full screen resolution etc.). Then
someone (the curator/editor) then takes those screencasts and adds the title
screen and carries out the encoding into different formats.

I realize point 2. will likely not sit well with the whole community, diy
ethos, but this might lower the barrier to entry signficantly as far as
actual screencast contributions go.

Blender for instance could make this last step (adding the title screen and
encoding) quite easy (although cpu-intensive).

Dunno, it's just a thought. I realize how much effort goes into producing
screencasts (It's been a month since my last Inkscape screencast!). Maybe
doing some things to try and lower that bar a bit would help.

RQ

To be honest I don't use xvidcap anymore, it's just too unreliable. I tend to use recordmydesktop. The reason for doing the separate audio and video was (2 years ago) mostly as a result of a limitation in the software. In that recordmydesktop would (and still does sometimes) lose sync between audio and video during the recording.

The procedure on the site was really initially a 'how I do it', not a 'you must do it like this', but I can see how it can be seen that way.

The second point you make was pretty much the way I'd liked it to go. Personally I have a dual boot system with one environment pretty much pristine, just for screencasting.

Ideally I'd like to scrap the pages that we have about "how-to" and start a fresh. I'd value your input for the way you do your screencasts.

https://wiki.ubuntu.com/ScreencastTeam/RecordingScreencasts is the main page we link to, and is the one that needs a bullet to the head IMO. Opinions?

Richard Querin (rfquerin) wrote :

On Thu, Aug 20, 2009 at 10:55 AM, Alan Pope <email address hidden> wrote:

> To be honest I don't use xvidcap anymore, it's just too unreliable. I
> tend to use recordmydesktop. The reason for doing the separate audio and
> video was (2 years ago) mostly as a result of a limitation in the
> software. In that recordmydesktop would (and still does sometimes) lose
> sync between audio and video during the recording.

I just bought a Snowflake mic, and I think sync may now be even more of an
issue for me since RMD will not use it properly and I will have to record on
a separate app at the same time as RMD. (Oh lord how long will it be until
the 2.6.31 kernel becomes available - apparently that fixes it ;) ). But
like you said, even up to now, we've had sync issues, but they are
relatively slight over the course of even a 30min screencast.

> The second point you make was pretty much the way I'd liked it to go.
> Personally I have a dual boot system with one environment pretty much
> pristine, just for screencasting.

Yes, running it in a VM session always seemed like an invitation to
performance issues for me before I got my laptop (my desktop is a 6 yr old
P4 and I'm not sure it handle the recording in a VM that well). Dual booting
I think would be the optimum way.

>
> Ideally I'd like to scrap the pages that we have about "how-to" and
> start a fresh. I'd value your input for the way you do your screencasts.

While that seems to be changing lately (with html5, ogg and blender all
coming more and more onto our radar) for us, up to very recently it's been
RecordMyDesktop and a series of mencoder scripts (and for me, a run through
Audacity too). For sure it could be simplified and standardized though. The
software has matured substantially since we started IMO. Right now we are
offering downloadable ogg, streaming ogg (if you're using FF3.5), and
streaming flv as a fallback for other browsers. We're really hoping for more
streaming ogg support since that takes away our need to transcode to flash
(for time reasons along with the freedom aspect).

And while I've still got bugs to work out, I'm hoping to move to Blender for
the post production of my screencasts (editing, transcoding etc.). Right now
I can import the ogv's that RMD generates, edit everything up, but I'm not
entirely happy with the output files.. it needs some tweaking ;)

RQ

Ok, I have cleared down all the spam (approximately 1500 spam comments), and approved all the ham (approx 50) dating back approximately a year. So that's on average over 100 spam a month and 4 ham per month.

I have requested that drupal on lanthanum (the box running screencasts.ubuntu.com) is updated via the Ubuntu Request Tracker. Ticket 7414 if anyone wants to track it.

Next I'll work on sorting the creating screencasts page on the wiki, whilst updating the demo site made by Emma, and once drupal is updated, a further request to get the theme updated.

Recording screencasts.. hah, that's way down the list ;)

OK, I can't find the "Ubuntu Request Tracker" or the "Canonical Request Tracker". Can you post a link? Anyway I wanted to tack a request onto the upgrade ticket:

1) Install the Drupal Shell if it's not already installed:
http://drupal.org/project/drush

This tool is simply wonderful :-)

I have an idea for a possible workflow to incorporate videos onto the site easily. It would require several modules (Drush makes installation much easier):
First for SPAM:
Akismet, reCaptcha

Second for auto-generation of posts (as seen above):
CCK, Views, FeedAPI, and Feed Element Mapper

Third, for admin approval and public voting:
Flags, VotingAPI, FiveStar

Here's the idea:
A) Subscribe to the blip.tv RSS feed for the 'ubuntu' and/or 'ubuntuscreencasts' tags (others if desired). Follow the video to map the proper fields from blip.tv to the Drupal node fields. Create a private page which lists these items, for users given moderator privelages.

B) Install the Flag plugin and enable a flag similar to "import" or "accept" on views containing videos so that they can be screened to ensure quality standards and license compatibility. When a moderator clicks the flag an action is triggered to scan the blip.tv page, snag the download link, download the video locally and attach it to the node.

C) "Publish" the node to the public area of the site to allow for viewing, voting, &c

http://drupal.org/project/akismet
http://drupal.org/project/cck
http://drupal.org/project/feedapi
http://drupal.org/project/feedapi_mapper
http://drupal.org/project/fivestar
http://drupal.org/project/flag
http://drupal.org/project/recaptcha
http://drupal.org/project/views
http://drupal.org/project/votingapi

>OK, I can't find the "Ubuntu Request Tracker" or the "Canonical Request Tracker". Can you post a link?

https://rt.ubuntu.com/Ticket/Display.html?id=7414

user/pass = ubuntu/ubuntu to view only.

> Anyway I wanted to tack a request onto the upgrade ticket:
> 1) Install the Drupal Shell if it's not already installed:
> http://drupal.org/project/drush

I'd not heard of it before and will certainly take a look at it, it looks very interesting. Thank you.

One thing to bear in mind is the Canonical hosted Drupal instance doesn't give us access to core Drupal files, so that includes updates to Drupal core, modules, themes and so on. We _have_ to pass requests via the Canonical IS team, and that includes requesting modules to be installed, and any other additional components. All code hosted on Canonical servers must be security reviewed for example.

Changed in ubuntu-website:
status: Confirmed → In Progress
mdgrech (mdgrech) wrote :

Can you please unsubscribe me from this thread.

On Tue, Aug 25, 2009 at 3:45 PM, Alan Pope <email address hidden> wrote:

> http://screencasts.ubuntu.com/2009/05/25/Ubuntu_Live_Installer_Boot_Screen
>
> It's a start :)
>
> --
> part of the website not up-to-date
> https://bugs.launchpad.net/bugs/237995
> You received this bug notification because you are a member of Ubuntu
> Screencast Team, which is a direct subscriber.
>

IKT (ikt) wrote :

!

I'm just listening to the ubuntu uk podcast and I heard the comment in this part of the website got mentioned!

Just thought I'd like to say the new look is fantastic and have already linked quite a few people to the new videos :)

Fantastic job! I hope to submit some screencasts in the future :)

Chris Johnston (cjohnston) wrote :

No activity on this bug in about a year and a half. Unless there is active work on this bug I'm going to close it again as wont fix.

Soul-Sing (soulzing) wrote :

http://screencasts.ubuntu.com/

Commands Used in this Episode
gpg --decrypt yourTextDoc.txt
gpp -- clearsign yourTextDoc.txt
Links Used in this Episode
http://keyserver.ubuntu.com:11371
http://keyserver.ubuntu.com
htps:launchpad.net/codeofconduct

please fix the syntax errors as: htps, /gpg -- clearsign/

Adolfo Jayme (fitojb) on 2013-05-01
no longer affects: ubuntu
Anthony Dillon (ya-bo-ng) wrote :

It seems this site is no longer in use. May this bug now be closed?

Changed in ubuntu-website:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.