[scopes] should Dash rotate

Bug #1465331 reported by kevin gunn on 2015-06-15
224
This bug affects 46 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Michał Sawicz
Ubuntu UX
Medium
Paty Davila
unity8 (Ubuntu)
Medium
Michael Zanetti

Bug Description

Shell rotation has now been released. On the phone, it feels a little odd that dash doesn't rotate.
Could we consider making dash into a rotating app ?

------ UX Comment ------

Orientation design: from portrait to landscape presentation can serve as a guide for the agreed design direction. (https://docs.google.com/presentation/d/14hMDaQDcGyBnMO7UYI76hfJRPbGME4tN5Wm70O3z0ds/edit#slide=id.ga333e0b9a_0_163

Specs will be posted/updated as soon as they are available.

Related branches

Oliver Grawert (ogra) wrote :

having only one app open and "flicking" between the app and the dash makes you alweays end up in the scopes manager by design now, there is no way to get back to the app if you once swiped to the dash... (this also happens a lot to me by accident when more than one app is open, but there it is less significant)

*if* the dash needs to stay that way, please leave at least the input gestures rotated so we don't kill usability...

Mitchell (curious-mitchell) wrote :

I agree with Olivier, and add that this doesn't appear to be an intelligent desgin choice. On the phone, it means I need to rotate it portrait again anytime I wish to use a scope - this is a huge impact on usability. On the tablet, this means I need to rotate the tablet to landscape anytime I use a scope - this also hugely impacts usability. I fail to see any reason why each screen-size has the scopes locked to a particular orientation - currently this seems an arbitrary design choice. I have had various Android devices doing similar things, and it's usually the first ui element I disable/change. Please consider making the scopes rotate with the rest of the system. Thanks.

Mitchell

Winael (vinzjobard) wrote :

Hi,

I use a lot my phone in landscape mode (to watch movies, to use GPS in car and music app in car, or to use the large keyboard. Each time I come back to the scope I need to take my phone in portrait mode that totally uncomfortable specially when I'm driving.

Plz allow the scopes to rotate as well, we really need this function.

Cheers

Phil Hughes (phil-hughes) wrote :

I would agree that this is poor design:

- I prefer to use my tablet in portrait mode, which means that I have to physically rotate the device every time I go to the dash
- there appears to be no way to dismiss System Settings, except by slow swipe from right and then closing it
- why is the lock screen on a tablet now similar to a desktop (no swipe to unlock, but a Username and Password prompt)? This makes sense only if the device is using a physical keyboard.

summary: - should Dash rotate
+ [scopes] should Dash rotate
Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Paty Davila (dizzypaty)
Randall Ross (randall) wrote :

Here's a basic design tenet we could and should fall back on:

"Everything that is running shall obey the wishes of the owner. "

If the owner wishes to hold and view her device in landscape orientation, then the OS should respect that choice and ensure that the UI and all running programs match that expectation. If the owner then wishes to hold and view her device in portrait orientation, then the OS should respect that choice and rotate the UI and all running programs to match.

Where other phones/devices get in "trouble" is when they cease to respect their owner. We, Ubuntu, should not fall into that trap.

wayne (wayne-n) wrote :

Does my opinion matter? If it does, I agree with Randall. If I wanted a phone to make me it's slave, I would buy apple or android. When i decided to buy my nexus 4, I was told that I would be able to install ubuntu on it one day and that it would be 'exactly like ubuntu desktop and that I can do whatever I want it to do"

It would cause me frustration to think that I had less options than a fruity phone.

How about this: give the ubuntu phone *full freedom* as default. Then, if you want to disable the scope from conveniently flipping with your needs, you can do so. Or, if someone is going to get in trouble for alllowing too much freedom, then you could make the custom install lock it the way you want and then have a setting in the appearance area that lets you unlock that feature.

Just don't restrict me. It cramps my style. Makes me grumpy-pants.

By the way, thanks to all of you for making my life better. That's true.

Joe Liau (joe) wrote :

How about each scope/program having the option of rotation or not, as well as an option to globally apply these options?

I agree that the device should obey, and be accessible at the time in question.
i.e. I might want it to rotate at this instant, but not necessarily the next time I access it.

Or, what if I wanted everything to be upside down? I think it important to consider this type of freedom.
We cannot assume the way that something is used, or force people to use it a certain way.

Daniel d'Andrada (dandrader) wrote :

Besides the lack of a design decision, there's a very practical reason why Dash doesn't rotate at the moment: it's slow as hell to relayout itself when its window gets resized. So it's better to not have a feature than to have a badly done one. That's specially true for the tablet where a rotating dash makes all the sense.

Sure this performance issue must be fixed, but it hasn't been a priority so far.

Randall Ross (randall) wrote :

@dandrader: Is there a bug filed already for the slow rotate issue?

On 06/08/15 14:44, Randall Ross wrote:
> @dandrader: Is there a bug filed already for the slow rotate issue?
>

I'm not sure. Probably not... And the more accurate term would be "slow
to resize". You can see that when you have unity8 in desktop mode (where
you have non-fullscreen windows lying around, like unity7) and you try
resize the Dash window.

Paty Davila (dizzypaty) on 2015-08-07
description: updated
Changed in ubuntu-ux:
status: Triaged → In Progress
Joe Liau (joe) wrote :

would you be able to open the google doc so that we can view it? Right now it is private

Thanks

Mateo Salta (mateo-salta) wrote :

Going between a app and scope while in landscape causes the whole ui to rotate, and makes it very confusing if not impossible to navigate in landscape - ie use app in landscape, try to task switch between apps and the scopes, the whole ui turns and prevents task switching from the same side of the screen.

Also note that in windowed mode the orientation on the phone breaks when using scopes, when the scopes should be within a window

doniks (kaabud-lp) wrote :

As a workaround you can comment out the line
X-Ubuntu-Supported-Orientations=primary
in
/usr/share/applications/unity8-dash.desktop
then you will have a rotating dash. You have to make the device writeable first.

Mateo Salta (mateo-salta) wrote :

You are a life saver Krusty!

I see why, they didn't like the layout for the phone - some scopes that have text boxes center the data in a rectangle in the middle, and it looks strange until there are two side by side, otherwise - performance wise it doesn't take much of a hit, and it sure beats having to turn the phone when you are simply changing apps using the phone in landscape, and not knowing where the launcher or tasks are.

The Dash should totally rotate, as right now it seems just a bandage for other scope sizing bugs, that are also apparent on different sizes of screens, and the size of the dash. And it is preventing proper task switching

zubozrout (zubozrout) wrote :

Funny. On Nexus 7 flo the dash is stuck in landscape while on Nexus 7 deb in portrait. Just seen someone on IRC asking about it and mentioning it would be best for him to use de device in portrait. I on the other hand have the N7 deb and would like to use the device in landscape. Bootscreen is in landscape but the login screen and the dash are in portrait. Seems like it is really messy right now. I would recommend the dash to rotate based on user preferences and not being hardwired.

Selene ToyKeeper (toykeeper) wrote :

So, the dash has had the ability to rotate for months... but if I understand correctly it's disabled because some scopes look a little odd in landscape mode. That still seems better than not being able to rotate at all, because the interface gets really awkward when trying to check a scope while using a rotated app.

Could we enable dash/scope rotation by default? It seems less awkward than how things are now, and might help motivate scope authors to support both layouts.

zubozrout (zubozrout) wrote :

@Selene Scriven: Well, on tablets you have the dash in landscape by default so the excuse of scopes not being prepared for landscape is not the real problem. Some may look odd in landscape, that is right, but in that case why not force portrait on tablets as well. I think forcing the dash to stay in one or the other mode is a fundamentaly bad idea and a poor decision.

Mateo Salta (mateo-salta) wrote :

Can we revisit this? Just got the M10, and like using in portrait, but the primary ui is unusable when turned sideways, and turning the whole tablet is unwieldy.

Mateo Salta (mateo-salta) wrote :

Also rotation is incredibaly smooth and fast ota10 on m10 fhd

Michał Sawicz (saviq) on 2016-05-05
Changed in ubuntu-ux:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Michał Sawicz (saviq)
milestone: none → 11
Paty Davila (dizzypaty) on 2016-05-06
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2016-05-06
Changed in unity8 (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
assignee: nobody → Michael Zanetti (mzanetti)
Paty Davila (dizzypaty) on 2016-05-06
Changed in ubuntu-ux:
status: Fix Released → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Randall Ross (randall) wrote :

Are there plans to also rotate the greeter? Seems odd to have to login always in landscape mode on my N7. New bug needed?

Michael Zanetti (mzanetti) wrote :

Making the greeter rotate is on our roadmap. I don't think we need a bug report for it. There's a Trello card. It will be part of some larger rework of the greeter.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers