[calendar] There is no way to delete an event

Bug #1240505 reported by David Planella on 2013-10-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Calendar App
Critical
Kunal Parmar
Ubuntu UX
Medium
Giorgio Venturi
qtorganizer5-eds
Fix Committed
Undecided
Unassigned
qtorganizer5-eds (Ubuntu)
Undecided
Unassigned

Bug Description

Right now we are able to edit events, but there is no option to delete them.

After a talk with design. Desired solution:

- Add a "Delete" toolbar action in the edit event view, which deletes the event being edited.

Related branches

lp:~pkunal-parmar/ubuntu-calendar-app/deleteEvent
Merged into lp:ubuntu-calendar-app at revision 186
David Planella: Approve on 2014-01-27
Ubuntu Phone Apps Jenkins Bot: Approve (continuous-integration) on 2014-01-18
Mihir Soni: Needs Fixing on 2013-10-17
lp:~renatofilho/qtorganizer5-eds/fix-1240505
Merged into lp:qtorganizer5-eds at revision 25
Gustavo Pichorim Boiko: Approve on 2014-01-06
PS Jenkins bot: Approve (continuous-integration) on 2014-01-05
David Planella (dpm) on 2013-10-16
Changed in ubuntu-calendar-app:
status: New → Triaged
importance: Undecided → High
David Planella (dpm) on 2013-10-16
description: updated
Kunal Parmar (pkunal-parmar) wrote :

Do we have icon for delete?

David Planella (dpm) wrote :

Yep, there is a delete icon indeed:

$ dpkg -L ubuntu-mobile-icons | grep delete
/usr/share/icons/ubuntu-mobile/actions/scalable/delete.svg

Here's a tip to see the available icons:
https://plus.google.com/115054251212417394181/posts/144iojDbjv5

Changed in ubuntu-calendar-app:
importance: High → Critical
Kunal Parmar (pkunal-parmar) wrote :

Edit event is called from EventDetails view.

If we delete event from EditEvent, what we should display in EventDetails.

I think its better to put delete button in EventDetails view same as Edit button.

Kunal Parmar (pkunal-parmar) wrote :

If seems there are few issue with EDS implementation.

removeItem with itemId is not implementend.
 eventModel.removeItem(event.itemId);

<pkunal-parmar> virtual QtOrganizer::QOrganizerItemEngineId* QOrganizerEDSFactory::createItemEngineId(const QMap<QString, QString>&, const QString&) const
<pkunal-parmar> virtual bool QOrganizerEDSEngine::startRequest(QtOrganizer::QOrganizerAbstractRequest*)
<pkunal-parmar> No implemented request 7
<pkunal-parmar> virtual void QOrganizerEDSEngine::requestDestroyed(QtOrganizer::QOrganizerAbstractRequest*)

Q_INVOKABLE void removeItem(QDeclarativeOrganizerItem *item);

Works, but it shows some error at end and does not emit modelChanged or itemCountChanged signal.

<pkunal-parmar> virtual bool QOrganizerEDSEngine::startRequest(QtOrganizer::QOrganizerAbstractRequest*)
<pkunal-parmar> void QOrganizerEDSEngine::removeItemsAsync(QtOrganizer::QOrganizerItemRemoveRequest*)
<pkunal-parmar> static void QOrganizerEDSEngine::removeItemsAsyncStart(RemoveRequestData*)
<pkunal-parmar> Remove item size: 1
<pkunal-parmar> static void QOrganizerEDSEngine::removeItemsAsyncStart(RemoveRequestData*)
<pkunal-parmar> Item source is null

Mihir Soni (mihirsoni) on 2013-10-19
Changed in ubuntu-calendar-app:
assignee: nobody → Kunal Parmar (pkunal-parmar)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtorganizer5-eds (Ubuntu):
status: New → Confirmed
Ingmar (ingmars-mailbox-uone) wrote :

Please fix this. You can't use a calendar-app without editing/deleting events at all.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:qtorganizer5-eds at revision 25, scheduled for release in qtorganizer5-eds, milestone Unknown

Changed in qtorganizer5-eds:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtorganizer5-eds - 0.1.1+14.04.20140108.2-0ubuntu1

---------------
qtorganizer5-eds (0.1.1+14.04.20140108.2-0ubuntu1) trusty; urgency=low

  [ Renato Araujo Oliveira Filho ]
  * Configured eds to run a new session for each test.
  * Implemented support for query items by id. (LP: #1240808)
  * Implemented support for save multiple items. This new implementation
    allows to save several items in the same call. The items can be part
    of the same collection or not.
  * fixed query items with recurrence.
  * Implemented remove item by id;. (LP: #1240505)
  * Fixed create items without collection id. (LP: #1262296)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 26
 -- Ubuntu daily release <email address hidden> Wed, 08 Jan 2014 02:58:12 +0000

Changed in qtorganizer5-eds (Ubuntu):
status: Confirmed → Fix Released

Fix committed into lp:ubuntu-calendar-app at revision None, scheduled for release in ubuntu-calendar-app, milestone alpha-1

Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
David Planella (dpm) on 2014-03-12
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2014-04-25
summary: - There is no way to delete an event
+ [calendar] There is no way to delete an event
Changed in ubuntu-ux:
assignee: nobody → Giorgio Venturi (giorgio-venturi)
Ingmar (ingmars-mailbox-uone) wrote :

I'm on r303 from 2014-04-24 and I cannot delete an all day event (also all day events seem to appear one day in advance from 2:00 to 2:00).

Changed in ubuntu-ux:
status: New → Triaged
John Lea (johnlea) on 2014-07-21
Changed in ubuntu-ux:
importance: Undecided → Medium
status: Triaged → New
John Lea (johnlea) on 2014-07-21
Changed in ubuntu-ux:
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers