[DASH] "quit" mode for 'recent apps' should be less persistent

Reported by Bill Filler on 2013-06-21
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Mike Nagle
Unity 8
High
Daniel d'Andrada
unity8 (Ubuntu)
High
Michał Sawicz

Bug Description

To reproduce
------------

Long press on a thumbnail in 'recent apps'
Quit mode initiated - x button appears on thumbnails
Tap anywhere not on thumbnails or swipe horizontally to switch scope and swipe back
Quit mode is still active

Desired solution (design input)
----------------------------------------------
Quit mode should be dismissed when tapping outside the app thumbnail or when switching to another scope (from launcher, by swiping or through the Tabs on header)

Archived bug description
------------------------

saucy-19 on maguro

If you have multiple apps running and you press and hold to quit one and then actually quit it, we should turn off quit mode (back to selection mode) so you can then select and switch to one of the other running apps. It's quite common that users want to close a particular app but then be able to navigate to another running app.

Steps.
- launch 3 apps
- go to apps lens
- press and hold app 3
- "x" button appears on apps 1, 2, 3
- select app 3

Expected results
- app 3 is closed and app 1 and 2 no longer show "X" and can be selected to navigate to

Actual results:
- app 3 closed and app 1 and 2 still show "X"

Related branches

lp:~dandrader/unity8/runningAppsEndClose
Merged into lp:unity8 at revision 565
PS Jenkins bot: Approve (continuous-integration) on 2013-11-30
Albert Astals Cid: Approve on 2013-11-29
Michał Sawicz: Pending requested 2013-11-22
Bill Filler (bfiller) on 2013-06-21
Changed in touch-preview-images:
assignee: nobody → Michał Sawicz (saviq)
Michał Sawicz (saviq) wrote :

I'm not sure that's the desired behaviour, although tapping outside of the running apps' thumbnails should dismiss the close mode for sure. Should we maybe dim the rest of the dash to show that clicking on that area would do so?

Added ubuntu-ux for design guidance.

Changed in touch-preview-images:
status: New → Incomplete
Bill Filler (bfiller) wrote :

@saviq
That's a good idea - tapping outside to dismiss close mode.

John Lea (johnlea) on 2013-07-16
Changed in ubuntu-ux:
assignee: nobody → Oren Horev (oreneeshy)
Oren Horev (oreneeshy) on 2013-07-16
summary: - "quit" mode in running apps lens should be cleared after app quit
+ [DASH] "quit" mode in running apps lens should be cleared after app quit
Oren Horev (oreneeshy) on 2013-09-17
description: updated
summary: - [DASH] "quit" mode in running apps lens should be cleared after app quit
+ [DASH] "quit" mode for 'recent apps' should be dismissed after whne
+ tapping anywhere outside the category
summary: - [DASH] "quit" mode for 'recent apps' should be dismissed after whne
- tapping anywhere outside the category
+ [DASH] "quit" mode for 'recent apps' should be dismissed when tapping
+ outside app thumbnail
Oren Horev (oreneeshy) on 2013-09-17
summary: - [DASH] "quit" mode for 'recent apps' should be dismissed when tapping
- outside app thumbnail
+ [DASH] "quit" mode for 'recent apps' should be more transient
summary: - [DASH] "quit" mode for 'recent apps' should be more transient
+ [DASH] "quit" mode for 'recent apps' should be less persistent
description: updated
Changed in ubuntu-ux:
status: New → Fix Committed
Oren Horev (oreneeshy) on 2013-09-30
description: updated
Changed in touch-preview-images:
status: Incomplete → New
Changed in ubuntu-ux:
importance: Undecided → High
Andrea Cimitan (cimi) on 2013-10-11
Changed in unity8:
assignee: nobody → Andrea Cimitan (cimi)
importance: Undecided → High
status: New → Triaged
Omer Akram (om26er) on 2013-10-11
affects: touch-preview-images → unity8 (Ubuntu)
Changed in unity8 (Ubuntu):
importance: Undecided → High
status: New → Triaged
Oren Horev (oreneeshy) on 2013-10-11
description: updated
description: updated
Andrea Cimitan (cimi) wrote :

On hold waiting feedback from SDK with InverseMouseArea behaviour

Daniel d'Andrada (dandrader) wrote :

hijacking bug

Changed in unity8:
assignee: Andrea Cimitan (cimi) → Daniel d'Andrada (dandrader)
status: Triaged → In Progress
Daniel d'Andrada (dandrader) wrote :

Got a simple solution on the way...

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision None, scheduled for release in unity8, milestone phone-v1-freeze

Changed in unity8:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.84+14.04.20131206.1-0ubuntu1

---------------
unity8 (7.84+14.04.20131206.1-0ubuntu1) trusty; urgency=low

  [ Michal Hruby ]
  * Ensure DashContent's ListView's currentItem is set if the model is
    not empty.

  [ Michał Sawicz ]
  * Don't generate build-deps .deb twice and allow overriding
    QML2_IMPORT_PATH in ./run.

  [ Albert Astals ]
  * Remove unused Applications/ folder .
  * Implement an 'interface' for Dash Renderers.
  * Use deelistmodel's conversion method Instead of a copy of the code .
  * Remove icons we don't use .
  * Do not start apps or go to dash on demo If you are pulling the
    launcher out while in demo mode it doesn't make sense to let you
    start applications. Besides it locks you out because it starts the
    app and the demo is still not finished so you can't really use any
    of the edges to escape Bug #1233696. (LP: #1233696)
  * Add a test for the carousel showing the preview when being clicked .
  * Fix collapsing of categories not working and the
    expansion/collapsing animation +test.

  [ Timo Jyrinki ]
  * Depend on either Qt 5.2 or libqt5v8-5-private-dev.
  * qtdeclarative5-private-dev 5.0.2-6ubuntu5 now depends directly on Qt
    V8 private headers. The remaining "qtdeclarative5-private-dev"
    dependency is enough now both when compiling against 5.0.2 or 5.2.

  [ Pete Woods ]
  * Handle optional parameterized action properties. (LP: #1256258)

  [ Andrea Cimitan ]
  * Implement an 'interface' for Dash Renderers.

  [ Michael Zanetti ]
  * Added music preview.
  * rename some parameters from desktopFile to appId as scopes are now
    changed to give us the appId.
  * unhardcode launcher's search paths for .desktop files.
  * Enable teasing of the phone greeter even though we have a
    lockscreen.
  * check if variant is valid to avoid asserting in debug mode when the
    connection to AccountsService doesn't work for some reason .

  [ Michael Terry ]
  * Add the DBus greeter API from the desktop greeter into the unity8
    greeter.

  [ Daniel d'Andrada ]
  * Dash: disable close mode when you click outside app thumbnails To
    leave the termination mode you can now just mouse/touch press
    anywhere outside the running applications' thumbnails The other way,
    which still works, is long-pressing a thumbnail once more. (LP:
    #1193414)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 579
 -- Ubuntu daily release <email address hidden> Fri, 06 Dec 2013 13:15:57 +0000

Changed in unity8 (Ubuntu):
status: Triaged → Fix Released
Michał Sawicz (saviq) on 2013-12-06
Changed in unity8:
status: Fix Committed → Fix Released
Mike Nagle (mikenagle) on 2014-04-07
Changed in ubuntu-ux:
assignee: Oren Horev (oreneeshy) → Mike Nagle (mikenagle)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers