"Downloads" folder in non-English installations never have localized name

Bug #630147 reported by RussianNeuroMancer on 2010-09-04
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
langpack-o-matic
Undecided
Unassigned
xdg-user-dirs (Ubuntu)
Undecided
Unassigned

Bug Description

If you install for example Russian version of Ubuntu then after installation Downloads folder will have "Загрузки" name.
If you install any non-English version of Kubuntu, Downloads folder after installation will always have "Downloads" name. Same problem with Ubuntu Maverick. Tested on daily build (13 September).

tags: added: kubuntu lucid maverick
summary: - Downloads folder in Kubuntu in non-English installation never renamed
+ Downloads folder in Kubuntu in non-English installation never have
+ localized name
summary: - Downloads folder in Kubuntu in non-English installation never have
+ "Downloads" folder in Kubuntu in non-English installation never have
localized name

they're made by /usr/bin/xdg-user-dirs-update which gets run by /etc/X11/Xsession.d/60xdg-user-dirs-update
and it should just pick up the system locale on first run

What is in your /etc/default/locale file?

Changed in xdg-user-dirs (Ubuntu):
milestone: none → ubuntu-10.10
Jonathan Riddell (jr) wrote :

Problem found, the translations are in the Gnome language packs
http://packages.ubuntu.com/search?searchon=contents&keywords=xdg-user-dirs.mo&mode=exactfilename&suite=lucid&arch=any

They should be in the foundation language packs

David Planella (dpm) on 2010-09-09
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
Jonathan Riddell (jr) wrote :

Lookin further in, xdg-user-dirs.mo files are shipped in both the xdg-user-dirs package and in language-pack-gnome-xx

However the one in the xdg-user-dirs package seems incomplete, it needs the xdg-user-dirs.mo file in the language-pack-gnome-xx package to correctly translate "Download"

summary: - "Downloads" folder in Kubuntu in non-English installation never have
- localized name
+ "Downloads" folder in non-English installations never have localized
+ name
description: updated
description: updated
David Planella (dpm) wrote :

I've just tested this installing the Ubuntu desktop image in Catalan and I could not reproduce it (i.e. the Downloads folder is correctly translated as Baixades). Could someone else confirm in another language or perhaps in Kubuntu?

Changed in ubuntu-translations:
status: Triaged → Incomplete

I this was fixed in a previous update. Today my Downloads directory name
is translated and shows «Descargas».

You can close the bug.

O Mar, 21-09-2010 ás 12:21 +0000, David Planella escribiu:
> I've just tested this installing the Ubuntu desktop image in Catalan and
> I could not reproduce it (i.e. the Downloads folder is correctly
> translated as Baixades). Could someone else confirm in another language
> or perhaps in Kubuntu?
>
> ** Changed in: ubuntu-translations
> Status: Triaged => Incomplete
>

--
Enviado desde Ubuntu

Martin Pitt (pitti) wrote :

Thanks for testing! Closing then.

Changed in langpack-o-matic:
status: New → Invalid
Changed in xdg-user-dirs (Ubuntu):
status: New → Fix Released
Changed in ubuntu-translations:
status: Incomplete → Fix Released
Seán Ó Séaghdha (seanos) wrote :

A fix may have been released but I still have this problem in 11.04 Natty (Gnome). How do I actually fix this?

Gabor Kelemen (kelemeng) wrote :

Hi Seán

You see this because the upstream ga.po is missing the translation of the Downloads string. Currently, Ubuntu only packages the upstream version, so please submit an updated file here: http://translationproject.org/domain/xdg-user-dirs.html

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers