Department names shows untranslated, albeit they're translated

Bug #545102 reported by Ricardo Pérez López on 2010-03-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
software-center (Ubuntu)
High
Michael Vogt
Lucid
High
Michael Vogt

Bug Description

Almost all the department names shows untranslated in my Spanish desktop, albeit they're fully translated in Launchpad; see, for example:

  - "Universal Access" translated as "Acceso Universal":
    https://translations.launchpad.net/ubuntu/lucid/+source/software-center/+pots/software-center/es/70/+translate

  - "Accessories" translated as "Accesorios:
    https://translations.launchpad.net/ubuntu/lucid/+source/software-center/+pots/software-center/es/19/+translate

  - "Themes & Tweaks" translated as "Temas y ajustes:
    https://translations.launchpad.net/ubuntu/lucid/+source/software-center/+pots/software-center/es/69/+translate

and the translations are included in the /usr/share/locale-langpack/es/LC_MESSAGE/software-center.mo:

  ricardo@kadath:~$ strings -eS /usr/share/locale-langpack/es/LC_MESSAGES/software-center.mo | grep "Acceso"
  Accesorios
  Acceso universal
  ricardo@kadath:~$ strings -eS /usr/share/locale-langpack/es/LC_MESSAGES/software-center.mo | grep "Temas"
  Temas y ajustes

I attach an screenshot to illustrate the problem.

Michael Vogt (mvo) on 2010-03-24
Changed in software-center (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-2
status: New → Triaged
Changed in software-center (Ubuntu Lucid):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.19

---------------
software-center (1.1.19) lucid; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/channelpane.py:
    - hide ratings in channel pane also (LP: #538129)

  [ Michael Vogt ]
  * softwarecenter/view/catview.py:
    - fix i18n bug in category list (LP: #545102)
  * merge lp:~kiwinote/software-center/use_new_icons, many
    thanks!
  * fix i18n issue in featured application (LP: #545095)
  * merge lp:~kiwinote/software-center/bug530187, many thanks to
    "Kiwinote" (LP: #530187)
 -- Michael Vogt <email address hidden> Thu, 25 Mar 2010 09:48:54 +0100

Changed in software-center (Ubuntu Lucid):
status: In Progress → Fix Released
Pedro Villavicencio (pedro) wrote :

marking the ubuntu-translations task as fixed , I've just checked on my desktop and the translations are there now, thanks.

Changed in ubuntu-translations:
importance: Undecided → High
status: New → Fix Released
Victor Vargas (kamus) wrote :

I have commited a primary translation for these phrases under LP but need to be revised, thanks!

Ricardo Pérez López (ricardo) wrote :

I'm sorry, but I must to say that the issue is not 100% solved. There're still some untranslated department names even using latest software-center 1.1.20:

- Science & Engineering
- Themes & Tweaks
- Painting & Editing
- Scanning & OCR
- Computer Science & Robotics

All these translations are included in the software-center.mo:

ricardo@kadath:/usr/share/locale-langpack/es/LC_MESSAGES$ strings -eS software-center.mo | grep Dibujo
Dibujo
ricardo@kadath:/usr/share/locale-langpack/es/LC_MESSAGES$ strings -eS software-center.mo | grep Pintura
Pintura y edición
ricardo@kadath:/usr/share/locale-langpack/es/LC_MESSAGES$ strings -eS software-center.mo | grep OCR
Scanning &amp; OCR
Scaner y OCR
ricardo@kadath:/usr/share/locale-langpack/es/LC_MESSAGES$ strings -eS software-center.mo | grep Ro
Computer Science &amp; Robotics
Role Playing
Juegos de Rol
ricardo@kadath:/usr/share/locale-langpack/es/LC_MESSAGES$ strings -eS software-center.mo | grep rob
Computación y robótica
ricardo@kadath:/usr/share/locale-langpack/es/LC_MESSAGES$ strings -eS software-center.mo | grep Tem
Temas y ajustes

I attach some screenshots to illustrate the problem.

Ricardo Pérez López (ricardo) wrote :
Ricardo Pérez López (ricardo) wrote :
Changed in software-center (Ubuntu Lucid):
status: Fix Released → Confirmed
Michael Vogt (mvo) wrote :

Thanks for spotting this! There is remaining is a xml quoting issue that needs to be sovled.

Ricardo Pérez López (ricardo) wrote :

Thanks to you, Michael! A superb job.

Aron Xu (happyaron) on 2010-03-26
Changed in ubuntu-translations:
status: Fix Released → Triaged
Michael Vogt (mvo) on 2010-03-26
Changed in software-center (Ubuntu Lucid):
status: Confirmed → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 1.1.21

---------------
software-center (1.1.21) lucid; urgency=low

  * merged from lp:~vish.../software-center/3newicons,
    many thanks
  * softwarecenter/view/catview.py:
    - fix icon size in sub-categories to match icon theme size
  * softwarecenter/view/catview.py:
    - fix another i18n issue with the translated categories,
      thanks to Ricardo Pérez López for noticing it (LP: #545102)
  * debian/control:
    - depend on latest aptdaemon to handle the cache when the dpkg
      journal is dirty
  * softwarecenter/backend/aptd.py:
    - ensure unused dependency removal (for direct dependencies only)
      via aptdaemon
 -- Michael Vogt <email address hidden> Fri, 26 Mar 2010 10:18:49 +0100

Changed in software-center (Ubuntu Lucid):
status: Fix Committed → Fix Released

Works great now! Thanks very much, Michael!

David Planella (dpm) on 2010-04-06
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers