"Enter the Ubuntu One password for" needs a placeholder

Bug #1370391 reported by GunChleoc on 2014-09-17
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Ubuntu Translations
High
Unassigned

Bug Description

Reported on the ubuntu-translators mailing list:

Hi. I'm translator for Korean language (ko).
Upon translating 'pay-ui', I found this string hard to translate.

../app/ui/DirectPurchase.qml:95

The string is : Enter the Ubuntu One password for
However, as Korean language (and other E.Asian languages)has opposite
sequence of words, it is hard to translate a string that would be preceded
by other word.

Please add some placeholder (such as {a} on the string) to make it easier
to translate.

Thanks
MinSik CHO

Related branches

David Planella (dpm) on 2014-09-17
tags: added: touch
Adolfo Jayme (fitojb) on 2014-09-17
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
dobey (dobey) wrote :

Adding ubuntu-ux as this is a result of the design placing the translated text, and the user's e-mail address (the account ID) on separate lines.

Changed in ubuntu-ux:
status: New → Incomplete
no longer affects: ubuntu-ux
dobey (dobey) wrote :

Adding design back, as we do need design input on this. The problem is the design as follows, is to have the text, and the user's e-mail address, on separate lines:

Enter the Ubuntu One password for
'<email address hidden>'

This means the string must be broken up for the English variant, and is causing the issue in this bug report. We need to change the design to accommodate localization needs.

Matthew Paul Thomas (mpt) wrote :

This does not require design input. I know how to code this not because I'm a designer, but because I’ve seen engineers do it before:

Make the string of the form "Enter the Ubuntu One password for %s". Then translators can include text before and/or after the "%s". Then when you display the localized text, display the e-mail address part on its own line.

no longer affects: ubuntu-ux
dobey (dobey) wrote :

@mpt I know 10 different ways to fix it, yes; but any of those fixes are not the design we were given to implement. Thus, if I change it and then Design complains about it not matching the design, we end up being blamed for not matching the design, and thus it needs design input (ie, to approve the design being changed).

dobey (dobey) on 2014-11-04
Changed in pay-ui:
status: New → Triaged
importance: Undecided → High
tags: added: rtm14
removed: touch
dobey (dobey) on 2014-11-13
Changed in pay-ui:
status: Triaged → In Progress
assignee: nobody → Rodney Dawes (dobey)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:pay-ui at revision 88, scheduled for release in pay-ui, milestone Unknown

Changed in pay-ui:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww03-2015
status: New → Confirmed
dobey (dobey) on 2014-12-16
Changed in pay-ui:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers