"Open a new window" quicklist menu entry translations are not loaded

Bug #1067856 reported by David Planella on 2012-10-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
WebApps: libunity-webapps
Undecided
Unassigned
libunity-webapps (Ubuntu)
High
Unassigned

Bug Description

[Test Case]
1) Login to the desktop using a language other than english
2) launch the amazon app from the launcher
3) after the page loads, right click on the amazon launcher and verify the quick lists are not translated
4) install the unity-webapps-service package from -proposed.
5) logout and log back in.
6) launch the amazon app again
7) after the page loads, right click on the amazon launcher and verify the quick lists are translated

[Regression potential]
None; previous version simply wasn't binding to the GETTEXT_DOMAIN, this fixes that.

[Impact]
When shown in the Dash, each webapp icon has got a Unity quicklist with several entries, which are (pending an upload that will implement this) all localized.

However, there is one particular quicklist menu entry for all webapps whose translations are not loaded, and thus always appear in English: "Open a new window". See the attached screenshot.

David Planella (dpm) wrote :
information type: Proprietary → Public
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
Maxim Ermilov (zaspire) wrote :

package does not include translations.

affects: webapps-applications → libunity-webapps
affects: webapps-applications (Ubuntu) → libunity-webapps (Ubuntu)
no longer affects: libunity-webapps
David Planella (dpm) wrote :

The translations in webapps-applications, as with most Ubuntu packages, are not shipped in the package itself, but in the language packs instead. In this case, the translations for libunity-webapps are shipped in /usr/share/locale-langpack/$LANGUAGECODE/LC_MESSAGES/unity_webapps.mo

However, they are not loaded even though they are present.

Looking at the code, the only thing that strikes me is:

configure.ac:GETTEXT_PACKAGE=unity_webapps
data/com.canonical.unity.webapps.gschema.xml: <schema id="com.canonical.unity.webapps" path="/com/canonical/unity/webapps/" gettext-domain="unity-webapps">

So it seems that the domain in the .gschema.xml file does not match the domain specified at build time. While this needs to be fixed, I believe it only affects translations of schema files, and I'm not sure it's related to translations not being loaded on the desktop file.

Another thing that I've noticed is that the webapps desktop files are missing the "X-Ubuntu-Gettext-Domain=unity_webapps" entry, which might be the root of the cause.

However, I don't seem to be able to manually add the entry to the webapps .desktop files to test it, as every time they are loaded in the launcher, my manually written entry seems to disappear. Any ideas?

David Planella (dpm) on 2012-10-19
summary: - "Open a new window" quicklist menu entries need internationalization
+ "Open a new window" quicklist menu entry translations are not loaded
description: updated
Ken VanDine (ken-vandine) wrote :

The .desktop files are created on the fly by libunity-webapps. So you can't modify them yourself, they'll just get generated again. So it looks like the generated files need to include that.

Maxim Ermilov (zaspire) wrote :

most translations was commited after release.
I release new version (= 2.4.2). It contains all translations.

Changed in libunity-webapps:
status: New → Fix Released
Maxim Ermilov (zaspire) wrote :

unity-webapps-context-daimon had incorrect GETTEXT_DOMAIN (in version < 2.4.2)

Ken VanDine (ken-vandine) wrote :

Steps to verify:

1) Login to the destkop using a language other than english
2) launch the amazon app from the launcher
3) after the page loads, right click on the amazon launcher and verify the quick lists are translated

Regression potential: None
Previous version simply wasn't binding to the GETTEXT_DOMAIN, this fixes that.

Changed in libunity-webapps (Ubuntu):
importance: Undecided → High
status: New → Confirmed

Hello David, or anyone else affected,

Accepted libunity-webapps into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libunity-webapps/2.4.1-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
description: updated
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Olivier Febwin (febcrash) wrote :

There is a problem with French translation.
The shortcut for Yes ("Oui" in french) translation isn't valid ("Y" displayed but it should be "O").
See attachment

Olivier Febwin (febcrash) wrote :

Amazon quick lists are translated
OK for french translation

Al 05/11/12 13:16, En/na Olivier FEBWIN ha escrit:
> There is a problem with French translation.
> The shortcut for Yes ("Oui" in french) translation isn't valid ("Y" displayed but it should be "O").

Hi Olivier,

While this is not related to the bug, it might be worth investigating it
as a separate one.

Would you mind filing a new bug, so that we can track it separately and
find out what needs fixing to get the right accelerators?

Thanks.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Olivier Febwin (febcrash) wrote :

ok ;)

Adolfo Jayme (fitojb) wrote :

For those following up, the bug reported by Olivier is LP: #1075151.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity-webapps - 2.4.1-0ubuntu3.1

---------------
libunity-webapps (2.4.1-0ubuntu3.1) quantal-proposed; urgency=low

  * debian/patches/lp_1067856.patch
    - Use the correct GETTEXT_DOMAIN (LP: #1067856)

libunity-webapps (2.4.1-0ubuntu3) quantal-proposed; urgency=low

  * debian/patches/lp_1067461.patch
    - Add Amazon affiliate codes to support more countries (es, it,
      cn and jp) (LP: #1067461)
 -- Ken VanDine <email address hidden> Wed, 24 Oct 2012 09:31:58 +0200

Changed in libunity-webapps (Ubuntu):
status: Confirmed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Adolfo Jayme (fitojb) on 2012-11-24
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers