Google response is not localized after a search using Ubuntu Start Page

Bug #363381 reported by Ricardo Pérez López on 2009-04-18
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu Start Page
High
Martin Albisetti

Bug Description

If I do a search using http://l10n.ubuntu.tla.ro/ubuntu-9.04-start-page/index.html.es , the Google response is in English rather than Spanish.

This problem is NOT present on Intrepid's http://l10n.ubuntu.tla.ro/ubuntu-8.10-start-page/index_template.html.es

I attach an screenshot to illustrate the problem.

Ricardo Pérez López (ricardo) wrote :
Ricardo Pérez López (ricardo) wrote :
Paul Sladen (sladen) wrote :

Tested and confirmed

Changed in ubuntu-start-page:
status: New → Confirmed
Nobuto Murata (nobuto) on 2010-03-05
summary: - Google response in English after a search using Ubuntu Start Page in
- Spanish
+ Google response is not localized after a search using Ubuntu Start Page
Nobuto Murata (nobuto) wrote :

In Ubuntu 10.04(Lucid),
start pages will be changed to the one at http://l10n.ubuntu.tla.ro/startpage-10.04/ .

And Spanish version is attached one.

Nobuto Murata (nobuto) wrote :

So I propose this patch for each language.

With the line below, we can get localized result page.
<input type="hidden" name="hl" value="es" />

This is a example for Spanish.
If Japanese language, the line is below.
<input type="hidden" name="hl" value="ja" />

Nobuto Murata (nobuto) wrote :

And this is the revised one for Spanish.

btw, Google CS states that we are searching "9.04 Start Page"...

Ricardo Pérez López (ricardo) wrote :

Works great, Nobuto. Thank you very much.

Fumihito YOSHIDA (hito) wrote :

Hi folks, I think that this bug is translation/localize related issue, same as https://bugs.launchpad.net/ubuntu-start-page/+bug/529214 (not dupe, but they squash by same action)

These root problems are same, aren't it?

Martin Albisetti (beuno) on 2010-04-26
Changed in ubuntu-start-page:
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Martin Albisetti (beuno)
Adi Roiban (adiroiban) wrote :

This bug is somehow a duplicate of bug 305905 .

Martin Albisetti (beuno) on 2010-05-18
Changed in ubuntu-start-page:
status: Triaged → Fix Committed
Martin Albisetti (beuno) wrote :

This has been deployed today.

Changed in ubuntu-start-page:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers