software evaluation impossible

Bug #773214 reported by Ngassam Nkwenga on 2011-04-29
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-1-2
High
Unassigned
Trunk
High
Unassigned
software-center (Ubuntu)
High
Michael Vogt
Natty
High
Unassigned
ubuntu-sso-client (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: software-center

Hi all,

It is not possible as now to evaluate an application from the software center. In beta and alpha I could do it, but now in Natty final I can no more do it. the pop up window shows up with "authentification" writed and hanged here without ending. attached is a screenshot of this pop up window

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 4.0
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Apr 29 14:43:07 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Ngassam Nkwenga (cyrildz) wrote :
Michael Vogt (mvo) on 2011-04-29
Changed in software-center (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in software-center (Ubuntu Natty):
importance: Undecided → High
Michael Vogt (mvo) wrote :

I can reproduce this with:

[install french locales using gnome-language-selector first]
$ bzr get lp:software-center/4.0
$ cd 4.0
$ LANGUAGE=fr PYTHONPATH=. python utils/report_review.py --review-id 1 --debug

Michael Vogt (mvo) wrote :

The error I get is:

ERROR:softwarecenter.backend.login_sso:_on_credentails_error for Logithèque Ubuntu: Problem while retrieving credentials (Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ubuntu_sso/credentials.py", line 118, in inner
    result = yield f(self, *a, **kw)
KeyError: u'\xe8'
)

Michael Vogt (mvo) wrote :

I'm happy to fix this is my code if I need to use the untranslated appname instead of _("Ubuntu Software Center"). However as this is displayed to the user as a string it seemed to me like the translated string would be more appropriate.

dobey (dobey) wrote :

So, I am pretty sure that the 'appname' argument should not be translated. If only to avoid multiple auth tokens when changing languages.

However, if the appname is in fact translated, we should also not fail.

dobey (dobey) wrote :

I am not sure if or how effected by this stable-1-0 is, but if it has the same problem we should probably fix it there as well and provide an SRU in Maverick.

Changed in ubuntu-sso-client (Ubuntu Natty):
milestone: none → natty-updates
Ngassam Nkwenga (cyrildz) wrote :

Thanks you guy

Michael Vogt (mvo) wrote :

I uploaded a update to natty-proposed now. This should appear soon as a update.

Changed in software-center (Ubuntu Natty):
status: New → In Progress
Changed in software-center (Ubuntu):
status: Triaged → Fix Committed

Accepted software-center into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed

SRU verification for Natty:
I have reproduced the problem with software-center 4.0 in natty and have verified that the version of software-center 4.0.1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.0.1

---------------
software-center (4.0.1) natty-proposed; urgency=low

  [ Michael Vogt ]
  * debian/control:
    - point to 4.0 bzr branch
  * merged lp:~mmcg069/software-center/Bug635994, many thanks
    (LP: #635994)
  * utils/submit_review.py:
    - fix missing translation (LP: #770439)
  * utils/submit_review.py:
    - improve logging on SSO failure (LP: #773214)
    - do not translate "appname" as ubuntu-sso-login will fail
      for translated names with utf8 chars (LP: #773214)
  * softwarecenter/db/reviews.py:
    - apply review sorting (LP: #773289)
  * softwarecenter/app.py:
    - do not translate "appname" as ubuntu-sso-login will fail
      for translated names with utf8 chars (LP: #773214)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/translation-fixes-lp770439:
    - fix translation not showing up (LP: #770439)
  * softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/widgets/reviews.py,
    test/test_appdetails_view.py:
    - enable writing a review immediately after the package
      installation is complete, add test case (LP: #769439)
 -- Michael Vogt <email address hidden> Fri, 29 Apr 2011 16:40:32 +0200

Changed in software-center (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
assignee: nobody → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-sso-client (Ubuntu Natty):
status: New → Confirmed
Changed in ubuntu-sso-client (Ubuntu):
status: New → Confirmed
dino99 (9d9) on 2013-05-18
tags: removed: natty
Adolfo Jayme (fitojb) on 2013-08-02
Changed in ubuntu-sso-client (Ubuntu Natty):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions