Default languages strategy for Ubuntu desktop CD

Bug #1520278 reported by Didier Roche on 2015-11-26
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Seeds
Fix Released
Undecided
Unassigned

Bug Description

Even if ubiquity is doing an awesome job at installing on demand languages on ubuntu, having more default languages as we used to on the destkop image enables us to have the live session localized. Also, offline installation will bring that support without adding supplementary download time.

Some loco team used to have respin of the default localized ubuntu image. Yours truly used to have handle this quite regularly for the french loco team. I know that the italian and finish locos used to do it as well. (not sure about the current status for them) However, UEFI support made it complicated and so those efforts have been dropped some cycles ago as far as I know.

I would thus propose that we enhance and complete our default language strategy for xenial. The LTS is an excellent time to make progress on this.

The proposal is to:
1. Install full language support for those shipped on xenial image. It means that opening "language selector" won't request any additional package to install[1]. If you are proceeding an online installation, additional packages won't be downloaded to complete your language installation. If you have done an offline one, you won't have the infamous after first boot "Language support is not complete" dialog. Note that for now, we have no complete language support on the live! For instance, in English, we have the following missing packages that language-support will require to install (or that ubiquity will download it for you if you are connected to the Internet):
hyphen-en-us, mythes-en-us, mythes-en-au, hunspell-en-ca, myspell-en-au, myspell-en-gb, myspell-en-za, libreoffice-help-en-gb, libreoffice-l10n-en-za, firefox-locale-en, thunderbird-locale-en, thunderbird-locale-en-gb, thunderbird-locale-en-us.

2. Based on popcon, number of native speaker and total number of speaker per language, it seems that the following language selection makes sense for our user base (more info on the language selection below):
en, es, zh (simplified), pt, de, fr, it, ru

3. We remove the difference between archs for now on the ubuntu desktop live seed (no language installed only on i386/powerpc like German and Portuguese, where they aren't installed on amd64), no more partial libreoffice help support only installed on i386 and amd64, for consistency.

Additional estimated size on the live to achieve this is 95Mb adding the full support for those 8 languages. This is of course a non negligeable image size increase. However, getting full language support for at least 8 languages (and no additional download on install for those) seems like a huge increase of quality to me. I'm sure as well that with the python2 drop support and other cleanup efforts, we would be able to regain a great part of that additional iso size (remember that our image was still at 1Gb not so long ago where we are at 1.2Gb now).

Finally, keep in mind that those locales are only part of the live image. The chosen language will be present on the installed system, but no other ones, even if shipped on image. So no extra space will be required on the installed target.

[1] apart from one font for simplified chinese which is weighting 8Mb.

-----
Full rationale on what to install, why and languages selection:

Back in the day we were still producing Ubuntu desktop ISO being able to burn on the CD, we had to fight a lot every cycle to keep the size reasonable, while still having a reasonable offer in term of default languages on the CD. However, at some point, this wasn't possible anymore and we dropped many languages as our default installation.

We lifted this image size restriction some cycles ago (and decided that the ISO will be used on DVDs or USB sticks) but didn't reintroduce languages that we dropped by then.

More and more locos (in particular Italian and French) don't do their own ISO respin anymore due to issues with UEFI.

In addition, some CD image time decision are still on the live (like german and portuguese are installed on all archs but amd64… which is the most widespread archs). We should use this time to cleanswap this.

Finally, when we install support for one language, we should install it fully. It means that opening "language selector" should tell you that the language is fully installed for the default application selection/dictionaries and that you don't rely on an Internet connexion to complete your locale installation. Even the default english selection
isn't complete and miss a bunch of packages. For instance, on xenial:

For this, we are going to use /usr/share/language-selector/data/pkg_depends (used by language-selector) and shipping them in live seed task for every dependent package that we shipped by default.

I propose we try and assess around the following criteria to decide what to install by default:
- Number of native speaker of one language: https://en.wikipedia.org/wiki/List_of_languages_by_number_of_native_speakers
- Popularity contest to assess what languages are using our community the most: http://popcon.ubuntu.com/by_vote. This as well will enable us to see communities (I think German people as an example) which are traditionally using their systems in English, contrary to others (italian, french), which are switching locale to their native languages.
- Previous ubuntu versions we shipped locale for (I propose we look at 10.04 LTS)
- Additional size on the ISO. We will approximate packagesize ~= size taken once extracted files are compressed in the squashfs.

I'm linking a seed branch fixing those issues. Note that ubiquity will need some checking to ensure that all desired packages are indeed installed even offline.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1520278/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Didier Roche (didrocks) on 2015-11-27
description: updated
Didier Roche (didrocks) on 2015-11-27
description: updated
Will Cooke (willcooke) on 2015-11-27
description: updated
Didier Roche (didrocks) on 2015-11-27
description: updated
summary: - Readding some default languages to Ubuntu desktop CD
+ Default languages strategy for Ubuntu desktop CD
description: updated
Didier Roche (didrocks) on 2015-11-27
description: updated
Didier Roche (didrocks) on 2015-11-27
description: updated
Didier Roche (didrocks) on 2015-12-01
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Didier Roche (didrocks) wrote :

This task is now fully done.

Changed in ubuntu:
status: Confirmed → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Didier,

On 2016-01-13 16:35, Didier Roche wrote:
> This task is now fully done.

Not quite, if I haven't missed something. Possibly you have only addressed the live session, while I'm thinking of the real install at first hand.

My concern is bug #1294858, which I marked as a duplicate of this one:

https://lists.ubuntu.com/archives/ubuntu-devel/2015-December/039032.html

There is quite some noise on that bug report, but the actual bug description is in this comment:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1294858/comments/3

I just installed from the daily build of Ubuntu xenial, and the first thing I did was running the check-language-support command:

gunnar@gunnar-ubuntu-xenial-64:~$ check-language-support
firefox-locale-sv hunspell-en-ca hunspell-sv-se hyphen-sv language-pack-gnome-sv language-pack-sv libreoffice-help-en-gb libreoffice-help-sv libreoffice-l10n-en-gb libreoffice-l10n-en-za libreoffice-l10n-sv mythes-en-au mythes-sv thunderbird-locale-en-gb thunderbird-locale-sv thunderbird-locale-sv-se wswedish
gunnar@gunnar-ubuntu-xenial-64:~$

(It's the same list of packages as the packages which you are prompted to install if you run gnome-language-selector.)

The English language support packages in the list show up for everyone who selects English in the installer, and that's what bug #1294858 actually is about.

The reason why there also are some Swedish packages is that I installed from Sweden, and hence selected a Swedish time zone location. That problem is addressed in another bug report, i.e. bug #1532519.

It would be great if both these issues could be fixed before the release of 16.04.

Didier Roche (didrocks) wrote :

Yeah, this task is quite different (I didn't dive into all details though).

This bug was really focusing on the default language selection. I hope the ubiquity maintainer (maybe try pinging cyphermox?) can focus on the other bug, which concerns more packages not on the iso + English ones, even if you select another language partially copied from the installer (which is why it's showing up as not fully supported).

To make it clear, I unduped it your duplicate action. Maybe try to reach directly Mathieu (cyphermox) on IRC? I bet this shouldn't be a big thing to fix, just put this on his radar :)

Gunnar Hjalmarsson (gunnarhj) wrote :

Will do. Thanks!

affects: ubuntu → ubuntu-seeds
scootergrisen (scootergrisen) wrote :

I am trying to get danish translation into the live ISO image so users can try out Ubuntu with danish translation without having to need a internet connection and without having to download/install/switch language/log out/log in to use Ubuntu with danish language.

I noticed the "Number of native speaker of one language" part with the link https://en.wikipedia.org/wiki/List_of_languages_by_number_of_native_speakers but danish language in not in the top 100 on that list.

Maybe it would also be a good idea to look at which languages have been translated the most when deciding which languages to include in the ISO's.

From what i can see on https://translations.launchpad.net/ubuntu danish translation is top 27 most translated language and the top 25 most contributors.

Gunnar Hjalmarsson (gunnarhj) wrote :

@scootergrisen: Commenting on a closed bug report is not a good way to start a discussion. I'd suggest that you post a message to the ubuntu-desktop mailing list:

https://lists.ubuntu.com/mailman/listinfo/ubuntu-desktop

and refer to bug #1671395 which you filed the other day.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers