Header actions text is cut off

Bug #1354812 reported by David Planella on 2014-08-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
High
Christian Dywan
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu RTM)
Undecided
Unassigned

Bug Description

See the attached screenshot.

- Expected: actions drop-down expands to fit the contained text. Alternatively, the documentation warns about a maximum character size. Alternatively, text is ellipsized.
- Actual: text longer than a given size (which?) is cut off

This will affect translations for system and core apps in particular, where the English text might fit, but translations that are longer will be cut off.

It corresponds to header actions for the following code snippet:

            head.actions: [
                Action {
                    text: i18n.tr("Settings")
                    iconName: "settings"
                    onTriggered: pageStack.push(settingsPage)
                },
                Action {
                    objectName: "hidepanelaction"
                    iconName: "edit-clear"
                    text: i18n.tr("Hide all key panels")
                    onTriggered: pgTerm.showExtraPanel(0)
                },
                Action {
                    objectName: "controlkeysaction"
                    text: i18n.tr("Show control keys panel")
                    onTriggered: pgTerm.showExtraPanel(1)
                },
                Action {
                    objectName: "functionkeysaction"
                    text: i18n.tr("Show function keys panel")
                    onTriggered: pgTerm.showExtraPanel(2)
                },
                Action {
                    objectName: "textkeysaction"
                    text: i18n.tr("Show arrow keys panel")
                    onTriggered: pgTerm.showExtraPanel(3)
                }
            ]
        }

Related branches

David Planella (dpm) wrote :
tags: added: avengers
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Tim Peeters (tpeeters) on 2014-10-07
Changed in ubuntu-ui-toolkit:
assignee: nobody → Christian Dywan (kalikiana)
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Zsombor Egri (zsombi) on 2014-10-16
Changed in ubuntu-ui-toolkit:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 1.1.1311+15.04.20141102-0ubuntu1

---------------
ubuntu-ui-toolkit (1.1.1311+15.04.20141102-0ubuntu1) vivid; urgency=medium

  [ Zoltán Balogh ]
  [ Christian Dywan <email address hidden>
  * Explicitly use Orange in Slider and ProgressBar.
    Fixes: LP: #1372585.
  * Copy components correctly in push_to_phone.sh and make copy.sh
    more robust.
  * Make push_to_phone.sh use a temporary folder and sudo.

  [ Zsombor Egri <email address hidden>
  * ThinDivider margins rolled back to edge-to-edge. Divider colors
    adjusted with design. Fixes: LP: #1380766.

  [ Tim Peeters <email address hidden>
  * Add updated header divider to use rectangles instead of images,
    and to auto-detect its color. Fixes: LP: #1372590.
  * Add internal property to hide the header separator.
    Needed in Unity8.

  [ Leonardo Arias Fonseca <email address hidden>
  * Fixed the infinite loop when running flickable tests.
    Fixes: LP: #1384703.
  * Added an autopilot helper for expandable list items.
    Fixes: LP: #1340227.
  * The autopilot helpers to swipe to show more now get the flickable
    containers by default. Fixes: LP: #1365674.
  * Replaced the tabs for spaces in UbuntuTestCase.
   Fixes: LP: #1324469.

ubuntu-ui-toolkit (1.1.1298+14.10.20141030~rtm-0ubuntu1) 14.09; urgency=low

  [ CI bot ]
  * Resync trunk

  [ Timo Jyrinki ]
  * Modify test .desktop file (LP: #1382414) (LP: #1382414)

ubuntu-ui-toolkit (1.1.1298+14.10.20141016.1-0ubuntu1) 14.09; urgency=medium

  [ Jussi Pakkanen]
  * Remove the thumbnailer image provider here, because thumbnailer
    provides it by itself Fixes LP: #1368492

  [ Lars Uebernickel ]
  * Icon: size correctly even if no or only one dimension is given

  [ Michael Sheldon]
  * Check that orientation changes are acceptable before applying new
    orientation based on active window change. Fixes LP: #1375306

  [ Zoltán Balogh ]
  * Updated test plan executer

  [ Zeller Benjamin ]
  * RenderTimer includes EGL platform files in the rendertime header,
    which can cause problems when included after QDataStream. The
    EGL headers pull the XLib files which define the Symbol Status.
  * Preparing qmlapicheck to support out of source builds for the
    cmake migration

  [ Renato Filho ]
  * Save alarms in invalid time zone. Use invalid time zone to
    floating time alarms.

  [ Tim Peeters ]
  * Make icons from theme in showcase gallery scrollable.
    Fixes: LP: #1336279.
  * Fix width of header contents. Fixes LP: #1378261.

  [ Sebastien Bacher ]
  * Don't use simple quotes around translatable strings, xgetting
    ignore those. Fixes LP: #1378774.

  [ Zsombor Egri ]
  * Alarm update regression caused by EDS changes. Also fixes Tags
    update. Requires qtorganizer5-eds updates as well!.
    Fixes LP: #1364949.
  * Forgotten Interface declaration in objects. Fixes LP: #1378298

  [ Christian Dywan ]
  * Make dialog contents scrollable. Fixes LP: #1376763
  * Make mouseMoveSlowly work with a negative distance.
    Fixes LP: #1343334
  * Read-only text entries don't blink or visibly take focus
    Fixes LP: #1370571
  * Anchor overflow but...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Zoltan Balogh (bzoltan) on 2014-11-19
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers