Cannot type into account login input boxes

Bug #1395724 reported by Omer Akram on 2014-11-24
60
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
ubuntu-system-settings-online-accounts (Ubuntu)
High
Unassigned
ubuntu-system-settings-online-accounts (Ubuntu RTM)
High
Unassigned
unity8 (Ubuntu)
Medium
Unassigned

Bug Description

1. Open system settings and go to accounts.
2. tap on 'Google' to add a google account
3. When the login page opens drag down the indicator bar from the top
4. Now try to type into the username/password boxes.

What happens:
OSK does not appear to type in there.

ProblemType: Bug
DistroRelease: Ubuntu RTM 14.09
Package: ubuntu-system-settings-online-accounts 0.5+14.10.20141029~rtm-0ubuntu1
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.14.7-0ubuntu8
Architecture: armhf
Date: Mon Nov 24 13:29:58 2014
InstallationDate: Installed on 2014-11-21 (2 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20141121-220606)
SourcePackage: ubuntu-system-settings-online-accounts
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) wrote :
Omer Akram (om26er) on 2014-11-24
tags: added: omertm
removed: omerrtm
Alberto Mardegan (mardy) on 2014-11-24
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) wrote :

I initially thought that this was related to Oxide, but it isn't: it also happens with account plugins which don't use Oxide at all (like UbuntuOne).

My guess is that there is something wrong with how the OSK, indicators and trusted sessions work together. Adding to unity8 for investigation.

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → Confirmed
Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
status: New → Confirmed
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
importance: Undecided → High
Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
importance: Undecided → High
Changed in unity8 (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Michał Sawicz (saviq) on 2015-01-05
Changed in unity8 (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Josh Arenson (josharenson)
Josh Arenson (josharenson) wrote :

This seems to be a regression in online account services. When I use the rtm branch, this issue doesn't exist. Investigating anyway, as the root cause could easily end up being unity8.

David Barth (dbarth) on 2015-02-11
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
status: Confirmed → Invalid
David Barth (dbarth) on 2015-02-11
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
assignee: Alberto Mardegan (mardy) → nobody
John McAleely (john.mcaleely) wrote :

This is claimed as the root cause of OEM bug #1412397. I'm not sure 'triaged'/'medium' is appropriate.

@pat - can you triage this for canonical-devicesl-system-image please?

Pat McGowan (pat-mcgowan) wrote :

@josh this is definitely reproducible in the rtm branch

@david these seems directly related to the non-standard way the login page is displayed in the separate online-accounts-ui process

Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
status: Invalid → Confirmed
assignee: nobody → David Barth (dbarth)
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
milestone: none → ww11-2015
Alberto Mardegan (mardy) wrote :

We are using the standard Ubuntu Webview:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/vivid/ubuntu-system-settings-online-accounts/vivid/view/head:/plugins/module/WebView.qml

This not related to the webview, please see my comment #2 again: also U1 is affected.

Alberto Mardegan (mardy) wrote :

See also bug 1421353. Pay UI is also using trusted sessions, so this is most likely a focus issue when trusted sessions are being used.

Josh Arenson (josharenson) wrote :

@pat I am unable to reproduce this any longer. Locking/unlocking the device, and exposing notifications both correctly hide/show the keyboard. Do you still see it? Should mention that I'm on devel-proposed/mako.

Pat McGowan (pat-mcgowan) wrote :

I still see it in both cases, latest devel proposed on krillin and recent image on mako

David Barth (dbarth) wrote :

I can't reproduce the problem anymore on mako/vivid (as of image #129). However, this is still very much a problem on krillin stable (#19)

Pat McGowan (pat-mcgowan) wrote :

marking fixed as it does not occur on vivid

Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Noemí (noemi-gallego) wrote :

Hi, I have reproduced it while entering a facebook account or a ubuntu account from telegram to active the notifications. I am currently testing on r19.

David Barth (dbarth) wrote :

I think it will stay as a known issue in the current RTM release, until we switch phones OTA with vivid in the next few months.
The issue is annoying, but users can easily get back to a known working state, by restarting a signup session.

Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
assignee: David Barth (dbarth) → nobody
Changed in unity8 (Ubuntu):
assignee: Josh Arenson (josharenson) → nobody
Albert Astals Cid (aacid) wrote :

Marking this as fix released for unity8 since we're under the vivid OTA now.

Changed in unity8 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers