Autopilot tests need to use autopkgtest runner

Bug #1338790 reported by Nicholas Skaggs on 2014-07-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dropping Letters
Undecided
Unassigned
Sudoku App
Undecided
Unassigned
Ubuntu Calculator App
Undecided
Unassigned
Ubuntu Calendar App
Undecided
Nicholas Skaggs
Ubuntu Clock App
Undecided
Unassigned
Ubuntu File Manager App
Undecided
Unassigned
Ubuntu Music App
Undecided
Unassigned
Ubuntu Notes app
Undecided
Nicholas Skaggs
Ubuntu Shorts App
Undecided
Unassigned
Ubuntu Terminal App
Undecided
Unassigned
Ubuntu Weather App
Undecided
Unassigned
camera-app
Invalid
Undecided
Unassigned
gallery-app
Invalid
Undecided
Unassigned
notes-app
Undecided
Unassigned
reminders-app (Ubuntu)
Undecided
Unassigned

Bug Description

Since autopkgtest now supports running autopilot tests for click packages, we should migrate to test provisioning and running via adt.

To do this, update the manifest to specify your test dependencies (look in your debian/control at the depends specified for your *-autopilot package). Specify them like so in the manifest file (copied from http://people.debian.org/~mpitt/autopkgtest/README.click-tests.html):

If a test does not need any additional dependencies, you can are all set. IE,

   "x-test": {
        "autopilot": "ubuntu_calculator_app"
    }

For those that do, specify them like so:

   "x-test": {
           "autopilot": {
                "command": "PYTHONPATH=tests/autopilot:$PYTHONPATH python3 -m autopilot.run run foo_tests",
            "depends": ["ubuntu-ui-toolkit-autopilot", "autopilot-touch"]
             }
   }

Tests can then be run by calling them via adt and specifying a target, like a phone. EG,

adt-run folder-of-branch/ click-package.click --- \ test-runner

For example;

adt-run ubuntu-calculator-app/ com.ubuntu.calculator_1.3.283_all.click --- \
      ssh -s /usr/share/autopkgtest/ssh-setup/adb

Note you'll need to provide the click package, so build it first. If you have native code, you'll need to cross compile. You can use click-buddy or qtcreator (or your favorite tool) to build.

-----------
Example;

bzr branch lp:~nskaggs/music-app/autopkgtest music-app
click-buddy --dir music-app
adt-run music-app/ com.ubuntu.music_1.3.517_all.click --- ssh -s adb

Related branches

description: updated
description: updated
Changed in dropping-letters:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in sudoku-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in ubuntu-calculator-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in ubuntu-calendar-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in ubuntu-filemanager-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in music-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in ubuntu-rssreader-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in reminders-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in ubuntu-terminal-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in ubuntu-weather-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
description: updated
description: updated
description: updated
description: updated
Changed in music-app:
status: New → In Progress
Martin Pitt (pitti) wrote :

The calculator app doesn't need any conversion, it does not have additional test dependencies.

Changed in ubuntu-calculator-app:
status: New → Invalid
Martin Pitt (pitti) wrote :

Calendar app tests work without metadata changes.

Changed in ubuntu-calendar-app:
status: New → Invalid
Martin Pitt (pitti) wrote :

Sorry, I was testing with a slightly older calendar-app click. Current one requires python-tz.

Changed in ubuntu-calendar-app:
status: Invalid → Triaged
Martin Pitt (pitti) wrote :

I ran the file manager tests. They don't need any metadata changes for autopkgtest, and I get 20/22 successes.

filemanager.tests.test_filemanager.TestFolderListPage.test_create_directory fails which is already filed as bug 1332563.
filemanager.tests.test_places.PlacesTestCase.test_go_to_root_must_open_the_root_directory failed, which I filed as bug 1338921

So nothing to change in filemanager wrt. test metadata.

Changed in ubuntu-filemanager-app:
status: New → Invalid
Martin Pitt (pitti) wrote :

Terminal app works fine with autopkgtest, all tests passed.

Changed in ubuntu-terminal-app:
status: New → Invalid
Changed in ubuntu-calculator-app:
assignee: Nicholas Skaggs (nskaggs) → nobody
Changed in ubuntu-filemanager-app:
assignee: Nicholas Skaggs (nskaggs) → nobody
Changed in ubuntu-terminal-app:
assignee: Nicholas Skaggs (nskaggs) → nobody
Martin Pitt (pitti) wrote :

Weather app tests pass with autopkgtest without modification.

Changed in ubuntu-weather-app:
assignee: Nicholas Skaggs (nskaggs) → nobody
status: New → Invalid
Martin Pitt (pitti) wrote :

clock app tests run fine with autopkgtest.

Changed in ubuntu-clock-app:
status: New → Invalid
Martin Pitt (pitti) wrote :

Music app: one test failure, reported as bug 1338935. Works fine otherwise.

Changed in music-app:
assignee: Nicholas Skaggs (nskaggs) → nobody
status: In Progress → Invalid
Martin Pitt (pitti) wrote :

dropping-letters works fine.

Changed in dropping-letters:
assignee: Nicholas Skaggs (nskaggs) → nobody
status: New → Invalid
Martin Pitt (pitti) wrote :

For the record, I added tasks for the other click apps that we install by default. Except for com.canonical.payui as its manifest doesn't declare a source bzr or tests, and http://bazaar.launchpad.net/~unity-api-team/pay-ui/first-branch/files doesn't seem to have any tests.

Martin Pitt (pitti) wrote :

sudoku-app is fine metadata-wise. I got one test failure, reported as bug 1338944.

Changed in sudoku-app:
assignee: Nicholas Skaggs (nskaggs) → nobody
status: New → Invalid
Martin Pitt (pitti) wrote :

rssreader-app aka shorts works fine.

Changed in ubuntu-rssreader-app:
assignee: Nicholas Skaggs (nskaggs) → nobody
status: New → Invalid
Martin Pitt (pitti) wrote :

reminders is currently not a click, so it either needs to get a DEP-8 autopkgtest or get clickified.

Changed in reminders-app:
status: New → Confirmed
Martin Pitt (pitti) wrote :

camera-app works fine

Changed in camera-app:
status: New → Invalid
Martin Pitt (pitti) wrote :

gallery-app works fine

Changed in gallery-app:
status: New → Invalid
Martin Pitt (pitti) wrote :
Download full text (12.1 KiB)

notes-app are a complete fail. I suppose the reason is "qmlscene: invalid option -- 'I' "?

ERROR: notes_app.tests.test_delete.TestDelete.test_slide_to_delete_left(with touch)
----------------------------------------------------------------------
Application Log (com.ubuntu.notes_notes_1.4.269): {{{
libust[4648/4651]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[4648/4651]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
/usr/lib/arm-linux-gnueabihf/qt5/bin/qmlscene: invalid option -- 'I'
Testability driver loaded. Wire protocol version is "1.4".
callbacks 0xb3b8f445 0xb3b8f33d
creating surface at (0, 58) with size (768, 1222) with title 'qmlscene'libust[4764/4767]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[4764/4767]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[4764/4766]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[4764/4766]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
/usr/lib/arm-linux-gnueabihf/qt5/bin/qmlscene: invalid option -- 'I'
Testability driver loaded. Wire protocol version is "1.4".
callbacks 0xb3bd2445 0xb3bd233d
creating surface at (0, 58) with size (768, 1222) with title 'qmlscene'libust[4844/4848]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[4844/4848]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
/usr/lib/arm-linux-gnueabihf/qt5/bin/qmlscene: invalid option -- 'I'
libust[4895/4899]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[4895/4899]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
/usr/lib/arm-linux-gnueabihf/qt5/bin/qmlscene: invalid option -- 'I'
libust[4947/4951]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[4947/4951]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
/usr/lib/arm-linux-gnueabihf/qt5/bin/qmlscene: invalid option -- 'I'
libust[4997/5003]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[4997/5003]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
/usr/lib/arm-linux-gnueabihf/qt5/bin/qmlscene: invalid option -- 'I'
libust[5049/5053]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[5049/5053]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-comm.c:886)
/usr/lib/arm-linux-gnueabihf/qt5/bin/qmlscene: invalid option -- 'I'
libust[5100/5103]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[5100/5103]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[5100/5104]: Error: Error opening shm /lttng-ust-wait-5-32011 (in get_wait_shm() at lttng-ust-...

Martin Pitt (pitti) wrote :

I filed bug 1338979 for the bad qmlscene invocation of notes-app. Until then the tests can't run, setting to incomplete for now as the closest thing to "blocked".

Changed in notes-app:
status: New → Incomplete
Martin Pitt (pitti) wrote :

For calendar-app I posted an updated manifest change to the MP, which I tested with latest autopkgtest. All tests succeed.

Changed in ubuntu-calendar-app:
status: Triaged → In Progress

Fix committed into lp:ubuntu-calendar-app at revision 347, scheduled for release in ubuntu-calendar-app, milestone alpha-1

Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
Changed in notes-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
status: Incomplete → In Progress
Changed in reminders-app:
status: Confirmed → In Progress

Fix committed into lp:reminders-app at revision 194, scheduled for release in reminders-app, milestone 0.4

Changed in reminders-app:
status: In Progress → Fix Committed
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
David Planella (dpm) on 2014-10-10
Changed in reminders-app:
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2014-10-30
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (5.1 KiB)

This bug was fixed in the package reminders-app - 0.4+15.04.20141118-0ubuntu1

---------------
reminders-app (0.4+15.04.20141118-0ubuntu1) vivid; urgency=low

  [ Akiva Avraham ]
  * Updated library imports to qtquick-2.3.
  * Upgraded ubuntu.components to 1.1 Upgraded ubuntu.components.xxxx to
    1.0.

  [ Paolo Rotolo ]
  * Added Tags icon.

  [ Alan Pope ]
  * Fix incorrect email address.

  [ Michael Zanetti ]
  * Add count properties to models.
  * add API to save notebooks.
  * correctly update the model when a notebook changes.
  * Some performance optimizations when having many, big notes
  * improve startup sequence
  * suppress some warnings. (LP: #1316800)
  * Add support for tags. (LP: #1379747)
  * Fixed bug 1378014 - Notes should be sorted by modification date by
    default Fixed bug 1380255 - Add day of the month to the notes
    preview. (LP: #1378014, #1380255)
  * Fixed change accounts page. (LP: #1379751)
  * Split the actual evernote code out from the QML plugin into a
    libqtevernote. (LP: #1385994)
  * Improve reminders delegate. (LP: #1318054)
  * fix pulldown positioning. (LP: #1368548)
  * split loading of notes into chunks
  * Don't reload the note's content when reloading a note for its
    resources. (LP: #1380987)
  * improve sorting by falling back on title if the first sortrole is
    equal. (LP: #1380987)
  * add gif support
  * Improve handling of connection errors.
  * include tags when cloning a note.
  * add scrollbars to listviews.
  * Don't always build translations
  * implement full note caching
  * improve note edit view. (LP: #1391410, #1316947)
  * small fixes in the new edit mode
  * Created URI handlers to load the app from the scope. (LP: #1391689,
    #1385995)

  [ Víctor R. Ruiz ]
  * "Search notes" unstranslated. Update to the code and template. (LP:
    #1356944)
  * Another batch of untranslated strings. Updated template. (LP:
    #1356944)

  [ Riccardo Padovani ]
  * Fixed #1340644 - Notes go in default notebook when edited. (LP:
    #1340644)
  * Upgraded the WebView to Oxide. (LP: #1317580)
  * Fixed #1340686 - Selecting a notebook then add a note doesn't
    default the note to the notebook. (LP: #1340686)
  * Added a couple of new i18n.tr, updated the translations template.
  * Updated the camera confirm page to have buttons again Added a check
    to be sure to delete previous temp picture. (LP: #1342249)
  * Update string for no account advice, removed reference to add
    reminder button. (LP: #1340635)
  * Fixed pull down to refresh behavior.
  * Implemented fronted to change notebooks name. (LP: #1340640)
  * Implemented bottomEdge.
  * Added a bouncing ProgressBar. (LP: #1372420)
  * Fix #1379886 - First time reminders tab is shown, the list is offset
    from the top. (LP: #1379886)
  * Fixed #1382730 - Unable to create new notes. (LP: #1382730)
  * Enabled automatic orientation. (LP: #1385429)
  * Fixed bug 1378014 - Notes should be sorted by modification date by
    default Fixed bug 1380255 - Add day of the month to the notes
    preview. (LP: #1378014, #1380255)
  * Fixed change accounts page. (LP: #1379751)
  * Created URI handlers to load the app from the scope. (LP: #...

Read more...

Changed in reminders-app (Ubuntu):
status: New → Fix Released
Changed in notes-app:
assignee: Nicholas Skaggs (nskaggs) → nobody
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers