Xubuntu shutdown prompt is missing

Bug #1944519 reported by Leó Kolbeinsson
64
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Fix Released
Undecided
Unassigned
casper (Ubuntu)
Triaged
Medium
Unassigned
plymouth (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Update: 2021-10-08 ISO issues appear with Xubuntu still; not with Ubuntu-MATE

Live session shutdown prompt is missing - system reboots at once

Testing Ubuntu Mate Impish ISO 22.09,2021

Clicked restart now button after install and no shutdown prompt appeared - the system rebooted at once and I could then login as normal.

Please see bug #1942987 https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1942987 for history.

I am filing this under plymouth - not sure if that is correct package.

ProblemType: Bug
DistroRelease: Ubuntu 21.10
Package: plymouth 0.9.5git20210406-0ubuntu2
ProcVersionSignature: Ubuntu 5.13.0-16.16-generic 5.13.13
Uname: Linux 5.13.0-16-generic x86_64
ApportVersion: 2.20.11-0ubuntu69
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: pass
CurrentDesktop: MATE
Date: Wed Sep 22 06:59:59 2021
DefaultPlymouth: /usr/share/plymouth/themes/ubuntu-mate-logo/ubuntu-mate-logo.plymouth
InstallationDate: Installed on 2021-09-22 (0 days ago)
InstallationMedia: Ubuntu-MATE 21.10 "Impish Indri" - Beta amd64 (20210922)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 046d:c535 Logitech, Inc. Dell Wireless Mouse WM123
 Bus 001 Device 004: ID 04f2:0402 Chicony Electronics Co., Ltd Genius LuxeMate i200 Keyboard
 Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. OptiPlex 7040
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.13.0-16-generic root=UUID=731e4ccb-cceb-48e4-bbda-f97dbe3b6f40 ro quiet splash vt.handoff=7
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.13.0-16-generic root=UUID=731e4ccb-cceb-48e4-bbda-f97dbe3b6f40 ro quiet splash vt.handoff=7
SourcePackage: plymouth
TextPlymouth: /usr/share/plymouth/themes/ubuntu-mate-text/ubuntu-mate-text.plymouth
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/23/2020
dmi.bios.release: 1.18
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.18.1
dmi.board.name: 0Y7WYT
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.18.1:bd12/23/2020:br1.18:svnDellInc.:pnOptiPlex7040:pvr:sku06B9:rvnDellInc.:rn0Y7WYT:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.family: OptiPlex
dmi.product.name: OptiPlex 7040
dmi.product.sku: 06B9
dmi.sys.vendor: Dell Inc.

Revision history for this message
Leó Kolbeinsson (leok) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Reassigning - it's casper that instructs plymouth to prompt and delay the reboot.

affects: plymouth (Ubuntu) → casper (Ubuntu)
summary: - Live session shutdown prompt is missing - system reboots at once
+ Ubuntu Mate live session shutdown prompt is missing - system reboots at
+ once
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote : Re: Ubuntu Mate live session shutdown prompt is missing - system reboots at once

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1944519

tags: added: iso-testing
tags: added: rls-ii-incoming
Revision history for this message
Chris Guiver (guiverc) wrote (last edit ):

Using Xubuntu daily 2021-09-21 I got no eject on some tried test boxes

Boxes that ended with plymouth (Xubuntu & logo - no spinner though)
- sony vaio svp112a1cw (i5-9400u, 4gb, intel haswell-ULT)
- dell [optiplex] 755 (c2d-e6850, 5gb, amd/ati radeon rv516/x1300/x1550)
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

Boxes that ended with black screen & cursor/underscore (static/not-blinking)
- dell [optiplex] 780 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)
- hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)

Box that ended with just black screen
- lenovo thinkpad x201 (i5-m520, 4gb, i915)

(comment also made on https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1942987 as I hadn't seen Brian/bdmurray's comment about new report)

Weird though (to me anyway) is I tested with Ubuntu-MATE yesterday looking specifically for this bug & didn't experience it on whatever boxes I QA-tested on. I experienced the lack of ENTER today with Xubuntu.

(I don't know how to find old/archived iso.qa.ubuntu.com reports unless a bug was filed .. though I think it's

http://iso.qa.ubuntu.com/qatracker/milestones/427/builds/237189/testcases/1303/results

meaning it was 5 of the boxes I used here with Xubuntu & didn't experience it.

-rw------- 1 guiverc guiverc 3.4G Sep 22 02:50 impish-desktop-amd64.iso
-rw-rw-r-- 1 guiverc guiverc 63K Sep 22 13:46 impish-desktop-amd64.manifest
-rw-rw-r-- 1 guiverc guiverc 6.7M Sep 22 13:50 impish-desktop-amd64.iso.zsync

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
Leó Kolbeinsson (leok)
summary: - Ubuntu Mate live session shutdown prompt is missing - system reboots at
- once
+ Ubuntu Mate shutdown prompt is missing - system reboots at once
tags: added: fr-1758
Revision history for this message
Brian Murray (brian-murray) wrote (last edit ): Re: Ubuntu Mate shutdown prompt is missing - system reboots at once

I tested this today using the 2021-10-07 ubuntu-mate ISO in qemu and I did see the message regarding removing installation media and pressing "ENTER". I saw the message regardless of whether I choose "Try Ubuntu" or installed immediately.

Changed in casper (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Leó Kolbeinsson (leok) wrote (last edit ):

I just ran 2 tests with the same ISO - 2021-10-07 ubuntu-mate Impish

Running in VirtualBox the prompt to remove media was present - I then tested on another machine - this time bare metal (Dell7280) and no prompt to remove media - system reboots at once.

Revision history for this message
Chris Guiver (guiverc) wrote :

I tested on 7 boxes with today's daily (Ubuntu-MATE; 2021-10-07) and received eject messages on all boxes I tested with

- lenovo thinkpad sl510 (c2d-t6570, 2gb ram, i915)
- lenovo thinkpad x201 (i5-m520, 4gb, i915)
- sony vaio svp112a1cw (i5-9400u, 4gb, intel haswell-ULT)
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)
- hp dc7900 (c2d-e8400, 4gb, intel 4 series integrated i915)
- dell [optiplex] 755 (c2d-e6850, 5gb, amd/ati radeon rv516/x1300/x1550)
- dell [optiplex] 780 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)

http://iso.qa.ubuntu.com/qatracker/milestones/424/builds/237917/testcases/1303/results/

Revision history for this message
Chris Guiver (guiverc) wrote (last edit ):

I've changed to back to new. Issues with Xubuntu daily ISO (2021-10-08) on various boxes, see

http://iso.qa.ubuntu.com/qatracker/milestones/424/builds/237961/testcases/1303/results/

In all cases I'm waiting 2 mins+ before pressing ENTER

Following stick at plymouth xubuntu(logo)
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)
- dell [optiplex] 755 (c2d-e6850, 5gb, amd/ati radeon rv516/x1300
- dell [optiplex] 780 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)

on pressing enter I get system messages then box shuts down

Following stick at plymouth xubuntu(logo)
- sony vaio svp112a1cw (i5-9400u, 4gb, intel haswell-ULT)

on pressing enter I get VAIO plymouth screen then shutdown

Following get a black screen (no logo, just "_" top left on each display)
- hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)
- lenovo thinkpad x201 (i5-m520, 4gb, i915)
- lenovo thinkpad sl510 (c2d-t6570, 2gb ram, i915)

on pressing enter the system shuts down (text system messages appeared on thinkpad x201 & sl510)

No Eject.media/Enter message is displayed on any thus far
this is likely identical responses to #4

(additional boxes added to this comment as I could test them)

Changed in casper (Ubuntu):
status: Incomplete → New
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Testing Ubuntu Mate Impish ISO 2021-10-08 on 6 boxes : http://iso.qa.ubuntu.com/qatracker/milestones/424/builds/237964/testcases/1303/results

In all tests the remove media message was present -

I also used new USB media for these tests that were performed on bare metal boxes (1 test on VirtualBox)

Dell [Latitude] 7280, i5-7300U,16Gb
Lenovo V14 IIL i3-1005G1,20GB
AWOW NY41 – Int.Cel. J4125, 8GB
Dell [ Optiplex] MT 7040, i7-6700,32 GB
Dell [ Optiplex] MT 7060, i7-8700, 32 GB
InWin BL641 i5-10400,32GB

Chris Guiver (guiverc)
description: updated
Revision history for this message
Leó Kolbeinsson (leok) wrote (last edit ):

Testing Xbuntu Impish ISO 2021-10-08 on the same 6 boxes as my comments #10

All 6 tests - no remove media message -

See : http://iso.qa.ubuntu.com/qatracker/milestones/424/builds/237961/testcases/1303/results/

Revision history for this message
Brian Murray (brian-murray) wrote :

I tested the following ISO Xubuntu 21.10 "Impish Indri" - Release amd64 (20211011.1) in kvm and saw the "_" in the top left and did not see a message about removing the live media. After I pressed ENTER the system did reboot.

summary: - Ubuntu Mate shutdown prompt is missing - system reboots at once
+ Xubuntu shutdown prompt is missing - system reboots at once
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: Xubuntu shutdown prompt is missing - system reboots at once

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-notes:
status: New → Fix Released
tags: added: rls-ii-notfixing
removed: rls-ii-incoming
Leó Kolbeinsson (leok)
Changed in casper (Ubuntu):
status: Confirmed → New
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Changed back status to new as this now occurring in Xubuntu Jammy

Testing Xubuntu Jammy QA daily ISO 03-12-2021 on 2 boxes

1. AWOW NY41 – Int.Cel. J4125 -VirtualBox
2. InWin BL641 i5-10400 - bare metal

http://iso.qa.ubuntu.com/qatracker/milestones/429/builds/240632/testcases/1300/results/

Select reboot no remove media message and Xubuntu logo appears for a millisecond and then just a black screen with "_" in top left corner as in comment # 12
5 minute wait - press enter - box reboots

Leó Kolbeinsson (leok)
summary: - Xubuntu shutdown prompt is missing - system reboots at once
+ Xubuntu shutdown prompt is missing
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Testing Xubuntu Jammy QA daily ISO 18-12-2021 on 2 boxes

No eject message on install running in VirtualBox and/or QEMU

No error on install on bare metal machine - the prompt appeared at the very bottom edge of the screen.

Test results here: http://iso.qa.ubuntu.com/qatracker/milestones/429/builds/241435/testcases/1300/results

Revision history for this message
Chris Guiver (guiverc) wrote :

Xubuntu daily jammy ISO (2021-12-31) test on
- dell [optiplex] 755 (c2d-e6850, 5gb, amd/ati radeon rv516/x1300/x1550)

no eject message occurred... eventually I went looking for it (ctrl+alt+various) and found the message; however ENTER at that point would not shutdown.

I'd forgotten which Ctrl+Alt+F1 was my starting point (I'd struck many combinations looking for enter message) which may have contributed to ENTER not working (going to wrong place?) so I evenetually SysRq-Sync then used power-off to shutdown box

tags: added: jammy
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in casper (Ubuntu):
status: New → Confirmed
Revision history for this message
Sean Davis (bluesabre) wrote :

I've added plymouth back to this bug since this issue was originally a plymouth+casper bug that was reportedly fixed: https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1942987

We've had several additional reports of this issue, and I've reproduced it on two different machines in the last couple of days with Xubuntu Jammy. As always, the text is not displayed, but hitting the enter key will continue the reboot process.

tags: added: xubuntu
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
Revision history for this message
Michael Lueck (mlueck) wrote :

I just pulled down Xubuntu jammy-desktop-2022-04-02-amd64.iso

Clean wiped drive installation, same behavior persists... blank screen with blinking cursor, no "Please remove the installation medium, then press ENTER:" text displayed.

Revision history for this message
Michael Lueck (mlueck) wrote :

I just rechecked the behavior of Xubuntu 20.04.0 LTS. That LiveDVD installer disk stayed in graphics mode as it shut down. There was an Xubuntu logo in the middle of the screen, and the text displayed at the bottom of the screen.

Contrasting with Xubuntu 22.04 on the same exact system, the LiveDVD shut down is text based.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Testing Xubuntu Kinetic daily ISO 13-05-2022 and this bug still present.
Tested both live session and full install on 3 boxes.
Test results:

http://iso.qa.ubuntu.com/qatracker/milestones/433/builds/247925/testcases/1303/results/

and :
http://iso.qa.ubuntu.com/qatracker/milestones/433/builds/247925/testcases/1300/results

tags: added: kinetic
tags: removed: impish
Revision history for this message
Chris Guiver (guiverc) wrote :

Experienced this today on a RC for Xubuntu 22.04.1 on
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

on clicking RESTART [when ubiquity completes].. the screen soon darkened & just sat there, underline-cursor top left...

it was left >20 mins, with me waiting for message to hit enter (me using box to side of it so I can see screen).

On hitting enter, it quickly rebooted and all good.

Quote from #xubuntu-devel

<Unit193> FWIW, I noticed this uh..."upstream" too, then rebuilt with bullseye and saw it there. So I wonder if plymouth itself had an issue.
<Unit193> ....I'm talking Debian bullseye vs bookworm, so could be entirely unrelated. But interesting to see the regression in both places.

Revision history for this message
Chris Guiver (guiverc) wrote :

Repeat of my #23 comment using Xubuntu 22.04.1 RC of 20220809 on
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

no eject media, just black screen with underline top left on both screens and it sits there (waiting).

I found the message by hitting a few Ctrl+Alt+Fn keys (sorry I hit them too quick to realize which found the message; may have been ctrl+alt+F1 but that may have been the second key).

either way ENTER did not cause reboot of the system; it just remained stuck there today... (maybe I confused it with all my ctrl+alt+fn keys) but I caused reboot using Alt_SysRq_REISUB

Revision history for this message
Chris Guiver (guiverc) wrote :

Another install (auto resize) to same box of 20220809 to
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

on hitting Ctrl+Alt+F1 I get to see the "Please remove the installation medium, then reboot"

but ENTER no longer does anything.. it just sits there..
using alt+sysrq+REISUB to reboot

Revision history for this message
Chris Guiver (guiverc) wrote :

A live QA-test on
- hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)

on shutdown of live session, box just stopped with black screens & cursor sitting top left.. power still on (left >8 mins)

this box turned OFF on pressing ENTER.

Revision history for this message
Chris Guiver (guiverc) wrote :

Second install today using
- hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)

first was full disk install & message to eject media & reboot appeared; on this second (install alongside/auto-resize) install I got no message.

after completion of ubiquity & selecting to reboot I get short delay than black screens with cursor (not-blinking) top left on each display... it just sits there..

after 5 mins I hit ENTER then the message to eject media/enter (or whatever it said) flashed & box rebooted.

Revision history for this message
Chris Guiver (guiverc) wrote :

live QA-tests on
- hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)
- sony vaio svp112a1cw (i5-9400u, 4gb, intel haswell-ULT)

hp: on shutdown of live session, box just stopped with black screens & cursor sitting top left.. power still on (left >8 mins)

this box turned OFF on pressing ENTER.

sony: (it was earlier so I can't be accurate any more, but no message appeared... ENTER caused the box to turn off though!)

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Ran 2 tests on Xubuntu Kinetic Beta ISO 20220927.1

No shutdown/remove media prompt after install - cursor hangs in upper left hand corner - select enter and system reboots.

Machines tested in UEFI+secure boot mode:
1. Dell [ Optiplex] MT 7060
2. AWOW NY41

Steve Langasek (vorlon)
Changed in plymouth (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Steve Langasek (vorlon) wrote :

Reproducible with xubuntu-22.10-beta-desktop-amd64.iso:
- boot a kvm VM (with UEFI)
- choose 'Try or Install Xubuntu'
- choose 'Try Xubuntu'
- go to 'logout' from the upper lefthand menu
- choose 'shutdown'
- screen goes black with a xubuntu logo on it
- hitting 'esc' shows console output about I/O errors on /dev/sr0, /dev/loop0 and squashfs errors about failing to read blocks.

This indicates the root filesystem has been pulled out from under the system before the plymouth prompt could be shown.

I thought casper's addition of a dependency on finalrd was meant to address this but apparently integrating casper-stop with finalrd was never done.

Changed in casper (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: foundations-todo
Revision history for this message
Jane Atkinson (irihapeti) wrote :

Also showed up in a Budgie install testcase: Install UEFI (Desktop).

Normally, installing Budgie doesn't have this issue, but the testcase in question is run while offline (no network connection), which might have something to do with it.

Revision history for this message
Jane Atkinson (irihapeti) wrote :

Version of Budgie is 20221018.1

Revision history for this message
Leó Kolbeinsson (leok) wrote :

This still present in Xubuntu Lunar daily ISO dated 24.11.2022
No reboot or remove media prompts after install.

tags: added: lunar
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers