Indicator Applet Complete doesn't change the background color in Ubuntu MATE 16.10

Bug #1598159 reported by APolihron on 2016-07-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-mate
Medium
Unassigned
mate-indicator-applet (Ubuntu)
Medium
Unassigned
mate-themes (Ubuntu)
Low
Unassigned
ubuntu-mate-artwork (Ubuntu)
Low
Unassigned

Bug Description

If you change the color of the panel (in my case it's more Transparent) the Indicator Applet Complete 1.14.1 doesn't change the background color (will use the system theme)

APolihron (apolitech) wrote :
APolihron (apolitech) wrote :
APolihron (apolitech) wrote :
Vlad Orlov (monsta) wrote :

Confirmed, that's a problem in GTK+3 build. I'll see what I can do about it...

Changed in ubuntu-mate:
status: New → Confirmed
Vlad Orlov (monsta) wrote :

Ok, so it's also broken in the original indicator-applet (for gnome-panel). That explains why it happens here even though I've adapted all their GTK+3 migration changes...

Changed in ubuntu-mate:
importance: Undecided → Medium
status: Confirmed → Triaged
tags: removed: yak
Martin Wimpress (flexiondotorg) wrote :

This is fixed in mate-indicator-applet 1.15.1-0ubuntu1 in the yakkety archive and also in the xenial-mate PPA, the only place MATE Desktop 1.14.x is available.

Changed in ubuntu-mate:
status: Triaged → Fix Released
Vlad Orlov (monsta) wrote :

Well, not really fixed by any changes in the applet, but rather in some themes.
More info here:
https://github.com/mate-desktop/mate-indicator-applet/issues/17#issuecomment-240700161

Vlad Orlov (monsta) wrote :

I also don't think Xenial is affected in any way since it has GTK+2 build, with or without xenial-mate PPA. The report is about 1.14.1 which was in Yakkety repos previously.

Martin Wimpress (flexiondotorg) wrote :

Re-opened. Fixed for some themes, but not all.

Changed in ubuntu-mate:
status: Fix Released → Triaged
summary: - Indicator Applet Complete 1.14.1 doesn't change the background color
+ Indicator Applet Complete doesn't change the background color in Ubuntu
+ MATE 16.10
Changed in mate-indicator-applet (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
APolihron (apolitech) wrote :

I found the problem. After some testing in buntu MATE 16.10 daily with MATE 1.15 latest the bug will apear when enable indicators are enable !!!!!

When the panel is transparent the Indicators are still shown on a solid background, for *some* themes.

To recreate this issue you'll need to use Ubuntu MATE 16.10 daily with all updates applied. Then use MATE Tweak to Enable Indicators and make the panel transparent.

  * From `ubuntu-mate-artwork` only the Ambiant-MATE theme is affected. Radiant-MATE works correctly.
  * Most themes from `mate-themes` 3.20.12 behave correctly although TraditionalOK and TraditionalGreen exhibit the issue.

Changed in ubuntu-mate-artwork (Ubuntu):
status: New → Triaged
Changed in mate-themes (Ubuntu):
status: New → Triaged
Changed in mate-indicator-applet (Ubuntu):
status: Triaged → Fix Released
Changed in mate-themes (Ubuntu):
importance: Undecided → Low
Changed in ubuntu-mate-artwork (Ubuntu):
importance: Undecided → Low
Changed in ubuntu-mate-artwork (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mate-artwork - 16.10.8

---------------
ubuntu-mate-artwork (16.10.8) yakkety; urgency=medium

  * Fix Advanced Menu themes to use flat elements. (LP: #1630366, #1624755)
  * Fix OSD colors. (LP: #1630538)
  * Fix LibreOffice toolbars and theme. (LP: #1624571, #1550990)
  * Fix symbolic icons for GtkExpander.
  * Fix Transmission progress bars. (LP: #1624565)
  * Fix Indicator Applet on transparent panels. (LP: #1598159)

 -- Martin Wimpress <email address hidden> Thu, 06 Oct 2016 23:35:00 +0100

Changed in ubuntu-mate-artwork (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-mate:
status: Triaged → Fix Released
Vlad Orlov (monsta) wrote :

For mate-themes package this is finally fixed upstream in version 3.20.20.

https://github.com/mate-desktop/mate-themes/commit/9878b34828fd25bd4ba478f1c3b3262bfb6a4eb1

Vlad Orlov (monsta) wrote :

Hmm, mate-themes package in Zesty is affected as well. Again, it's now fixed upstream in version 3.22.11.

https://github.com/mate-desktop/mate-themes/commit/044efc6bd20481fe06b5c854cb8c7b815d93c838

tags: added: zesty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.