no suspend in 16.04 PPC

Bug #1541078 reported by Fritz Hudnut on 2016-02-02
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubuntu-mate
Undecided
Unassigned

Bug Description

Gents:

I just did an install a few days ago using the Alpha1 live DVD on my Powermac 3,1 PPC . . . and overall it's a very nice system. But, one dealbreaker for me is lack of "suspend" from either desktop or log in manager . . . . The screen does indeed go black, but the computer keeps spinning along as nothing has happened . . . and clicking mouse and or keyboard doesn't revive the display. The computer has to be shut down using the power button.

I ran a large "dist-upgrade" the next day after the install and the problem persists; so I don't know if that is now "Alpha2"??? Problem replicated after the update . . . . Doesn't look like anyone else has had this issue, but is a problem that I've had with many iterations of ubuntu 12.04, 14.04, and now 16.04 . . . . I have 2 GB RAM and swap is 2.7 GB . . . .

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1541078

tags: added: iso-testing
ernsteiswuerfel (erhard-f) wrote :

Same issue on a Powerbook 5,6 (installed it from yesterdays 2016-02-13 daily live).

Martin Wimpress (flexiondotorg) wrote :

The following page documents several known issue with suspend on the PowerPC.

  * https://bugs.launchpad.net/ubuntu-mate/+bug/1544814

At the very bottom of that page it suggests installing `pbbuttonsd`. Can you install that and let me know if it helps?

Changed in ubuntu-mate:
status: New → Triaged
Fritz Hudnut (este-el-paz) wrote :

@Martin:

Thanks for the post and suggestion; I'll post back when I've had a chance to do that and test it out . . . couple days probably . . . .

Fritz Hudnut (este-el-paz) wrote :

@Martin:

The link you provided seemed to be about the cursor disappearing when using compiz . . . nothing mentioned about "suspend" or pbbuttonsd . . . .

But, I booted into 16.04, ran apt update/upgrade, I see there is a large upgrade available . . . nothing on pbbuttonsd, so I went to Synaptic and checked it and it shows that version 0.8.1a-2, the latest version, is installed . . . . That mentions "apple hotkeys" for eject and other stuff, but nothing about "suspend." Since I just checked this the other day and suspend didn't work I can assume that nothing has changed via pbbuttonsd for this issue . . . .

Emil (emil-vanting) wrote :

Same problem on a HP Pavilion g6. When I boot from ISO, it works as expected, but after install and upgrade, I get a black screen and a nonresponding spinning system. I did not try suspend before upgrade.

I tried sudo apt install pbbuttonsd, but got the massage "no available version". What is the proper way to do this?

Martin Wimpress (flexiondotorg) wrote :

This wiki page is referenced in the Ubuntu MATE release notes, and has been for sometime :-)

  * https://wiki.ubuntu.com/PowerPCKnownIssues

In that page is the following text:

If you need suspend then you'll have to use the fbdev driver, but you'll want to increase the default colour depth via a yaboot parameter (for example, video=radeonfb:1024x768-32) or an xorg.conf:

Section "Screen"
  Identifier "Screen0"
  DefaultDepth 24
EndSection

Changed in ubuntu-mate:
status: Triaged → Invalid
Fritz Hudnut (este-el-paz) wrote :

@Martin:

I've been playing with PPC linux for perhaps 5 years, and during that time I have tried all of the "known issues" solutions to get "suspend," and for me, none of them are "valid" . . . . Over in Linux Mint on my MBPro I have working "suspend."

The point being that "suspend" is such a ***basic*** function that there really is no excuse why it isn't working--out of the box. I posted this bug here because I was under the impression that 16.04 PPC was shooting for a high quality system, one that provides ***full function**** and not kicking the can down the road . . . as has been done before and seemingly continues to be.

So far I haven't needed an xorg.conf file or Yaboot params to get the basic GUI function; perhaps if there is a rainy day in LA I'll test it out--but I have very low expectations that either of those suggestions will work--been there, done that . . . increased the size of the swap, increased the RAM . . . until it gets written into the kernel I don't believe that anything will actually work to provide the very basic function . . . I'm stepping away from the computer to have a meal; I don't need to keep the computer spinning, but I don't want to go through the boot sequence every time I need a break . . . that description apparently doesn't enter anyone else's mind as ***necessary***?????

Emil (emil-vanting) wrote :

@Martin:

Does it apply to a HP as well?

Found out it is somewhere after kernel 4.4.0-7 the problem occurs. When I boot 4.4.0-7, standby works fine. I tried 4.4.0-14-15-17, they all lock the system with a black screen and spinning system, when going into standby.

hesediel84 (hesediel84) wrote :

Ti seems to be the same thing, look there
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1566828n

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers