Ubuntu Manpage Repository

mount man page has run-on underlines

Reported by Ted Bodfish on 2010-01-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Manpage Repository
Low
Unassigned

Bug Description

There's a problem with run-on underlining on the mount man page. I think the
problem is on line 130 or 131 (according to my different browsers'
page source display) of the Karmic version:

The file <u><a href="../man5/fstab.5.html">fstab</a></b>(5)), may
contain lines describing what

should be something like:

The file <b><a href="../man5/fstab.5.html">fstab</a></b>(5)), may
contain lines describing what

so that the </b> has an opening tag and there's no extra <u> tag.

Dustin Kirkland  (kirkland) wrote :
Changed in ubuntu-manpage-repository:
status: New → Confirmed
importance: Undecided → Low
Dustin Kirkland  (kirkland) wrote :

This appears to be a bug in an older version of w3m.

To fix this problem, we'll need the manpages.ubuntu.com host to upgrade to Lucid's w3m, which is w3m 0.5.2-2.1ubuntu1.

Changed in ubuntu-manpage-repository:
status: Confirmed → In Progress
Dustin Kirkland  (kirkland) wrote :

Hmm, still a problem, even running from Lucid. I need to do a bit more debugging.

Changed in ubuntu-manpage-repository:
status: In Progress → Confirmed
Dustin Kirkland  (kirkland) wrote :

Sorry, was looking at a cached page. This will be fixed if I can get the host to upgrade to latest w3m.

Changed in ubuntu-manpage-repository:
status: Confirmed → In Progress
Dustin Kirkland  (kirkland) wrote :

Lamont, can you tell me what version of w3m is running on manpages.ubuntu.com?

Dustin Kirkland  (kirkland) wrote :

<lamont> kirkland: dpkg --status w3m| grep Vers
<lamont> Version: 0.5.2-2ubuntu1~0.CAT.8.04

Dustin Kirkland  (kirkland) wrote :

FWIW, w3m 0.5.2-2.1ubuntu1 tested and works fine. Might need 0.5.2-2.1ubuntu1 ported to m.u.c

Dustin Kirkland  (kirkland) wrote :

Hmm, maybe not ... the .1 version only affected:

  * debian/patches/06-gnukfreebsd-ftbfs-fix:
    - Fix FTBFS on GNU/kFreeBSD by extending the check on the FreeBSD
      version to __FreeBSD_kernel_version, as exported by the FreeBSD
      kernel on the GNU/kFreeBSD environments, as suggested by Petr
      Salinger (Closes: #493486).

I doubt that's it...

Changed in ubuntu-manpage-repository:
status: In Progress → Fix Committed
Changed in ubuntu-manpage-repository:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers