unreadable characters in recovery mode

Bug #573502 reported by Nobuto Murata on 2010-05-02
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
Ubuntu Japanese Kaizen Project
High
Unassigned
Ubuntu Translations
High
Unassigned
friendly-recovery (Ubuntu)
Undecided
Unassigned
language-pack-ja-base (Ubuntu)
Undecided
Unassigned
language-pack-zh-hans-base (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 10.04 LTS

there are unreadable characters in recovery mode for Japanese installations of lucid.

[Take a look at the linked screenshots and you should be able to figure it out]
http://launchpadlibrarian.net/47192384/Ubuntu%2010.04%20LTS%20Lucid%20Lynx%20%28Installed%29%20%5B%E5%AE%9F%E8%A1%8C%E4%B8%AD%5D%20-%20VirtualBox%20OSE_001.png

translated point:
/usr/share/locale-langpack/ja/LC_MESSAGES/friendly-recovery.mo
https://translations.launchpad.net/ubuntu/lucid/+source/friendly-recovery/+pots/friendly-recovery/ja/+translate

tranlated point of "OK" and "Cancel"
/usr/share/locale-langpack/ja/LC_MESSAGES/newt.mo
https://translations.launchpad.net/ubuntu/lucid/+source/newt/+pots/newt/ja/+translate

Nobuto Murata (nobuto) wrote :
Nobuto Murata (nobuto) on 2010-05-02
description: updated
description: updated
Rolf Leggewie (r0lf) on 2010-05-03
description: updated
summary: - Recovery Modeで読めない文字がある
+ Recovery Modeで読めない文字がある (unreadable characters in recovery mode)
Nobuto Murata (nobuto) on 2010-05-03
summary: - Recovery Modeで読めない文字がある (unreadable characters in recovery mode)
+ unreadable characters in recovery mode
description: updated
Nobuto Murata (nobuto) wrote :

This bug is also reproducible in locale "zh_CN".

It might be font or multi-byte characters issue in friendly-recovery.

Until friendly-recovery can show characters properly, it's good option to show English messages in troubled locales.
I will add tasks about lang-packs.

David Planella (dpm) on 2010-05-04
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
Michael Vogt (mvo) wrote :

It appears that the font on the terminal just does not have the right glyphs for display. If that is the case we need to indeed disable the CJK translations for now.

On 05/04/2010 10:33 PM, Michael Vogt wrote:
> It appears that the font on the terminal just does not have the right
> glyphs for display. If that is the case we need to indeed disable the
> CJK translations for now.

IIRC, the terminal fonts are 8 bit bitmap fonts. So, many more languages
would be affected, not only CJK.

Rolf Leggewie (r0lf) wrote :

Which font is that? I can have a look if you want.

David Planella (dpm) wrote :

Colin Watson tells us that the Linux console can't render CJK, that it's not a matter of fonts - it doesn't have the rendering technology. As Arne is mentioning, other languages will also be affected.

Other notes:

<cjwatson> people who need CJK text on consoles use things like jfbterm
<cjwatson> which wouldn't be impossible, we have a framebuffer there already in most situations now, it's just fairly cumbersome

So I think in the short term what we should do is disable translations for the affected locales.

So far we've got:

 * ja
 * zh_*
 * ko
 * ...

Arne Goetje (arnegoetje) wrote :

David, I would suggest to ask translation teams to test the recovery mode for their language and report back on this bug. Basically every language, which does not use Latin, standard Cyrillic or Greek scripts, plus Vietnamese would need to be tested.

Fumihito YOSHIDA (hito) wrote :

Just FYI,
> So I think in the short term what we should do is disable translations for the affected locales.

Its not enough to console fonts problems, because normally operations outputs are not readable too(see atachment).

IMHO, more better behavior is just fallback to LANG=C with zn_*, ja, ko and more affected langs if we can.

Aron Xu (happyaron) wrote :

The problem exists in zh_CN locale. I'm wondering if this could be solved by using framebuffer in the future. For now I'd say disabling translations is a good idea.

Nobuto Murata (nobuto) wrote :

I will ask to send call for testing on Ubuntu Translators mailing list later.

BTW, according to developers comment, this issue should be fixed in friendly-recovery by disabling translations in some locale. I will mark as Invalid against language-pack-* tasks.

Changed in ubuntu-jp-improvement:
assignee: nobody → Nobuto MURATA (nobuto)
importance: Critical → High
status: New → In Progress
Changed in language-pack-ja-base (Ubuntu):
status: New → Invalid
Changed in language-pack-zh-hans-base (Ubuntu):
status: New → Invalid
Nobuto Murata (nobuto) wrote :

As a result of talking IIRC with David, I will send e-mail to Ubuntu Translators mailing list to gather affected languages.

Changed in ubuntu-translations:
assignee: nobody → Nobuto MURATA (nobuto)
status: Triaged → In Progress
Changed in ubuntu-jp-improvement:
assignee: Nobuto MURATA (nobuto) → nobody
status: In Progress → Triaged
Yaron (sh-yaron) wrote :

Well, I reported this bug:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/693921

But if this bug is supposed to fix all of the listed languages I think I'll mark it as duplicate.

Nobuto Murata (nobuto) wrote :

Michael Vogt,
In Ubuntu Translators mailing list, I have got the list below. Could you disable loading translations on these affected locales? Thanks in advance.

Affected:
  ar_*
  he_IL
  ja_JP
  ko_KR
  ru_RU
  sl_SI (with 5%)
  vi_VN (with 70%)
  zh_*

NOT Affected:
  bg_BG
  ca_*
  da_DK (some characters not displayed properly, but no problem to read)
  de_*
  en_*
  es_ES
  fr_FR
  gl_ES
  hr_HR
  is_IS
  nb_NO
  nl_NL
  nn_NO
  pl_PL
  pt_BR

Note: Some Arabic(ar) and Hebrew(he) users said that switching the default font to theirs like /usr/share/consolefonts/Arabic-* fonts makes both English and localised string readable. I don't know how easy or difficult to implement switching the font. But I wrote this for your information.

Changed in ubuntu-translations:
assignee: Nobuto MURATA (nobuto) → nobody
status: In Progress → Confirmed
Nobuto Murata (nobuto) wrote :

Sorry, with 5% and 70% means percentage of unreadable characters.

Changed in friendly-recovery (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

Attached is a debdiff with a possible fix for the problem. It adds a blacklist that filters the languages you suggested. Testing / double checking very welcome.

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package friendly-recovery - 0.2.11

---------------
friendly-recovery (0.2.11) natty; urgency=low

  * usr/share/recovery-mode/l10n.sh:
    - blacklist certain locales where we don't have good console
      fonts (LP: #573502)
  * fix fsck option (LP: #566200)
  * refresh pot file
 -- Michael Vogt <email address hidden> Tue, 19 Apr 2011 17:57:06 +0200

Changed in friendly-recovery (Ubuntu):
status: Confirmed → Fix Released
Nobuto Murata (nobuto) wrote :

I can confirm friendly-recovery now fall back in English on locale ja_JP. Thanks!

Changed in ubuntu-translations:
status: Confirmed → Fix Released
Changed in ubuntu-jp-improvement:
status: Triaged → Fix Released
Michael Vogt (mvo) wrote :

Thanks a lot for your help on this Nobuto MURATA :)

reibian (satoshishinozaki) wrote :

How would I get the "fix" and apply to a broken system?

Aron Xu (happyaron) wrote :

If you are running Natty, then update package friendly-recovery to the latest version would fix your problem. If you are running Oneiric or newer, it isn't affected by this bug.

If you are running older versions than Natty, then sorry they aren't getting the fixes in any updates till now.

reibian (satoshishinozaki) wrote :

Hmmm. So, it seems I am SOL. I can boot into the recovery mode, but as it is Lucid, the command line gets filled with solid diamonds instead of appropriate text. I think I am able to get into "netroot" option although most of the messages are unreadable. Could I run the following and, somehow, update/upgrade?

sudo dpkg --reconfigure -a
sudo apt-get -f install

Thanks.

V字龍(Vdragon) (vdragon) wrote :

In my own opinion, this is still a workaround.
CJK characters should still normally displayed even in TTY.
This is Linux Kernel's issue, so I link it to here

Rex Tsai (chihchun) on 2013-05-15
Changed in linux:
status: New → Invalid
Rolf Leggewie (r0lf) on 2013-05-22
Changed in linux:
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers