Large grey border around gnome-terminal shadows when transparency is enabled (wayland)

Bug #1650395 reported by Wise Melon on 2016-12-15
92
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Medium
Unassigned
gnome-terminal (Ubuntu)
Medium
Unassigned
Zesty
Medium
Unassigned
Bionic
Undecided
Unassigned

Bug Description

I have found that after switching from Xorg to Wayland on Ubuntu GNOME 16.10 with GNOME 3.22, that there is a large strange grey border around the window:

- Fullscreen_gnome-terminal_in_AO_no_strange_border.png
- Fullscreen_gnome-terminal_window.png
- gnome-terminal_in_AO_strange_border.png
- gnome-terminal_window_strange_border.png

But this only occurs when the window is not fullscreen, and when transparency is enabled. Turning transparency off immediately fixes the issue.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: gnome-terminal 3.22.1-1ubuntu0~yakkety1 [origin: LP-PPA-gnome3-team-gnome3-staging]
ProcVersionSignature: Ubuntu 4.8.0-30.32-generic 4.8.6
Uname: Linux 4.8.0-30-generic x86_64
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Dec 15 21:29:17 2016
InstallationDate: Installed on 2016-05-15 (214 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to yakkety on 2016-10-19 (57 days ago)

Jeremy Bicha (jbicha) wrote :

By the way, gnome-terminal upstream doesn't support transparency since a few years. Some distros have patched it back in.

Yes, I know, I was thinking about that... So could it be an issue with the way it was patched in?

Jeremy Bicha (jbicha) wrote :

I'm curious whether this works on Fedora 25. Fedora also has a patch for gnome-terminal transparency but I believe their patch is different. Do you want to try to reproduce the bug there and report back here?

I have tested this on Fedora 25 and it works fine. No strange border or anything. So it's probably our patch then or its handling.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
seanlano (seanlano) wrote :

I can confirm this issue still happens in Ubuntu GNOME 17.04, with GNOME Terminal 3.20.2.

I can confirm this is happening in Ubuntu Gnome 17.04.
http://imgur.com/a/uuPbx

Peter S (peter-sevemark) wrote :

I can also confirm it in Ubuntu Gnome 17.04

Jeremy Bicha (jbicha) wrote :

Juan, where did you get the theme you are using?

Fred (eldmannen+launchpad) wrote :

That looks like it could be the Arc theme.
In the repository as 'arc-theme'.
https://github.com/horst3180/arc-theme

Jeremy Bicha (jbicha) wrote :

Thanks, Fred, but I want to know if he has installed an old version of the theme so I want to know where he got the theme from.

summary: Strange large grey border around gnome-terminal when transparency is
- enabled
+ enabled (shadow is opaque)
tags: added: shadows visual-quality

Thank you for taking the time to report this bug and helping to make Ubuntu better.

I am unable to duplicate this bug with the information provided. Please answer the following questions:

Could you check if this bug also affects Ubuntu 17.04?

What theme are you using and where did you get the theme from?

Does this bug affect all themes or just specific themes?

Changed in gnome-shell (Ubuntu):
status: Confirmed → Incomplete
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Incomplete

I use Ubuntu gnome 17.10 with theme United-gnome installed from its github.com page. It affect all themes after the install and it have probably something to do with transparent panel enabled during theme installation.

Jeremy Bicha (jbicha) wrote :

Lech, do you experience this bug if you change your theme to Adwaita? or to Ambiance?

Yes, I have screen with adwaita. I think I'll experience it with ambience too, but I'm not on desktop atm.

Jeremy Bicha (jbicha) on 2017-05-21
Changed in gnome-terminal (Ubuntu):
status: Incomplete → Confirmed
no longer affects: gnome-shell (Ubuntu)
tags: added: artful gnome-17.10 wayland zesty
removed: gnome3-ppa gnome3-staging third-party-packages
Changed in gnome-terminal (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-gnome:
importance: Undecided → Medium
status: New → Confirmed
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Triaged
Changed in ubuntu-gnome:
status: Confirmed → Triaged
milestone: none → artful

I also experienced this issue with: Adwaita, Numix, and Arc all from the official Ubuntu repositories.

Jeremy Bicha (jbicha) wrote :

Yes, I can duplicate this bug now. I don't normally enable transparency in my Terminal so I hadn't really experienced this earlier.

Jeremy Bicha (jbicha) on 2017-06-07
summary: - Strange large grey border around gnome-terminal when transparency is
- enabled (shadow is opaque)
+ Large grey border around gnome-terminal when transparency is enabled
+ (wayland)
summary: - Large grey border around gnome-terminal when transparency is enabled
- (wayland)
+ Large grey border around gnome-terminal shadows when transparency is
+ enabled (wayland)
amano (jyaku) wrote :

Can someone confirm that this is fixed with the latest gnome-terminal update in artful?

Jeremy Bicha (jbicha) wrote :

amano, this bug is still present in Ubuntu 17.10 Alpha "artful". This bug will be marked Fix Released when it's fixed.

Khurshid Alam (khurshid-alam) wrote :

May the patch gdk_window_set_background_rgba(gdk_window, transoarent) in gtk doesn't work under wayland when transparency is enabled? No problem under X with Unity though.

Jeremy Bicha (jbicha) on 2017-07-13
Changed in gnome-terminal (Ubuntu Zesty):
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.24.2-0ubuntu4

---------------
gnome-terminal (3.24.2-0ubuntu4) artful; urgency=medium

  * debian/patches/0001-screen-window-Extra-padding-around-transparent-termi.patch:
    Fix transparency on Wayland. Patch by Owen Taylor, via Debarshi Ray @
    Fedora, thanks! (LP: #1650395)
  * Rearrange the patches a bit.
  * debian/control{,.in}: Fix Vcs-Svn to Vcs-Bzr

 -- Iain Lane <email address hidden> Thu, 13 Jul 2017 16:07:50 +0100

Changed in gnome-terminal (Ubuntu):
status: Triaged → Fix Released

On Ubuntu 17.10, with wayland, looks like a very similar problem is still there. Should we open another ticket maybe?

Łukasz Zemczak (sil2100) wrote :

Since this bug has been linked from an SRU, we would need it to have the SRU template information filled in. Could that be done?

Hello Nikita, or anyone else affected,

Accepted gnome-terminal into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-terminal/3.28.2-1ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-terminal (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

@Robie, I run Arch now, so it would be best if someone else tested this, otherwise if nobody is around other than me to test it then I will happily do so in my QEMU VM. Just let me know if nobody gets back to you about this in a while.

Iain Lane (laney) wrote :

This is fixed, sorry for the confusion; it's only linked to the SRU because it's a backport and I'd copied and pasted the merge changelog entry including bug reference.

Changed in gnome-terminal (Ubuntu Bionic):
status: Fix Committed → Fix Released

Great news! Glad to hear it! I was surprised to see this issue still around.

Iain Lane (laney) on 2018-06-21
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for gnome-terminal has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers