Strange behaviour when trying to empty Trash in Nautilus, and it fails

Bug #1610200 reported by Wise Melon on 2016-08-05
22
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
Ubuntu GNOME
Undecided
Unassigned
gtk+3.0 (Ubuntu)
High
Unassigned

Bug Description

Ever since Nautilus had that little thing in the top bar indicating how long it would take to copy or delete something, Nautilus has always behaved strangely, normally showing "Preparing" for the entirety of the time and then magically disappearing when it is done and flashing the icon several times. But the most strange thing of all just happened, and is still affecting me.

I moved a very large folder with many sub-folders and file into Trash, Nautilus reports the following for the properties of the folder "203,334 items, totalling 1.7 GB". So once I had done this I clicked the button to "Empty" the Trash, normally with large items such as this one and the new Nautilus system of indication it takes a while and doesn't appear to do much. But this time it right out failed, it just won't let me delete the folder, though when I copied other things into the Trash as well as this folder it deleted them, just left this folder seemingly.
And then this happened, the indicator became a separate window, and when I closed it, so did Nautilus. But this is what it looked like:

    Nautilus_Strange_Deleting_Window.png
    Nautilus_Strange_Deleting_Window_In_AO.png

This is the strangest thing so far that has happened with this, and yes, when clicking the close, minimize, and maximize buttons on this new "window", they did do what they do on any window.

This really is bizarre for it to become a separate window. I looked in my syslog and these were the Nautilus logs for that time period:

Aug 5 11:40:05 <Computer-Name> org.gnome.Nautilus[3525]: Initializing nautilus-dropbox 2015.10.28
Aug 5 11:40:05 <Computer-Name> org.gnome.Nautilus[3525]: (nautilus:12634): Gtk-WARNING **: Theme parsing error: <broken file>:1:0: Failed to import: The resource at '/org/gnome/libgd/tagged-entry/default.css' does not exist
Aug 5 11:47:24 <Computer-Name> org.gnome.Nautilus[3525]: (nautilus:12634): Gtk-CRITICAL **: gtk_window_realize: assertion '!_gtk_widget_get_realized (widget)' failed
Aug 5 11:50:07 <Computer-Name> org.gnome.Nautilus[3525]: (nautilus:12634): Gdk-WARNING **: nautilus: Fatal IO error 11 (Resource temporarily unavailable) on X server :1.
Aug 5 11:51:16 <Computer-Name> org.gnome.Nautilus[3525]: Initializing nautilus-dropbox 2015.10.28
Aug 5 11:51:20 <Computer-Name> org.gnome.Nautilus[3525]: (nautilus:13023): Gtk-WARNING **: Theme parsing error: <broken file>:1:0: Failed to import: The resource at '/org/gnome/libgd/tagged-entry/default.css' does not exist

And I still haven't been able to delete the folder.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: nautilus 1:3.20.1-3ubuntu1~xenial1 [origin: LP-PPA-gnome3-team-gnome3-staging]
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Aug 5 12:02:49 2016
InstallationDate: Installed on 2016-05-15 (81 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Changed in nautilus:
importance: Unknown → High
status: Unknown → Confirmed

This bug has already been fixed upstream and a patch released. This should now be backported in.

Changed in nautilus:
importance: High → Unknown
status: Confirmed → Unknown
tags: added: needs-packaging
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
Jeremy Bicha (jbicha) wrote :

This should be fixed in gtk+ 3.20.7

affects: nautilus → gtk
affects: nautilus (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: New → Triaged
Changed in ubuntu-gnome:
status: New → Triaged
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - Strange behaviour when trying to empty Trash in Nautilus, and it fails
+ [needs-packaging] Strange behaviour when trying to empty Trash in
+ Nautilus, and it fails
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Wishlist
description: updated
Adolfo Jayme (fitojb) on 2016-08-14
tags: added: upgrade-software-version
removed: needs-packaging
summary: - [needs-packaging] Strange behaviour when trying to empty Trash in
- Nautilus, and it fails
+ Strange behaviour when trying to empty Trash in Nautilus, and it fails
Changed in gtk+3.0 (Ubuntu):
importance: Wishlist → Low
Sebastien Bacher (seb128) wrote :

it has been fixed upstream in gtk commit https://git.gnome.org/browse/gtk+/commit/?id=46cdb44f

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in gtk+3.0 (Ubuntu):
importance: Low → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.20.9-1ubuntu1

---------------
gtk+3.0 (3.20.9-1ubuntu1) yakkety; urgency=medium

  * Merge with Debian. Remaining changes:
    + Install the settings.ini file to set our themes
    + Enable parallel builds
    + Install a gsettings override to start filechoosers in the cwd
    + Enable Mir backend
    + Ubuntu specific patches:
      - 073_treeview_almost_fixed.patch
      - 074_eventbox_scroll_mask.patch
      - bzg_gtkcellrenderer_grabbing_modifier.patch
      - ubuntu_gtk_custom_menu_items.patch
      - print-dialog-show-options-of-remote-dnssd-printers.patch
      - uimanager-guard-against-nested-node-updates.patch
      - x-canonical-accel.patch
      - message-dialog-restore-traditional-look-on-unity.patch
      - 0001-gtk-reftest-Force-icon-theme-to-Adwaita.patch
      - restore_filechooser_typeaheadfind
      - 0001-calendar-always-emit-day-selected-once.patch
      - 0001-gtkwindow-set-transparent-background-color.patch
      - ubuntu_fileselector_behaviour.patch
      - unity-border-radius.patch
      - unity-headerbar-maximized-mode.patch
      - 0001-Update-the-GDK-Mir-backend-to-fix-a-few-problems.patch
      - 0001-Improve-external-drives-detection.patch
  * Don't ignore test failures. Accidentally set in 3.18.9-1ubuntu2
  * debian/control.in:
    - Build-depend on adwaita-icon-theme-full for icon name check test
  * debian/rules: Mark additional known test failures:
    - box-shadow-changes-modify-clip.ui
    - label-text-shadow-changes-modify-clip.ui

gtk+3.0 (3.20.9-1) unstable; urgency=medium

  [ Jeremy Bicha ]
  * Team upload
  * New upstream release
  * debian/control.in:
    - Drop unnecessary version number from dependency on adwaita-icon-theme
  * debian/patches/0001-Revert-Improve-external-drives-detection.patch:
    - Dropped, applied in new version

  [ Simon McVittie ]
  * Another new upstream release
  * Explicitly build-depend on docbook-xsl, libxml2-utils and xsltproc
    to be able to generate man pages from their source code. Move docbook-xml
    to Build-Depends since the man pages are in an Architecture: any package.
  * Drop Build-Depends-Indep on docbook-utils, the old SGML toolchain,
    which is currently uninstallable (#834616) and does not appear to be
    needed for anything

 -- Jeremy Bicha <email address hidden> Fri, 26 Aug 2016 03:54:54 -0400

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.