Touchpad gsettings being ignored

Bug #1586657 reported by Wise Melon on 2016-05-28
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GSettings Desktop Schemas
Unknown
Critical
One Hundred Papercuts
High
Unassigned
Ubuntu GNOME
Undecided
Unassigned
gnome-control-center (Ubuntu)
High
Unassigned

Bug Description

I think this is just the touchpad, though I don't have a mouse to test this with so it could also be affecting the mouse or a wider range of settings. But I have found that after upgrading to GNOME 3.20 on Ubuntu GNOME 16.04 that all my gsettings for things like natural scrolling and tap to click are being ignored and it doesn't matter what I have them set to, they are doing what they like. I have also seen others experiencing the same issues.

This is what dconf-editor shows me the settings are set to:

    dconf-editor_touchpad_settings.png

And yet even though the tap to click option is set to 'false', my touchpad is acting as though it has been set to 'true' ever since the upgrade, same for natural scrolling. As I have said, these are the only settings that I have noticed this with, however I have not really tested it with any of the others so I cannot say for sure how many settings this issue affects.

Changed in ubuntu-gnome:
status: New → Confirmed
Changed in gsettings-desktop-schemas (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Please try installing

xserver-xorg-input-libinput

and log out and log back in.

Vishwa Prakash H V (severustux) wrote :

Same problem with me. My "Mouse & Touchpad" Settings is empty (see the attachment). Changes made to touchpad schemas have no effect. I am using SynPS/2 Synaptics TouchPad.

@Jeremy,

Yes, installing that and then logging out and in again solves the problem and even adds a new section to the gnome-control-center's Mouse & Touchpad settings. This package should really be installed by default and as a dependency of something.

no longer affects: gsettings-desktop-schemas
Vishwa Prakash H V (severustux) wrote :

installing xserver-xorg-input-libinput solves the problem

Wait, I understand that this issue is affecting all distros, so is this a downstream issue or an upstream one?

Also, I have just noticed that when I install this package, although it fixes the problem it does something crazy to the mouse sensitivity (possibly) and speed, but no matter what I do with the speed settings I can't stop it just jumping and shaking all the time even if I'm not even trying to move it... It's either too fast or too slow, it's like an overly exciting owl or something... I'm just mulling over whether I should report this as a bug or not or keep trying with the settings...

Vishwa Prakash H V (severustux) wrote :

@Nikita Yerenkov-Scott (yerenkov-scott) Same happens with mine. After installing this package, mo cursor has become Hyper Exited. I cant hold it still for a seconds. Its shivering all the time and too fast.

In addition to this. My usable touchpad area is reduced very much. If I start slowly from my right down corner towards top, it does not move.

My Conclusion : this is not a perfect solution.

@Severus Tux, Yes, I am getting the same, I think it time I did file a bug report against that package, this is getting a little bit too much. Though maybe I will have a look at the dconf-editor and gnome-tweak-tool options first because I was sure there was something about touchpad usability area or something like that, but I could be mistaken.

Jeremy Bicha (jbicha) wrote :

The Settings app (gnome-control-center and gnome-settings-daemon) included in GNOME 3.20 only support the new xserver-xorg-input-libinput driver.

We would just make that a dependency of gnome-control-center then except that unity-control-center doesn't yet support changing touchpad settings with it. For Ubuntu GNOME 16.10 (still in development), the libinput package is a recommends currently.

Yes, it is a different touchpad driver and works differently than the old -synaptics driver. Maybe it will be more comfortable once you get used to it. If not, you can report a new bug:

ubuntu-bug xserver-xorg-input-libinput

affects: gsettings-desktop-schemas (Ubuntu) → gnome-control-center (Ubuntu)

@Severus Tux, I have filed two reports so far here on the issues you have described (and I also experience):

- Bug #1586683
- Bug #1586686

Changed in mutter (Ubuntu):
status: New → Confirmed

@yerenkov-scott .

I had removed this package from my computer as it was buggy. But this morning, When I did `sudo apt-get dist-upgrade` xserver-xorg-input-libinput was installed and gdm was removed (gdm3 still exists) . Now I cant have any other option other than waiting for devs to fix that package.

Changed in gsettings-desktop-schemas:
importance: Unknown → Critical
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
Changed in mutter (Ubuntu):
importance: Undecided → High
Jeremy Bicha (jbicha) wrote :

According to the announcement at https://launchpad.net/~gnome3-team/+archive/ubuntu/gnome3-staging/
the GNOME3 Staging PPA is no longer supported for Ubuntu 16.04 LTS. If you have the PPA enabled on that release, please ppa-purge. Then you can optionally remain on 16.04 LTS or upgrade to a newer Ubuntu version if you want newer GNOME versions.

Ubuntu GNOME itself does not have this bug.

For the remaining issue of GNOME touchpad settings not working correctly when xserver-xorg-input-synaptics is installed on Ubuntu GNOME 16.10+, see https://launchpad.net/bugs/1686081 Due to the nature of that bug, I don't think it will be possible to fix that in current Ubuntu stable releases.

no longer affects: mutter (Ubuntu)
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-gnome:
status: Confirmed → Fix Released
Paul White (paulw2u) wrote :

Closing as all other bug tasks resolved.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.