GNOME Software does not install third-party .deb packages

Bug #1573206 reported by Øystein Alværvik on 2016-04-21
This bug affects 369 people
Affects Status Importance Assigned to Milestone
GNOME Software
New
Undecided
Unassigned
GRadio
New
Undecided
Unassigned
SoundConverter
Undecided
Unassigned
Ubuntu GNOME
Undecided
Unassigned
Ubuntu Studio
High
Unassigned
gdebi
New
Undecided
Unassigned
gnome-software (Ubuntu)
High
Robert Ancell

Bug Description

Ubuntu 16.04 LTS (clean install). 64-bit. Final release.
Gnome-software version: 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2
  Version table:
 *** 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2 500
        500 http://no.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status

I intended to install MEGA Sync Client, Google Chrome and Dropbox by downloading the needed packages from their websites (respectively https://mega.nz/#sync and https://www.google.com/chrome/ and https://www.dropbox.com/install?os=lnx ). I opened the packages one by one with gnome-software and pressed Install - nothing, except for a super-quick progress bar animation, happened. No matter how many times I tried, same result. Also, an icon pops up on the panel saying "Waiting to install", but nothing seems to happen.

This only seems to happen with third-party packages; installing a random deb from packages.ubuntu.com/xenial worked.

I even tried to reinstall the system to make this work, but same problem.

Gdebi, however, installs the packages as expected.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-software 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Apr 21 21:01:52 2016
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-software
InstallationDate: Installed on 2016-04-21 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcEnviron:
 LANGUAGE=nn_NO:nn:no_NO:no:nb_NO:nb:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=nn_NO.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed

The same is true for this hangouts plugin I use in Firefox. It require this deb:
https://www.google.com/tools/dlpage/hangoutplugin

But, it won't install.

Same is true for this deb:
http://torrent-search.sourceforge.net/download

Vincent Thiele (vincentthiele) wrote :

Please fix this, it's a no go for an LTS release!

Stanislav (stanislav-schmidt) wrote :

Same issue here. Can't install any deb package in software centre.

Workarounds:
1) Use the GDebi Package Installer https://apps.ubuntu.com/cat/applications/precise/gdebi/
2) Use the command line: dpkg -i <filename>.deb

/ (0-) wrote :
/ (0-) wrote :
dusk (dusktumult) wrote :

This is happening to me to.
I cant seem to get either of the workarounds to work. When i try to install the gdebi package installer in the software center it does the same thing as when I try to install .deb files.
I had previously installed things via the software center but now nothing is installing. I can't really do anything on my computer without any software. Please Fix!

Changed in gnome-software (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Jonayad Rahman (jonayadrahman) wrote :

Same problem for me. I try to install Chrome. it just keep me waiting. and didn't give any result. Please try to fix it quickly.

Anuj Sharma (anujsharma9196) wrote :

Please fix it. I'm too suffering from this irritating bug

Subhadeep Dey (subhadeep-dey) wrote :

I thought I was the only one facing this issue, but it seems that it's a common issue. Hope it gets resolved soon.

Belenos (belenos) wrote :

Same problem here!

Shinjan Saha (sahashinjan) wrote :

It affects me as well....

Masi (soopo) wrote :

The same problem is with Google Chrome's 64bit .deb package in completely fresh 16.04. First application in fresh installation (not upgrade). Thread here http://askubuntu.com/q/761190/25388

same bug here also ...
unfortunately :(

As Stanislav mentioned, in post #6, there are other ways you can installed these deb packages.

However, even after you get the deb package installed, it breaks your ability to sudo apt-get update.

See here:
http://askubuntu.com/a/760348/256054

/ (0-) wrote :

Lonnie, the only error you should worry about is regarding dependencies after installing via dpkg. This can be fixed by doing a:

apt-get install -f

The other error is caused by SHA1 removal and can safely be ignored until the repos are updated:

https://wiki.debian.org/Teams/Apt/Sha1Removal

There is also another bug report addressing that issue.

Same thing happen to me. Please, fix it to continue enjoying Ubuntu 16!

Mario (marcorr70) wrote :

I have a similar problem, was disappointed to watch the software center not able me to install third party .deb programs. I believe it's a step back and a bad promotion for ubuntu.

Mario (marcorr70) wrote :

Also Gdebi doesn't solve the problem, returned me dependencies problem and wasn't able itself to solve.

Changed in ubuntu-gnome:
status: New → Confirmed

I couldn't find a report filed on this issue upstream already so I have done so and added a bug watch to monitor that here.

Changed in gnome-software:
importance: Unknown → High
status: Unknown → Confirmed
postadelmaga (postadelmaga) wrote :

also affects me.

Siddhartha (narenana) wrote :

Reproducible for multiple packages on Ubuntu 16.04 LTS

Changed in ubuntustudio:
status: New → Confirmed
Pablo Celayes (pablocelayes) wrote :

Same here, trying to install Chrome or Skype.

bogdan.rusu (rusubogdan93) wrote :

it affects me also

To anyone that has not noticed yet. Even the packages that ARE getting installed via this "Ubuntu Software" program, appear as NOT installed when one checks again. I tried with Audacity and Darktable. Both are properly installed.. both appear as if they are not.

@PanosKatertziadis, Please report that as a separate issue. Though I believe I have already seen a similar report upstream, though I could be mistaken.

summary: - Ubuntu Software does not install third-party .deb packages
+ GNOME Software does not install third-party .deb packages
Changed in gnome-software (Ubuntu):
status: Triaged → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Sebastien Bacher (seb128) wrote :

The fix is not working as it should, it seems to use the package name where the filename/path is wanted

Changed in gnome-software (Ubuntu):
status: Fix Committed → Triaged
status: Triaged → In Progress
tags: added: trello-import
Will Cooke (willcooke) on 2016-04-25
tags: removed: trello-import

It affects me also.

Doni (jerss2k) wrote :

This affects me as well.

Adnan Yumer (adnanyumer) wrote :

Affects me too.

Tim Hitchins (timtjtim) wrote :

Hi, this has been fixed upstream. If you still have issues, please fully update with:

    sudo apt-get update
    sudo apt-get upgrade

and check again. If it isn't working, please restart. Finally, if you're fully up to date (check again after the restart) please post back here, and we will look into it. Your Ubuntu distro would be helpful info too.

Changed in ubuntu-gnome:
status: Confirmed → Fix Released
Changed in ubuntustudio:
status: Confirmed → Fix Released
Changed in gnome-software (Ubuntu):
status: In Progress → Fix Released

There're no official updates for this software. The fix hasn't been released.

Changed in gnome-software:
status: Confirmed → Fix Released
brad (dragonsawareness) wrote :

Hi, this has been fixed upstream. If you still have issues, please fully update with:

    sudo apt-get update
    sudo apt-get upgrade

brad@Brad-Ubuntu-16:~$ sudo apt-get update
[sudo] password for brad:
Hit:1 http://archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [92.2 kB]
Hit:3 http://archive.canonical.com/ubuntu xenial InRelease
Hit:4 http://archive.ubuntu.com/ubuntu xenial-backports InRelease
Get:5 http://archive.ubuntu.com/ubuntu xenial-security InRelease [92.2 kB]
Fetched 184 kB in 1s (140 kB/s)
Reading package lists... Done
brad@Brad-Ubuntu-16:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
brad@Brad-Ubuntu-16:~$

There is no fix in Ubuntu 16.04?

Erik Pöhm (erzzo) wrote :

Im affected too

Albert Cutrona (acutbal) wrote :

I'm with Ubuntu 16.04, still not working. I've updated my system a few minutes ago, only an update for Numix theme and G'Mic for Gimp. Maybe the fix is not available?

Regards!! :)

Kumaraguru (gurukumara) wrote :

I know there are workarounds to install deb packages but I am totally disappointed with the new package installer. Shouldn't this be properly tested before release? especially, before pushing a LTS release?

Bruce Pieterse (octoquad) wrote :

All affected, apologies for the confusion but a fixed has landed upstream and has not yet landed yet in Ubuntu. The new upstream version will need to be packaged first before distributed to the main release pocket. If you need to install a package, please refer to comment #6 for the mean time.

Changed in ubuntu-gnome:
status: Fix Released → Triaged
Bruce Pieterse (octoquad) wrote :

Could someone revert the status for Ubuntu Studio and gnome-software (Ubuntu) I don't have the correct permissions to do so. Thanks

Ross Gammon (rosco2) on 2016-04-26
Changed in ubuntustudio:
status: Fix Released → Triaged
importance: Undecided → High
Chip Sharp (chipsharpdotcom) wrote :

Do we have an ETA on the fix being released into the wild? I don't know what the typical turn-around/repackage time is for something like this.

--C#

Bryan Karlan (bkarlan-n) wrote :

Same problem. Can't install Nylas N1 email nor Opera.

David Imiri (techbin1) wrote :

Affecting me too. Gdebi was good workaround, but would like to see this addressed.

Anders Ström (strom-anders) wrote :

It seems like if a third party package has been (attempted) installed, automated updates are disabled.

/ (#17)

However, even after you get the deb package installed, it breaks your ability to sudo apt-get update. /

---

"Hi, this has been fixed upstream. If you still have issues, please fully update with:

    sudo apt-get update
    sudo apt-get upgrade"

Does the upstream fix for everyone affected (who has attempted to install a third party package such as Google Chrome) entail to start a terminal session and run these commands, while adding "sudo apt-get -f install"?

Leipero (lei-pero) wrote :

Same problem, Vivaldi, Handbrake .deb can't be installed via Software, Gdebi works as expected.

David (davidrabello) wrote :

Same problem here. I can't install any software that comes from 3rd party.deb - I Am So Disappointed Right Now, I was so happy with 15.10. :/

Mathew Hodson (mathew-hodson) wrote :

There hasn't been a new release for xenial or yakkety yet. When a new package is released, the bug status for the Ubuntu task should be updated automatically, so you shouldn't need to change it.

Changed in gnome-software (Ubuntu):
status: Fix Released → Triaged
smurfendrek (smurfendrek123) wrote :

Also affects me

faical117 (faical117) wrote :

This stupid bug affects me too :-(
How can they release a new version with a bug like this one ?

Corrected link to the upstream patch from comment #29:
   https://git.gnome.org/browse/gnome-software/commit/?id=a98db57a724ea4433b03e9101964c1b594fa89e5

It's actually hard to tell that it's the right patch, as it has no comment, no link to the bug, no explanation. Not sure what the policy is at Canonical/Gnome about documenting bugfixes...

3li0 (guzmane) wrote :

Not sure why it states fix released, tried to update/upgrade but there were no updates applied:

eli@homel006:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Unable to install Chrome, Vivaldi, Slimjet, or any thrid party *.DEB package in general via the software center.

LTGoldman (lt-goldman) wrote :

I had this as well for Google Chrome and a workaround seems to be:

 open terminal and use dpkg -i <packagename>.deb followed by sudo apt-get -f install which brought in the dependent packages needed for Chrome to install.

Amr Ibrahim (amribrahim1987) wrote :

Please verify the fix in xenial-proposed.

Sam Van den Eynde (samvde) wrote :

.deb installation tested for Vivaldi and Chrome using gnome-software, gnome-software-common and ubuntu-software from xenial-proposed.

No problems encountered.

1berto (t-uruntu-s) wrote :

Enabled xenial-proposed, apt-get update + apt-get upgrade.

Tried to install teamviewer, but no luck... Installing via Gdebi is not a problem...

Thanks for working hard in solution to this matter!

Amr Ibrahim (amribrahim1987) wrote :

You'll have to log out then log in after updating to the version in xenial-proposed because gnome-software has a process that runs in the background, or end the process manually without logging out.

Amr Ibrahim (amribrahim1987) wrote :

Please test again a see whether you can install a third-party deb.

Amr Ibrahim (amribrahim1987) wrote :

Please follow the update instructions of xenial-proposed and write your comments there bug #1573408.

affects: gnome-software → ubuntu-translations
Changed in ubuntu-translations:
importance: High → Undecided
status: Fix Released → New
no longer affects: ubuntu-translations
Dea1993 (andrea-deangelis93) wrote :

bug also affect me on ubuntu 16.04 64bit

RoDoLFo TX (rodolfo-inec) wrote :

I was convinced this was a bug on the 3rd-party files I tried to install because I REFUSED TO BELIEVE an LTS release of Ubuntu would get this far with such bug, this is unacceptable. This is so sad.
I will consider this a "jump ship right NOW" warning, so I'll take it.

Jim (jime567) wrote :

Affects my 32 bit system as well as 64 bit system.

Rather Muneer (rmmuneer06) wrote :

All we are interested in, is that has the bug been fixed or not? Giving these temporary fixes won't solve the issue. I have been suffering from the day i upgraded to ubuntu 16.04, regretting it now.

Nick (nicholaskade) wrote :

Loving 16.04 except for the downloads. hoping it gets fixed soon.

Has the fix being released?

Dilum Tharaka (dilumtharaka1) wrote :

Is the fix out for this annoying issue?

Matthias Klumpp (ximion) wrote :

> Has the fix being released?

Yes - check the bug report which this one is a duplicate of.

It's out. I purged all the packages I had installed with dpkg -i and tested
by installing 64 bit chrome about 20 minutes ago.
On May 6, 2016 1:55 PM, "Dilum Tharaka" <email address hidden> wrote:

> *** This bug is a duplicate of bug 1573408 ***
> https://bugs.launchpad.net/bugs/1573408
>
> Is the fix out for this annoying issue?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1573206
>
> Title:
> GNOME Software does not install third-party .deb packages
>
> Status in GNOME Software:
> New
> Status in Ubuntu GNOME:
> Triaged
> Status in Ubuntu Studio:
> Triaged
> Status in gnome-software package in Ubuntu:
> Triaged
>
> Bug description:
> Ubuntu 16.04 LTS (clean install). 64-bit. Final release.
> Gnome-software version:
> 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2
> Version table:
> *** 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2 500
> 500 http://no.archive.ubuntu.com/ubuntu xenial/main amd64
> Packages
> 100 /var/lib/dpkg/status
>
>
> I intended to install MEGA Sync Client, Google Chrome and Dropbox by
> downloading the needed packages from their websites (respectively
> https://mega.nz/#sync and https://www.google.com/chrome/ and
> https://www.dropbox.com/install?os=lnx ). I opened the packages one by
> one with gnome-software and pressed Install - nothing, except for a
> super-quick progress bar animation, happened. No matter how many times I
> tried, same result. Also, an icon pops up on the panel saying "Waiting to
> install", but nothing seems to happen.
>
> This only seems to happen with third-party packages; installing a
> random deb from packages.ubuntu.com/xenial worked.
>
> I even tried to reinstall the system to make this work, but same
> problem.
>
> Gdebi, however, installs the packages as expected.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: gnome-software
> 3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2
> ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
> Uname: Linux 4.4.0-21-generic x86_64
> ApportVersion: 2.20.1-0ubuntu2
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Thu Apr 21 21:01:52 2016
> EcryptfsInUse: Yes
> ExecutablePath: /usr/bin/gnome-software
> InstallationDate: Installed on 2016-04-21 (0 days ago)
> InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64
> (20160420.1)
> ProcEnviron:
> LANGUAGE=nn_NO:nn:no_NO:no:nb_NO:nb:en
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=nn_NO.UTF-8
> SHELL=/bin/bash
> SourcePackage: gnome-software
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-software/+bug/1573206/+subscriptions
>

Cedara (cedara2) wrote :

Thanks for fixing the bug, finally could install the vivaldi-third-party-deb from nautilus.

Joe Dunster (joe-dunster) wrote :

I've installed 16.04 on a 32 bit laptop (yesterday) but am unable to install .deb files with the software installer... infact the software installer is just a blank screen now

brad (dragonsawareness) wrote :

Can someone please change the status to fixed

psionprime (psionprime) wrote :

It's not fixed as of 2016-05-24 08:50 edt. Installs sometimes happen but no indicator that the package is installed, just the same "Install" button shows. Further, "Important OS updates" does nothing for hours. I wind up using Synaptic to mark and upgrade the system. Synaptic is installed as Software doesn't display all available packages.

I appreciate the efforts for all involved in the Ubuntu project.

coskibum (1coskibum) wrote :

This effecting me to from adding programs from the Ubuntu software. Firewall says it's installed but when I try to configure it, it will not open up.I have uninstalled and reinstalled it and still nothing.

Also when I try to install Ubuntu Tweak the same thing happens.

This after a clean install of 16.04:

Hardware:
AMD FX 8350
18gb ram
new motherboard - Asus Sabertooth 990FC R2.0

Shoaib Sadiq (shoaibsadiq) wrote :

I am new to ubuntu and facing this kind of error in the beginning isn't welcoming..

description: updated

Being new to Ubuntu and already facing things like wont be able to install such things as Google Chrome and other 3rd party soft, and can't manage why is difficult. Hope this changes.

Whitney (blessedwhitney) wrote :

Also affects me -- this is particular troublesome bug for new people (ubuntus target demographic) since Chrome, a popular browser with syncing abilities, can only be installed via a work around.

Peter (readingmymail) wrote :

Please fix this bug!!! This has not been fixed despite what has been claimed. I have done a clean install of both 16.04 and 16.04.1 and the bug persists. Come on guys, this is a LTS release, and this should be addressed. Work-arounds is not a solution for faulty software.

It looks to me that when you try to install some package from the Software Centre, it starts the install then hangs. I believe this is because a dialog box should appear asking for admin credentials to install the software, but since that dialog box does not appear it just sits there waiting.

My set up is a Dell Precision M4500 (but this isn't a hardware issue - it is most definitely a software problem). My installation is a fully encrypted hard drive with encrypted home directory if that makes a difference.

Please mark this bug as not fixed.

Jonathan Martins (web-j) wrote :

man, what a shame! A nice feature for the user broken soo long! Elevate the IMPORTANCE!

Jeremy Bicha (jbicha) wrote :

@Peter please file a new bug about your issue since this particular bug is fixed, especially with a fresh install of Ubuntu 16.04. Please include specifics since there isn't enough information in your comment here for developers to know what exactly isn't working.

You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures.

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).
Thanks!

Seems to instal with GDebi as also via terminal but at the end does not work

Fernando D. (fdbozzo) wrote :

This bug affects me too. I know that apparently it's fixed on the "Proposed" repos, but I don't want to enable it because I don't want to became a beta-tester with my System.

When be this fix available as normal update?

My system info:
cat /proc/version
Linux version 4.4.0-31-generic (buildd@lgw01-16) (gcc version 5.3.1 20160413 (Ubuntu 5.3.1-14ubuntu2.1) ) #50-Ubuntu SMP Wed Jul 13 00:07:12 UTC 2016

Fernando D. (fdbozzo) wrote :

I forgot to say that I've fresh installed from 16.04.1 ISO

Jeremy Bicha (jbicha) wrote :

Fernando, it is a normal update now. It was only a proposed update for a few days so it could be tested first to make sure it fixed bugs and didn't make things worse. The fix is also included in Ubuntu 16.04.1.

If it's still not working, please run ubuntu-bug gnome-software to report a new bug.

You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you could provide a complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures.

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).
Thanks!

Fernando D. (fdbozzo) wrote :

Hi Jeremy:

In the meanwhile I've installed the previous Ubuntu Software Center that works ok and have a more clear design.

Very thanks for answering! If I use this Software Center again, I'll report any problem following the steps you described.

Best Ragards.-

Zheng Cheng (guokrfans) wrote :

This affects me as well.

Is there any updates on a fix as over 4 months have passed and this problem still exists?

Andres Vega (avegacon) wrote :

I am also having this problem.

When are they going to fix this bug?

fred (nightfeaver) wrote :

Also having the problem.

Jordan van Zyl (jordan5zulu) wrote :

This also affects me

Deafpyrotiger (deafpyrotiger) wrote :

Happy to report that this affects me as well, it seems that this is a persistent bug as it has been 9 months since first reporting now...

stephy (stephy) wrote :

It affects me too..

Mihaly Vadai (vadaim) wrote :

I found that SOME repositories don't have the package files for Gnome updates, but some others do. So for me the same symptoms occurred with Gnome updates.

Changing my local repository to another one fixed the problem for me. In my case adding deb http://fr.archive.ubuntu.com/ubuntu xenial-updates main solved the problem.

Here's a list of mirrors I think work at least with gnome updates:

http://packages.ubuntu.com/xenial-updates/all/gnome-software-common/download

I downloaded the ubuntu-16.04.2-desktop-amd64.iso from Ubuntu's main website around a month ago and it has this bug. I tried to install Chrome using the GUI and it failed, but using dpkg was fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers